locked WSJTX Won't Decode #AudioIssues #windows11 #Yaesu #decode


Robert44
 

Hello all. I'm having trouble getting WSJTX to decode when trying to use FT8. I have successfully used FT8 before with my Yaesu FT-991A with a Mac computer but I have changed over to PCs and am running Windows 11. I am new to PCs and Windows as I have been using a Mac for the last 12 years so I may be doing something stupid. I have the Silicone Labs driver installed on my PC and I am using the computer and radio settings from the following website:

https://www.w6pql.com/misc/wsjt-x/ft991-wsjt-x.pdf

I have CAT control of the radio and the green button and red transmit button lights up when pushed. I can transmit, change frequencies, etc. but the computer will not decode FT8. I am getting the following error message:

WSJT-X
Error in sound input.
An error opening the audio input device has occurred.

Any help would be greatly appreciated!! Many thanks!!

Robert K5TPC


Bruce N7XGR
 

Robert,
https://support.microsoft.com/en-us/windows/turn-on-app-permissions-for-your-microphone-in-windows-10-94991183-f69d-b4cf-4679-c98ca45f577a

Bruce N7XGR

On Fri, Nov 25, 2022 at 8:26 PM Robert44 via groups.io <robert44henry=
yahoo.com@groups.io> wrote:

Hello all. I'm having trouble getting WSJTX to decode when trying to use
FT8. I have successfully used FT8 before with my Yaesu FT-991A with a Mac
computer but I have changed over to PCs and am running Windows 11. I am
new to PCs and Windows as I have been using a Mac for the last 12 years so
I may be doing something stupid. I have the Silicone Labs driver installed
on my PC and I am using the computer and radio settings from the following
website:

https://www.w6pql.com/misc/wsjt-x/ft991-wsjt-x.pdf

I have CAT control of the radio and the green button and red transmit
button lights up when pushed. I can transmit, change frequencies, etc. but
the computer will not decode FT8. I am getting the following error message:

WSJT-X
Error in sound input.
An error opening the audio input device has occurred.

Any help would be greatly appreciated!! Many thanks!!

Robert K5TPC







Michael Black
 

RFI Problems
TestsIf problems are occurring only during transmit: #1 Reduce power to zero and see if the problem stops -- if it does stop than it is definitely RFI.  You will see certain higher power levels on certain bands that cause problems. Then, if problems are occurring during non-transmit periods it indicates a system problem with USB devices so... #1 Check USB Power Management option is turned off on all USB devices Device Manager for Windows. For Linux set autosuspend=-1 https://docs.kernel.org/driver-api/usb/power-management.html
RFI Fixes: #1 Free - Move USB cables to another port -- some ports are more susceptible than others. #2 Free -- Check your grounding system.  rod-outside-the-shack is a common problem when it's not bonded to the main house ground.  Common grounding mistakes, sources, and solutions: A. Ground rod outside the shack that is not bonded to the main house ground. B. Shack equipment bonded incorrectly (e.g. daisy chained instead of common ground point) C. Desktop computer grounded to the house ground and not the shack ground.  Run a separate RF ground from the computer chassis to your station RF ground.           For a laptop use the retaining screw of a DB9 or DB25 connector shell, if your device still has them. D. Ethernet cables that bring RFI into the computer...which then ends up going to the rig too since the ethernet shield is tied to the case which is tied to USB shield which is tied to pin 4 on the USB cable (a very common problem on most all USB devices -- see my QRZ page).    Ethernet patch cables up through CAT6 are UTP, which stands for UNSHIELDED Twisted Pairs, four to be specific.  There is NO separate shield conductor in the jacket, nor a metallic shield around the RJ45 connector itself.           Just use a ferrite toroid at each end. E. Wall warts -- 24VAC supplies in sprinkler and alarm systems are notorious for picking up RFI into your electrical system.    24 VAC transformers can be RF-bypassed using .005 ufd caps from each output lead to safety ground. You can often use the cover plate mounting screw as your ground connection. F. Speaker wires The same approach as E also works for external speaker audio leads. G. Lamps (yes...lamps around the house have unshielded wires as do many other appliances). H. Washer/Dryers are notorious for generating and picking up RFI.  In general, newer high-efficiency models have more RF problems.      Ferrite torroids INSIDE the appliance housing can work wonders if the wiring harness has connectors in the AC line input, OR an external noise filter for the AC line cord of a washing machine can reduce RF spurs by 25 dB or more. I. HVAC systems with variable speed blower control systems both cause RF noise and react badly to RF fields -- we believe adding torroids inside the unit on the power lines will work. J. If you use a powered USB expansion hub, add a ferrite toroid on the cable coming from the USB power supply. K. SignaLink -- You can ground the metal box shell by simply wrapping an 18ga wire (or use a small crimped ring or spade terminal) under the head of any of the screws holding the rear panel, then connect to your station RF ground.     The case is isolated from both USB and analog audio signal grounds, so this does not affect use of the USB shield isolators. L. DC power supply -- both linear and switching -- READ THE PS MANUAL FIRST!  This step may void some manufacturers' warranty and UL/CSA approvals.            Remove any jumpers between the DC negative output lead and PS chassis or line cord ground  Add a .005 ufd cap from each DC output lead to chassis ground if not already there.            NOTE: Samlex DC outputs are already isolated and bypassed, but many others, including Astron, may randomly have the negative side grounded and no RF bypassing.  B through L may all need chokes. http://www.k9yc.com/GroundingAndAudio.pdf  #3 Free -- start unplugging devices around the house and see if there's one device that is acting as a bad source of RFI.  This presupposes you can easily repeat the problem on your rig setup. #4 Cheap -- Add some USB shield isolators (see my QRZ page).  I use one on my SignaLink for example. #5 Minimal $$ -- Good USB cables like this https://www.amazon.ca/Tripp-U023-006-Device-Ferrite-Chokes/dp/B003MQ29B2/ref=sr_1_5?crid=11YRNPWDVWGCU&keywords=usb+cable+with+choke&qid=1658187349&sprefix=usb+cable+with+choke%2Caps%2C139&sr=8-5 #6 Maybe free (if you have chokes...otherwise can get a bit costly) -- add chokes to USB cables first, then all other cables including power, ethernet, and control cables. Fair-Rite torroids are good quality -- do NOT buy cheap Chinese ones --  https://www.fair-rite.com/product/toroids-5943003801/  You can use clip-ons but torroids allow multiple wraps and give better results. https://www.fair-rite.com/product/round-cable-snap-its-431176451/ I couldn't find type 31 torroids at Fair-Rite as of 20220721 but Palomar has some palomar-engineers.com/ferrite-products/ferrite-cores/ferrite-ring-toroid-combo-pack/ Newark also carries them https://newark.com/c/passive-components/emc-rfi-suppression/ferrites-ferrite-assortments?brand=fair-rite RFI Problems
Mike W9MDB

On Friday, November 25, 2022 at 07:26:15 PM CST, Robert44 via groups.io <robert44henry@...> wrote:

Hello all.  I'm having trouble getting WSJTX to decode when trying to use FT8.  I have successfully used FT8 before with my Yaesu FT-991A with a Mac computer but I have changed over to PCs and am running Windows 11.  I am new to PCs and Windows as I have been using a Mac for the last 12 years so I may be doing something stupid.  I have the Silicone Labs driver installed on my PC and I am using the computer and radio settings from the following website:

https://www.w6pql.com/misc/wsjt-x/ft991-wsjt-x.pdf

I have CAT control of the radio and the green button and red transmit button lights up when pushed.  I can transmit, change frequencies, etc. but the computer will not decode FT8.  I am getting the following error message:

WSJT-X
Error in sound input.
An error opening the audio input device has occurred.

Any help would be greatly appreciated!!  Many thanks!!

Robert  K5TPC


Michael Black
 

RFI Problems


Tests
If problems are occurring only during transmit:
    #1 Reduce power to zero and see if the problem stops -- if it does stop than it is definitely RFI.  You will see certain higher power levels on certain bands that cause problems.
    
Then, if problems are occurring during non-transmit periods it indicates a system problem with USB devices so...
    #1 Check USB Power Management option is turned off on all USB devices
        Device Manager for Windows.
        For Linux set autosuspend=-1 https://docs.kernel.org/driver-api/usb/power-management.html


RFI Fixes:
    #1 Free - Move USB cables to another port -- some ports are more susceptible than others.
    #2 Free -- Check your grounding system.  rod-outside-the-shack is a common problem when it's not bonded to the main house ground. 
        Common grounding mistakes, sources, and solutoins:
        A. Ground rod outside the shack that is not bonded to the main house ground.
        B. Shack equipment bonded incorrectly (e.g. daisy chained instead of common ground point)
        C. Desktop computer grounded to the house ground and not the shack ground.  Run a separate RF ground from the computer chassis to your station RF ground.
           For a laptop use the retaining screw of a DB9 or DB25 connector shell, if your device still has them.
        D. Ethernet cables that bring RFI into the computer...which then ends up going to the rig too since the ethernet shield is tied to the case which is tied to USB shield which is tied to pin 4 on the USB cable (a very common problem on most all USB devices -- see my QRZ page).
           Ethernet patch cables up through CAT6 are UTP, which stands for UNSHIELDED Twisted Pairs, four to be specific.  There is NO separate shield conductor in the jacket, nor a metallic shield around the RJ45 connector itself.
           Just use a ferrite toroid at each end.
        E. Wall warts -- 24VAC supplies in sprinkler and alarm systems are notorious for picking up RFI into your electrical system.
           24 VAC transformers can be RF-bypassed using .005 ufd caps from each output lead to safety ground. You can often use the cover plate mounting screw as your ground connection.
        F. Speaker wires The same approach as E also works for external speaker audio leads.
        G. Lamps (yes...lamps around the house have unshielded wires as do many other appliances).
        H. Washer/Dryers are notorious for generating and picking up RFI.  In general, newer high-efficiency models have more RF problems.  
           Ferrite toroids INSIDE the appliance housing can work wonders if the wiring harness has connectors in the AC line input, OR an external noise filter for the AC line cord of a washing machine can reduce RF spurs by 25 dB or more.
        I. HVAC systems with variable speed blower control systems both cause RF noise and react badly to RF fields -- we believe adding torroids inside the unit on the power lines will work.
        J. If you use a powered USB expansion hub, add a ferrite toroid on the cable coming from the USB power supply.
        K. SignaLink -- You can ground the metal box shell by simply wrapping an 18ga wire (or use a small crimped ring or spade terminal) under the head of any of the screws holding the rear panel, then connect to your station RF ground. 
           The case is isolated from both USB and analog audio signal grounds, so this does not affect use of the USB shield isolators.
        L. DC power supply -- both linear and switching -- READ THE PS MANUAL FIRST!  This step may void some manufacturers' warranty and UL/CSA approvals. 
           Remove any jumpers between the DC negative output lead and PS chassis or line cord ground  Add a .005 ufd cap from each DC output lead to chassis ground if not already there. 
           NOTE: Samlex DC outputs are already isolated and bypassed, but many others, including Astron, may randomly have the negative side grounded and no RF bypassing. 
        B through L may all need chokes.    
        http://www.k9yc.com/GroundingAndAudio.pdf 
    #3 Free -- start unplugging devices around the house and see if there's one device that is acting as a bad source of RFI.  This presupposes you can easily repeat the problem on your rig setup.
        
    #4 Cheap -- Add some USB shield isolators (see my QRZ page).  I use one on my SignaLink for example.
    #5 Minimal $$ -- Good USB cables like this
    https://www.amazon.ca/Tripp-U023-006-Device-Ferrite-Chokes/dp/B003MQ29B2/ref=sr_1_5?crid=11YRNPWDVWGCU&keywords=usb+cable+with+choke&qid=1658187349&sprefix=usb+cable+with+choke%2Caps%2C139&sr=8-5
    #6 Maybe free (if you have chokes...otherwise can get a bit costly) -- add chokes to USB cables first, then all other cables including power, ethernet, and control cables.
    Fair-Rite torroids are good quality -- do NOT buy cheap Chinese ones --  https://www.fair-rite.com/product/toroids-5943003801/  You can use clip-ons but torroids allow multiple wraps and give better results.
    https://www.fair-rite.com/product/round-cable-snap-its-431176451/
    I couldn't find type 31 torroids at Fair-Rite as of 20220721 but Palomar has some palomar-engineers.com/ferrite-products/ferrite-cores/ferrite-ring-toroid-combo-pack/
    Newark also carries them https://newark.com/c/passive-components/emc-rfi-suppression/ferrites-ferrite-assortments?brand=fair-rite
    RFI Problems


Mike W9MDB

Resending without HTML formatting.

On Saturday, November 26, 2022 at 01:29:26 AM CST, Michael Black via groups.io <mdblack98@...> wrote:





RFI Problems
TestsIf problems are occurring only during transmit: #1 Reduce power to zero and see if the problem stops -- if it does stop than it is definitely RFI.  You will see certain higher power levels on certain bands that cause problems. Then, if problems are occurring during non-transmit periods it indicates a system problem with USB devices so... #1 Check USB Power Management option is turned off on all USB devices Device Manager for Windows. For Linux set autosuspend=-1 https://docs.kernel.org/driver-api/usb/power-management.html
RFI Fixes: #1 Free - Move USB cables to another port -- some ports are more susceptible than others. #2 Free -- Check your grounding system.  rod-outside-the-shack is a common problem when it's not bonded to the main house ground.  Common grounding mistakes, sources, and solutions: A. Ground rod outside the shack that is not bonded to the main house ground. B. Shack equipment bonded incorrectly (e.g. daisy chained instead of common ground point) C. Desktop computer grounded to the house ground and not the shack ground.  Run a separate RF ground from the computer chassis to your station RF ground.           For a laptop use the retaining screw of a DB9 or DB25 connector shell, if your device still has them. D. Ethernet cables that bring RFI into the computer...which then ends up going to the rig too since the ethernet shield is tied to the case which is tied to USB shield which is tied to pin 4 on the USB cable (a very common problem on most all USB devices -- see my QRZ page).    Ethernet patch cables up through CAT6 are UTP, which stands for UNSHIELDED Twisted Pairs, four to be specific.  There is NO separate shield conductor in the jacket, nor a metallic shield around the RJ45 connector itself.           Just use a ferrite toroid at each end. E. Wall warts -- 24VAC supplies in sprinkler and alarm systems are notorious for picking up RFI into your electrical system.    24 VAC transformers can be RF-bypassed using .005 ufd caps from each output lead to safety ground. You can often use the cover plate mounting screw as your ground connection. F. Speaker wires The same approach as E also works for external speaker audio leads. G. Lamps (yes...lamps around the house have unshielded wires as do many other appliances). H. Washer/Dryers are notorious for generating and picking up RFI.  In general, newer high-efficiency models have more RF problems.      Ferrite torroids INSIDE the appliance housing can work wonders if the wiring harness has connectors in the AC line input, OR an external noise filter for the AC line cord of a washing machine can reduce RF spurs by 25 dB or more. I. HVAC systems with variable speed blower control systems both cause RF noise and react badly to RF fields -- we believe adding torroids inside the unit on the power lines will work. J. If you use a powered USB expansion hub, add a ferrite toroid on the cable coming from the USB power supply. K. SignaLink -- You can ground the metal box shell by simply wrapping an 18ga wire (or use a small crimped ring or spade terminal) under the head of any of the screws holding the rear panel, then connect to your station RF ground.     The case is isolated from both USB and analog audio signal grounds, so this does not affect use of the USB shield isolators. L. DC power supply -- both linear and switching -- READ THE PS MANUAL FIRST!  This step may void some manufacturers' warranty and UL/CSA approvals.            Remove any jumpers between the DC negative output lead and PS chassis or line cord ground  Add a .005 ufd cap from each DC output lead to chassis ground if not already there.            NOTE: Samlex DC outputs are already isolated and bypassed, but many others, including Astron, may randomly have the negative side grounded and no RF bypassing.  B through L may all need chokes.  http://www.k9yc.com/GroundingAndAudio.pdf  #3 Free -- start unplugging devices around the house and see if there's one device that is acting as a bad source of RFI.  This presupposes you can easily repeat the problem on your rig setup.  #4 Cheap -- Add some USB shield isolators (see my QRZ page).  I use one on my SignaLink for example. #5 Minimal $$ -- Good USB cables like this https://www.amazon.ca/Tripp-U023-006-Device-Ferrite-Chokes/dp/B003MQ29B2/ref=sr_1_5?crid=11YRNPWDVWGCU&keywords=usb+cable+with+choke&qid=1658187349&sprefix=usb+cable+with+choke%2Caps%2C139&sr=8-5 #6 Maybe free (if you have chokes...otherwise can get a bit costly) -- add chokes to USB cables first, then all other cables including power, ethernet, and control cables. Fair-Rite torroids are good quality -- do NOT buy cheap Chinese ones --  https://www.fair-rite.com/product/toroids-5943003801/  You can use clip-ons but torroids allow multiple wraps and give better results. https://www.fair-rite.com/product/round-cable-snap-its-431176451/ I couldn't find type 31 torroids at Fair-Rite as of 20220721 but Palomar has some palomar-engineers.com/ferrite-products/ferrite-cores/ferrite-ring-toroid-combo-pack/ Newark also carries them https://newark.com/c/passive-components/emc-rfi-suppression/ferrites-ferrite-assortments?brand=fair-rite RFI Problems
Mike W9MDB





    On Friday, November 25, 2022 at 07:26:15 PM CST, Robert44 via groups.io <robert44henry@...> wrote: 

Hello all.  I'm having trouble getting WSJTX to decode when trying to use FT8.  I have successfully used FT8 before with my Yaesu FT-991A with a Mac computer but I have changed over to PCs and am running Windows 11.  I am new to PCs and Windows as I have been using a Mac for the last 12 years so I may be doing something stupid.  I have the Silicone Labs driver installed on my PC and I am using the computer and radio settings from the following website:

https://www.w6pql.com/misc/wsjt-x/ft991-wsjt-x.pdf

I have CAT control of the radio and the green button and red transmit button lights up when pushed.  I can transmit, change frequencies, etc. but the computer will not decode FT8.  I am getting the following error message:

WSJT-X
Error in sound input.
An error opening the audio input device has occurred.

Any help would be greatly appreciated!!  Many thanks!!

Robert  K5TPC


Steve Lively, AF1SL
 

I'm having a similar issue with WSJT-X on my Raspberry Pi setup. I can get flrig talking to the radio, a G90, and flrig shows good signal level. WSJT-X, however, does not show any signal level and nothing in the waterfall. I have CAT control and PTT control, but no audio. There are a dozen audio options to choose from, but only one choice prevent WSJT-X from complaining about the audio selection. I'm sure there is an internal setting somewhere, either in the RPi system of WSJT-X, but I have no idea where it would be. I'm new to RPi, normally a Mac user. Interestingly, the same set up on my Mac results in WSJT-X crashing,, either upon launch or immediately upon hitting the "Test CAT" button.


Robert44
 

Hello Bruce, Michael and Steve and many thanks for the help. I checked the permission choices in the mic setup and all looks well. I also don't think I am having any RFI problems.

I changed the 991A's menu settings to the following and the radio now decodes:

29 9600
31 9600
32 100
62 others
64 1500
65 1500
66 off
68 off
71 RTS
72 USB
73 100
108 RTS
109 USB

All other menu items are set at default.

As I said, the radio now decodes but it will not transmit!! I don't know what I did to make it decode or now not transmit. When I try to transmit I get an error message that states, "Error in sound output. No audio output device configured." As mentioned before the radio at first would not decode but would transmit.

If you look at setting 73, I have it set to 100. This is "Data Out Level." When it is at the default 50 the audio level on the left of the WSJTX screen is way too low. When I set it to 100 it is still a bit too low but is at about 30 even when strong signals are present so it still needs to go a bit higher but I don't know how to make it go higher.

One thing I failed to mention at the start of this thread is I use this same computer to run FT8 from my ICOM 705 and it works just fine. I wonder if having the computer setup for also the Icom could mess things up somehow??? It's clear I have some sort of gremlins at work (the 991A is a difficult radio to use in my opinion) but I am at a loss as to what to do. Many thanks for any input.

Robert K5TPC


Michael Black
 

Use USB mode and not USB-D which has limited bandwidth on the 991.

Menu 103 set to Rear.  My notes on Tx show menu 107=42 and the RF Gain knob half-way.  RF Gain at max causing digitization problems.

If you lower the Pwr slider to minimum in WSJT-X can you transmit then?  If so that would be RFI.
If you still see that message uninstall the USB driver for the rig and reboot and see it works then.

Mike W9MDB

On Saturday, November 26, 2022 at 07:49:59 PM CST, Robert44 via groups.io <robert44henry@...> wrote:





Hello Bruce, Michael and Steve and many thanks for the help.  I checked the permission choices in the mic setup and all looks well.  I also don't think I am having any RFI problems.

I changed the 991A's menu settings to the following and the radio now decodes:

29  9600
31  9600
32  100
62  others
64  1500
65  1500
66  off
68  off
71  RTS
72  USB
73  100
108 RTS
109 USB

All other menu items are set at default.

As I said, the radio now decodes but it will not transmit!!  I don't know what I did to make it decode or now not transmit.  When I try to transmit I get an error message that states, "Error in sound output.  No audio output device configured."  As mentioned before the radio at first would not decode but would transmit.

If you look at setting 73, I have it set to 100.  This is "Data Out Level."  When it is at the default 50 the audio level on the left of the WSJTX screen is way too low.  When I set it to 100 it is still a bit too low but is at about 30 even when strong signals are present so it still needs to go a bit higher but I don't know how to make it go higher.

One thing I failed to mention at the start of this thread is I use this same computer to run FT8 from my ICOM 705 and it works just fine.  I wonder if having the computer setup for also the Icom could mess things up somehow???  It's clear I have some sort of gremlins at work (the 991A is a difficult radio to use in my opinion) but I am at a loss as to what to do.  Many thanks for any input.

Robert K5TPC


Robert44
 

I got things working for both decode and transmit. Under sound settings, it was set for 1 channel, 16 bit, 48000 Hz. I corrected this to 2 channel. Also, the computer microphone for codec somehow was turned off (if I am stating the problem correctly), so I turned it on. All is well now. Many thanks guys!

Robert K5TPC