locked WSJTX FAIL to install R Pi 3B+ Bullseye 32 bit #install #linux #raspberryPi


Kenneth Blackwell
 

Trying to install WSJTX 2.5.4 I received the following error messages. Note: I installed the dependencies specified by the WSJTX manual. Also compiling from source isn't practical for me.....I dug into it deeply....got hungup with "texinfo" requirement.

Thanks,
Ken, KB4XT


ken@raspberrypi:~/Downloads $ sudo dpkg -i wsjtx_2.5.4_armhf.deb
Selecting previously unselected package wsjtx.
(Reading database ... 126170 files and directories currently installed.)
Preparing to unpack wsjtx_2.5.4_armhf.deb ...
Unpacking wsjtx (2.5.4) ...
dpkg: dependency problems prevent configuration of wsjtx:
wsjtx depends on libboost-atomic1.67.0; however:
Package libboost-atomic1.67.0 is not installed.
wsjtx depends on libboost-chrono1.67.0; however:
Package libboost-chrono1.67.0 is not installed.
wsjtx depends on libboost-date-time1.67.0; however:
Package libboost-date-time1.67.0 is not installed.
wsjtx depends on libboost-filesystem1.67.0; however:
Package libboost-filesystem1.67.0 is not installed.
wsjtx depends on libboost-log1.67.0; however:
Package libboost-log1.67.0 is not installed.
wsjtx depends on libboost-regex1.67.0 (>= 1.67.0-10); however:
Package libboost-regex1.67.0 is not installed.
wsjtx depends on libboost-system1.67.0; however:
Package libboost-system1.67.0 is not installed.
wsjtx depends on libboost-thread1.67.0; however:
Package libboost-thread1.67.0 is not installed.
wsjtx depends on libreadline7 (>= 6.0); however:
Package libreadline7 is not installed.

dpkg: error processing package wsjtx (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:
wsjtx
ken@raspberrypi:~/Downloads $ sudo apt install libboost
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libboost
ken@raspberrypi:~/Downloads $ sudo apt install libreadline7
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libreadline7 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libreadline7' has no installation candidate
ken@raspberrypi:~/Downloads $ he following error messages. Note: I installed the dependencies specified in WSJTX manual.


Tim Dawson
 

Add "-DWSJT_GENERATE_DOCS=OFF" to your cmake, and it shouldn't use texinfo . . .

And looks like the code never read the manual . . . your output clearly shows that libboost and libreadline are required . . .

On October 4, 2022 2:48:41 PM CDT, Kenneth Blackwell <klblackw38@...> wrote:
Trying to install WSJTX 2.5.4 I received the following error messages. Note: I installed the dependencies specified by the WSJTX manual. Also compiling from source isn't practical for me.....I dug into it deeply....got hungup with "texinfo" requirement.

Thanks,
Ken, KB4XT


ken@raspberrypi:~/Downloads $ sudo dpkg -i wsjtx_2.5.4_armhf.deb
Selecting previously unselected package wsjtx.
(Reading database ... 126170 files and directories currently installed.)
Preparing to unpack wsjtx_2.5.4_armhf.deb ...
Unpacking wsjtx (2.5.4) ...
dpkg: dependency problems prevent configuration of wsjtx:
wsjtx depends on libboost-atomic1.67.0; however:
Package libboost-atomic1.67.0 is not installed.
wsjtx depends on libboost-chrono1.67.0; however:
Package libboost-chrono1.67.0 is not installed.
wsjtx depends on libboost-date-time1.67.0; however:
Package libboost-date-time1.67.0 is not installed.
wsjtx depends on libboost-filesystem1.67.0; however:
Package libboost-filesystem1.67.0 is not installed.
wsjtx depends on libboost-log1.67.0; however:
Package libboost-log1.67.0 is not installed.
wsjtx depends on libboost-regex1.67.0 (>= 1.67.0-10); however:
Package libboost-regex1.67.0 is not installed.
wsjtx depends on libboost-system1.67.0; however:
Package libboost-system1.67.0 is not installed.
wsjtx depends on libboost-thread1.67.0; however:
Package libboost-thread1.67.0 is not installed.
wsjtx depends on libreadline7 (>= 6.0); however:
Package libreadline7 is not installed.

dpkg: error processing package wsjtx (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:
wsjtx
ken@raspberrypi:~/Downloads $ sudo apt install libboost
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libboost
ken@raspberrypi:~/Downloads $ sudo apt install libreadline7
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libreadline7 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libreadline7' has no installation candidate
ken@raspberrypi:~/Downloads $ he following error messages. Note: I installed the dependencies specified in WSJTX manual.





--
Sent from my Android device with K-9 Mail. Please excuse my brevity.


Ron / W4MMP
 

Hi,

Do this (yes this is brute force approach).

Go here: https://packages.debian.org/search?searchon=names&keywords=libboost.

Find the package(s) you need.

1) The first missing library is : libboost-atomic1.67.0
2) On the website page you will see:

Package libboost-atomic1.67-dev

- [stretch-backports](https://packages.debian.org/stretch-backports/libboost-atomic1.67.0) (libs): atomic data types, operations, and memory ordering constraints
1.67.0-13+deb10u1~bpo9+1: amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el s390x
- [buster (oldstable)](https://packages.debian.org/buster/libboost-atomic1.67.0) (libs): atomic data types, operations, and memory ordering constraints
1.67.0-13+deb10u1: amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el s390x

3) Click on "buster (oldstable). This will take you to this:
4) Package: libboost-atomic1.67-dev (1.67.0-13+deb10u1) . This is the package you need.
5) sudo apt install libboost-atomic1.67-dev

The "-dev" should draw in the runtime libraries. If not then the run time library is needed: libboost-atomic1.67.0

Yep, it is convoluted but it works.

OK, soap box, and I know I'm treading on someone's sacred ground, but the reason for some many versions is that Linux gurus don't believe in backwards compatibility.

73,
Ron / W4MMP

On 10/4/2022 16:10, Tim Dawson wrote:

Add "-DWSJT_GENERATE_DOCS=OFF" to your cmake, and it shouldn't use texinfo . . .

And looks like the code never read the manual . . . your output clearly shows that libboost and libreadline are required . . .

On October 4, 2022 2:48:41 PM CDT, Kenneth Blackwell
[<klblackw38@...>](mailto:klblackw38@...)
wrote:

Trying to install WSJTX 2.5.4 I received the following error messages. Note: I installed the dependencies specified by the WSJTX manual. Also compiling from source isn't practical for me.....I dug into it deeply....got hungup with "texinfo" requirement.

Thanks,
Ken, KB4XT

ken@raspberrypi:~/Downloads $ sudo dpkg -i wsjtx_2.5.4_armhf.deb
Selecting previously unselected package wsjtx.
(Reading database ... 126170 files and directories currently installed.)
Preparing to unpack wsjtx_2.5.4_armhf.deb ...
Unpacking wsjtx (2.5.4) ...
dpkg: dependency problems prevent configuration of wsjtx:
wsjtx depends on libboost-atomic1.67.0; however:
Package libboost-atomic1.67.0 is not installed.
wsjtx depends on libboost-chrono1.67.0; however:
Package libboost-chrono1.67.0 is not installed.
wsjtx depends on libboost-date-time1.67.0; however:
Package libboost-date-time1.67.0 is not installed.
wsjtx depends on libboost-filesystem1.67.0; however:
Package libboost-filesystem1.67.0 is not installed.
wsjtx depends on libboost-log1.67.0; however:
Package libboost-log1.67.0 is not installed.
wsjtx depends on libboost-regex1.67.0 (>= 1.67.0-10); however:
Package libboost-regex1.67.0 is not installed.
wsjtx depends on libboost-system1.67.0; however:
Package libboost-system1.67.0 is not installed.
wsjtx depends on libboost-thread1.67.0; however:
Package libboost-thread1.67.0 is not installed.
wsjtx depends on libreadline7 (>= 6.0); however:
Package libreadline7 is not installed.

dpkg: error processing package wsjtx (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:
wsjtx
ken@raspberrypi:~/Downloads $ sudo apt install libboost
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libboost
ken@raspberrypi:~/Downloads $ sudo apt install libreadline7
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libreadline7 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libreadline7' has no installation candidate
ken@raspberrypi:~/Downloads $ he following error messages. Note: I installed the dependencies specified in WSJTX manual.
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.


Ron / W4MMP
 

OK,
I made a mistake. You need to select the bullseye version of the libraries. I'm still running buster and have stuck in my brain.

73,
Ron / W4MMP