Locked wsjtx_2.5.4 stops receiving in Ubuntu 22.04 LTS for FT8 #install


OS: Ubuntu Linux

NOTE: this is a new installation and was originally posted in the linuxham group (Andy, ka2uqw advised me to post it in this group)

PROBLEM: The moment the first TRANSMISSION happens (from my PC/radio), the program stops receiving new messages in the "Band Activity" pane. The vertical signal strength bar graph on the left side of the pane drops to nothing. Clicking on the "Monitor" or "Decode" selections do not cause the "Band Activity" pane to resume receiving new messages (although they do toggle). And even though exiting WSJT closes out its 2 windows, it does not completely close the program out. Relaunching causes this pop up message: "Another instance may be running try to remove stale lock file?". The only way I can restart WSJT is to open a linux terminal window and kill the still active original WSJT process.

I am sure this is a WSJT/Ubuntu problem and not hardware. I have individual external SSD caddys in my PC each having there own physical ON/OFF POWER SWITCH. I can boot either SSD WITHOUT having the other active (I am saying this to make it clear, this is NOT a dual boot setup on just one SSD). On my second SSD, I have MicroSoft Windows 10 Home installed and wsjtx_2.5.4. Using the EXACT SAME Hardware setup (PC, serial, USB, SignaLink box) connected to my Yaesu FT-450D radio (and no changes to the radio settings), WSJT in W10 works perfectly with no problems. This confirms the problem is in the wsjtx_2.5.4 software/drivers/settings running it in Ubuntu 22.04 LTS, and NOT the hardware.

I ran "disk wipe" on the Ubuntu SSD to completely erase it before installing Ubuntu 22.04 LTS and wsjtx_2.5.4. I have tried installing previous version combinations of Ubuntu (i.e 18.04) and wsjtx (including the just released) and disk wiping before each combination before installing. All have the exact same problem stated above.

This is a new 3 month old ASUS B660-PLUS D4 motherboard, with an Intel I5 6 core cpu (CPU has built in graphics). It only has the audio chip built in to the MB which I am using. The ASUS owners manual only says the audio is "Realtek 7.1 Surround Sound High Definition Audio CODEC". It does not say what the audio chip is. In the wsjtx audio selection section for transmit/receive I have selected "default" for both.

Any recommendations would be appreciated - thanks!

Jerry - WA1NSE

Gee, I have the same problem with 22.04 and version 2.5.4 on a high end lenovo yoga think pad. The radio is an Elecraft K4. Have you figured out a fix yet?

Roeland Jansen, PA3MET

if it happens after a TX... maybe the USB stack is hosed?

Reset the USB device, restart wsjtx and see. The 7300 can have this issue as wel.

If and only IF the USB port needs to be reset, I start a command:

sudo ./usbreset /dev/bus/usb/`lsusb -d 0451:2046 | cut -d ":" -f1 | cut -d " " -f2`/`lsusb -d 0451:2046 | cut -d ":" -f1 | cut -d " " -f4`

where usbreset is:

int main(int argc, char **argv)
const char *filename;
int fd;
int rc;

if (argc != 2) {
fprintf(stderr, "Usage: usbreset device-filename\n");
return 1;
filename = argv[1];

fd = open(filename, O_WRONLY);
if (fd < 0) {
perror("Error opening output file");
return 1;

printf("Resetting USB device %s\n", filename);
rc = ioctl(fd, USBDEVFS_RESET, 0);
if (rc < 0) {
perror("Error in ioctl");
return 1;
printf("Reset successful\n");

return 0;

note that if this works, you should look at your usb cabling and rf ingress.

Michael Black

And here's some info (rather old) about preventing USB devices from sleeping.


Mike W9MDB

Jerry - WA1NSE

I just installed version 2.6.1 on my Ubuntu 22.04 LTS Lenovo Thinkpad Laptop. The problem persists and I do not have any idea what to do about it.

The behavior is that when I start wsjtx it looks like everything is working. The waterfall is progressing and I see signals being decoded correctly. I press tune (5 Watts into an outdoor antenna--no RF in the shack; I have verified this carefully.) and the transmitter does turn on. I then press tune again and the transmitter turns off, as expected. But the waterfall stops, the spectrum plot goes flat and the band activity stops accumulating apparent messages. However, tune still toggles the transmitter.

The rig is an elecraft K4D. It appears not to be concerned about this problem. The problem is entirely in the laptop.

An interesting symptom is that if I exit wsjtx while it is working (before transmitting) it correctly exits. However if I exit wsjtx after transmitting and the receiver stops working, the GUIs close correctly, but the wsjtx process hangs around and I have to kill it manually. But after killing the broken wsjtx process I can start a new one and everything looks like it is working again.

I have it set up as CAT using ttyUSB0, and I my audio is set to pulse audio on both input and output. When I press test-cat in the radio settings I do not get either a green or a red signal. But that may be irrelevant because the CAT ptt seems to work fine.

Does anyone have any suggestions about this problem?

Alan G4ZFQ

On 28/01/2023 03:10, Jerry - WA1NSE wrote:
I press tune (5 Watts into an outdoor antenna--no RF in the shack; I have verified this carefully.) and the transmitter does turn on. I then press tune again and the transmitter turns off, as expected. But the waterfall stops,

This does really seem like RF in the shack.
Does it happen when power is set to zero? Or, into a dummy load. That must be the definitive test.

73 Alan G4ZFQ

Jerry - WA1NSE

This failure behavior occurs when driving 1W into a dummy load. In fact I just tried it with the transceiver in TX-test mode, which actually disables the transmitter--used for practice and testing macros. The failure is quite robust and it does not involve any real RF being generated.