Topics

WSJT-X with IC-7000, Ubuntu, mhuxd, and a Digi Keyer II


sd_wireless
 

I am trying to get WSJT-X working with an IC-7000, Ubuntu, mhuxd, and a Digi Keyer II. At this point, rig control seems to be working fine. Where I am having problems is with audio.

One oddity I've noted appears to be driven by the choice of the "Rig" on the "Radio" tab. When I am running WSJT-X on Windows I select "Ham Radio Deluxe" as the "Rig" and the "Transmit Audio Source" on the "Radio" tab is available to me.

When I am running Ubuntu I am selecting "ICOM IC-7000" as the "Rig" and the "Transmit Audio Source" on the "Radio" tab is grayed and selected to "Front/Mic". The Digii Keyer II is also telling me the Mic is selected as the audio source. I know this because the "Line" light on the front of the device is flashing. When "Rear/Data" is selected (running on Windows and using HRD) the light is solid red, indicating the audio source is the rear data port.

Is there any way to get WSJT-X to allow me to select the "Rear/Data" port when the "Rig" is set to "ICOM IC-7000"?

Note, the behavior of WSJT-X and the Digi Keyer do not change regardless of the "Mode" setting on the IC-7000. They both function the same regardless of whether USB or RTTY are selected on the radio.


Bill Somerville
 

On 21/11/2020 21:59, sd_wireless via groups.io wrote:
I am trying to get WSJT-X working with an IC-7000, Ubuntu, mhuxd, and a Digi Keyer II. At this point, rig control seems to be working fine. Where I am having problems is with audio.

One oddity I've noted appears to be driven by the choice of the "Rig" on the "Radio" tab. When I am running WSJT-X on Windows I select "Ham Radio Deluxe" as the "Rig" and the "Transmit Audio Source" on the "Radio" tab is available to me.

When I am running Ubuntu I am selecting "ICOM IC-7000" as the "Rig" and the "Transmit Audio Source" on the "Radio" tab is grayed and selected to "Front/Mic". The Digii Keyer II is also telling me the Mic is selected as the audio source. I know this because the "Line" light on the front of the device is flashing. When "Rear/Data" is selected (running on Windows and using HRD) the light is solid red, indicating the audio source is the rear data port.

Is there any way to get WSJT-X to allow me to select the "Rear/Data" port when the "Rig" is set to "ICOM IC-7000"?

Note, the behavior of WSJT-X and the Digi Keyer do not change regardless of the "Mode" setting on the IC-7000. They both function the same regardless of whether USB or RTTY are selected on the radio.
OM,

Icom radios do not have a regular CAT command to select the Tx audio source, it is normally dependent on rig menu settings and sometime on the mode selected (e.g. USB-DATA if available). The Tx audio source options in WSJT-X are enabled for rigs that have a different TX CAT command for different audio sources. These CAT commands are found on a few Kenwood rigs. With HRD as a rig control intermediary we do not concern ourselves what the rig being controlled is so we must allow for source selection whether it be functional or not.

73
Bill
G4WJS.


Joe Subich, W4TV
 

When I am running Ubuntu I am selecting "ICOM IC-7000" as the "Rig" and the "Transmit Audio Source" on the "Radio" tab is grayed and selected to "Front/Mic". The Digii Keyer II is also telling me the Mic is selected as the audio source. I know this because the "Line" light on the front of the device is flashing. When "Rear/Data" is selected (running on Windows and using HRD) the light is solid red, indicating the audio source is the rear data port.
I don't know anything about LINUX however ...

1) The IC-7000 mic and ACC jacks are effectively in parallel. The
IC-7000 does not have a USB_D mode and does not provide for
selecting audio source (MIC or ACC) based on mode.
2) Digieyer II connects to the ACC jack - there is no provision for
setting "mic" audio.
3) the flashing LINE LED on DK II indicates you have selected
"Headset microphone (microHAM CODEC)" *FOR INPUT* (receive)
in WSJTX (however that is indicated in LINUX). You will need
to fix your File -> Settings -> Audio -> input selection in
WSJTX.

73,

... Joe, W4TV


On 2020-11-21 4:59 PM, sd_wireless via groups.io wrote:
I am trying to get WSJT-X working with an IC-7000, Ubuntu, mhuxd, and a Digi Keyer II. At this point, rig control seems to be working fine. Where I am having problems is with audio.
One oddity I've noted appears to be driven by the choice of the "Rig" on the "Radio" tab. When I am running WSJT-X on Windows I select "Ham Radio Deluxe" as the "Rig" and the "Transmit Audio Source" on the "Radio" tab is available to me.
When I am running Ubuntu I am selecting "ICOM IC-7000" as the "Rig" and the "Transmit Audio Source" on the "Radio" tab is grayed and selected to "Front/Mic". The Digii Keyer II is also telling me the Mic is selected as the audio source. I know this because the "Line" light on the front of the device is flashing. When "Rear/Data" is selected (running on Windows and using HRD) the light is solid red, indicating the audio source is the rear data port.
Is there any way to get WSJT-X to allow me to select the "Rear/Data" port when the "Rig" is set to "ICOM IC-7000"?
Note, the behavior of WSJT-X and the Digi Keyer do not change regardless of the "Mode" setting on the IC-7000. They both function the same regardless of whether USB or RTTY are selected on the radio.