Topics

WSJT-X: macOS 11 Big Sur


Bill Somerville
 

Hi Mac users,

those of you that have upgraded to Big Sur have noted that the Pwr slider on the WSJT-X main window does not operate correctly. I can confirm this. We do not currently have a fix but I hope to have something in place before the WSJT-X v2.3.0 GA release. In the meantime there is a workaround that may suit some of you which is to run using the alternate dark theme that is shipped with WSJT-X:

open /Applications/wsjtx.app --args -stylesheet :/qdarkstyle/style.qss

If your preference is for a light theme then the Qt fusion style also woks but this style does not use native UI widgets so doesn't have much of an Apple Mac look and feel:

open /Applications/wsjtx.app --args -style fusion

For those running on the new X1 Mac hardware we have verified that WSJT-X does run under the Apple Rosetta 2 emulator but the recommended mechanism to adjust the system shared memory parameters on system startup does not work. We are working on that. For now you can manually adjust the required settings after system start up:

sudo sysctl kern.sysv.shmmax=104857600
sudo sysctl kern.sysv.shmall=25600

Thanks to John, G4KLA, for researching and testing the above procedure.

I can't promise any schedule for a native X1, or even a universal build of WSJT-X, we are dependent on third-party library and tool developers supporting the X1 silicon before we can even start on that. Initial reports on other applications are that applications running under the Rosetta 2 emulator perform well and in some cases outperform the application running on Intel silicon.

73
Bill
G4WJS.


David VK3DRH
 

G'day Bill,

Thanks for the quick response to this problem and the suggested workaround - dark style works without a problem on my tbMBP with Big Sur. 

Personally can I say thanks to you and all the developers, as a Mac user I recognise I'm in the minority regarding computing in the ham shack so I do appreciate the time and effort you all make to support the MacOS. Thanks.

David VK3DRH


Gary Rogers
 

Hi Bill. Just reporting that 2.3.0 rc2 working FB after upgrade to Big Sur. Just had to rerun sysctl.conf. I leave the gain slider alone as I set my FT 857D at 50w and carry on. Thanks again!


Bill Somerville
 

On 21/11/2020 23:32, Gary Rogers wrote:
Hi Bill. Just reporting that 2.3.0 rc2 working FB after upgrade to Big Sur. Just had to rerun sysctl.conf. I leave the gain slider alone as I set my FT 857D at 50w and carry on. Thanks again!
Hi Gary,

thanks for the update. I can confirm the Qt developers have fixed the issue that caused the Pwr slider to misbehave on Big Sur in their latest release. Assuming no other major issues are found we plan to use that for the next release.

73
Bill
G4WJS.