locked WSJT-X/Kenwood TS-440s CAT secret sauce #Cat_RigControl #Kenwood #Windows10


know whey <jaypea500@...>
 

After a few nasty go-rounds, I was able to finally get WSJT-X to control my Kenwood TS-440s. I wanted to pass along the parameters I found to work. As always, YMMV. NOTE: I'm using Windows 10. Again, YMMV if you're on another OS.

First, I installed the IC-10 interface chips in the TS-440s. This is necessary for computer control of the rig. I got the set of two chips from piexx.com.

I then obtained a USB-CAT interface cable from BlueMax49ers.com (KJ6ZWL). The cable is built with the FTDI chipset and the driver installs automatically.

Now, the settings. The IC-10 manual lays out the parameters thusly:

Transfer rate: 4800 BPS
Bit construction: 1 start bit, 8 character bits, 2 stop bits
Parity: None

First thing I did was setup WSJT-X like this:

rig: Kenwood TS-440s
(Looked for the COM port assignment for the interface cable in Device Manager - COM7 on my setup)
baud rate: 4800
data bits: 8
stop bits: 2
handshake: hardware (this was a lucky guess - not indicated in the IC-10 manual, but doesn't work without this.)
mode: USB
split operation: rig

After a few Test CAT failures, I had a thought.

I went back into W10 Device Manager, pulled up the properties page for the interface cable driver, clicked the Port Settings tab, and adjusted the settings to the above, except for Flow Control which I left at None (Flow Control in W10 and Handshake in WSJT-X seem to be the same thing, but setting Flow Control to hardware keeps it from working for some odd reason. So None it is.)

Went back to WSJT-X, and voila! A green Test CAT button, three beeps from the transceiver, and the display changed to the frequency shown in WSJT-X. Switching bands in WSJT-X, the TS-440s followed along dutifully.

A sigh of relief and a celebratory beer followed.

I should note that I left the PTT Control on VOX as I use a Signalink USB interface for the PTT and audio. The settings also worked with CAT selected, but I didn't try to key it up to see if it would PTT. I got this far, why tempt fate?

I hope this helps anyone trying to get a TS-440s running with WSJT-X.

...joe kd2qbk


Michael Black
 

If you had just selected "Default" for all the serial information it would have worked out of the box.
The TS-440 does not have hardware flow control.
We put in the the "Default" selections a few years ago due to all the questions about serial setup.
I'm not aware of ANY rig that does not work with the defaults unless you have a bad serial cable (3-wire) on a rig that wants 5-wire control (i.e. hardware flow control).
Mike W9DMB

On Wednesday, September 28, 2022 at 07:36:51 AM CDT, know whey <jaypea500@...> wrote:

After a few nasty go-rounds, I was able to finally get WSJT-X to control my Kenwood TS-440s.  I wanted to pass along the parameters I found to work.  As always, YMMV.  NOTE: I'm using Windows 10.  Again, YMMV if you're on another OS.

First, I installed the IC-10 interface chips in the TS-440s.  This is necessary for computer control of the rig.  I got the set of two chips from piexx.com.

I then obtained a USB-CAT interface cable from BlueMax49ers.com (KJ6ZWL).  The cable is built with the FTDI chipset and the driver installs automatically.

Now, the settings.  The IC-10 manual lays out the parameters thusly:

Transfer rate: 4800 BPS
Bit construction: 1 start bit, 8 character bits, 2 stop bits
Parity: None

First thing I did was setup WSJT-X like this:

rig: Kenwood TS-440s
(Looked for the COM port assignment for the interface cable in Device Manager - COM7 on my setup)
baud rate: 4800
data bits: 8
stop bits: 2
handshake: hardware (this was a lucky guess - not indicated in the IC-10 manual, but doesn't work without this.)
mode: USB
split operation: rig

After a few Test CAT failures, I had a thought.

I went back into W10 Device Manager, pulled up the properties page for the interface cable driver, clicked the Port Settings tab, and adjusted the settings to the above, except for Flow Control which I left at None (Flow Control in W10 and Handshake in WSJT-X seem to be the same thing, but setting Flow Control to hardware keeps it from working for some odd reason. So None it is.)

Went back to WSJT-X, and voila!  A green Test CAT button, three beeps from the transceiver, and the display changed to the frequency shown in WSJT-X.  Switching bands in WSJT-X, the TS-440s followed along dutifully.

A sigh of relief and a celebratory beer followed.

I should note that I left the PTT Control on VOX as I use a Signalink USB interface for the PTT and audio.  The settings also worked with CAT selected, but I didn't try to key it up to see if it would PTT.  I got this far, why tempt fate?

I hope this helps anyone trying to get a TS-440s running with WSJT-X.

...joe kd2qbk


Joe Subich, W4TV
 

On 2022-09-27 11:11 PM, know whey (joe kd2qbk) wrote:

I should note that I left the PTT Control on VOX as I use a
Signalink USB interface for the PTT and audio. The settings also
worked with CAT selected, but I didn't try to key it up to see if it
would PTT.
PTT via CAT command in the TS-400 (and most other Kenwood transceivers)
selects TX audio via the microphone. If your Signalink (sound card) is
connected to the ACC2 jack (the most convenient connection), you must
provide a PTT contact closure to *both* pin 13 (PTT) and pin 9 (mic
mute) in the TS-440 to select audio from the ACC2 jack.

In later Kenwood transceivers, data PTT must be provided on pin 9.

Only the very latest Kenwood transceivers (TS-480, 890, 990) have
separate CAT commands to simulate PTT on pin 9 of the ACC2 jack.

73,

... Joe, W4TV


On 2022-09-27 11:11 PM, know whey wrote:
After a few nasty go-rounds, I was able to finally get WSJT-X to control my Kenwood TS-440s. I wanted to pass along the parameters I found to work. As always, YMMV. NOTE: I'm using Windows 10. Again, YMMV if you're on another OS.
First, I installed the IC-10 interface chips in the TS-440s. This is necessary for computer control of the rig. I got the set of two chips from piexx.com.
I then obtained a USB-CAT interface cable from BlueMax49ers.com (KJ6ZWL). The cable is built with the FTDI chipset and the driver installs automatically.
Now, the settings. The IC-10 manual lays out the parameters thusly:
Transfer rate: 4800 BPS
Bit construction: 1 start bit, 8 character bits, 2 stop bits
Parity: None
First thing I did was setup WSJT-X like this:
rig: Kenwood TS-440s
(Looked for the COM port assignment for the interface cable in Device Manager - COM7 on my setup)
baud rate: 4800
data bits: 8
stop bits: 2
handshake: hardware (this was a lucky guess - not indicated in the IC-10 manual, but doesn't work without this.)
mode: USB
split operation: rig
After a few Test CAT failures, I had a thought.
I went back into W10 Device Manager, pulled up the properties page for the interface cable driver, clicked the Port Settings tab, and adjusted the settings to the above, except for Flow Control which I left at None (Flow Control in W10 and Handshake in WSJT-X seem to be the same thing, but setting Flow Control to hardware keeps it from working for some odd reason. So None it is.)
Went back to WSJT-X, and voila! A green Test CAT button, three beeps from the transceiver, and the display changed to the frequency shown in WSJT-X. Switching bands in WSJT-X, the TS-440s followed along dutifully.
A sigh of relief and a celebratory beer followed.
I should note that I left the PTT Control on VOX as I use a Signalink USB interface for the PTT and audio. The settings also worked with CAT selected, but I didn't try to key it up to see if it would PTT. I got this far, why tempt fate?
I hope this helps anyone trying to get a TS-440s running with WSJT-X.
...joe kd2qbk


know whey <jaypea500@...>
 

Nope. Nope, nope, nope.

The reason I went through the exercise was because the "default" settings did not work in my case for whatever reason. If you'd rather I didn't post my experiences on the list, please say so and I'll refrain from doing so. But to spout off with, "If you had just selected "Default" blah, blah blah...." without experiencing what I did is just very snotty. I tend to find a lot of that on this list.

As for me, I just hope my experience will help someone else...

...joe kd2qbk


Michael Black
 

I'll apologize if you were offended...not my intent...but I should have phrased that as a question instead.  So mia culpa, wet noodle, and all other modes of abuse accepted.
Now that you have it working could you test the Defaults again?   The settings you show are what the Defaults should be.  If that's not working them something is broken that we need to fix.
    .serial_data_bits =  8,    .serial_stop_bits =  2,    .serial_parity =  RIG_PARITY_NONE,    .serial_handshake =  RIG_HANDSHAKE_NONE,

Mike W9MDB

On Thursday, September 29, 2022 at 02:27:57 AM CDT, know whey <jaypea500@...> wrote:

Nope.  Nope, nope, nope.

The reason I went through the exercise was because the "default" settings did not work in my case for whatever reason.  If you'd rather I didn't post my experiences on the list, please say so and I'll refrain from doing so.  But to spout off with, "If you had just selected "Default" blah, blah blah...." without experiencing what I did is just very snotty.  I tend to find a lot of that on this list.

As for me, I just hope my experience will help someone else...

...joe kd2qbk