Topics

locked sticky Windows audio and sleep mode #AudioIssues


Frank W2YK
 

When my PC turns the screen off (not sleep mode), and then wakes up again, WSJT receives OK.  But when I try to transmit, the CAT/PTT stuff works OK, but no audio is sent to the rig.  I have to restart WSJT to actually transmit a signal.  I just changes PCs, and this didn't happen with my previous PC.  Both were running Win10 through a microKeyerIII to a Yaesu FTDX101.  This may be more of a PC question...  I just don't know where to look...

Thanks, Frank W2YK


rcktscientist64
 

Mine did that when the screen saver came on on the HDMI monitor. I disabled the audio driver for that monitor and it has worked since.

Bruce - K5WBM

On Sep 18, 2020, at 3:56 PM, Frank W2YK <W2YK@arrl.net> wrote:

When my PC turns the screen off (not sleep mode), and then wakes up again, WSJT receives OK. But when I try to transmit, the CAT/PTT stuff works OK, but no audio is sent to the rig. I have to restart WSJT to actually transmit a signal. I just changes PCs, and this didn't happen with my previous PC. Both were running Win10 through a microKeyerIII to a Yaesu FTDX101. This may be more of a PC question... I just don't know where to look...

Thanks, Frank W2YK


Frank W2YK
 

I'm using 3 monitors, 2xHDMI and 1 Display Port.  The old system has one HDMI, a DVI and VGA!.  I'll play around...

Thanks


Steven Rutledge
 

I was just about to follow up on a post I made earlier, actually several.  My receive was locking up after a period of time with new Windows 10 computer.  I'm not an IT guy so I was confounded.  I finally discovered it was the sleep mode on Winows 10.  I don't think I never had my Windows 7 desktop or laptops go into sleep mode.  In fact, I'm not sure I knew it existed.  I leave them on all the time.  Anyway, I started fooling around with sleep mode and it appears that was the problem, I hope.  Just actually came to that conclusion this morning.  Thanks to all who tried to help me out earlier. 

73,

Steve, N4JQQ


JP Tucson, AZ
 

Ya know, 

After reading hundreds of these types of issues during the past 6+ months, it really make one wonder what the real problem is...!

Ask yourselves, why in the hell are these computers going to sleep at all?

The affected components are obviously being used; as proven by the fact that wsjtx quits working when those various components (audio, video, usb, etc.) go off into never, never land. Since wsjtx is constantly running & using resources - nothing should be timing out! 

Given, ms sucks and they have made a crappy system that doesn't work well most of the time.

Is there perhaps some coding that wsjtx can use to send more robust signals thru the the computer system, so that it can't go to sleep?  

73 - John - N7GHZ


On Wed, Oct 28, 2020, 1:50 PM Steven Rutledge <steven.t.rutledge@...> wrote:
I was just about to follow up on a post I made earlier, actually several.  My receive was locking up after a period of time with new Windows 10 computer.  I'm not an IT guy so I was confounded.  I finally discovered it was the sleep mode on Winows 10.  I don't think I never had my Windows 7 desktop or laptops go into sleep mode.  In fact, I'm not sure I knew it existed.  I leave them on all the time.  Anyway, I started fooling around with sleep mode and it appears that was the problem, I hope.  Just actually came to that conclusion this morning.  Thanks to all who tried to help me out earlier. 

73,

Steve, N4JQQ



ve3ki
 

Windows makes its decisions on power-saving actions like sleep mode based on keyboard and mouse activity. It does not know about activity on serial ports, sound cards, etc.

There are settings that can and should be changed to prevent Windows from putting USB devices to sleep unexpectedly. There is a nice summary at <http://www.dxlabsuite.com/dxlabwiki/PreventUSBPortPowerDown>. These settings changes should be applied on any Windows computer that is being used for real-time amateur radio activities.

73,
Rich VE3KI


On Wed, Oct 28, 2020 at 06:03 PM, JP Tucson, AZ wrote:
Ya know, 
 
After reading hundreds of these types of issues during the past 6+ months, it really make one wonder what the real problem is...!
 
Ask yourselves, why in the hell are these computers going to sleep at all?
 
The affected components are obviously being used; as proven by the fact that wsjtx quits working when those various components (audio, video, usb, etc.) go off into never, never land. Since wsjtx is constantly running & using resources - nothing should be timing out! 
 
Given, ms sucks and they have made a crappy system that doesn't work well most of the time.
 
Is there perhaps some coding that wsjtx can use to send more robust signals thru the the computer system, so that it can't go to sleep?  

73 - John - N7GHZ

On Wed, Oct 28, 2020, 1:50 PM Steven Rutledge <steven.t.rutledge@...> wrote:
I was just about to follow up on a post I made earlier, actually several.  My receive was locking up after a period of time with new Windows 10 computer.  I'm not an IT guy so I was confounded.  I finally discovered it was the sleep mode on Winows 10.  I don't think I never had my Windows 7 desktop or laptops go into sleep mode.  In fact, I'm not sure I knew it existed.  I leave them on all the time.  Anyway, I started fooling around with sleep mode and it appears that was the problem, I hope.  Just actually came to that conclusion this morning.  Thanks to all who tried to help me out earlier. 

73,

Steve, N4JQQ



JP Tucson, AZ
 

Hi Rich,

The kb & mouse activity is true, but since you need to move & click the mouse to log, & select new stations to operate...  the system still isn't picking that up.



73 - John - N7GHZ


On Wed, Oct 28, 2020, 3:27 PM ve3ki <ve3iay@...> wrote:
Windows makes its decisions on power-saving actions like sleep mode based on keyboard and mouse activity. It does not know about activity on serial ports, sound cards, etc.

There are settings that can and should be changed to prevent Windows from putting USB devices to sleep unexpectedly. There is a nice summary at <http://www.dxlabsuite.com/dxlabwiki/PreventUSBPortPowerDown>. These settings changes should be applied on any Windows computer that is being used for real-time amateur radio activities.

73,
Rich VE3KI


On Wed, Oct 28, 2020 at 06:03 PM, JP Tucson, AZ wrote:
Ya know, 
 
After reading hundreds of these types of issues during the past 6+ months, it really make one wonder what the real problem is...!
 
Ask yourselves, why in the hell are these computers going to sleep at all?
 
The affected components are obviously being used; as proven by the fact that wsjtx quits working when those various components (audio, video, usb, etc.) go off into never, never land. Since wsjtx is constantly running & using resources - nothing should be timing out! 
 
Given, ms sucks and they have made a crappy system that doesn't work well most of the time.
 
Is there perhaps some coding that wsjtx can use to send more robust signals thru the the computer system, so that it can't go to sleep?  

73 - John - N7GHZ

On Wed, Oct 28, 2020, 1:50 PM Steven Rutledge <steven.t.rutledge@...> wrote:
I was just about to follow up on a post I made earlier, actually several.  My receive was locking up after a period of time with new Windows 10 computer.  I'm not an IT guy so I was confounded.  I finally discovered it was the sleep mode on Winows 10.  I don't think I never had my Windows 7 desktop or laptops go into sleep mode.  In fact, I'm not sure I knew it existed.  I leave them on all the time.  Anyway, I started fooling around with sleep mode and it appears that was the problem, I hope.  Just actually came to that conclusion this morning.  Thanks to all who tried to help me out earlier. 

73,

Steve, N4JQQ






Bill Somerville
 

Hi Rich and John,

that is partially right. For connected devices like serial ports the power save options are not in play as having a connection open is enough to stop power saving. For audio streams there is no connection as such, an application requests or subscribes to a device stream. Those streams source or sink data to a shared resource and Windows will power that device down without regard for any application using it. Applications are not notified when audio streams are shut off by power saving.

73
Bill
G4WJS.

On 28/10/2020 22:26, ve3ki wrote:
Windows makes its decisions on power-saving actions like sleep mode based on keyboard and mouse activity. It does not know about activity on serial ports, sound cards, etc.

There are settings that can and should be changed to prevent Windows from putting USB devices to sleep unexpectedly. There is a nice summary at <http://www.dxlabsuite.com/dxlabwiki/PreventUSBPortPowerDown>. These settings changes should be applied on any Windows computer that is being used for real-time amateur radio activities.

73,
Rich VE3KI


On Wed, Oct 28, 2020 at 06:03 PM, JP Tucson, AZ wrote:
Ya know, 
 
After reading hundreds of these types of issues during the past 6+ months, it really make one wonder what the real problem is...!
 
Ask yourselves, why in the hell are these computers going to sleep at all?
 
The affected components are obviously being used; as proven by the fact that wsjtx quits working when those various components (audio, video, usb, etc.) go off into never, never land. Since wsjtx is constantly running & using resources - nothing should be timing out! 
 
Given, ms sucks and they have made a crappy system that doesn't work well most of the time.
 
Is there perhaps some coding that wsjtx can use to send more robust signals thru the the computer system, so that it can't go to sleep?  

73 - John - N7GHZ

On Wed, Oct 28, 2020, 1:50 PM Steven Rutledge <steven.t.rutledge@...> wrote:
I was just about to follow up on a post I made earlier, actually several.  My receive was locking up after a period of time with new Windows 10 computer.  I'm not an IT guy so I was confounded.  I finally discovered it was the sleep mode on Winows 10.  I don't think I never had my Windows 7 desktop or laptops go into sleep mode.  In fact, I'm not sure I knew it existed.  I leave them on all the time.  Anyway, I started fooling around with sleep mode and it appears that was the problem, I hope.  Just actually came to that conclusion this morning.  Thanks to all who tried to help me out earlier. 

73,

Steve, N4JQQ



Martin G0HDB
 

On Wed, Oct 28, 2020 at 10:26 PM, ve3ki wrote:
Windows makes its decisions on power-saving actions like sleep mode based on keyboard and mouse activity. It does not know about activity on serial ports, sound cards, etc.

There are settings that can and should be changed to prevent Windows from putting USB devices to sleep unexpectedly. There is a nice summary at <http://www.dxlabsuite.com/dxlabwiki/PreventUSBPortPowerDown>. These settings changes should be applied on any Windows computer that is being used for real-time amateur radio activities.
Just to add to the above...

I'm in the process of setting up  a new PC to be used for my amateur radio apps including WSJT-X; the PC has a 3GHz i7-9700 8-core CPU with 16G RAM, a 500G SSD and is running Win 10 Pro.  I'd configured the PC to access one of my NAS devices via the Ethernet LAN and began to notice that even though the PC was set to never go to sleep it was losing its connection to the NAS.

I then twigged that the PC's Ethernet network adaptor's properties had the option to allow Windows to turn off the adaptor to save power checked; disabling that option seems to have cured the problem of the loss of access to the NAS.  All I need to do now is sort out all the other aspects of Win 10 that have been frustrating me...  :-)

--
Martin G0HDB


 

Back when I was working, I worked for a CAD company and had some of the company’s tools installed on a W7 laptop with a Linux VM to run the tools. I was touring European cities and the tools worked fine in the hotel, but in the demonstrations they wouldn’t. The license key was cut for the particular laptop and used the Ethernet MAC address. The second time I booted up the laptop on battery, Windows decided to save power by powering off the Ethernet chip, thereby rendering the MAC address unavailable. If I had a proper dual-boot machine Linux may not have done that.

 

Phil GM3ZZA.

 

Sent from Mail for Windows 10

 

From: Martin G0HDB
Sent: 29 October 2020 10:42
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Windows audio and sleep mode

 

On Wed, Oct 28, 2020 at 10:26 PM, ve3ki wrote:

Windows makes its decisions on power-saving actions like sleep mode based on keyboard and mouse activity. It does not know about activity on serial ports, sound cards, etc.

There are settings that can and should be changed to prevent Windows from putting USB devices to sleep unexpectedly. There is a nice summary at <http://www.dxlabsuite.com/dxlabwiki/PreventUSBPortPowerDown>. These settings changes should be applied on any Windows computer that is being used for real-time amateur radio activities.

Just to add to the above...

I'm in the process of setting up  a new PC to be used for my amateur radio apps including WSJT-X; the PC has a 3GHz i7-9700 8-core CPU with 16G RAM, a 500G SSD and is running Win 10 Pro.  I'd configured the PC to access one of my NAS devices via the Ethernet LAN and began to notice that even though the PC was set to never go to sleep it was losing its connection to the NAS.

I then twigged that the PC's Ethernet network adaptor's properties had the option to allow Windows to turn off the adaptor to save power checked; disabling that option seems to have cured the problem of the loss of access to the NAS.  All I need to do now is sort out all the other aspects of Win 10 that have been frustrating me...  :-)

--
Martin G0HDB

 


--
73 Phil GM3ZZA


groups@...
 

Instructions to prevent USB power downs are to be found here.  Don't forget to include the HDMI interface as well.

http://www.dxlabsuite.com/dxlabwiki/PreventUSBPortPowerDown