#txaudio #linux WSJT-X No TX audio issue #linux #txaudio


KM4OVZ
 

Hello! I'm using the Ubuntu Linux version of WSJT-X. Audio output does not seem to work at this time. Audio input works fine, I can select an input device from Pulse Audio volume control or from inside WSJT-X and it works. Decoding FT-8 works. But output audio does nothing. If I go into TX mode or Tune mode, no output source shows up in Pulse Audio and nothing can be heard on the selected output device. I've tried different devices, different audio adapters and so on. The program simply doesn't put out audio when in TX mode. TX audio works fine when the windows build of WSJT-X is ran through Wine. Audio inputs and outputs work great. However, wine doesn't work well with USB devices and as such rig control does not function.
 
I've tried on many different computers all running Pop OS 21.04 which is an Ubuntu based distro. I'm using the latest stable build of WSJT-X on all of them and they all give the same results with no TX audio. 
 
If you need any more information about our systems or setup I'll be happy to answer them!


Bill Somerville
 

On 26/08/2021 02:11, KM4OVZ wrote:
Hello! I'm using the Ubuntu Linux version of WSJT-X. Audio output does not seem to work at this time. Audio input works fine, I can select an input device from Pulse Audio volume control or from inside WSJT-X and it works. Decoding FT-8 works. But output audio does nothing. If I go into TX mode or Tune mode, no output source shows up in Pulse Audio and nothing can be heard on the selected output device. I've tried different devices, different audio adapters and so on. The program simply doesn't put out audio when in TX mode. TX audio works fine when the windows build of WSJT-X is ran through Wine. Audio inputs and outputs work great. However, wine doesn't work well with USB devices and as such rig control does not function.
I've tried on many different computers all running Pop OS 21.04 which is an Ubuntu based distro. I'm using the latest stable build of WSJT-X on all of them and they all give the same results with no TX audio.
If you need any more information about our systems or setup I'll be happy to answer them!
OM (name?),

telling us which rig you are using, and how it is connected to your PC for audio and CAT control, might allow us to offer some suggestions, without that information we are unlikely to be able to help you.

73
Bill
G4WJS.


Nick
 

No problems here using Ubuntu 18.04 and wsjt-x-2.4.0. But I do not use pulseaudio.

Have you tried setting the TX sound card level in alsamixer? If the level is set to 0 not sure what pulseaudio will make of it.


KM4OVZ
 

The rig I'm trying to use is an icom 7300, as well as a Yaesu FT-100. Both have fine cat control on Linux, with the active frequency showing in wsjtx. TX works fine but there's no audio output. The way audio is sent to the radio is by an external audio port on the computer. Alternatively a USB soundcard can be used for the same result of sending audio out. 

WSJTX has "default" set for both input and output audio. The current devices are set as default and selected in the OS. Playing audio from any other program works as expected. Audio goes in, shows on the waterfall, and decodes fine. Wsjtx just isn't putting out any sound! No sources pop up in pavucontrol when it's in transmit mode either. 

Running 'padsp wsjtx' will make the first transmission have audio, but on the next cycle there's no sound again. 


KM4OVZ
 

TX Power has no effect :(


KM4OVZ
 
Edited

Does the wsjtx soundcard output descriptor match that expected and shown with aplay -l   ?

Yes it matches


Bill Somerville
 

On 26/08/2021 13:38, KM4OVZ wrote:
The rig I'm trying to use is an icom 7300, as well as a Yaesu FT-100. Both have fine cat control on Linux, with the active frequency showing in wsjtx. TX works fine but there's no audio output. The way audio is sent to the radio is by an external audio port on the computer. Alternatively a USB soundcard can be used for the same result of sending audio out.

WSJTX has "default" set for both input and output audio. The current devices are set as default and selected in the OS. Playing audio from any other program works as expected. Audio goes in, shows on the waterfall, and decodes fine. Wsjtx just isn't putting out any sound! No sources pop up in pavucontrol when it's in transmit mode either.

Running 'padsp wsjtx' will make the first transmission have audio, but on the next cycle there's no sound again.
OM (name ??),

do not use the system default audio devices for transmitter Tx audio.

73
Bill
G4WJS.


KM4OVZ
 
Edited

do not use the system default audio devices for transmitter Tx audio
Well I did try selecting the actual device as well but the effect is the same. Default output works fine. It's gotta be an bug on WSJT-X's end because it works fine on the windows version.


KM4OVZ
 

I tried it with my laptop, using an icom 7300. Cat control worked fine and so did the audio. Maybe wsjtx just doesn't play nice with built in soundcards.


Steve K4RVA
 

Sorry, I don't mean to hijack your thread, but I am having the same (or similar) issue.

I installed wsjtx_2.4.0_amd64.deb on a very fresh install of Linux Mint 20.2 Cinnamon on a laptop with integrated audio. Audio input and FT8 decoding works fine. CAT control (Kenwood TS-570D) and PTT via CAT are working.

But when I click either 'Tune' or 'Enable TX', the button will turn red but I do not get any audio out, and the 'wsjtx' process goes straight to 100% CPU utilization. At this point, the waterfall freezes, the audio input level meter goes blank (the green vertical bar disappears), and new decoded messages no longer appear in the Band Activity window. The interface stills responds, ie. I can open any menu items, click the Tune button, but the application is no longer functioning.

When I close WSJT-X (either by clicking the 'X' or via File->Exit), the application windows go away but the 'wsjtx' process is still running at 100% CPU. I can kill it easily with a Ctrl-C from the terminal where I started it, or with a SIGTERM from inside 'top'.

I tried installing it on a different PC, also with Linux Mint 20.2, also with integrated/on-board audio and I got the exact same results.
I tried selecting several of the various audio output devices on both PCs (default, jack, oss, pulse, front, and several others with long cryptic names) and I got the same results.
I looked through ~/.local/share/WSJT-X/*.log and /var/log/syslog, but nothing was immediately apparent. Not exactly sure what to look for, though.
Fldigi outputs audio on both PCs.
It looks like pulseaudio is the audio server being used, but I don't know which other ones to look for in case there is a conflict or something.

Does anyone have any suggestion on where to look next? Is anyone else running 2.4.0 on Linux Mint (or another Ubuntu/Debian variety) successfully?

Cheers,
Steve K4RVA


Steve K4RVA
 

Well, how about this for a coincidence.. I've been futzing around with this for the last two days, and not making any progress. Tonight I received several updates on Linux Mint, which included the kernel and 'alsa-ucm-conf'. I thought I would give it another try and - behold! WSJT-X is now sending audio!

FYI, I have the 'alsa_input...' and 'alsa_output..." audio devices selected in the configuration menu.

Cheers,
Steve K4RVA


Doug
 

Curious if there was a solution to this issue?
I'm having similar troubles with TX and audio output on OpenSuSE Leap 15.3 Linux with all WSJT-x versions (2.4, 2.5 and 2.5.2), software obtained from the 'hamradio' repository.
I've tried this in three different desktop environments (KDE, Cinnamon and LXDE).
The application will decode fine with 'pulse' audio as an input selection, but will not output audio, when using pavucontrol I don't see a virtual audio device populate when attempting any of the transmit functions in WSJT-x. Once TX test or any other TX function is attempted CPU utilization goes to 100% and the waterfall stops responding and closing both windows still leaves the process running in the background and has to be killed.
I can use fldigi with 'pulseaudio' selected as the input/output devices and JTDX with alsa devices selected and they both key the radio via CAT and transmit audio just fine so I know that hamlib and the audio is working but it just doesn't seem to be with WSJT-x.
Also there seems to be something common between WSJT-x and JS8call, as they both exhibit the same symptoms (if that helps).
The PC is a HP-Z420 with a sound device on board Intel c600/x79 which works with other applications (streaming media, multimedia files via VLC, etc). I've attempted using all the different sound devices in the output selection except for the surround devices as I don't have that jack connected to my radio.

Is there a log file location that might shed some light on what is failing in the background?

Doug
N7BFS


Bill Somerville
 

On 23/11/2021 04:32, Doug via groups.io wrote:
Curious if there was a solution to this issue?
I'm having similar troubles with TX and audio output on OpenSuSE Leap 15.3 Linux with all WSJT-x versions (2.4, 2.5 and 2.5.2), software obtained from the 'hamradio' repository.
I've tried this in three different desktop environments (KDE, Cinnamon and LXDE).
The application will decode fine with 'pulse' audio as an input selection, but will not output audio, when using pavucontrol I don't see a virtual audio device populate when attempting any of the transmit functions in WSJT-x. Once TX test or any other TX function is attempted CPU utilization goes to 100% and the waterfall stops responding and closing both windows still leaves the process running in the background and has to be killed.
I can use fldigi with 'pulseaudio' selected as the input/output devices and JTDX with alsa devices selected and they both key the radio via CAT and transmit audio just fine so I know that hamlib and the audio is working but it just doesn't seem to be with WSJT-x.
Also there seems to be something common between WSJT-x and JS8call, as they both exhibit the same symptoms (if that helps).
The PC is a HP-Z420 with a sound device on board Intel c600/x79 which works with other applications (streaming media, multimedia files via VLC, etc). I've attempted using all the different sound devices in the output selection except for the surround devices as I don't have that jack connected to my radio.

Is there a log file location that might shed some light on what is failing in the background?

Doug
N7BFS
Hi Doug,

I would expect the audio devices with alsa in the name to work.

73
Bill
G4WJS.


Doug
 

Agreed Bill, for some reason though it just isn't cooperating on TX...


Bill Somerville
 

On 23/11/2021 22:27, Doug via groups.io wrote:
Agreed Bill, for some reason though it just isn't cooperating on TX...
Hi Doug,

use pavucontrol to monitor the Tx audio level. Use the "Tune" button to check as the stream is only created when a transmission starts.

73
Bill
G4WJS.


Doug
 

Thanks Bill, the stream was not being created when using WSJT-x but was with the aforementioned app's, WSJT-x wasn't even keying the radio.
So after some digging I found a new version of hamlib available in the hamradio repository and installed that and now it (WSJT-x), JS8call and JTDX all transmit as expected :)
The 'vanilla' install of hamlib that SuSE installed appeared to be rather old (version 3.3-bp153) and once I found and installed the version from the hamradio repository (version 4.3.1-lp153.32) WSJT-x started to transmit.

Thanks for responding

Doug
N7BFS


Doug
 

Oh and just in case it helps anyone else, the radio (Yaesu FTDX5000) was being controlled via a 'true' RS232 port (/dev/ttyS0) not a USB converter.