Topics

[SOLVED] Re: [WSJTX] [WSJT-X] Unable to properly #install wsjt=-x auto logging to Log4OM #install


Andy_501
 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
Change the value of "start" to 4, which means disabled.  Reboot PC


All the troubleshooting steps to find a process ID to end and solution was as above:

*************************************************************************
Nothing appears to be using port 80 yet:

both wampache64 service and telnet command below get same results

C:\WINDOWS\system32>telnet 127.0.0.1 80
Connecting To 127.0.0.1...Could not open connection to the host, on port 80: Connect failed

C:\WINDOWS\system32>

no servers launched and all WAMP64 services disabled cmd status requests returned:


C:\WINDOWS\system32>netstat -o -n -a | findstr 0.0:80

C:\WINDOWS\system32>netsh http show servicestate

Snapshot of HTTP service state (Server Session View):
-----------------------------------------------------

Server session ID: FF00000120000001
    Version: 2.0
    State: Active
    Properties:
        Max bandwidth: 4294967295
        Timeouts:
            Entity body timeout (secs): 120
            Drain entity body timeout (secs): 120
            Request queue timeout (secs): 120
            Idle connection timeout (secs): 120
            Header wait timeout (secs): 120
            Minimum send rate (bytes/sec): 150
    URL groups:
    URL group ID: FE00000140000001
        State: Active
        Request queue name: Request queue is unnamed.
        Properties:
            Max bandwidth: inherited
            Max connections: inherited
            Timeouts:
                Timeout values inherited
            Number of registered URLs: 1
            Registered URLs:
                HTTP://*:5357/BBC53C66-F4F2-490C-9501-ED6AC15A2B4F/

Server session ID: FF00000320000001
    Version: 2.0
    State: Active
    Properties:
        Max bandwidth: 4294967295
        Timeouts:
            Entity body timeout (secs): 120
            Drain entity body timeout (secs): 120
            Request queue timeout (secs): 120
            Idle connection timeout (secs): 120
            Header wait timeout (secs): 120
            Minimum send rate (bytes/sec): 150
    URL groups:
    URL group ID: FF00000040000005
        State: Active
        Request queue name: Request queue is unnamed.
        Properties:
            Max bandwidth: inherited
            Max connections: inherited
            Timeouts:
                Timeout values inherited
            Number of registered URLs: 1
            Registered URLs:
                HTTP://LOCALHOST:58941/

Request queues:
    Request queue name: Request queue is unnamed.
        Version: 2.0
        State: Active
        Request queue 503 verbosity level: Basic
        Max requests: 1000
        Number of active processes attached: 1
        Process IDs:
            3060

    Request queue name: Request queue is unnamed.
        Version: 2.0
        State: Active
        Request queue 503 verbosity level: Basic
        Max requests: 1000
        Number of active processes attached: 1
        Process IDs:
            11224




On 2021-02-21 08:44, Andy_501 via groups.io wrote:
It appears Win10 Pro's latest update has made a change to access to port 80 such that Wampache64 portion of the WAMP server bundle does not start.

Thus without apache running phpmyadmin will not give access to a MariadB or mysql Log4OM database if you chose to use that on install of Log4OM. Not sure if https default port was likewise affected. I completely lost all Log4OM db setups when I assumed it was a corrupt WAMP s/w and re-installed it before discovering the port 80 block.

I changed the port config in the wampache64 tools to 8088 and all started normally so it appears I can rebuild the lost log database. If anyone has come across this and has a fix to restore access to the standard http and https ports of 80 & 443 any info and tips would be appreciated.

Some suggested google search fixes suggest it is related to iis service having to be disabled in windows control panel Programs & Features --> turn windows features on/off disable web services but that is already OFF when I checked so that is not causing the block.

Getting WSJT-x to autolog to Log4OM for me on hold now until I can come up with a fix so that all three services apache, Maria/msql dB's and php all work properly with original default port settings so I can safely rebuild the db to work with and have WSJT-x access.


Thanks & 73

Andy ve4per