#raspberryPi #install #install #raspberryPi


Edward Seeliger
 

I have attempted to build wsjtx-2.5.2 for Raspian Bullseye (32 GB card) from source for the RPI Zero W2 following the recipe contained in the source tarball.
The build fails (crashes the RPI Zero W2) at the 61% location (Performing build step for 'wsjtx'). There are no error messages.
I must restart the RPI Zero W2 to recover operation.
The recipe builds hamlib without errors.
I have installed all the dependencies as listed and installed CMake using snap - CMake version 3.22.0 --Classic version. All the dependencies exceed the minimum required versions.
Any suggestions on how to proceed / correct the error are appreciated.
Edd - KD5M


Bill Somerville
 

On 24/11/2021 15:17, Edward Seeliger wrote:
I have attempted to build wsjtx-2.5.2 for Raspian Bullseye (32 GB card) from source for the RPI Zero W2 following the recipe contained in the source tarball.
The build fails (crashes the RPI Zero W2) at the 61% location (Performing build step for 'wsjtx'). There are no error messages.
I must restart the RPI Zero W2 to recover operation.
The recipe builds hamlib without errors.
I have installed all the dependencies as listed and installed CMake using snap - CMake version 3.22.0 --Classic version. All the dependencies exceed the minimum required versions.
Any suggestions on how to proceed / correct the error are appreciated.
Edd - KD5M
Hi Ed,

you may be running out of memory during the build. Make sure you do not add a '-j' option to the build command as parallel building will surely use too much memory.

73
Bill
G4WJS.


William Smith
 

The instructions in the source tarall are much easier to parse if you already know what you are doing.  🤷‍♂️

I got some hints from http://www.kk5jy.net/wsjtx-build/

Here's what I did:

From a clean Bullseye install (11.1) via Raspberry Pi Imager

sudo apt-get install cmake

export CXXFLAGS='-O2 -march=native -mtune=native'
export CFLAGS='-O2 -march=native -mtune=native'

sudo apt-get install emacs-nox (or your favorite editor to build the script below)
build a script from the webpage above and execute it (takes a long time)

wget https://github.com/Hamlib/Hamlib/releases/download/4.3.1/hamlib-4.3.1.tar.gz
tar xvzf <that>
cd <there>
/configure --prefix=/usr/local --enable-static
make
sudo make install
sudo ldconfig
rigctl --version shows: rigctl Hamlib 4.3.1 Mon Sep 13
which rigctl returns: /usr/local/bin/rigctl
reboot to confirm somehting doesn't break
Success!

----------  Now for wsjt-x

export CXXFLAGS='-O2 -march=native -mtune=native'
export CFLAGS='-O2 -march=native -mtune=native'

wget https://physics.princeton.edu/pulsar/k1jt/wsjtx-2.5.2.tgz
tar xvzf <that>
cd <there>
cd src
[Aha!  This is where hamlib 4.4 comes from!]
tar -zxvf wsjtx.tgz
mkdir build
cd build
cmake ../wsjtx
make
sudo make install


Hope this helps!

73, Willie N1JBJ

On Nov 24, 2021, at 10:17 AM, Edward Seeliger <eseeliger@...> wrote:

I have attempted to build wsjtx-2.5.2 for Raspian Bullseye (32 GB card) from source for the RPI Zero W2 following the recipe contained in the source tarball.
The build fails (crashes the RPI Zero W2) at the 61% location (Performing build step for 'wsjtx'). There are no error messages.
I must restart the RPI Zero W2 to recover operation.
The recipe builds hamlib without errors.
I have installed all the dependencies as listed and installed CMake using snap - CMake version 3.22.0 --Classic version. All the dependencies exceed the minimum required versions.
Any suggestions on how to proceed / correct the error are appreciated.
Edd - KD5M




Bill Somerville
 

Willie,

the INSTALL instructions are a lot easier if you follow them, hi!

There is no need to build Hamlib separately if you use the WSJT-X sources tarball we provide, in fact it is pointless as the sources tarball already includes Hamlib and the build script builds Hamlib and statically links it into WSJT-X.

73
Bill
G4WJS.

On 24/11/2021 15:24, William Smith wrote:
The instructions in the source tarall are much easier to parse if you already know what you are doing.  🤷‍♂️

I got some hints from http://www.kk5jy.net/wsjtx-build/

Here's what I did:

From a clean Bullseye install (11.1) via Raspberry Pi Imager

sudo apt-get install cmake

export CXXFLAGS='-O2 -march=native -mtune=native'
export CFLAGS='-O2 -march=native -mtune=native'

sudo apt-get install emacs-nox (or your favorite editor to build the script below)
build a script from the webpage above and execute it (takes a long time)

wget https://github.com/Hamlib/Hamlib/releases/download/4.3.1/hamlib-4.3.1.tar.gz
tar xvzf <that>
cd <there>
/configure --prefix=/usr/local --enable-static
make
sudo make install
sudo ldconfig
rigctl --version shows: rigctl Hamlib 4.3.1 Mon Sep 13
which rigctl returns: /usr/local/bin/rigctl
reboot to confirm somehting doesn't break
Success!

----------  Now for wsjt-x

export CXXFLAGS='-O2 -march=native -mtune=native'
export CFLAGS='-O2 -march=native -mtune=native'

wget https://physics.princeton.edu/pulsar/k1jt/wsjtx-2.5.2.tgz
tar xvzf <that>
cd <there>
cd src
[Aha!  This is where hamlib 4.4 comes from!]
tar -zxvf wsjtx.tgz
mkdir build
cd build
cmake ../wsjtx
make
sudo make install


Hope this helps!

73, Willie N1JBJ

On Nov 24, 2021, at 10:17 AM, Edward Seeliger <eseeliger@...> wrote:

I have attempted to build wsjtx-2.5.2 for Raspian Bullseye (32 GB card) from source for the RPI Zero W2 following the recipe contained in the source tarball.
The build fails (crashes the RPI Zero W2) at the 61% location (Performing build step for 'wsjtx'). There are no error messages.
I must restart the RPI Zero W2 to recover operation.
The recipe builds hamlib without errors.
I have installed all the dependencies as listed and installed CMake using snap - CMake version 3.22.0 --Classic version. All the dependencies exceed the minimum required versions.
Any suggestions on how to proceed / correct the error are appreciated.
Edd - KD5M



Edward Seeliger
 

Good afternoon Bill - thanks.
I did not add any suffixes (-j) / options to the build command except as specified in the tarball instructions. But that is what I suspect is happening.
I will have to research (learn again) how to change (temporaily) the memory allotment on the RPI and see if that works.
Thanks.
Edd - KD5M


Bill Somerville
 

On 24/11/2021 16:30, Edward Seeliger wrote:
Good afternoon Bill - thanks.
I did not add any suffixes (-j) / options to the build command except as specified in the tarball instructions. But that is what I suspect is happening.
I will have to research (learn again) how to change (temporaily) the memory allotment on the RPI and see if that works.
Thanks.
Edd - KD5M
Hi Edd,

OK. Make sure you don't have other unnecessary applications running while the build is running. I have not tried a build on a Pi Zero, I believe the Pi Zero 2 W only has 1/2 Gbyte of RAM and that may well not be enough. Do you have another Pi system with more memory you can build on?

73
Bill
G4WJS.


Karza
 

Hi Edd,

perhaps you could try to use the -j parameter to reduce the number of parallelism of the compile process. ( Even down to 1 )

Of course the compile will then take ( a lot ) more time, but might actually succeed.

( Once upon a time I was too eager and pecified too large number for -j which then caused compile failure. )

73's de Kari, oh2gqc




On 24.11.2021 18.30, Edward Seeliger wrote:
Good afternoon Bill - thanks.
I did not add any suffixes (-j) / options to the build command except as specified in the tarball instructions. But that is what I suspect is happening.
I will have to research (learn again) how to change (temporaily) the memory allotment on the RPI and see if that works.
Thanks.
Edd - KD5M


Bill Somerville
 

Hi Karl,

the default with no '-j' argument is a serial build, equivalent to '-j1'.

73
Bill
G4WJS.

On 24/11/2021 17:13, Karza wrote:
Hi Edd,

perhaps you could try to use the -j parameter to reduce the number of parallelism of the compile process. ( Even down to 1 )

Of course the compile will then take ( a lot ) more time, but might actually succeed.

( Once upon a time I was too eager and pecified too large number for -j which then caused compile failure. )

73's de Kari, oh2gqc




On 24.11.2021 18.30, Edward Seeliger wrote:
Good afternoon Bill - thanks.
I did not add any suffixes (-j) / options to the build command except as specified in the tarball instructions. But that is what I suspect is happening.
I will have to research (learn again) how to change (temporaily) the memory allotment on the RPI and see if that works.
Thanks.
Edd - KD5M



Karza
 

Thanks for the info Bill.

I should have known... :(

'Kari

On 24.11.2021 19.15, Bill Somerville wrote:
Hi Karl,

the default with no '-j' argument is a serial build, equivalent to '-j1'.

73
Bill
G4WJS.

On 24/11/2021 17:13, Karza wrote:
Hi Edd,

perhaps you could try to use the -j parameter to reduce the number of parallelism of the compile process. ( Even down to 1 )

Of course the compile will then take ( a lot ) more time, but might actually succeed.

( Once upon a time I was too eager and pecified too large number for -j which then caused compile failure. )

73's de Kari, oh2gqc




On 24.11.2021 18.30, Edward Seeliger wrote:
Good afternoon Bill - thanks.
I did not add any suffixes (-j) / options to the build command except as specified in the tarball instructions. But that is what I suspect is happening.
I will have to research (learn again) how to change (temporaily) the memory allotment on the RPI and see if that works.
Thanks.
Edd - KD5M







Loyd
 

Hello Mr. Edd
I have heard that the Bulleye os has some issues with installing some programs.
go back Buster and try install WSJTX
 here is a link to get it if needed


On Wed, Nov 24, 2021 at 10:18 AM Edward Seeliger <eseeliger@...> wrote:
I have attempted to build wsjtx-2.5.2 for Raspian Bullseye (32 GB card) from source for the RPI Zero W2 following the recipe contained in the source tarball.
The build fails (crashes the RPI Zero W2) at the 61% location (Performing build step for 'wsjtx'). There are no error messages.
I must restart the RPI Zero W2 to recover operation.
The recipe builds hamlib without errors.
I have installed all the dependencies as listed and installed CMake using snap - CMake version 3.22.0 --Classic version. All the dependencies exceed the minimum required versions.
Any suggestions on how to proceed / correct the error are appreciated.
Edd - KD5M




--
Loyd C. Headrick
WX4LH


Edward Seeliger
 

Good afternoon Loyd, Kari, and Bill - thanks to all for your suggestions.
I have WSJTX 2.5.2 installed and working on multiple OS Buster / RPI 3 and RPI4s. I will try the build procedure on an RPI4 with Bullseye soon.
There were no other applications running except nano for me to read the build instructions from the INSTALL file.
But I wanted to add it to a new RPI Zero W2 I have recently received (as much as anythng to try to run the build from source process).
Yes Bill, the RPI Zero 2 W has only 512 MB of SDRAM - if that is too little to allow the build process to run then so be it - it was worth a try (and a learning exercise for me).
Have a great Thanksgiving tomorrow (you can enjoy it with us if you like Kari and Bill!).
Edd - KD5M


Edward Seeliger
 

Good evening Bill.
I have successfully used the install recipe contained in the source tarball to build WSJTX 2.5.2 on an RPI 4B (4GB SDRAM) on RPI OS Bullseye.
But I believe the last line in the recipe is incorrect -- "sudo cmake --build . --target install" gives an error "sudo: cmake: command not found". I think the correct script should be "sudo make install" - that command runs and installs wsjtx 2.5.2 into /usr/local/bin and will run from that location, albeit without a desktop icon. It must be run with the RUN command or migrate to the folder and click on it.

The tarball recipe will not run beyond building hamlib on my RPI Zero W2 (500MB SDRAM) on RPI OS Bullseye.

Please verify my change for the last line in the recipe is correct.

Thanks for your help. As always, I learned some more about Linux and Raspian!

Edd - KD5M


Bill Somerville
 

On 25/11/2021 04:06, Edward Seeliger wrote:
Good evening Bill.
I have successfully used the install recipe contained in the source tarball to build WSJTX 2.5.2 on an RPI 4B (4GB SDRAM) on RPI OS Bullseye.
But I believe the last line in the recipe is incorrect -- "sudo cmake --build . --target install" gives an error "sudo: cmake: command not found". I think the correct script should be "sudo make install" - that command runs and installs wsjtx 2.5.2 into /usr/local/bin and will run from that location, albeit without a desktop icon. It must be run with the RUN command or migrate to the folder and click on it.

The tarball recipe will not run beyond building hamlib on my RPI Zero W2 (500MB SDRAM) on RPI OS Bullseye.

Please verify my change for the last line in the recipe is correct.

Thanks for your help. As always, I learned some more about Linux and Raspian!

Edd - KD5M

Hi Edd,

because you have not installed the cmake Debian package, root does not have cmake on its PATH. Try:

sudo -E cmake --build . --target install

although that may also fail depending on the security options set for sudo. The issue is not the command but the way you have installed CMake. Probably easier to install the distribution cmake package.

I thought you wanted to run on your Pi Zero, to do that try making a Debian package that you can then move to your target machine to install with dpkg.

cmake --build . --target package

You may need to install more packages for the package target to complete.

73
Bill
G4WJS.


Edward Seeliger
 

Good morning Bill
sudo -E cmake .... didn't work. I also tried to install cmake on a fresh OS Bullseye image using the sh script as described on the cmake site - that didn't seem to work either.
On my RPI 4B 4GB I started with a clean RPI OS Bullseye again, installed all the prerequisites from the INSTALL recipe using APT package manager including cmake and built the install and package versions following the recipe. It all works as it should.
Thanks for your help.
Yes, my original goal was to build and install on the RPI Zero W2. Now I must learn how to move the wsjtx package version from one RPI to another.
There is always something else to learn.
Have a nice weekend.
Edd - KD5M


Bill Somerville
 

On 25/11/2021 16:10, Edward Seeliger wrote:
Good morning Bill
sudo -E cmake .... didn't work. I also tried to install cmake on a fresh OS Bullseye image using the sh script as described on the cmake site - that didn't seem to work either.
On my RPI 4B 4GB I started with a clean RPI OS Bullseye again, installed all the prerequisites from the INSTALL recipe using APT package manager including cmake and built the install and package versions following the recipe. It all works as it should.
Thanks for your help.
Yes, my original goal was to build and install on the RPI Zero W2. Now I must learn how to move the wsjtx package version from one RPI to another.
There is always something else to learn.
Have a nice weekend.
Edd - KD5M

Edd,

have you tried installing the default cmake package from the Raspberry Pi OS repository?

sudo apt install cmake

73
Bill
G4WJS.


Gary trock
 

Pardon my ignorance. These discussions are so far above me. Are many of you software professionals or can you point out to me reading to help me better understand?
Gary N8GT


On Nov 25, 2021, at 8:17 AM, Bill Somerville <g4wjs@...> wrote:


On 25/11/2021 16:10, Edward Seeliger wrote:
Good morning Bill
sudo -E cmake .... didn't work. I also tried to install cmake on a fresh OS Bullseye image using the sh script as described on the cmake site - that didn't seem to work either.
On my RPI 4B 4GB I started with a clean RPI OS Bullseye again, installed all the prerequisites from the INSTALL recipe using APT package manager including cmake and built the install and package versions following the recipe. It all works as it should.
Thanks for your help.
Yes, my original goal was to build and install on the RPI Zero W2. Now I must learn how to move the wsjtx package version from one RPI to another.
There is always something else to learn.
Have a nice weekend.
Edd - KD5M

Edd,

have you tried installing the default cmake package from the Raspberry Pi OS repository?

sudo apt install cmake

73
Bill
G4WJS.





Bill Somerville
 

Gary,

Edd is trying to install WSJT-X on a Raspberry Pi Zero 2 W board. He can't use the Debian package we provide because he has installed a later version of Raspberry Pi OS on his board which means he needs to to compile WSJT-X from sources. He can't do that on the target board because it has insufficient RAM to complete the build. He is able to build on another Raspberry Pi with more resources and then should be able to build a Debian package that he can transfer to the target board and install.

If any of that is relevant to you then let us know what issues you have?

73
Bill
G4WJS.

On 25/11/2021 16:25, Gary trock wrote:
Pardon my ignorance. These discussions are so far above me. Are many of you software professionals or can you point out to me reading to help me better understand?
Gary N8GT


On Nov 25, 2021, at 8:17 AM, Bill Somerville <g4wjs@...> wrote:


On 25/11/2021 16:10, Edward Seeliger wrote:
Good morning Bill
sudo -E cmake .... didn't work. I also tried to install cmake on a fresh OS Bullseye image using the sh script as described on the cmake site - that didn't seem to work either.
On my RPI 4B 4GB I started with a clean RPI OS Bullseye again, installed all the prerequisites from the INSTALL recipe using APT package manager including cmake and built the install and package versions following the recipe. It all works as it should.
Thanks for your help.
Yes, my original goal was to build and install on the RPI Zero W2. Now I must learn how to move the wsjtx package version from one RPI to another.
There is always something else to learn.
Have a nice weekend.
Edd - KD5M

Edd,

have you tried installing the default cmake package from the Raspberry Pi OS repository?

sudo apt install cmake

73
Bill
G4WJS.



Gary trock
 

No current issues but I don’t understand most of this. 


On Nov 25, 2021, at 8:31 AM, Bill Somerville <g4wjs@...> wrote:


Gary,

Edd is trying to install WSJT-X on a Raspberry Pi Zero 2 W board. He can't use the Debian package we provide because he has installed a later version of Raspberry Pi OS on his board which means he needs to to compile WSJT-X from sources. He can't do that on the target board because it has insufficient RAM to complete the build. He is able to build on another Raspberry Pi with more resources and then should be able to build a Debian package that he can transfer to the target board and install.

If any of that is relevant to you then let us know what issues you have?

73
Bill
G4WJS.

On 25/11/2021 16:25, Gary trock wrote:
Pardon my ignorance. These discussions are so far above me. Are many of you software professionals or can you point out to me reading to help me better understand?
Gary N8GT


On Nov 25, 2021, at 8:17 AM, Bill Somerville <g4wjs@...> wrote:


On 25/11/2021 16:10, Edward Seeliger wrote:
Good morning Bill
sudo -E cmake .... didn't work. I also tried to install cmake on a fresh OS Bullseye image using the sh script as described on the cmake site - that didn't seem to work either.
On my RPI 4B 4GB I started with a clean RPI OS Bullseye again, installed all the prerequisites from the INSTALL recipe using APT package manager including cmake and built the install and package versions following the recipe. It all works as it should.
Thanks for your help.
Yes, my original goal was to build and install on the RPI Zero W2. Now I must learn how to move the wsjtx package version from one RPI to another.
There is always something else to learn.
Have a nice weekend.
Edd - KD5M

Edd,

have you tried installing the default cmake package from the Raspberry Pi OS repository?

sudo apt install cmake

73
Bill
G4WJS.






Edward Seeliger
 
Edited

Good morning again Bill.
Yes, using apt to install cmake worked.
I moved the package from the RPI 4 to the RPI Zero using a memory stick (had not occurred to me that they can be read by the RPI OS when I previously used it on Windows machines).
wsjtx is now installed on the RPI Zero W2 and opens without errors - it even has the wsjtx icon installed.

Gary, I am not a software professional but a mere ham who likes to tinker. To learn more just use your search engine of choice - you can eventually find answers to most of your questions about Linux, Raspian OS, Debian, Windows operating systems as you need. And sometimes there is someone like Bill who can provide the snippet of guidance to push you forward.

I apologize to those who found this thread not of interest in this forum, but maybe someone else trying to build wsjtx on the RPI Zero want use his time as I have.

Happy Thanksgiving to those in the US.
Bill, again, thanks for your help and all you and the team have done in perfecting wsjtx for us weak signal hams!

Edd - KD5M


Gary trock
 

I am interested in ALL these discussions on this group. I’m hoping to better understand most of it in the future.
Gary


On Nov 25, 2021, at 8:44 AM, Edward Seeliger <eseeliger@...> wrote:



[Edited Message Follows]

Good morning again Bill.
Yes, using apt to install cmake worked.
I moved the package from the RPI 4 to the RPI Zero using a memory stick (had not occurred to me that they can be read by the RPI OS when I previously used it on Windows machines).
wsjtx is now installed on the RPI Zero W2 and opens without errors - it even has the wsjtx icon installed.

Gary, I am not a software professional but a mere ham who likes to tinker. To learn more just use your search engine of choice - you can eventually find answers to most of your questions about Linux, Raspian OS, Debian, Windows operating systems as you need. And sometimes there is someone like Bill who can provide the snippet of guidance to push you forward.

I apologize to those who found this thread not of interest in this forum, but maybe someone else trying to build wsjtx on the RPI Zero want use his time as I have.

Happy Thanksgiving to those in the US.
Bill, again, thanks for your help and all you and the team have done in perfecting wsjtx for us weak signal hams!

Edd - KD5M