Topics

moderated Possible solution to crashes & slow/intermittent operation #install #wsjt-x-crashing


JP Tucson, AZ
 

Hello,
 
Found this in a news story today - it may explain some of our issues with 
slow running & crashes using windows 10.
 
If I've said it once, I've said it a million times folks - WINDOWS SUCKS!!!
 

Reports of Game Mode [which is by default always ON! - stupid windows!] leading to stutters and frozen screens with both NVIDIA and AMD graphics hardware. 

 [Turns out, I too have a NVIDIA video card]

Why could this happen? Well, all we have is speculation. However, in allocating more hardware resources to a PC game and deprioritizing background tasks, Game Mode could theoretically take resources away from important background tasks, causing system stutters or slowing the game itself down. Or perhaps there are just strange bugs in Game Mode with specific games or graphics drivers. Windows is very complicated. [Translation: windows sucks!!!]  [I know, I am starting to sound like a broken record...]

Either way, if you encounter strange problems—stutters, freezes, crashes, or all-around low FPS—while playing a PC game, you might want to disable Game Mode and see if that solves your problem. It’s a useful troubleshooting step.

How to Enable and Disable Windows 10’s Game Mode

To control Game Mode, open the Settings window from the Start menu or by pressing Windows+i. Head to Settings > Gaming > Game Mode.

 

Here, you’ll find just a single setting: Game Mode, which you can turn on or off. By default, it’s on. If you’d like to disable Game Mode, just click the switch and set it to “Off.”

Game Mode settings on Windows 10That’s it.

Source:

https://www.howtogeek.com/706859/did-you-know-windows-10-pcs-have-game-mode-on-by-default/


Good luck!  Hope this helps!

73 - John - N7GHZ


bill.neuro
 

GOOD GOLLY!!!!!  I think you have done it.

I have been losing entire frames of FT-4 messages for as long as I have been using wsjtx.

My main attempts to fix it have been to reduce LPC latency, but nothing has worked. But after I disabled Win10's Game Mode, IT WORKS! It seems to be decoding every transmission. It still gives me an empty frame after I switch bands, but that is ok.

Thank you for the tip. I hope others try it, too 

Bill K2NS

Sent from my T-Mobile 5G Device


-------- Original message --------
From: "JP Tucson, AZ" <samcat88az@...>
Date: 1/12/21 5:03 PM (GMT-05:00)
To: main@WSJTX.groups.io
Subject: [WSJTX] Possible solution to crashes & slow/intermittent operation #wsjt-x-crashing #install

Hello,
 
Found this in a news story today - it may explain some of our issues with 
slow running & crashes using windows 10.
 
If I've said it once, I've said it a million times folks - WINDOWS SUCKS!!!
 

Reports of Game Mode [which is by default always ON! - stupid windows!] leading to stutters and frozen screens with both NVIDIA and AMD graphics hardware. 

 [Turns out, I too have a NVIDIA video card]

Why could this happen? Well, all we have is speculation. However, in allocating more hardware resources to a PC game and deprioritizing background tasks, Game Mode could theoretically take resources away from important background tasks, causing system stutters or slowing the game itself down. Or perhaps there are just strange bugs in Game Mode with specific games or graphics drivers. Windows is very complicated. [Translation: windows sucks!!!]  [I know, I am starting to sound like a broken record...]

Either way, if you encounter strange problems—stutters, freezes, crashes, or all-around low FPS—while playing a PC game, you might want to disable Game Mode and see if that solves your problem. It’s a useful troubleshooting step.

How to Enable and Disable Windows 10’s Game Mode

To control Game Mode, open the Settings window from the Start menu or by pressing Windows+i. Head to Settings > Gaming > Game Mode.

 

Here, you’ll find just a single setting: Game Mode, which you can turn on or off. By default, it’s on. If you’d like to disable Game Mode, just click the switch and set it to “Off.”

Game Mode settings on Windows 10That’s it.

Source:

https://www.howtogeek.com/706859/did-you-know-windows-10-pcs-have-game-mode-on-by-default/


Good luck!  Hope this helps!

73 - John - N7GHZ


JP Tucson, AZ
 

Hi Bill, 

Well that's fantastic, I am glad it solved your issues! 🙂

But in all fairness, I didn't come up with the solution, just saw the article & put 2 & 2 together, as it seemed to sound quite familiar to the issues many folks here have discussed.

Again, I am glad you are running smoothly & I hope this helps all of us having similar issues.

Good hunting on the air!

73 - John - N7GHZ


On Tue, Jan 12, 2021, 7:27 PM bill.neuro <k1ns@...> wrote:
GOOD GOLLY!!!!!  I think you have done it.

I have been losing entire frames of FT-4 messages for as long as I have been using wsjtx.

My main attempts to fix it have been to reduce LPC latency, but nothing has worked. But after I disabled Win10's Game Mode, IT WORKS! It seems to be decoding every transmission. It still gives me an empty frame after I switch bands, but that is ok.

Thank you for the tip. I hope others try it, too 

Bill K2NS

Sent from my T-Mobile 5G Device


-------- Original message --------
From: "JP Tucson, AZ" <samcat88az@...>
Date: 1/12/21 5:03 PM (GMT-05:00)
Subject: [WSJTX] Possible solution to crashes & slow/intermittent operation #wsjt-x-crashing #install

Hello,
 
Found this in a news story today - it may explain some of our issues with 
slow running & crashes using windows 10.
 
If I've said it once, I've said it a million times folks - WINDOWS SUCKS!!!
 

Reports of Game Mode [which is by default always ON! - stupid windows!] leading to stutters and frozen screens with both NVIDIA and AMD graphics hardware. 

 [Turns out, I too have a NVIDIA video card]

Why could this happen? Well, all we have is speculation. However, in allocating more hardware resources to a PC game and deprioritizing background tasks, Game Mode could theoretically take resources away from important background tasks, causing system stutters or slowing the game itself down. Or perhaps there are just strange bugs in Game Mode with specific games or graphics drivers. Windows is very complicated. [Translation: windows sucks!!!]  [I know, I am starting to sound like a broken record...]

Either way, if you encounter strange problems—stutters, freezes, crashes, or all-around low FPS—while playing a PC game, you might want to disable Game Mode and see if that solves your problem. It’s a useful troubleshooting step.

How to Enable and Disable Windows 10’s Game Mode

To control Game Mode, open the Settings window from the Start menu or by pressing Windows+i. Head to Settings > Gaming > Game Mode.

 

Here, you’ll find just a single setting: Game Mode, which you can turn on or off. By default, it’s on. If you’d like to disable Game Mode, just click the switch and set it to “Off.”

Game Mode settings on Windows 10That’s it.

Source:

https://www.howtogeek.com/706859/did-you-know-windows-10-pcs-have-game-mode-on-by-default/


Good luck!  Hope this helps!

73 - John - N7GHZ




Charlie Hoffman
 

Thank you for that info.
I will turn off the gaming mode but I do frequently use the screen or video capture features so I'll need to remember to reenable it when needed.

My largest boost in performance was from changing from MS Access to MySQL for my HRD logging.
The larger the DB got the slower my system ran.   I even had to limit my log size to one year at a time.
Now that I changed to MySQL, the DB size does not seem to have an slowing effect on speed.

The next best performance increase came from changing from a mechanical disk drive to a SSD.
They are so inexpensive now that I highly recommend that everyone change and use the original drive as a backup.

I'm using a I7 laptop with W10 for my HAM computing needs.


bill.neuro
 

Can you explain how you switch to MySQL. Is this some kind of feature in HRD? I use Win10 and HRD with my FTdx3000 and wsjt-x and have been pleased.

My log has about 3,000 QSOs, but wsjt-x logs new QSOs into HRD cleanly and quickly. I manually enter SSB and CW QSOs into the HRD log, and that's smooth too. But maybe it's screwing with my decodes. Did you dump HRD's log altogether, or is there some kind of mod?

Bill K1NS

Sent from my T-Mobile 5G Device


-------- Original message --------
From: Charlie Hoffman <hoffmanc@...>
Date: 1/13/21 2:04 PM (GMT-05:00)
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Possible solution to crashes & slow/intermittent operation #install #wsjt-x-crashing

Thank you for that info.
I will turn off the gaming mode but I do frequently use the screen or video capture features so I'll need to remember to reenable it when needed.

My largest boost in performance was from changing from MS Access to MySQL for my HRD logging.
The larger the DB got the slower my system ran.   I even had to limit my log size to one year at a time.
Now that I changed to MySQL, the DB size does not seem to have an slowing effect on speed.

The next best performance increase came from changing from a mechanical disk drive to a SSD.
They are so inexpensive now that I highly recommend that everyone change and use the original drive as a backup.

I'm using a I7 laptop with W10 for my HAM computing needs.


Charlie Hoffman
 

There is a lot of info on this forum about the change.
This video will provide better instructions than I can provide.

Installing MySQL (MariaDB) for your HRD Logbook - Bing video