new version 25 doesnt switch ic9100 to usb-d mode #Cat_RigControl #Icom


bob lee
 

hi all, upgraded from version 24 to version 25 and have noticed the new version doesnt put my 9100 into data mode, it stays in usb (voice) mode
I've switch back to version 24 which like all the others I've used, switches the rig to usb-d mode
I cant find anything in the config screens thats different.
Is there somewhere to change the commands sent to initialize the rig
The rig is connected to the computer through the usb cable

thanks Bob VE3CGA


Bill Somerville
 

On 14/10/2021 00:47, bob lee wrote:
hi all, upgraded from version 24 to version 25 and have noticed the new version doesnt put my 9100 into data mode, it stays in usb (voice) mode
I've switch back to version 24 which like all the others I've used, switches the rig to usb-d mode
I cant find anything in the config screens thats different.
Is there somewhere to change the commands sent to initialize the rig
The rig is connected to the computer through the usb cable

thanks Bob VE3CGA
Hi Bob,

so I can see what is happening please run the following test.

Put the attached file into your WSJT-X configuration files directory (on MS Windows that is the same as the log files directory "Menu->Open log directory"), restart WSJT-X, carry out a *minimal* test that demonstrates the issue, then quit WSJT-X. It will have created a file called WSJT-X_RigControl.log on your Desktop. Send me (g4wjs <at> classdesign <dot> com) the log file for analysis please?

Once you have sent the log file you can delete the log file and log configuration file to return to normal operation.

73
Bill
G4WJS.


bob lee
 

thanks Bill, the file is on the way

Bob VE3CGA


Bill Somerville
 

On 14/10/2021 13:11, bob lee wrote:
thanks Bill, the file is on the way

Bob VE3CGA
Hi Bob,

this has been confirmed as a Hamlib regression which has recently been repaired, as you are on Windows you can try using an updated Hamlib DLL. Try putting the libhamlib-4.dll from the bin directory in this archive of the daily Hamlib snapshot builds into your WSJT-X bin directory (C:\WSJT\wsjtx\bin\):

http://n0nb.users.sourceforge.net/hamlib-w64-4.4~git-16a879bc-20211014.zip

This assumes you are using a 64-bit install of WSJT-X. If you are using a 32-bit install then the 32-bit archive is available from here:

http://n0nb.users.sourceforge.net/

73
Bill
G4WJS.


bob lee
 

Hi Bill, well just about there.
the usb-d mode is now selected going into wsjtx
however the rig is put into filter 2 which really narrows the field of view
additionally it leaves the USB mode in filter#2 as version 24 does as I found out yesterday (below)

Running version 24 I never realized it (originally thought it had been previously set by me) but although it starts up just fine with usb-d mode & filter set at #1, when I exit and manually switch back out of data mode, whatever band was selected with wsjt-x is left in filter #2 even though wsjt-x ran in data mode with the filter set to filter #1.
In other words, with wsjtx exited, manually switching to usb mode the filter is now filter #2. Manually switching back to data mode shows filter #1 (good)

I dont know if the data mode ON cmd $FEFE7cE01A060101FD could be inserted into the 9100 configuration 
Different program but I have do this with mmsstv radio commands for each bands then I deselect, put mode back to USB with filter untouched: $FEFE7cE01A060000FD

From the manual pg 193:

 
I wonder if there is somewhere in the wsjtx files where I could insert these command strings

tnx Bob VE3CGA


bob lee
 

Hi Bill, I sent a few minutes ago but it must have gone to cyberspace so I'll try again

I added the dll to ver25 and it does startup data mode (great) however the filter is changed to #2 position which is narrower

Yesterday I noticed after using ver 24 that is sets up fine  usb=d and filter #1 but after closing wsjtx and going back to just USB mode that the filter was selected as #2
I had noticed this before but thought I had selected it working SSB with some adjacent qrm

So when I use mmsstv I set it up in the menus to call the freq (not shown) and usb data mode FEFE7cE01A060101FD
I also setup a data mode off button for when I leave mmsstv FEFE7cE01A060000FD

I'm wondering if there is some place in the files where as wsjtx is initialized that the USB data mode command could be inserted
This was from the manual pg 193

I though of using a script or bat file but I think wsjtx would write over it with the usb-d with filter#2

thanks, Bob VE3CGA


Michael Black
 

I've gone back and forth with Icom several times....

Their default mode is filter 2 and I used to force it to filter 1.  I changed hamlib to let the rig default to whatever it wants and if Icom ever fixes that (not holding my breath) so that the filter follows the band stack then everybody will be happy.

Meanwhile you need to set filter 2 to your data mode wide filter.

My other choice is to do same as FLRig and "remember" whatever filter you select but hamlib currently doesn't try to remember anything so would be a significant change to having hamlib save a config file.

Mike W9MDB




On Friday, October 15, 2021, 10:24:58 AM CDT, bob lee <ve3cga@...> wrote:


Hi Bill, well just about there.
the usb-d mode is now selected going into wsjtx
however the rig is put into filter 2 which really narrows the field of view
additionally it leaves the USB mode in filter#2 as version 24 does as I found out yesterday (below)

Running version 24 I never realized it (originally thought it had been previously set by me) but although it starts up just fine with usb-d mode & filter set at #1, when I exit and manually switch back out of data mode, whatever band was selected with wsjt-x is left in filter #2 even though wsjt-x ran in data mode with the filter set to filter #1.
In other words, with wsjtx exited, manually switching to usb mode the filter is now filter #2. Manually switching back to data mode shows filter #1 (good)

I dont know if the data mode ON cmd $FEFE7cE01A060101FD could be inserted into the 9100 configuration 
Different program but I have do this with mmsstv radio commands for each bands then I deselect, put mode back to USB with filter untouched: $FEFE7cE01A060000FD

From the manual pg 193:

 
I wonder if there is somewhere in the wsjtx files where I could insert these command strings

tnx Bob VE3CGA




Bill Somerville
 

Mike,

WSJT-X always requests a mode change with no change in the filter settings. I know this is somewhat problematic with some Icom rigs that do not allow reading the filter settings on the SPLIT Tx VFO without swapping VFOs. Perhaps those that want to use the Icom default filter settings and can't be bothered to customize them as needed should be forced to put up with VFO swapping when changing modes in SPLIT, so Hamlib can read the current filter settings and honour the RIG_PASSBAND_NOCHANGE option by reading the current value to reuse just before setting the mode.

Note that WSJT-X always requests a mode switch (possible redundant) when setting the frequency, this will not change as it copes well with inadvertent operator mode changes via the front panel.

73
Bill
G4WJS.

On 15/10/2021 16:47, Michael Black via groups.io wrote:
I've gone back and forth with Icom several times....

Their default mode is filter 2 and I used to force it to filter 1.  I changed hamlib to let the rig default to whatever it wants and if Icom ever fixes that (not holding my breath) so that the filter follows the band stack then everybody will be happy.

Meanwhile you need to set filter 2 to your data mode wide filter.

My other choice is to do same as FLRig and "remember" whatever filter you select but hamlib currently doesn't try to remember anything so would be a significant change to having hamlib save a config file.

Mike W9MDB




On Friday, October 15, 2021, 10:24:58 AM CDT, bob lee <ve3cga@...> wrote:


Hi Bill, well just about there.
the usb-d mode is now selected going into wsjtx
however the rig is put into filter 2 which really narrows the field of view
additionally it leaves the USB mode in filter#2 as version 24 does as I found out yesterday (below)

Running version 24 I never realized it (originally thought it had been previously set by me) but although it starts up just fine with usb-d mode & filter set at #1, when I exit and manually switch back out of data mode, whatever band was selected with wsjt-x is left in filter #2 even though wsjt-x ran in data mode with the filter set to filter #1.
In other words, with wsjtx exited, manually switching to usb mode the filter is now filter #2. Manually switching back to data mode shows filter #1 (good)

I dont know if the data mode ON cmd $FEFE7cE01A060101FD could be inserted into the 9100 configuration 
Different program but I have do this with mmsstv radio commands for each bands then I deselect, put mode back to USB with filter untouched: $FEFE7cE01A060000FD

From the manual pg 193:

 
I wonder if there is somewhere in the wsjtx files where I could insert these command strings

tnx Bob VE3CGA



Michael Black
 

Just put in a patch that should re-use the existing filter if RIG_PASSBAND_NOCHANGE  is requested.

So at least once a filter is selected it should stick.

Mike W9MDB




On Friday, October 15, 2021, 10:55:46 AM CDT, Bill Somerville <g4wjs@...> wrote:


Mike,

WSJT-X always requests a mode change with no change in the filter settings. I know this is somewhat problematic with some Icom rigs that do not allow reading the filter settings on the SPLIT Tx VFO without swapping VFOs. Perhaps those that want to use the Icom default filter settings and can't be bothered to customize them as needed should be forced to put up with VFO swapping when changing modes in SPLIT, so Hamlib can read the current filter settings and honour the RIG_PASSBAND_NOCHANGE option by reading the current value to reuse just before setting the mode.

Note that WSJT-X always requests a mode switch (possible redundant) when setting the frequency, this will not change as it copes well with inadvertent operator mode changes via the front panel.

73
Bill
G4WJS.

On 15/10/2021 16:47, Michael Black via groups.io wrote:
I've gone back and forth with Icom several times....

Their default mode is filter 2 and I used to force it to filter 1.  I changed hamlib to let the rig default to whatever it wants and if Icom ever fixes that (not holding my breath) so that the filter follows the band stack then everybody will be happy.

Meanwhile you need to set filter 2 to your data mode wide filter.

My other choice is to do same as FLRig and "remember" whatever filter you select but hamlib currently doesn't try to remember anything so would be a significant change to having hamlib save a config file.

Mike W9MDB




On Friday, October 15, 2021, 10:24:58 AM CDT, bob lee <ve3cga@...> wrote:


Hi Bill, well just about there.
the usb-d mode is now selected going into wsjtx
however the rig is put into filter 2 which really narrows the field of view
additionally it leaves the USB mode in filter#2 as version 24 does as I found out yesterday (below)

Running version 24 I never realized it (originally thought it had been previously set by me) but although it starts up just fine with usb-d mode & filter set at #1, when I exit and manually switch back out of data mode, whatever band was selected with wsjt-x is left in filter #2 even though wsjt-x ran in data mode with the filter set to filter #1.
In other words, with wsjtx exited, manually switching to usb mode the filter is now filter #2. Manually switching back to data mode shows filter #1 (good)

I dont know if the data mode ON cmd $FEFE7cE01A060101FD could be inserted into the 9100 configuration 
Different program but I have do this with mmsstv radio commands for each bands then I deselect, put mode back to USB with filter untouched: $FEFE7cE01A060000FD

From the manual pg 193:

 
I wonder if there is somewhere in the wsjtx files where I could insert these command strings

tnx Bob VE3CGA






Bruce N7XGR
 

I can not understand what this problem really is because all three USB-D
filters can be adjusted to user preference.  Page 73 of the IC9100
user manual describes on how to adjust the filter widths.
In fact I prefer FIL2 because I have it adjusted to a wider setting.
Just follow the instructions on page 73 and all will be fine.
Also the regular 3 USB mode RX filters can be adjusted the same way.
Remember that since this 9100 does not have a SD card for saving
settings it is advised to write down all settings that have been changed
by the user.  Print out the SET mode pages out of the manual and make
your notations accordingly along with any TX and RX filter settings.

Bruce  N7XGR


On Fri, Oct 15, 2021 at 11:45 AM bob lee <ve3cga@...> wrote:
Hi Bill, I sent a few minutes ago but it must have gone to cyberspace so I'll try again

I added the dll to ver25 and it does startup data mode (great) however the filter is changed to #2 position which is narrower

Yesterday I noticed after using ver 24 that is sets up fine  usb=d and filter #1 but after closing wsjtx and going back to just USB mode that the filter was selected as #2
I had noticed this before but thought I had selected it working SSB with some adjacent qrm

So when I use mmsstv I set it up in the menus to call the freq (not shown) and usb data mode FEFE7cE01A060101FD
I also setup a data mode off button for when I leave mmsstv FEFE7cE01A060000FD

I'm wondering if there is some place in the files where as wsjtx is initialized that the USB data mode command could be inserted
This was from the manual pg 193

I though of using a script or bat file but I think wsjtx would write over it with the usb-d with filter#2

thanks, Bob VE3CGA




Bruce N7XGR
 

I can not understand what this problem really is because all three USB-D
filters can be adjusted to user preference.  Page 73 of the IC9100
user manual describes on how to adjust the filter widths.
In fact I prefer FIL2 because I have it adjusted to a wider setting.
Just follow the instructions on page 73 and all will be fine.
Also the regular 3 USB mode RX filters can be adjusted the same way.
Remember that since this 9100 does not have a SD card for saving
settings it is advised to write down all settings that have been changed
by the user.  Print out the SET mode pages out of the manual and make
your notations accordingly along with any TX and RX filter settings.

Bruce  N7XGR

On Fri, Oct 15, 2021 at 11:24 AM bob lee <ve3cga@...> wrote:
Hi Bill, well just about there.
the usb-d mode is now selected going into wsjtx
however the rig is put into filter 2 which really narrows the field of view
additionally it leaves the USB mode in filter#2 as version 24 does as I found out yesterday (below)

Running version 24 I never realized it (originally thought it had been previously set by me) but although it starts up just fine with usb-d mode & filter set at #1, when I exit and manually switch back out of data mode, whatever band was selected with wsjt-x is left in filter #2 even though wsjt-x ran in data mode with the filter set to filter #1.
In other words, with wsjtx exited, manually switching to usb mode the filter is now filter #2. Manually switching back to data mode shows filter #1 (good)

I dont know if the data mode ON cmd $FEFE7cE01A060101FD could be inserted into the 9100 configuration 
Different program but I have do this with mmsstv radio commands for each bands then I deselect, put mode back to USB with filter untouched: $FEFE7cE01A060000FD

From the manual pg 193:

 
I wonder if there is somewhere in the wsjtx files where I could insert these command strings

tnx Bob VE3CGA