Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07


Peter E
 

Hi everyone,

I am trying to run multiple instances of WSJT-X to decode very weak signals on 137Khz. I have been running 2 instances (one WSPR and one FST4W-30) on a Windows 7 laptop OK, but when I add a third instance
with FST4W-2, the decodes stop working and the decode light stays on permanently. I have then tried the 3 instances on a Thinkpad, running Win10, and it works for a while but then only decodes intermittently. I am using it to receive only.

I am running v2.4.0. Does anyone have any tips on how to get multiple instances running reliably, or how to reduce processor load when running multiple instances?

Cheers,
Peter - VK2AN


Bill Somerville
 

On 26/09/2021 01:05, Peter E wrote:
Hi everyone,

I am trying to run multiple instances of WSJT-X to decode very weak signals on 137Khz. I have been running 2 instances (one WSPR and one FST4W-30) on a Windows 7 laptop OK, but when I add a third instance
with FST4W-2, the decodes stop working and the decode light stays on permanently. I have then tried the 3 instances on a Thinkpad, running Win10, and it works for a while but then only decodes intermittently. I am using it to receive only.

I am running v2.4.0. Does anyone have any tips on how to get multiple instances running reliably, or how to reduce processor load when running multiple instances?

Cheers,
Peter - VK2AN
Hi Peter,

how much physical memory does your PC have?

73
Bill
G4WJS.


Peter E
 

Hi Bill,

Both of them have 4Gb. One is Win7 the other Win10.

I did another test today with 3 instances on the Win10 machine and the processor utilization never went over 60%, but it still stopped decoding.

Cheers,
Peter


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: Sunday, 26 September 2021 9:45 PM
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07
 
On 26/09/2021 01:05, Peter E wrote:
> Hi everyone,
>
> I am trying to run multiple instances of WSJT-X to decode very weak
> signals on 137Khz. I have been running 2 instances (one WSPR and one
> FST4W-30) on a Windows 7 laptop OK, but when I add a third instance
> with FST4W-2, the decodes stop working and the decode light stays on
> permanently. I have then tried the 3 instances on a Thinkpad, running
> Win10, and it works for a while but then only decodes intermittently.
> I am using it to receive only.
>
> I am running v2.4.0. Does anyone have any tips on how to get multiple
> instances running reliably, or how to reduce processor load when
> running multiple instances?
>
> Cheers,
> Peter - VK2AN

Hi Peter,

how much physical memory does your PC have?

73
Bill
G4WJS.


Bob Turner
 

4G is a good amount of memory for W7.  For W10, its barely enough.  I have 16g Win10 machines.  One of them may have 32G.  I’ve never tried more than one instance of WSJTx though.  I usually have Outlook, Excel, Word, Chrome and three instances of Putty open while WSJTX decodes.

 

7 3  Bob

N2SCJ

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Peter E
Sent: Sunday, September 26, 2021 8:17 AM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07

 

Hi Bill,

 

Both of them have 4Gb. One is Win7 the other Win10.

 

I did another test today with 3 instances on the Win10 machine and the processor utilization never went over 60%, but it still stopped decoding.

 

Cheers,

Peter

 


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: Sunday, 26 September 2021 9:45 PM
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07

 

On 26/09/2021 01:05, Peter E wrote:
> Hi everyone,
>
> I am trying to run multiple instances of WSJT-X to decode very weak
> signals on 137Khz. I have been running 2 instances (one WSPR and one
> FST4W-30) on a Windows 7 laptop OK, but when I add a third instance
> with FST4W-2, the decodes stop working and the decode light stays on
> permanently. I have then tried the 3 instances on a Thinkpad, running
> Win10, and it works for a while but then only decodes intermittently.
> I am using it to receive only.
>
> I am running v2.4.0. Does anyone have any tips on how to get multiple
> instances running reliably, or how to reduce processor load when
> running multiple instances?
>
> Cheers,
> Peter - VK2AN

Hi Peter,

how much physical memory does your PC have?

73
Bill
G4WJS.


N1BUG
 

On 9/25/21 8:05 PM, Peter E wrote:
I have been running 2 instances (one WSPR and one FST4W-30) on a Windows 7 laptop OK, but when I add a third instance
with FST4W-2, the decodes stop working and the decode light stays on permanently.

Hi Peter,

Check to be certain every instance specifies a unique rig-name parameter. The behavior you report with the decode light staying on will happen if any instance does not have a unique rig-name specified. I have made that mistake more times than I care to admit.

I have run as many as 12 instances for receiving on 137 and 475 kHz.

73,
Paul N1BUG


 

With W10, my 4 Gb laptop suddenly crawled to halt (probably after an update). I noticed memory usage had peaked at 85% and the disk was getting hammered, so obviously it had started swapping furiously. I added another 4 Gb and it’s is now usually OK. Only if windows updates itself the subsequent disk traffic caused stuff to go slowly. For 10 minutes or so after starting the machine.

 

73 Phil.

 

Sent from Mail for Windows

 

From: Bob Turner
Sent: 26 September 2021 13:28
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07

 

4G is a good amount of memory for W7.  For W10, its barely enough.  I have 16g Win10 machines.  One of them may have 32G.  I’ve never tried more than one instance of WSJTx though.  I usually have Outlook, Excel, Word, Chrome and three instances of Putty open while WSJTX decodes.

 

7 3  Bob

N2SCJ

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Peter E
Sent: Sunday, September 26, 2021 8:17 AM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07

 

Hi Bill,

 

Both of them have 4Gb. One is Win7 the other Win10.

 

I did another test today with 3 instances on the Win10 machine and the processor utilization never went over 60%, but it still stopped decoding.

 

Cheers,

Peter

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: Sunday, 26 September 2021 9:45 PM
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07

 

On 26/09/2021 01:05, Peter E wrote:
> Hi everyone,
>
> I am trying to run multiple instances of WSJT-X to decode very weak
> signals on 137Khz. I have been running 2 instances (one WSPR and one
> FST4W-30) on a Windows 7 laptop OK, but when I add a third instance
> with FST4W-2, the decodes stop working and the decode light stays on
> permanently. I have then tried the 3 instances on a Thinkpad, running
> Win10, and it works for a while but then only decodes intermittently.
> I am using it to receive only.
>
> I am running v2.4.0. Does anyone have any tips on how to get multiple
> instances running reliably, or how to reduce processor load when
> running multiple instances?
>
> Cheers,
> Peter - VK2AN

Hi Peter,

how much physical memory does your PC have?

73
Bill
G4WJS.

 


--
73 Phil GM3ZZA


Peter E
 

Hi Paul,

Haven't heard your sigs lately.
My 137 antenna is really lousy but I get into the States regularly on 476.

I have redone the whole setup and have three completely separate instances - before, one of them didn't have the rig-name parameter but the other 2 did. I have also created separate directories and point the "start in" window to these directories.

I have tested it with a small Arduino test TX I have and it is now seems to be working, but the decodes go on for a LONG time, they finish just before the new 2-minute period starts.

I am wondering, what sort of machine are you running the 12 instances on? and how much memory does it have?

Cheers,
Peter


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of N1BUG <paul@...>
Sent: Sunday, 26 September 2021 9:56 PM
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Multiple instances of WSJT-X on Windows machine. #WSJTX_config #Windows07
 
On 9/25/21 8:05 PM, Peter E wrote:
> I have been running 2 instances (one WSPR and one
> FST4W-30) on a Windows 7 laptop OK, but when I add a third instance
> with FST4W-2, the decodes stop working and the decode light stays on
> permanently.


Hi Peter,

Check to be certain every instance specifies a unique rig-name
parameter. The behavior you report with the decode light staying on will
happen if any instance does not have a unique rig-name specified. I have
made that mistake more times than I care to admit.

I have run as many as 12 instances for receiving on 137 and 475 kHz.

73,
Paul N1BUG