locked DXLab Commander in Parallels talking to WSJT-X on a mac #Cat_RigControl #windows11


Dan Stancil
 

I have DXLab Commander running in a virtual Windows 11 machine in Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it works
great with my rig. However, when I set the rig to DXLab Commander, I get
the "Failed to connect to DX Lab Suite Commander Connection refused" error
message. I've checked the ports (Base Port: 52000 on DXLab commander), and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X on my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O


David Herring
 

Dan,

Is WSJT-X running natively on the Mac (as in you’re running the MacOS version) or is it running the Windows version in the same virtual machine as DXLab?

If WSJT-X is the Mac version running natively on the Mac, then you have WSJT-X and DXLab running on, logically speaking, 2 different computers and so using loopback addresses will not work. In this case you will need to use the Windows machine’s IP address on your network.


73,
Dave - N5DCH

On Oct 3, 2022, at 10:57 AM, Dan Stancil <ddstancil@...> wrote:

I have DXLab Commander running in a virtual Windows 11 machine in Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it works
great with my rig. However, when I set the rig to DXLab Commander, I get
the "Failed to connect to DX Lab Suite Commander Connection refused" error
message. I've checked the ports (Base Port: 52000 on DXLab commander), and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X on my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O





Dan Stancil
 

Hi Dave,

Yes, I'm running WSJT-X natively on the Mac, so I'm sure you've identified
the issue! So I opened the console in the virtual windows machine and typed
ipconfig /all, and wrote down the ip address. Then I went to WSJT-X
configuration and entered the windows IP address:52002 as the Network
Server. It's still not working, but now I don't get the error message until
it times out (before I was getting it immediately). I'm guessing that the
missing piece now is getting DXLab commander to listen to the Mac's IP
address instead of 127.0.0.1, but it's not clear to me where to set this.

Thanks for your help!

73,
Dan WY3O

On Mon, Oct 3, 2022 at 2:51 PM David Herring <david.n5dch@...> wrote:

Dan,

Is WSJT-X running natively on the Mac (as in you’re running the MacOS
version) or is it running the Windows version in the same virtual machine
as DXLab?

If WSJT-X is the Mac version running natively on the Mac, then you have
WSJT-X and DXLab running on, logically speaking, 2 different computers and
so using loopback addresses will not work. In this case you will need to
use the Windows machine’s IP address on your network.


73,
Dave - N5DCH




On Oct 3, 2022, at 10:57 AM, Dan Stancil <ddstancil@...> wrote:

I have DXLab Commander running in a virtual Windows 11 machine in
Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it
works
great with my rig. However, when I set the rig to DXLab Commander, I get
the "Failed to connect to DX Lab Suite Commander Connection refused"
error
message. I've checked the ports (Base Port: 52000 on DXLab commander),
and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X on my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O










Mike Chace-Ortiz
 

I’ve not used it, though I am a long -time Parallels user, but Parallels supports port forwarding <https://kb.parallels.com/en/124718> when enabled, so I assume you’ll have to use that feature to get the VM communicating with the host.

73
—mco

On Oct 3, 2022, at 1:14 PM, David Herring <david.n5dch@...> wrote:

Dan,

Is WSJT-X running natively on the Mac (as in you’re running the MacOS version) or is it running the Windows version in the same virtual machine as DXLab?

If WSJT-X is the Mac version running natively on the Mac, then you have WSJT-X and DXLab running on, logically speaking, 2 different computers and so using loopback addresses will not work. In this case you will need to use the Windows machine’s IP address on your network.


73,
Dave - N5DCH




On Oct 3, 2022, at 10:57 AM, Dan Stancil <ddstancil@...> wrote:

I have DXLab Commander running in a virtual Windows 11 machine in Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it works
great with my rig. However, when I set the rig to DXLab Commander, I get
the "Failed to connect to DX Lab Suite Commander Connection refused" error
message. I've checked the ports (Base Port: 52000 on DXLab commander), and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X on my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O







David Herring
 

Dan,

It’s been a long time since I’ve used Parallels, so Mike’s suggestion about port forwarding may work, I honestly don’t recall enough about such as that in Parallels to say. If it does, then you’re in business. If not, then I have another idea...

It sounds like your Windows VM is configured in Parallels to have either Shared Networking or Host-Only Networking. What I would recommend is to reconfigure Parallels to provide Windows with Bridged Networking. That way, Windows will be just like any other device on your network, pull an IP from your router, fully accessible from your network, etc. I think then using that IP address will work straight away. If it does not, then its possible that Windows Firewall is in the way and then you’d have to open the right port(s), but it's unlikely that will be necessary. Most likely DXLab opened the right ports when it was installed. I just mention this in case you run into trouble. Hopefully you won’t.

GL!

73,
Dave - N5DCH

On Oct 3, 2022, at 3:48 PM, Mike Chace-Ortiz <mchaceortiz@...> wrote:

I’ve not used it, though I am a long -time Parallels user, but Parallels supports port forwarding <https://kb.parallels.com/en/124718> when enabled, so I assume you’ll have to use that feature to get the VM communicating with the host.

73
—mco

On Oct 3, 2022, at 1:14 PM, David Herring <david.n5dch@...> wrote:

Dan,

Is WSJT-X running natively on the Mac (as in you’re running the MacOS version) or is it running the Windows version in the same virtual machine as DXLab?

If WSJT-X is the Mac version running natively on the Mac, then you have WSJT-X and DXLab running on, logically speaking, 2 different computers and so using loopback addresses will not work. In this case you will need to use the Windows machine’s IP address on your network.


73,
Dave - N5DCH




On Oct 3, 2022, at 10:57 AM, Dan Stancil <ddstancil@...> wrote:

I have DXLab Commander running in a virtual Windows 11 machine in Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it works
great with my rig. However, when I set the rig to DXLab Commander, I get
the "Failed to connect to DX Lab Suite Commander Connection refused" error
message. I've checked the ports (Base Port: 52000 on DXLab commander), and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X on my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O









Dan Stancil
 

Mike,

Thanks for the suggestion. However, it appears that port forwarding is not
available on my version of Parallels (it appears to be available on the pro
and business editions, but not my standard edition). So I switched to try
Bridged Networking....

Dave,

I think I'm getting closer, but I'm still missing something. I reconfigured
Parallels for Bridged Networking, and confirmed that it now had an IP
address on my local network. I could ping my mac from the VM, but not the
other way around. So I went into Windows Firewall and enabled the inbound
rule for File and Printer Sharing (Echo Request - ECMPv4-In). I could then
ping in either direction. I then put in the new address for the VM in the
WSTJ-X configuration, specifying port 52002. But it still didn't work. So I
went back to Windows Firewall and added a rule to specifically open port
52002, but still no luck. I'm getting a socket operation timed out error
message.

I would welcome any additional ideas, and I really appreciate the help!

73,
Dan, WY3O

On Mon, Oct 3, 2022 at 7:52 PM David Herring <david.n5dch@...> wrote:

Dan,

It’s been a long time since I’ve used Parallels, so Mike’s suggestion
about port forwarding may work, I honestly don’t recall enough about such
as that in Parallels to say. If it does, then you’re in business. If not,
then I have another idea...

It sounds like your Windows VM is configured in Parallels to have either
Shared Networking or Host-Only Networking. What I would recommend is to
reconfigure Parallels to provide Windows with Bridged Networking. That
way, Windows will be just like any other device on your network, pull an IP
from your router, fully accessible from your network, etc. I think then
using that IP address will work straight away. If it does not, then its
possible that Windows Firewall is in the way and then you’d have to open
the right port(s), but it's unlikely that will be necessary. Most likely
DXLab opened the right ports when it was installed. I just mention this in
case you run into trouble. Hopefully you won’t.

GL!

73,
Dave - N5DCH




On Oct 3, 2022, at 3:48 PM, Mike Chace-Ortiz <mchaceortiz@...>
wrote:

I’ve not used it, though I am a long -time Parallels user, but Parallels
supports port forwarding <https://kb.parallels.com/en/124718> when
enabled, so I assume you’ll have to use that feature to get the VM
communicating with the host.

73
—mco

On Oct 3, 2022, at 1:14 PM, David Herring <david.n5dch@...>
wrote:

Dan,

Is WSJT-X running natively on the Mac (as in you’re running the MacOS
version) or is it running the Windows version in the same virtual machine
as DXLab?

If WSJT-X is the Mac version running natively on the Mac, then you have
WSJT-X and DXLab running on, logically speaking, 2 different computers and
so using loopback addresses will not work. In this case you will need to
use the Windows machine’s IP address on your network.


73,
Dave - N5DCH




On Oct 3, 2022, at 10:57 AM, Dan Stancil <ddstancil@...> wrote:

I have DXLab Commander running in a virtual Windows 11 machine in
Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with
no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it
works
great with my rig. However, when I set the rig to DXLab Commander, I
get
the "Failed to connect to DX Lab Suite Commander Connection refused"
error
message. I've checked the ports (Base Port: 52000 on DXLab commander),
and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander
first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X on
my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O














David Herring
 

Dan,

Well shoot. That should have just worked. Oh well, stuff happens. ;-)

I have a few ideas to explore here. Take then in order and stop as soon as things start to work.

1) On windows, Control Panel -> Network And Sharing Center, check your network to see if it is listed as an Private Network, Public Network or Guest Network. If it is anything other than Private I recommend changing it to Private. Most likely this happened automatically when you enabled network sharing, but I mention this just in case. If you need to change it to Private, this link is to a good page that tells how: https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/. If it wasn’t Private and you successfully changed it to Private, go back and try your WSJT-X and DXLab connection again and see if this addressed it.

2) Control Panel -> Windows Defender Firewall. Left side, click on “Allow an App or Feature Through Windows Defender Firewall.” On the list of apps you are then presented with, scroll down and make sure DXLab and *all* parts of that suite are listed there and that the Private box is checked, thus allowing the apps themselves through the firewall. If they are not, add them or modify them as needed. Then check your connectivity from WSJT-X.

3) Failing all that, go back to Control Panel -> Windows Defender Firewall. Left side, click on “Advanced Settings.” A new window opens. Click on inbound rules. Scroll down and find the rule(s) that apply to DXLab and what ever other parts of that are installed on your machine. Make sure that Profile is Private, Enabled is YES, Local Address is ANY, Remote Address is Local Subnet, and then Protocol, Local Port, Remote Port and all the rest of the fields to the right are all set to ANY. If they are not, modify them so. After this, go to Outbound Rules and do the same thing. Now test your connectivity and see if WSJT-X can reach DXLab.

If all this still does not work, then maybe tomorrow I will think of other things…

Disclaimer: Step 3 is maybe a little more liberal than a rule ought to be. But you are on your (I assume) home network so the risk should be minimal. The goal here is to get the connection working. You can and are encouraged to circle back and tighten things up to suit your preferences once things are working. I am not responsible for anything that may or may not happen on or to your network. ;-)

GL!

73,
Dave - N5DCH

On Oct 3, 2022, at 8:06 PM, Dan Stancil <ddstancil@...> wrote:

Mike,

Thanks for the suggestion. However, it appears that port forwarding is not
available on my version of Parallels (it appears to be available on the pro
and business editions, but not my standard edition). So I switched to try
Bridged Networking....

Dave,

I think I'm getting closer, but I'm still missing something. I reconfigured
Parallels for Bridged Networking, and confirmed that it now had an IP
address on my local network. I could ping my mac from the VM, but not the
other way around. So I went into Windows Firewall and enabled the inbound
rule for File and Printer Sharing (Echo Request - ECMPv4-In). I could then
ping in either direction. I then put in the new address for the VM in the
WSTJ-X configuration, specifying port 52002. But it still didn't work. So I
went back to Windows Firewall and added a rule to specifically open port
52002, but still no luck. I'm getting a socket operation timed out error
message.

I would welcome any additional ideas, and I really appreciate the help!

73,
Dan, WY3O

On Mon, Oct 3, 2022 at 7:52 PM David Herring <david.n5dch@... <mailto:david.n5dch@...>> wrote:

Dan,

It’s been a long time since I’ve used Parallels, so Mike’s suggestion
about port forwarding may work, I honestly don’t recall enough about such
as that in Parallels to say. If it does, then you’re in business. If not,
then I have another idea...

It sounds like your Windows VM is configured in Parallels to have either
Shared Networking or Host-Only Networking. What I would recommend is to
reconfigure Parallels to provide Windows with Bridged Networking. That
way, Windows will be just like any other device on your network, pull an IP
from your router, fully accessible from your network, etc. I think then
using that IP address will work straight away. If it does not, then its
possible that Windows Firewall is in the way and then you’d have to open
the right port(s), but it's unlikely that will be necessary. Most likely
DXLab opened the right ports when it was installed. I just mention this in
case you run into trouble. Hopefully you won’t.

GL!

73,
Dave - N5DCH




On Oct 3, 2022, at 3:48 PM, Mike Chace-Ortiz <mchaceortiz@...>
wrote:

I’ve not used it, though I am a long -time Parallels user, but Parallels
supports port forwarding <https://kb.parallels.com/en/124718> when
enabled, so I assume you’ll have to use that feature to get the VM
communicating with the host.

73
—mco

On Oct 3, 2022, at 1:14 PM, David Herring <david.n5dch@...>
wrote:

Dan,

Is WSJT-X running natively on the Mac (as in you’re running the MacOS
version) or is it running the Windows version in the same virtual machine
as DXLab?

If WSJT-X is the Mac version running natively on the Mac, then you have
WSJT-X and DXLab running on, logically speaking, 2 different computers and
so using loopback addresses will not work. In this case you will need to
use the Windows machine’s IP address on your network.


73,
Dave - N5DCH




On Oct 3, 2022, at 10:57 AM, Dan Stancil <ddstancil@...> wrote:

I have DXLab Commander running in a virtual Windows 11 machine in
Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with
no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it
works
great with my rig. However, when I set the rig to DXLab Commander, I
get
the "Failed to connect to DX Lab Suite Commander Connection refused"
error
message. I've checked the ports (Base Port: 52000 on DXLab commander),
and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander
first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X on
my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O















Dave AA6YQ
 

+ AA6YQ comments below

Yes, I'm running WSJT-X natively on the Mac, so I'm sure you've identified the issue! So I opened the console in the virtual windows machine and typed ipconfig /all, and wrote down the ip address. Then I went to WSJT-X configuration and entered the windows IP address:52002 as the Network Server. It's still not working, but now I don't get the error message until it times out (before I was getting it immediately). I'm guessing that the missing piece now is getting DXLab commander to listen to the Mac's IP address instead of 127.0.0.1, but it's not clear to me where to set this.

+ Commander is listening for incoming commands on port 52002 of the IP address of the (virtual) Windows machine on which it is running.

73,

Dave, AA6YQ


Dave AA6YQ
 

+ AA6YQ comments below

I think I'm getting closer, but I'm still missing something. I reconfigured Parallels for Bridged Networking, and confirmed that it now had an IP address on my local network. I could ping my mac from the VM, but not the other way around. So I went into Windows Firewall and enabled the inbound rule for File and Printer Sharing (Echo Request - ECMPv4-In). I could then ping in either direction. I then put in the new address for the VM in the WSTJ-X configuration, specifying port 52002.

+ Where in WSJT-X are you specifying the new address?

+ Have you considered running WSJT-X on Windows?

73,

Dave, AA6YQ


Dan Stancil
 

Dave H:

Changing the network from public to private did the trick! It seems to be
working fine now. Thanks for all your help!

73,
Dan, WY3O

On Tue, Oct 4, 2022 at 2:34 AM David Herring <david.n5dch@...> wrote:

Dan,

Well shoot. That should have just worked. Oh well, stuff happens. ;-)

I have a few ideas to explore here. Take then in order and stop as soon as
things start to work.

1) On windows, Control Panel -> Network And Sharing Center, check your
network to see if it is listed as an Private Network, Public Network or
Guest Network. If it is anything other than Private I recommend changing
it to Private. Most likely this happened automatically when you enabled
network sharing, but I mention this just in case. If you need to change it
to Private, this link is to a good page that tells how:
https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/.
If it wasn’t Private and you successfully changed it to Private, go back
and try your WSJT-X and DXLab connection again and see if this addressed it.

2) Control Panel -> Windows Defender Firewall. Left side, click on “Allow
an App or Feature Through Windows Defender Firewall.” On the list of apps
you are then presented with, scroll down and make sure DXLab and *all*
parts of that suite are listed there and that the Private box is checked,
thus allowing the apps themselves through the firewall. If they are not,
add them or modify them as needed. Then check your connectivity from
WSJT-X.

3) Failing all that, go back to Control Panel -> Windows Defender
Firewall. Left side, click on “Advanced Settings.” A new window opens.
Click on inbound rules. Scroll down and find the rule(s) that apply to
DXLab and what ever other parts of that are installed on your machine.
Make sure that Profile is Private, Enabled is YES, Local Address is ANY,
Remote Address is Local Subnet, and then Protocol, Local Port, Remote Port
and all the rest of the fields to the right are all set to ANY. If they are
not, modify them so. After this, go to Outbound Rules and do the same
thing. Now test your connectivity and see if WSJT-X can reach DXLab.

If all this still does not work, then maybe tomorrow I will think of other
things…

Disclaimer: Step 3 is maybe a little more liberal than a rule ought to
be. But you are on your (I assume) home network so the risk should be
minimal. The goal here is to get the connection working. You can and are
encouraged to circle back and tighten things up to suit your preferences
once things are working. I am not responsible for anything that may or may
not happen on or to your network. ;-)

GL!

73,
Dave - N5DCH




On Oct 3, 2022, at 8:06 PM, Dan Stancil <ddstancil@...> wrote:

Mike,

Thanks for the suggestion. However, it appears that port forwarding is
not
available on my version of Parallels (it appears to be available on the
pro
and business editions, but not my standard edition). So I switched to try
Bridged Networking....

Dave,

I think I'm getting closer, but I'm still missing something. I
reconfigured
Parallels for Bridged Networking, and confirmed that it now had an IP
address on my local network. I could ping my mac from the VM, but not the
other way around. So I went into Windows Firewall and enabled the inbound
rule for File and Printer Sharing (Echo Request - ECMPv4-In). I could
then
ping in either direction. I then put in the new address for the VM in the
WSTJ-X configuration, specifying port 52002. But it still didn't work.
So I
went back to Windows Firewall and added a rule to specifically open port
52002, but still no luck. I'm getting a socket operation timed out error
message.

I would welcome any additional ideas, and I really appreciate the help!

73,
Dan, WY3O

On Mon, Oct 3, 2022 at 7:52 PM David Herring <david.n5dch@...
<mailto:david.n5dch@...>> wrote:

Dan,

It’s been a long time since I’ve used Parallels, so Mike’s suggestion
about port forwarding may work, I honestly don’t recall enough about
such
as that in Parallels to say. If it does, then you’re in business. If
not,
then I have another idea...

It sounds like your Windows VM is configured in Parallels to have either
Shared Networking or Host-Only Networking. What I would recommend is to
reconfigure Parallels to provide Windows with Bridged Networking. That
way, Windows will be just like any other device on your network, pull
an IP
from your router, fully accessible from your network, etc. I think then
using that IP address will work straight away. If it does not, then its
possible that Windows Firewall is in the way and then you’d have to open
the right port(s), but it's unlikely that will be necessary. Most
likely
DXLab opened the right ports when it was installed. I just mention
this in
case you run into trouble. Hopefully you won’t.

GL!

73,
Dave - N5DCH




On Oct 3, 2022, at 3:48 PM, Mike Chace-Ortiz <mchaceortiz@...>
wrote:

I’ve not used it, though I am a long -time Parallels user, but
Parallels
supports port forwarding <https://kb.parallels.com/en/124718> when
enabled, so I assume you’ll have to use that feature to get the VM
communicating with the host.

73
—mco

On Oct 3, 2022, at 1:14 PM, David Herring <david.n5dch@...>
wrote:

Dan,

Is WSJT-X running natively on the Mac (as in you’re running the MacOS
version) or is it running the Windows version in the same virtual
machine
as DXLab?

If WSJT-X is the Mac version running natively on the Mac, then you
have
WSJT-X and DXLab running on, logically speaking, 2 different computers
and
so using loopback addresses will not work. In this case you will need
to
use the Windows machine’s IP address on your network.


73,
Dave - N5DCH




On Oct 3, 2022, at 10:57 AM, Dan Stancil <ddstancil@...>
wrote:

I have DXLab Commander running in a virtual Windows 11 machine in
Parallels
Desktop on an intel Mac running OSX 12.6. It controls my IC-7300 with
no
problem. I also have WSJT-X 2.5.4 running on my mac, and by itself it
works
great with my rig. However, when I set the rig to DXLab Commander, I
get
the "Failed to connect to DX Lab Suite Commander Connection refused"
error
message. I've checked the ports (Base Port: 52000 on DXLab
commander),
and
I have tried both leaving the WSJT-X Network server blank, as well as
127.0.0.1:52002, but neither works. I'm launching DXLab Commander
first,
before trying to connect with WSJT-X.

I'm wondering if there is something else I need to do to get WSJT-X
on
my
mac to talk to Commander on the virtual windows machine?

73,
Dan WY3O




















Dan Stancil
 

Dave,

Thanks for the clarification. This adventure has helped me understand a
number of things better :-)

73,
Dan WY3O

On Tue, Oct 4, 2022 at 2:34 AM Dave AA6YQ <aa6yq@...> wrote:

+ AA6YQ comments below

Yes, I'm running WSJT-X natively on the Mac, so I'm sure you've identified
the issue! So I opened the console in the virtual windows machine and typed
ipconfig /all, and wrote down the ip address. Then I went to WSJT-X
configuration and entered the windows IP address:52002 as the Network
Server. It's still not working, but now I don't get the error message until
it times out (before I was getting it immediately). I'm guessing that the
missing piece now is getting DXLab commander to listen to the Mac's IP
address instead of 127.0.0.1, but it's not clear to me where to set this.

+ Commander is listening for incoming commands on port 52002 of the IP
address of the (virtual) Windows machine on which it is running.

73,

Dave, AA6YQ







Dan Stancil
 

Dave,

Thanks for the suggestion. Running WSJT-X under Windows was on my radar as
plan B; maybe it would have been easier, but my present
configuration appears to be working great now.

Thanks again!

73,
Dan WY3O

PS-I entered the new address in WSJT-X on the Preferences->Radio tab under
"Network Server:"

On Tue, Oct 4, 2022 at 2:35 AM Dave AA6YQ <aa6yq@...> wrote:

+ AA6YQ comments below

I think I'm getting closer, but I'm still missing something. I
reconfigured Parallels for Bridged Networking, and confirmed that it now
had an IP address on my local network. I could ping my mac from the VM, but
not the other way around. So I went into Windows Firewall and enabled the
inbound rule for File and Printer Sharing (Echo Request - ECMPv4-In). I
could then ping in either direction. I then put in the new address for the
VM in the WSTJ-X configuration, specifying port 52002.

+ Where in WSJT-X are you specifying the new address?

+ Have you considered running WSJT-X on Windows?

73,

Dave, AA6YQ







David Herring
 

Dan,

Very happy to hear that this is working for you!

Looking forward to logging a QSO with you some time…

:-)

73,
Dave - N5DCH

On Oct 4, 2022, at 5:41 AM, Dan Stancil <ddstancil@...> wrote:

Dave,

Thanks for the suggestion. Running WSJT-X under Windows was on my radar as
plan B; maybe it would have been easier, but my present
configuration appears to be working great now.

Thanks again!

73,
Dan WY3O

PS-I entered the new address in WSJT-X on the Preferences->Radio tab under
"Network Server:"

On Tue, Oct 4, 2022 at 2:35 AM Dave AA6YQ <aa6yq@...> wrote:

+ AA6YQ comments below

I think I'm getting closer, but I'm still missing something. I
reconfigured Parallels for Bridged Networking, and confirmed that it now
had an IP address on my local network. I could ping my mac from the VM, but
not the other way around. So I went into Windows Firewall and enabled the
inbound rule for File and Printer Sharing (Echo Request - ECMPv4-In). I
could then ping in either direction. I then put in the new address for the
VM in the WSTJ-X configuration, specifying port 52002.

+ Where in WSJT-X are you specifying the new address?

+ Have you considered running WSJT-X on Windows?

73,

Dave, AA6YQ










Dave AA6YQ
 

Thanks for the clarification. This adventure has helped me understand a number of things better :-)

+ Great! If you send me a summary of the settings required to make this work, I'll add an Article in "Getting Started with DXLab" under you byline so others can benefit from your "exploring".

Dave


Dan Stancil
 

Dave,

Here are the key steps:

starting point:
1. A default installation of Parallels Desktop 18.0.2 for Mac, Standard
Edition, running Windows 11 Home, v 22H2;
2. Installed and working version of DXLab Launcher 2.1.7 and Commander
15.5.1 configured to control an IC-7300 on the Windows virtual machine
2. Installed and working version of of WSJT-X v2.5.4 on my Mac (Intel i5 on
an iMac running macOS Monterey v12.6), configured to control an IC-7300

Additional steps needed to get them to work together:
1. Change the Windows system to Bridged Networking (see, e.g., instructions
here
<http://download.parallels.com/desktop/v15/docs/en_US/Parallels%20Desktop%20User's%20Guide/43135.htm>.
This reference is for Windows 10, but it works for 11 also)
a. Shut down the virtual Windows machine
b. On the Parallels Desktop Control Center, click the gear icon to
open the "Windows 11" configuration window
c. Click on the lock on the lower left-hand side, and log in as
administrator to make changes
d. Click on the Network on the left, and in the Source: drop down
menu, select "Default Adapter"
e. Click the lock to prevent unauthorized changes
f. Close the Windows 11 Configuration window
2. Launch the virtual Windows machine
3. Change the network from public to private (see, e.g. instructions here
<https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/>
)
a. Open the Settings app
b. click on Network & internet
c. click on "Ethernet" on the right (for a wired network connection)
d. select the "Private network" option
e. Note the IPv4 address of the VM before closing this window (address
shown near the bottom), e.g., 192.168.50.12
4. Set WSJT-X on the Mac to point to DXLab Commander on the virtual machine
a. Open the preferences window (WSJT-X->preferences)
b. Set the Rig field to "DX Lab Suite Commander"
c. Set the Network Server field to VMIPv4address:52002, e.g.,
192.168.50.12:52002
d. Close the preferences window

For things to work properly, fire things up in this order:
1. turn on the rig
2. launch DXLab Commander in the VM
3. launch WSJT-S on the Mac

Hopefully I got all this right (and if so, it was due to a lot of help from
my friends Dave N5DCH and Dave AA6YQ), and it will be helpful to others.

Thanks!
Dan

On Tue, Oct 4, 2022 at 5:25 PM Dave AA6YQ <aa6yq@...> wrote:

Thanks for the clarification. This adventure has helped me understand a
number of things better :-)

+ Great! If you send me a summary of the settings required to make this
work, I'll add an Article in "Getting Started with DXLab" under you byline
so others can benefit from your "exploring".

Dave







Dave AA6YQ
 

Thanks, Dan!

73,

Dave, AA6YQ

-----Original Message-----
From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Dan Stancil
Sent: Tuesday, October 04, 2022 9:49 PM
To: main@wsjtx.groups.io
Subject: Re: [WSJTX] DXLab Commander in Parallels talking to WSJT-X on a mac #Cat_RigControl #windows11

Dave,

Here are the key steps:

starting point:
1. A default installation of Parallels Desktop 18.0.2 for Mac, Standard Edition, running Windows 11 Home, v 22H2; 2. Installed and working version of DXLab Launcher 2.1.7 and Commander
15.5.1 configured to control an IC-7300 on the Windows virtual machine 2. Installed and working version of of WSJT-X v2.5.4 on my Mac (Intel i5 on an iMac running macOS Monterey v12.6), configured to control an IC-7300

Additional steps needed to get them to work together:
1. Change the Windows system to Bridged Networking (see, e.g., instructions here <http://download.parallels.com/desktop/v15/docs/en_US/Parallels%20Desktop%20User's%20Guide/43135.htm>.
This reference is for Windows 10, but it works for 11 also)
a. Shut down the virtual Windows machine
b. On the Parallels Desktop Control Center, click the gear icon to open the "Windows 11" configuration window
c. Click on the lock on the lower left-hand side, and log in as administrator to make changes
d. Click on the Network on the left, and in the Source: drop down menu, select "Default Adapter"
e. Click the lock to prevent unauthorized changes
f. Close the Windows 11 Configuration window 2. Launch the virtual Windows machine 3. Change the network from public to private (see, e.g. instructions here <https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/>
)
a. Open the Settings app
b. click on Network & internet
c. click on "Ethernet" on the right (for a wired network connection)
d. select the "Private network" option
e. Note the IPv4 address of the VM before closing this window (address shown near the bottom), e.g., 192.168.50.12 4. Set WSJT-X on the Mac to point to DXLab Commander on the virtual machine
a. Open the preferences window (WSJT-X->preferences)
b. Set the Rig field to "DX Lab Suite Commander"
c. Set the Network Server field to VMIPv4address:52002, e.g.,
192.168.50.12:52002
d. Close the preferences window

For things to work properly, fire things up in this order:
1. turn on the rig
2. launch DXLab Commander in the VM
3. launch WSJT-S on the Mac

Hopefully I got all this right (and if so, it was due to a lot of help from my friends Dave N5DCH and Dave AA6YQ), and it will be helpful to others.

Thanks!
Dan




On Tue, Oct 4, 2022 at 5:25 PM Dave AA6YQ <aa6yq@...> wrote:

Thanks for the clarification. This adventure has helped me understand
a number of things better :-)

+ Great! If you send me a summary of the settings required to make
+ this
work, I'll add an Article in "Getting Started with DXLab" under you
byline so others can benefit from your "exploring".

Dave











--
This email has been checked for viruses by AVG antivirus software.
www.avg.com


Dave AA6YQ
 

Thanks, Dan!

Here's a first cut:

https://www.dxlabsuite.com/dxlabwiki/WSJTXonMacCommanderonParallels

Step 5 of the Configuration section is confusing because its steps a through e don't match what's described in

https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/

Which one is correct?

Please tell me about additional corrections and changes that are required.

Dave

-----Original Message-----
From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Dan Stancil
Sent: Tuesday, October 04, 2022 9:49 PM
To: main@wsjtx.groups.io
Subject: Re: [WSJTX] DXLab Commander in Parallels talking to WSJT-X on a mac #Cat_RigControl #windows11

Dave,

Here are the key steps:

starting point:
1. A default installation of Parallels Desktop 18.0.2 for Mac, Standard Edition, running Windows 11 Home, v 22H2; 2. Installed and working version of DXLab Launcher 2.1.7 and Commander
15.5.1 configured to control an IC-7300 on the Windows virtual machine 2. Installed and working version of of WSJT-X v2.5.4 on my Mac (Intel i5 on an iMac running macOS Monterey v12.6), configured to control an IC-7300

Additional steps needed to get them to work together:
1. Change the Windows system to Bridged Networking (see, e.g., instructions here <http://download.parallels.com/desktop/v15/docs/en_US/Parallels%20Desktop%20User's%20Guide/43135.htm>.
This reference is for Windows 10, but it works for 11 also)
a. Shut down the virtual Windows machine
b. On the Parallels Desktop Control Center, click the gear icon to open the "Windows 11" configuration window
c. Click on the lock on the lower left-hand side, and log in as administrator to make changes
d. Click on the Network on the left, and in the Source: drop down menu, select "Default Adapter"
e. Click the lock to prevent unauthorized changes
f. Close the Windows 11 Configuration window 2. Launch the virtual Windows machine 3. Change the network from public to private (see, e.g. instructions here <https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/>
)
a. Open the Settings app
b. click on Network & internet
c. click on "Ethernet" on the right (for a wired network connection)
d. select the "Private network" option
e. Note the IPv4 address of the VM before closing this window (address shown near the bottom), e.g., 192.168.50.12 4. Set WSJT-X on the Mac to point to DXLab Commander on the virtual machine
a. Open the preferences window (WSJT-X->preferences)
b. Set the Rig field to "DX Lab Suite Commander"
c. Set the Network Server field to VMIPv4address:52002, e.g.,
192.168.50.12:52002
d. Close the preferences window

For things to work properly, fire things up in this order:
1. turn on the rig
2. launch DXLab Commander in the VM
3. launch WSJT-S on the Mac

Hopefully I got all this right (and if so, it was due to a lot of help from my friends Dave N5DCH and Dave AA6YQ), and it will be helpful to others.

Thanks!
Dan




On Tue, Oct 4, 2022 at 5:25 PM Dave AA6YQ <aa6yq@...> wrote:

Thanks for the clarification. This adventure has helped me understand
a number of things better :-)

+ Great! If you send me a summary of the settings required to make
+ this
work, I'll add an Article in "Getting Started with DXLab" under you
byline so others can benefit from your "exploring".

Dave











--
This email has been checked for viruses by AVG antivirus software.
www.avg.com


Dan Stancil
 

Dave,

Apologies for the delay in responding! Your summary looks good to me. The
real test is whether this works for others, of course!

Regarding step 5: when I scroll down the webpage to the instructions for
Windows 11 with a wired ethernet connection, it appears to me that the
steps are in agreement. The website does give the procedures for Wifi
connections, and Windows 10 as well as Windows 11, so there are several
sets of instructions. Please let me know if you do see a discrepancy, as I
may not be looking at something correctly.

Regards,
Dan

On Fri, Oct 7, 2022 at 3:55 AM Dave AA6YQ <aa6yq@...> wrote:

Thanks, Dan!

Here's a first cut:

https://www.dxlabsuite.com/dxlabwiki/WSJTXonMacCommanderonParallels

Step 5 of the Configuration section is confusing because its steps a
through e don't match what's described in


https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/

Which one is correct?

Please tell me about additional corrections and changes that are required.

Dave


-----Original Message-----
From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Dan
Stancil
Sent: Tuesday, October 04, 2022 9:49 PM
To: main@wsjtx.groups.io
Subject: Re: [WSJTX] DXLab Commander in Parallels talking to WSJT-X on a
mac #Cat_RigControl #windows11

Dave,

Here are the key steps:

starting point:
1. A default installation of Parallels Desktop 18.0.2 for Mac, Standard
Edition, running Windows 11 Home, v 22H2; 2. Installed and working version
of DXLab Launcher 2.1.7 and Commander
15.5.1 configured to control an IC-7300 on the Windows virtual machine 2.
Installed and working version of of WSJT-X v2.5.4 on my Mac (Intel i5 on an
iMac running macOS Monterey v12.6), configured to control an IC-7300

Additional steps needed to get them to work together:
1. Change the Windows system to Bridged Networking (see, e.g.,
instructions here <
http://download.parallels.com/desktop/v15/docs/en_US/Parallels%20Desktop%20User's%20Guide/43135.htm
.
This reference is for Windows 10, but it works for 11 also)
a. Shut down the virtual Windows machine
b. On the Parallels Desktop Control Center, click the gear icon to
open the "Windows 11" configuration window
c. Click on the lock on the lower left-hand side, and log in as
administrator to make changes
d. Click on the Network on the left, and in the Source: drop down
menu, select "Default Adapter"
e. Click the lock to prevent unauthorized changes
f. Close the Windows 11 Configuration window 2. Launch the virtual
Windows machine 3. Change the network from public to private (see, e.g.
instructions here <
https://www.digitalcitizen.life/how-set-your-networks-location-private-or-public-windows-10/
)
a. Open the Settings app
b. click on Network & internet
c. click on "Ethernet" on the right (for a wired network connection)
d. select the "Private network" option
e. Note the IPv4 address of the VM before closing this window
(address shown near the bottom), e.g., 192.168.50.12 4. Set WSJT-X on the
Mac to point to DXLab Commander on the virtual machine
a. Open the preferences window (WSJT-X->preferences)
b. Set the Rig field to "DX Lab Suite Commander"
c. Set the Network Server field to VMIPv4address:52002, e.g.,
192.168.50.12:52002
d. Close the preferences window

For things to work properly, fire things up in this order:
1. turn on the rig
2. launch DXLab Commander in the VM
3. launch WSJT-S on the Mac

Hopefully I got all this right (and if so, it was due to a lot of help
from my friends Dave N5DCH and Dave AA6YQ), and it will be helpful to
others.

Thanks!
Dan




On Tue, Oct 4, 2022 at 5:25 PM Dave AA6YQ <aa6yq@...> wrote:

Thanks for the clarification. This adventure has helped me understand
a number of things better :-)

+ Great! If you send me a summary of the settings required to make
+ this
work, I'll add an Article in "Getting Started with DXLab" under you
byline so others can benefit from your "exploring".

Dave











--
This email has been checked for viruses by AVG antivirus software.
www.avg.com