Topics

CAT/PTT Delay when WSJT-X controlling DXlab Commander #Cat_RigControl #BugReport


John K3TN
 

I've been migrating my shack computer to a refurb Win 10 machine, slowly getting everything going again. 

I have WSJT-X integrated to DXLab per the directions, first by turning off Commander and setting rig to K3S in WSJT-X. That works fine, both working stations and logging them in DXkeeper. Latest version of WSJT-X, latest versions of DXLab programs.

Then, followed the instructions here to have WSJT-X talk to Commander. First hint of an issue was the Test CAT button was slow to turn green. Then, answering a few FT8 CQs, the radio would PTT 3 seconds late every time and I get no responses.

My time synch is fine, .1 seconds off at most as shown in the WSJT-X screen. 

I queried this on the DXLab Group and others have the same problem. Bill G4WJS suggested setting the WSJT-X option "Settings->Radio->Mode->None", then set USB DATA A mode on the rig manually. This does remove the delay, but requires manual mode changes every time I change bands. 

The issue appears to be the way WSJT-X reaffirms radio settings before every PTT. Is there some way to make an option vs. hard-coded? That would eliminate the delay, not really cause me any other problems as I don't change anything on the radio while FT8 is active.

Thanks and 73 John K3TN



Go back to turning Commander off, WSJT-X talk to the K3S, all good.


Dave Garber
 

Have a look at teleposts lbp2 bridge.   It is designed to workvwith k3 and gives virtual port to your k3 so multiprograms can have a comport to the radio.


On Wed., Jan. 13, 2021, 6:09 a.m. John K3TN via groups.io, <jpescatore=aol.com@groups.io> wrote:
I've been migrating my shack computer to a refurb Win 10 machine, slowly getting everything going again. 

I have WSJT-X integrated to DXLab per the directions, first by turning off Commander and setting rig to K3S in WSJT-X. That works fine, both working stations and logging them in DXkeeper. Latest version of WSJT-X, latest versions of DXLab programs.

Then, followed the instructions here to have WSJT-X talk to Commander. First hint of an issue was the Test CAT button was slow to turn green. Then, answering a few FT8 CQs, the radio would PTT 3 seconds late every time and I get no responses.

My time synch is fine, .1 seconds off at most as shown in the WSJT-X screen. 

I queried this on the DXLab Group and others have the same problem. Bill G4WJS suggested setting the WSJT-X option "Settings->Radio->Mode->None", then set USB DATA A mode on the rig manually. This does remove the delay, but requires manual mode changes every time I change bands. 

The issue appears to be the way WSJT-X reaffirms radio settings before every PTT. Is there some way to make an option vs. hard-coded? That would eliminate the delay, not really cause me any other problems as I don't change anything on the radio while FT8 is active.

Thanks and 73 John K3TN



Go back to turning Commander off, WSJT-X talk to the K3S, all good.



John K3TN
 

I have a Microham MK2r+ that sets up virtual ports and I have two for the K3 control - but using one for Commander and a different one for WSJT-X still results in WSJT rig control errors.


Dave Garber
 

Perhaps there is a baud rate issue.


On Wed., Jan. 13, 2021, 9:30 a.m. John K3TN via groups.io, <jpescatore=aol.com@groups.io> wrote:
I have a Microham MK2r+ that sets up virtual ports and I have two for the K3 control - but using one for Commander and a different one for WSJT-X still results in WSJT rig control errors.



Joe Subich, W4TV
 

What kind of rig control errors? Have you posted the error
messages?

What are your settings for the "Forward autoinformaton to CAT port"
settings in Router -> CAT -> SET (Which port is Commander and which
is WSJTX)?

73,

... Joe, W4TV


John K3TN via groups.io wrote:

I have a Microham MK2r+ that sets up virtual ports and I have two
for the K3 control - but using one for Commander and a different one
for WSJT-X still results in WSJT rig control errors.


Tony Collett
 

My K3 uses LPBridge to integrate, also with DXLabs programs and it also "stutters" on changing frequencies (not band changes but changes of Tx QRG in the audio bandwidth).
It might sometimes cause up to a 5 second delay on FT8 (doesn't seem to affect FT4 as much) but 90% of the time I still get a response to my call so don't assume the delay in starting a transmission causes you not to make the contact.

My PTT is with VOX from a SignaLink not hardware and if I don't change my Tx QRG just prior to a transmission there is no delay.

GL with the new PC
73
Tony G4NBS


John K3TN
 

The errors in that configuration were from WSJT-X, something like "WSJT has detected rig control errors" with Retry/Cancel and a few other options. Ran into this a few years ago when first getting going with WSJT and no suggestions helped.

I'll check those Router parameters and post.


John K3TN
 

Jim N7US sent me his configuration and that approach solved my problem:

In WSJT-X, don't use CAT PTT, use RTS PTT via a COM port. In Microham Router, check PTT box for that COM port.

Now, rig band/mode control works, PTT works, no PTT delay.

I assume WSJT sending rig control information on every transmission, PTT delayed because of that?

73 John K3TN