locked WSJT-X 2.6.0-rc1 #hamlib


Bengt SM6MUY
 

Hi

Upgraded and I have CAT issue now from time to time. Hamlib error and it doesn't help to do "retry" which worked before. The frequency setting is 0.000. The only fix is to restart the PC. Very annoying.

Tried to go back to 2.5.4 but it didn't help.Even did a unistall and a new install. Aree there any "hidden" files somewhere which should be removed ?

73/Bengt, SM6MUY


Rig failure
Hamlib error: rig_set_conf_called
rig_confparam_lookup called for 3
rig_set_conf:no_xchg='1'

and so on...


Michael Black
 

If only a restart fixes it then it sounds like something with the serial port driver.
I assume you have a USB serial adapter?  What rig is this?
Uninstall the serial port in the Device Manager (I'm also assuming you are on Window).
Then reboot and let it reinstall.  It might change COM port numbers on you.
Also...how often is "time to time" ?
Another thing to check in Device Manager is to turn off Power Management on all USB devices that have that option.
Mike W9MDB

On Saturday, July 16, 2022 at 04:25:22 AM CDT, Bengt SM6MUY via groups.io <muy@...> wrote:

Hi

Upgraded and I have CAT issue now from time to time. Hamlib error and it
doesn't help to do "retry" which worked before. The frequency setting is
0.000. The only fix is to restart the PC. Very annoying.

Tried to go back to 2.5.4 but it didn't help.Even did a unistall and a
new install. Aree there any "hidden" files somewhere which should be
removed ?

73/Bengt, SM6MUY


Rig failure
Hamlib error: rig_set_conf_called
rig_confparam_lookup called for 3
rig_set_conf:no_xchg='1'

and so on...


Michael Black
 

What rig?
First off let's try the latest hamlibNew hamlib for installation directions
#1 Shut down WSJTX/JTDX
#2 Download either the 32-bit or 64-bit DLL matching the 32/64-bit version of WSJTX/JTDX -- hopefully your browser doesn't block it but may warn you multiple times.
If you can do a "Save As" you can save it directly in \WSJT\WSJTX\bin and replace the libhamlib-4.dll that is there.
http://n0nb.users.sourceforge.net/dll32/libhamlib-4.dll
http://n0nb.users.sourceforge.net/dll64/libhamlib-4.dll
Linux/Unix/Mac users need to compile the latest tar file from http://n0nb.users.sourceforge.net/\Note: If compiling on Unix-like systems please uninstall any Hamlib package you have before installing the new build
#3 If you don't save directly you need to open a file browser and move the file that way.
If you're not familiar with that here's a video on the file browser - https://www.youtube.com/watch?v=AyVqCJrs9dk
=========================================================================================Then..if you still see the problem....Please place this file as described belowhttps://www.dropbox.com/s/t52ngcalsgnpm8m/wsjtx_log_config.ini?dl=0
C:\Users\[username]\AppData\Local\WSJT-X The WSJT-X_Rigcontrol.log file will be in the same location For Linux put it in   ~/.config The WSJT-X_Rigcontrol.log file will be here: ~/.local/share/WSJT-X Restart WSJT-X and duplicate the problem.Shut down WSJT-X
Then send me the WSJT-X_RigControl.log fileMike W9MDB

On Saturday, July 16, 2022 at 04:25:22 AM CDT, Bengt SM6MUY via groups.io <muy@...> wrote:

Hi

Upgraded and I have CAT issue now from time to time. Hamlib error and it
doesn't help to do "retry" which worked before. The frequency setting is
0.000. The only fix is to restart the PC. Very annoying.

Tried to go back to 2.5.4 but it didn't help.Even did a unistall and a
new install. Aree there any "hidden" files somewhere which should be
removed ?

73/Bengt, SM6MUY


Rig failure
Hamlib error: rig_set_conf_called
rig_confparam_lookup called for 3
rig_set_conf:no_xchg='1'

and so on...


Bengt SM6MUY
 

Normally it works fine. But if I start to "play" with the radio, IC-7300 WSJT-X "complains after a while (loosing the connection). It's not any new thing. Always been like that. But before it was just to press "retry" and then the connection between WSJT-X and the radio was established again. That don't work anymore.

I'm using a USB connection but I have not changed any (Windows) driver. Everything is like before I did the upgrade to 2.6.0. Something happened when I did the upgrade. Ok I will try to re-install the USB driver again.

73/Bengt

On 2022-07-16 14:40, Michael Black via groups.io wrote:
If only a restart fixes it then it sounds like something with the serial port driver.
I assume you have a USB serial adapter?  What rig is this?
Uninstall the serial port in the Device Manager (I'm also assuming you are on Window).
Then reboot and let it reinstall.  It might change COM port numbers on you.
Also...how often is "time to time" ?
Another thing to check in Device Manager is to turn off Power Management on all USB devices that have that option.
Mike W9MDB



On Saturday, July 16, 2022 at 04:25:22 AM CDT, Bengt SM6MUY via groups.io <muy@...> wrote:
Hi

Upgraded and I have CAT issue now from time to time. Hamlib error and it
doesn't help to do "retry" which worked before. The frequency setting is
0.000. The only fix is to restart the PC. Very annoying.

Tried to go back to 2.5.4 but it didn't help.Even did a unistall and a
new install. Aree there any "hidden" files somewhere which should be
removed ?

73/Bengt, SM6MUY


Rig failure
Hamlib error: rig_set_conf_called
rig_confparam_lookup called for 3
rig_set_conf:no_xchg='1'

and so on...










Michael Black
 

Upgrade to the latest Hamlib -- and if you still have problems do the debug stuff too.
New hamlib for installation directions
#1 Shut down WSJTX/JTDX
#2 Download either the 32-bit or 64-bit DLL matching the 32/64-bit version of WSJTX/JTDX -- hopefully your browser doesn't block it but may warn you multiple times.
If you can do a "Save As" you can save it directly in \WSJT\WSJTX\bin and replace the libhamlib-4.dll that is there.
http://n0nb.users.sourceforge.net/dll32/libhamlib-4.dll
http://n0nb.users.sourceforge.net/dll64/libhamlib-4.dll
Linux/Unix/Mac users need to compile the latest tar file from http://n0nb.users.sourceforge.net/\Note: If compiling on Unix-like systems please uninstall any Hamlib package you have before installing the new build
#3 If you don't save directly you need to open a file browser and move the file that way.
If you're not familiar with that here's a video on the file browser - https://www.youtube.com/watch?v=AyVqCJrs9dk

For Debug:
Please place this file as described belowhttps://www.dropbox.com/s/t52ngcalsgnpm8m/wsjtx_log_config.ini?dl=0
C:\Users\[username]\AppData\Local\WSJT-X The WSJT-X_Rigcontrol.log file will be in the same location For Linux put it in   ~/.config The WSJT-X_Rigcontrol.log file will be here: ~/.local/share/WSJT-X Restart WSJT-X and duplicate the problem.Shut down WSJT-X
Then send me the WSJT-X_RigControl.log fileMike W9MDB

On Saturday, July 16, 2022 at 06:10:36 PM CDT, Bengt SM6MUY via groups.io <muy@...> wrote:

Normally it works fine. But if I start to "play" with the radio, IC-7300
WSJT-X "complains after a while (loosing the connection). It's not any
new thing. Always been like that. But before it was just to press
"retry" and then the connection between WSJT-X and the radio was
established again. That don't work anymore.

I'm using a USB connection but I have not changed any (Windows) driver.
Everything is like before I did the upgrade to 2.6.0. Something happened
when I did the upgrade. Ok I will try to re-install the USB driver again.

73/Bengt

On 2022-07-16 14:40, Michael Black via groups.io wrote:
If only a restart fixes it then it sounds like something with the serial port driver.
I assume you have a USB serial adapter?  What rig is this?
Uninstall the serial port in the Device Manager (I'm also assuming you are on Window).
Then reboot and let it reinstall.  It might change COM port numbers on you.
Also...how often is "time to time" ?
Another thing to check in Device Manager is to turn off Power Management on all USB devices that have that option.
Mike W9MDB


 

      On Saturday, July 16, 2022 at 04:25:22 AM CDT, Bengt SM6MUY via groups.io <muy@...> wrote:
 
  Hi

Upgraded and I have CAT issue now from time to time. Hamlib error and it
doesn't help to do "retry" which worked before. The frequency setting is
0.000. The only fix is to restart the PC. Very annoying.

Tried to go back to 2.5.4 but it didn't help.Even did a unistall and a
new install. Aree there any "hidden" files somewhere which should be
removed ?

73/Bengt, SM6MUY


Rig failure
Hamlib error: rig_set_conf_called
rig_confparam_lookup called for 3
rig_set_conf:no_xchg='1'

and so on...






   





dl8le
 

I have a similar problem at the IC7300 at our club station with version 2.5.4 even after updating to a new libhamlib-4.dll (there was a post about this topic in this group several weeks ago already). My problem started at the beginning of this year and the situation became worse over time (loosing connection after 1 - 2 hours to a situation loosing the connection after 10 - 15 min). Windows updates are done as early as possible and the IC7300 firmware is the latest version.

I have de-installed and re-installed the ICOM driver a couple of times, but no success, I have tried different USB connectors and cables with the same result, and even the approach using DXLab Suite Commander as radio which worked in the past whenever there was a serial port problem did not work any longer because N1MM and Commander of DXLab also lost the connection to the radio. I have tried Omni-Rig as well, which worked very well when using WSJT-X together with a Kenwood TS2000 (with direct com-port connection that radio lost connection also quite frequently, very annoying).

If there is not a hardware problem with the USB-port of the radio (one of the next topics I want to investigate, but did not had the proper measuring equipment and not enough time so far) I have the impression that there is something in the driver of the IC7300 which is not adapted to the changes happened in W10 since it was published. Therefore I would be very much interested in the experience of other IC7300 users using W10 with all recent updates but also in the results of the analysis of the debug file. As I don't have access to the radio and the pc at the moment and for the next weeks I cannot send any debugging file by myself.

73

Juergen, DL8LE


Michael Black
 

Check your USB devices in Device Manager and ensure Power Management is turned off.
Mike W9MDB

On Sunday, July 17, 2022 at 03:29:37 PM CDT, dl8le <dl8le@...> wrote:

I have a similar problem at the IC7300 at our club station with version 2.5.4 even after updating to a new libhamlib-4.dll (there was a post about this topic in this group several weeks ago already). My problem started at the beginning of this year and the situation became worse over time (loosing connection after 1 - 2 hours to a situation loosing the connection after 10 - 15 min). Windows updates are done as early as possible and the IC7300 firmware is the latest version.

I have de-installed and re-installed the ICOM driver a couple of times, but no success, I have tried different USB connectors and cables with the same result, and even the approach using DXLab Suite Commander as radio which worked in the past whenever there was a serial port problem did not work any longer because N1MM and Commander of DXLab also lost the connection to the radio. I have tried Omni-Rig as well, which worked very well when using WSJT-X together with a Kenwood TS2000 (with direct com-port connection that radio lost connection also quite frequently, very annoying).

If there is not a hardware problem with the USB-port of the radio (one of the next topics I want to investigate, but did not had the proper measuring equipment and not enough time so far) I have the impression that there is something in the driver of the IC7300 which is not adapted to the changes happened in W10 since it was published. Therefore I would be very much interested in the experience of other IC7300 users using W10 with all recent updates but also in the results of the analysis of the debug file. As I don't have access to the radio and the pc at the moment and for the next weeks I cannot send any debugging file by myself.

73

Juergen, DL8LE


dl8le
 

Done already: the serial and the audio port are both available in the device manager as working properly.
Power management: no automatic shut off of monitor or pc when connected to the power line.


73

Juergen, DL8LE


Joe Subich, W4TV
 

Power management: no automatic shut off of monitor or pc when connected to the power line.
In Power Options -> Advanced Settings -> *USB Settings* ->
*USB selective suspend setting*, make sure *BOTH* "On battery"
and "Plugged in" are *DISABLED*

Also, use "High Performance" as your base settings.

73,

... Joe, W4TV

On 2022-07-17 4:40 PM, dl8le wrote:
Done already: the serial and the audio port are both available in the device manager as working properly.
Power management: no automatic shut off of monitor or pc when connected to the power line.
73
Juergen, DL8LE


Wes Larson
 

I am running Windows 7 64 bit on my lap-top and followed the instructions installing the SSL 64 bit and it did not work until I installed the 32 bit versions of the SSL. only then did the ARRL Log book of the world file would down load with out error. I still don't see the difference in the Band Activity for Log Book of the World users