locked ICOM IC-7300 & Vara HF Winlink & WSJT-X issues - Solved! #Icom #install


Lyle Giese
 

I already posted this info on the VARA-MODEM area, but thought this might be of use over here also.  This can happen with any two programs accessing your radio using a virtual USB ComPort.


Just in case anyone else stumbles across this. Not sure if this is documented any where but...

Just getting starting with Winlink & Vara HF. Turn on IC-7300. Open Winlink and all works as it should and I am able to send/receive email. Close Winlink. Open WSJT-X doesn't work. Cann't talk to IC-7300.

Have to exit WSJT-X, power cycle IC-7300. Open WSJT-X, works fine. Close WSJT-X. Open Winlink, Open Vara HF session, doesn't talk to radio. Close Winlink, power cycle IC-7300. Open Winlink, Vara HF works fine.

Restarting Win 10 computer has no effect in clearing the control lockout. Have to power cycle IC-7300 to clear control lockout when openning the second program.

Then I rechecked radio setting between the two programs and when setting them up, just accepted the default values and they worked until I tried to use the other program without power cycling the IC-7300.

I rechecked the radio settings and saw a difference. The Baud rate for the fake USB/com port was different between the two programs. Reset Vara HF to the same baud rate WSJT-X used and now I can switch between program without having tp power cycle the radio. Apparently, the IC-7300 locks into the first com port baud rate and stays there until it is power cycled. ARGHH! WSJT-X defaulted to 1115,200 and Vara HF defaulted to 9600.

Setting baud rate on WSJT-X:
Open WSJT-X --> File --> Settings --> Radio --> Baud Rate defaulted to 115200.

Setting baud rate on Vara HF:
Open Winlink --> open Vara HF Winlink session --> Settings --> Radio Setup --> Radio Control Port section --> Baud, defaulted to 9600, reset to 115200 and click on Update

If you reset the baud rate in Vara HF, you may need to exit Winlink completely and power cycle your IC-7300 and then you will be good to go.

Also in the Radio Setup page for Vara HF, the USB Digital, not USB needs to be used. I think it defaulted to USB instead, but I discovered that early one.

Hope this helps someone else!
Lyle Giese
KD9RCN