locked WSJT-X Help with 2.5.4 release #stopped_working


Larry Bliss
 

All,

Like George - WB5JJJ, I had uninstalled 2.5.4 and re-installed 2.6.0. (see previous email sent yesterday, which I can't find the post???)

It is working now with 2.6.0 and I'm happy with it and found no issues.

Thanks to Gary - AG0N, Reino OH3mA, & George - WB5JJJ for helping me resolve this issue.

GL & 73,
Larry - KK6MF

Enjoy!


WB5JJJ - George
 

There is some sort of glitch in the v2.6.0-rc1 installer/uninstaller. Once you install rc1, many folks cannot roll back to v2.5.4 or ANY earlier release. I found this out firsthand. Looks like I'm stuck with the rc1, not a bad thing, but I typically try a new rc and then roll back until the stable release it out.

It was posted a week or so back that the WSJTx team was aware of this problem and rolled out a "fix" under the same rc1 file name (why?), but even downloading and installing and uninstalling that "fix" did not solve the problem. Computer reboots did not fix the problem either. No JT9 instances running. Other than blowing away anything related to WSJTx (files, folder, registry), rebooting and installing 2.5.4, I don't see a way to roll back. Have not tried that, but it appears to me to be the only logical way.

--
73's
George - WB5JJJ
Hamshack Holine #4969
Hams over IP #100105


Reino Talarmo
 

Hi Larry,

I re-read your original mail and the error message you got was generates due to the second initiation attempt. The real reason why the 2.5.4 did not opened in first place is not clear to me. I need to admit that my computer knowledge is also quite limited, but I am learning a bit more now and then, hi!

By the way you can copy any wsjt-x error message simply going into the error windows and copy it using Ctrl+C, no painting is needed. Then you may add it into a Notepad or Mail text by Ctrl+V.

You could try to generate new instance of wsjt-x as presented in 16. Frequently Asked Questions second item:
Start WSJT-X from a command-prompt window, assigning each a unique identifier as in the following two-instance example. This procedure will isolate the Settings file and the writable file location for each instance of WSJT-X.

wsjtx --rig-name=Test

Then your should have a new AppData location "Test" for all wsjtx.ini etc. files. I have not tested myself, whether totally new wsjtx.ini file will be generated for the "test", but that file could be a reason. You may also try to delete it while not running the wsjt-x. You could make is sure by re-starting Windows before any attempt. I think that WSJT-X will generate a new wsjtx.ini, if there is none. There are also some other "wisdom" files that are computer specific that may be corrupted.

Hope this helps a bit. Otherwise you need a real computer and wsjt-x specialist.

73, Reino OH3mA


Larry Bliss
 

Hi Reino and all,

Note: My computer knowledge (15 years ago) was Intermediate at best.
Prior to sending out my first email, I checked user>AppData>Local>WSJT-X for All.txt, WSJT-X.ini, wsjtx.log files (I couldn't figure out a way to attach the .jpg file to show a screen print.

This morning, I could not duplicate the running error with 2.5.4. The app, as before attempted to run, but didn't produce an error.

Next I focused on jt9.exe running in the back ground using the Task Manager app. Nothing found

I did find jt9.exe in C:\WSJT\wsjtx\bin.

At this point, I stuck!


Larry Bliss
 

Did you reboot? Should reboot after loading newer version.

To Gary's point...This was all done a day or two before our vacation and I don't recall rebooting then. When we got back from our trip the problem was still there.


Reino Talarmo
 

After a period of about 1/2 an hour with no contacts in the log. I uninstalled 2.6.0.
When I clicked on it again, Windows says the application is running. hmm
Hi Larry

You have two questions. First why you did not get any QSOs using 2.6.0-rc1? What was wrong? You should tell more what else you found e.g. whether you really had output power or something else.

The second one is simple. You may have installed 2.5.4 while WSJT-X was running. So process JT9.exe was still running, when you tried run the 2.5.4. As Gary said you may restart Windows or you may try to kill the orphan FT9.exe process.

73, Reino OH3mA


Gary - AG0N
 

On Jul 1, 2022, at 21:14, Larry Bliss <kk6mf@...> wrote:

My question is: What steps are needed to fix this?

Did you reboot? Should reboot after loading newer version.

Gary - AG0N


Larry Bliss
 

Release 2.5.4 doesn't start now.

Background... I have close to 10,000 FT4/8 contacts after 2+ years with Windows 10.
So, I felt confident in upgrading to a newer release.I took a chance & loaded 2.6.0-RC1, which loaded with not problem.
After a period of about 1/2 an hour with no contacts in the log. I uninstalled 2.6.0.

My previous installation was not available, so I installed the 2.5.4 release.
2.5.4 loaded with no apparent problem, When I clicked on the icon to start WSJT-X , the icon moved a little, but failed to open the program.
When I clicked on it again, Windows says the application is running. hmm

My question is: What steps are needed to fix this?

Thanks & 73,
Larry Bliss - KK6MF