locked #raspberryPi #WSPR v2.3.0 - Band Hoping Schedule window is not displayed #raspberryPi #WSPR


gareth.pale <gareth.paley@...>
 

As per subject, in WSPR mode when I tick band hopping and then hit the schedule button it doesn't bring up a schedule window.

I've installed the latest available version of WSJT-X (v2.3.0) on the latest version of Debian Bullseye on a 3B+ Raspberry Pi with a 7" touch screen. No other apps are running, I've even switched off the waterfall.

The first time I press the button I can see for an instant it trying to draw an outline for a window but then it disappears. Subsequent pushes of the Schedule button does nothing. The Pi task bar just shows WSJT-X running.

All other functions work perfectly

Hope someone has seen this before and fixed it because I'm stumped.

Gareth
de M0WWS


Bob K4RCG
 

GA Gareth, I've seen that before and I've never been able to determine why
it occurs. Seems re-starting WSJT/WSPR clears it up. Also, you may want
to try WSJT-X v2.5.4; works a treat on my RasP4/Buster OS.

73 de Bob
K4RCG

On Sun, Apr 17, 2022 at 2:41 PM gareth.pale <gareth.paley@...> wrote:

As per subject, in WSPR mode when I tick band hopping and then hit the
schedule button it doesn't bring up a schedule window.

I've installed the latest available version of WSJT-X (v2.3.0) on the
latest version of Debian Bullseye on a 3B+ Raspberry Pi with a 7" touch
screen. No other apps are running, I've even switched off the waterfall.

The first time I press the button I can see for an instant it trying to
draw an outline for a window but then it disappears. Subsequent pushes of
the Schedule button does nothing. The Pi task bar just shows WSJT-X running.

All other functions work perfectly

Hope someone has seen this before and fixed it because I'm stumped.

Gareth
de M0WWS






gareth.pale <gareth.paley@...>
 

Thanks Bob, I'm not sure how to install v2.5.4 because the PI Installer only seems to find v2. 3.0. I'll have a look for v2.5.4 package and install it manually if I can.

Sent from my Xperia by Sony smartphone

---- Bob K4RCG wrote ----

GA Gareth, I've seen that before and I've never been able to determine why
it occurs. Seems re-starting WSJT/WSPR clears it up. Also, you may want
to try WSJT-X v2.5.4; works a treat on my RasP4/Buster OS.

73 de Bob
K4RCG

On Sun, Apr 17, 2022 at 2:41 PM gareth.pale <gareth.paley@...> wrote:

As per subject, in WSPR mode when I tick band hopping and then hit the
schedule button it doesn't bring up a schedule window.

I've installed the latest available version of WSJT-X (v2.3.0) on the
latest version of Debian Bullseye on a 3B+ Raspberry Pi with a 7" touch
screen. No other apps are running, I've even switched off the waterfall.

The first time I press the button I can see for an instant it trying to
draw an outline for a window but then it disappears. Subsequent pushes of
the Schedule button does nothing. The Pi task bar just shows WSJT-X running.

All other functions work perfectly

Hope someone has seen this before and fixed it because I'm stumped.

Gareth
de M0WWS









Karl Beckman WA8NVW - NNV5BH
 

GARETH -
It appears that you are working with an old version - the current version of WSJTx is 2.5.4 and it is already a few months old.

--
Karl  WA8NVW  OH
WA8NVW@...
in WSJTX@groups.io


gareth.pale <gareth.paley@...>
 

Thanks Karl, when I run preferences, Add/Remove Software and type in
"wsjt-x" and it searches for packages and all it finds is v2.3.0.

I've just built a Buster image and I'm gonna boot my PI with this version
because Bob, K4RCG say's he's running that OS rather than the Bullseye
version I've been running. Let's see if Add/Remove Software finds version 2.5.4
for this OS, if not I'll see if I can find the package file and install it
from the command line instead.

Many Thanks
Gareth
de M0WWS

On Sun, Apr 17, 2022 at 6:08 PM Karl Beckman WA8NVW - AFA5VB <
wa8nvw@...> wrote:

GARETH -
It appears that you are working with an old version - the current version
of WSJTx is 2.5.4 and it is already a few months old.

--
Karl WA8NVW OH
WA8NVW@...
in WSJTX@groups.io






Bob K4RCG
 

Gareth, it should be on the WSJT/Princeton web page. It should have
everything you need.

73
Bob K4RCG

On Sun, Apr 17, 2022 at 11:49 Gareth Paley <gareth.paley@...> wrote:

Thanks Bob, I'm not sure how to install v2.5.4 because the PI Installer
only seems to find v2. 3.0. I'll have a look for v2.5.4 package and install
it manually if I can.

Sent from my Xperia by Sony smartphone


---- Bob K4RCG wrote ----

GA Gareth, I've seen that before and I've never been able to determine why

it occurs. Seems re-starting WSJT/WSPR clears it up. Also, you may want

to try WSJT-X v2.5.4; works a treat on my RasP4/Buster OS.



73 de Bob

K4RCG



On Sun, Apr 17, 2022 at 2:41 PM gareth.pale <gareth.paley@...>
wrote:



As per subject, in WSPR mode when I tick band hopping and then hit the
schedule button it doesn't bring up a schedule window.
I've installed the latest available version of WSJT-X (v2.3.0) on the
latest version of Debian Bullseye on a 3B+ Raspberry Pi with a 7" touch
screen. No other apps are running, I've even switched off the waterfall.
The first time I press the button I can see for an instant it trying to
draw an outline for a window but then it disappears. Subsequent pushes of
the Schedule button does nothing. The Pi task bar just shows WSJT-X
running.

All other functions work perfectly
Hope someone has seen this before and fixed it because I'm stumped.
Gareth
de M0WWS











gareth.pale <gareth.paley@...>
 

Thanks, downloaded and installed and schedule is now working. Cat control
is now throwing up hamlib protocol errors with the same wsjtx settings I
had before as so I'm updating that now...

On Sun, 17 Apr 2022, 22:09 Robert Stohlman, <bobstohlman@...> wrote:

Gareth, it should be on the WSJT/Princeton web page. It should have
everything you need.

73
Bob K4RCG

On Sun, Apr 17, 2022 at 11:49 Gareth Paley <gareth.paley@...> wrote:

Thanks Bob, I'm not sure how to install v2.5.4 because the PI Installer
only seems to find v2. 3.0. I'll have a look for v2.5.4 package and install
it manually if I can.

Sent from my Xperia by Sony smartphone


---- Bob K4RCG wrote ----

GA Gareth, I've seen that before and I've never been able to determine why

it occurs. Seems re-starting WSJT/WSPR clears it up. Also, you may want

to try WSJT-X v2.5.4; works a treat on my RasP4/Buster OS.



73 de Bob

K4RCG



On Sun, Apr 17, 2022 at 2:41 PM gareth.pale <gareth.paley@...>
wrote:



As per subject, in WSPR mode when I tick band hopping and then hit the
schedule button it doesn't bring up a schedule window.
I've installed the latest available version of WSJT-X (v2.3.0) on the
latest version of Debian Bullseye on a 3B+ Raspberry Pi with a 7" touch
screen. No other apps are running, I've even switched off the waterfall.
The first time I press the button I can see for an instant it trying to
draw an outline for a window but then it disappears. Subsequent pushes
of

the Schedule button does nothing. The Pi task bar just shows WSJT-X
running.

All other functions work perfectly
Hope someone has seen this before and fixed it because I'm stumped.
Gareth
de M0WWS











Bob K4RCG
 

Let us know how it works out Gareth. GL

73 de Bob K4RCG

On Mon, Apr 18, 2022 at 1:55 PM Gareth Paley <gareth.paley@...> wrote:

Thanks, downloaded and installed and schedule is now working. Cat control
is now throwing up hamlib protocol errors with the same wsjtx settings I
had before as so I'm updating that now...

On Sun, 17 Apr 2022, 22:09 Robert Stohlman, <bobstohlman@...> wrote:

Gareth, it should be on the WSJT/Princeton web page. It should have
everything you need.

73
Bob K4RCG

On Sun, Apr 17, 2022 at 11:49 Gareth Paley <gareth.paley@...>
wrote:

Thanks Bob, I'm not sure how to install v2.5.4 because the PI Installer
only seems to find v2. 3.0. I'll have a look for v2.5.4 package and install
it manually if I can.

Sent from my Xperia by Sony smartphone


---- Bob K4RCG wrote ----

GA Gareth, I've seen that before and I've never been able to determine
why

it occurs. Seems re-starting WSJT/WSPR clears it up. Also, you may want

to try WSJT-X v2.5.4; works a treat on my RasP4/Buster OS.



73 de Bob

K4RCG



On Sun, Apr 17, 2022 at 2:41 PM gareth.pale <gareth.paley@...>
wrote:



As per subject, in WSPR mode when I tick band hopping and then hit the
schedule button it doesn't bring up a schedule window.
I've installed the latest available version of WSJT-X (v2.3.0) on the
latest version of Debian Bullseye on a 3B+ Raspberry Pi with a 7" touch
screen. No other apps are running, I've even switched off the
waterfall.

The first time I press the button I can see for an instant it trying to
draw an outline for a window but then it disappears. Subsequent pushes
of

the Schedule button does nothing. The Pi task bar just shows WSJT-X
running.

All other functions work perfectly
Hope someone has seen this before and fixed it because I'm stumped.
Gareth
de M0WWS











gareth.pale <gareth.paley@...>
 

I started afresh with a new Raspberry Buster image. Then I followed the
instructions at:

https://physics.princeton.edu/pulsar/k1jt/wsjtx-doc/wsjtx-main-2.5.4.html#INSTALL_LINUX

executing the following first:

sudo apt install libgfortran5 libqt5widgets5 libqt5network5
libqt5printsupport5 libqt5multimedia5-plugins libqt5serialport5
libqt5sql5-sqlite libfftw3-single3 libgomp1 libboost-all-dev libusb-1.0-0
libportaudio2

then installed the package file:

wget https://physics.princeton.edu/pulsar/K1JT/wsjtx_2.5.4_armhf.deb

finally installed it with the command:

sudo dpkg -i wsjtx_2.5.4_armhf.deb

WSJTX-X v.2.5.4 is now installed and running, the schedule box comes up
when I select band hopping but I am having problems configuring it to
connect to my rig.


I'm using exactly the same Radio and Audio settings as I have on my WSJT-X
v.2.4.0 I have running on my Windows 10 PC and I get the following error
when I hit the Test CAT button:

Rig Failure

Hamlib error: Protocol error
rig_get_vfo: returning -8(Protocol error
0000 00
read_block_generic(): Timed out 3.2545 seconds after 1 chars
read_block_generic(): Timed out 3.2545 seconds after 1 chars)rig_get_vfo:
elapsed=3015ms
rig.c(2587):rig_get_vfo return(-8) Protocol error
rig_get_vfo: returning -8(Protocol error
0000 00
read_block_generic(): Timed out 3.2545 seconds after 1 chars
read_block_generic(): Timed out 3.2545 seconds after 1 chars)rig_get_vfo:
elapsed=3015ms
rig_get_vfo: elapsed=3015ms while testing getting current VFO

The rig I'm using is an mcHF clone which uses the FT-817 command set, so
that's Rig the rig I select Rig: Yaesu FT-817. Serial Port: /dev/ttyACM0,
Baud Rate 38400, Data Bits 8, Stop Bits Default, Hand Shake Default, PTT
Method CAT, mode None, Split operation None. Audio settings -
Soundcard Input: plughw:CARD=mchf,DEV=0, Output: plughw:CARD=mchf,DEV=0.
This works fine on version 2.3.0.

I think I'm going to unistall and go back to 2.3.0 as I can live without
scheduled band hopping but it's useless without CAT control.

Regards
Gareth
de M0WWS





On Tue, Apr 19, 2022 at 12:03 AM Robert Stohlman <bobstohlman@...>
wrote:

Let us know how it works out Gareth. GL

73 de Bob K4RCG

On Mon, Apr 18, 2022 at 1:55 PM Gareth Paley <gareth.paley@...>
wrote:

Thanks, downloaded and installed and schedule is now working. Cat control
is now throwing up hamlib protocol errors with the same wsjtx settings I
had before as so I'm updating that now...

On Sun, 17 Apr 2022, 22:09 Robert Stohlman, <bobstohlman@...>
wrote:

Gareth, it should be on the WSJT/Princeton web page. It should have
everything you need.

73
Bob K4RCG

On Sun, Apr 17, 2022 at 11:49 Gareth Paley <gareth.paley@...>
wrote:

Thanks Bob, I'm not sure how to install v2.5.4 because the PI Installer
only seems to find v2. 3.0. I'll have a look for v2.5.4 package and install
it manually if I can.

Sent from my Xperia by Sony smartphone


---- Bob K4RCG wrote ----

GA Gareth, I've seen that before and I've never been able to determine
why

it occurs. Seems re-starting WSJT/WSPR clears it up. Also, you may want

to try WSJT-X v2.5.4; works a treat on my RasP4/Buster OS.



73 de Bob

K4RCG



On Sun, Apr 17, 2022 at 2:41 PM gareth.pale <gareth.paley@...>
wrote:



As per subject, in WSPR mode when I tick band hopping and then hit the
schedule button it doesn't bring up a schedule window.
I've installed the latest available version of WSJT-X (v2.3.0) on the
latest version of Debian Bullseye on a 3B+ Raspberry Pi with a 7"
touch

screen. No other apps are running, I've even switched off the
waterfall.

The first time I press the button I can see for an instant it trying
to

draw an outline for a window but then it disappears. Subsequent
pushes of

the Schedule button does nothing. The Pi task bar just shows WSJT-X
running.

All other functions work perfectly
Hope someone has seen this before and fixed it because I'm stumped.
Gareth
de M0WWS











Brian Morrison
 

On Tue, 19 Apr 2022 18:45:37 +0100
"gareth.pale" <gareth.paley@...> wrote:

I think I'm going to unistall and go back to 2.3.0 as I can live without
scheduled band hopping but it's useless without CAT control.
Which hamlib version are you using Gareth? The 4.5~git version has had
a lot of changes, so if you can try the current git version in place of
whatever the Pi currently uses it might behave better.

--

Brian G8SEZ


gareth.pale <gareth.paley@...>
 

Success.

When I had version 2.5.4 installed although I couldn't get it to connect to
my rig I was able to get the schedule window up briefly and enter what I
wanted - 40m and 20m simultaneously on morning and evening greyline and 20m
day time and 40m night time.

After I removed version 2.5.4 I noticed that all the settings persisted
when I installed v 2.3.0 - a config file must have been left somewhere and
not removed under the automated de-install.

Now I'm running WSJT-X version 2.0.0 would you believe. It picked it up in
the add/remove applications when I searched for wsjtx. Rig control is fine
and I can tick band hoping but it doesn't bring up the schedule but the
schedule is there nonetheless.

I'm happy now. I can free up my PC for other things and just have the
raspberry running my WSPR beacon.

Thanks all
de M0WWS

On Tue, Apr 19, 2022 at 7:56 PM Brian Morrison <bdm@...> wrote:

On Tue, 19 Apr 2022 18:45:37 +0100
"gareth.pale" <gareth.paley@...> wrote:

I think I'm going to unistall and go back to 2.3.0 as I can live without
scheduled band hopping but it's useless without CAT control.
Which hamlib version are you using Gareth? The 4.5~git version has had
a lot of changes, so if you can try the current git version in place of
whatever the Pi currently uses it might behave better.

--

Brian G8SEZ