Locked #hamlib Error - IC-705 - Wireless #hamlib


Running Windows 10 - WSJT-X v 2.4.0 c19d62 - IC-705, [wireless in Access Point Mode]

When I first hook up the IC-705 to WSJT-X, using the Icom remote utility, the CAT control turns green and I begin receiving signals. When I test the PTT, I get the following error message:

Hamlib error: IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6) while opening connection to rig

Timestamp: 2022-03-15T02:36:55.730Z

After I receive this error message, I can make changes in the WSJT-X settings but nothing changes and the error code repeats.

I even tried running it as the IC-7300, changing the CI-V, but no joy there either.

The only thing I'm not sure about the set-up is in the Icom Remote utility, it says the "AUDIO DEVICE" settings are 'Speaker = Default; Mic = Default; Virtual Audio = Icom V_VAUDIO-1 [1=2 0=0], even though I had previously selected Icom V_AUDIO. On the computer sound card, I've also selected Icom V_AUDIO.

I closed WSJT-X and opened the RS-BA1 Remote software and the I can control everything in the IC-705 'wirelessly' from the laptop except I can't transmit.

I had a similar problem with my IC-7300 months ago. The problem began as I tried using N3FJP for the logging. I never fixed it, just gave up for a few months and hte problem fixed itself. Don't know what I did, the 7300 is running FT8 and N3FJP automatically logs. Don't want to wait this time, haha!


Wayne - W7WGC