locked WSJT-X Loses TX Audio Connection to transceiver #AudioIssues


Glen Jenkins WB4KTF
 

I have been having an issue for months where my WSJT-X will function properly for a while in both RX and TX, but then fail. After some time (even less than an hour of idle time) it will remain receiving but when I try to TX or TUNE, the audio over USB fails (no RF output) even though the transceiver gets keyed to TX. The Configuration Settings are not changing. I do have USB port Power Management 'disabled', so the PC (WIN10) is not shutting down these ports to save power. I have to shut down WSJT-X then relaunch it to get TX working again. Suggestions appreciated. Rig: IC-7610
--
Glen, WB4KTF
Austin, TX


Michael Black
 

Take a look at your sound control panel when this happens.I'll bet your audio is going out another device.This can happen when the audio devices get reset.  Either due to you plugging/unplugging a USB device or RFI causing a device reset.Getting your shack grounding system in good order is a must.Chokes can help.  Particularly on AC transformers from alarm systems, HVAC and sprinkler systems because those are all big antenna systems and AC transformers just love sine waves.
So..first off please describe your grounding system.

Mike W9MDB

On Friday, February 25, 2022, 02:07:39 AM CST, Glen Jenkins WB4KTF <wb4ktf@...> wrote:

I have been having an issue for months where my WSJT-X will function properly for a while in both RX and TX, but then fail.  After some time (even less than an hour of idle time) it will remain receiving but when I try to TX or TUNE, the audio over USB fails (no RF output) even though the transceiver gets keyed to TX.  The Configuration Settings are not changing.  I do have USB port Power Management 'disabled', so the PC (WIN10) is not shutting down these ports to save power.  I have to shut down WSJT-X then relaunch it to get TX working again.  Suggestions appreciated. Rig: IC-7610
--
Glen, WB4KTF
Austin, TX


Chris VE3NRT
 

I have the same problem when I haven't transmitted for a while, using the audio device built into the motherboard. WSJT-X still receives signals and keys the transmitter, but it sends no audio to the rig. Restarting WSJT-X fixes it.

There are at least two reasons not to suspect RFI. First is that restarting a program fixes it, and second is that there is no RF present. There is also no unplugging/replugging required. Just go away for a couple of hours, come back, and audio output no longer works. It could be related to the audio port in the monitor going to sleep when it goes into power save mode. That seems far-fetched, but easy enough to check.

Next time it happens I'll poke around in device manager, etc., and report back if I see anything unusual.

73,
Chris


Michael Black
 

The walk-away problem is usuallyi USB selective suspend.Turn them ALL off on ALL USB devices and hubs.
Mike W9MDB

On Friday, February 25, 2022, 09:22:42 AM CST, Chris VE3NRT <dx@...> wrote:

I have the same problem when I haven't transmitted for a while, using the audio device built into the motherboard. WSJT-X still receives signals and keys the transmitter, but it sends no audio to the rig. Restarting WSJT-X fixes it.

There are at least two reasons not to suspect RFI. First is that restarting a program fixes it, and second is that there is no RF present. There is also no unplugging/replugging required. Just go away for a couple of hours, come back, and audio output no longer works. It could be related to the audio port in the monitor going to sleep when it goes into power save mode. That seems far-fetched, but easy enough to check.

Next time it happens I'll poke around in device manager, etc., and report back if I see anything unusual.

73,
Chris


Bruce - K5WBM
 

I can confirm that an hdmi monitor going to sleep can cause the audio issue you describe. I had to disable the monitor audio source on my system and have not had issues since.

Bruce - K5WBM

On Feb 25, 2022, at 9:22 AM, Chris VE3NRT <dx@...> wrote:

I have the same problem when I haven't transmitted for a while, using the audio device built into the motherboard. WSJT-X still receives signals and keys the transmitter, but it sends no audio to the rig. Restarting WSJT-X fixes it.

There are at least two reasons not to suspect RFI. First is that restarting a program fixes it, and second is that there is no RF present. There is also no unplugging/replugging required. Just go away for a couple of hours, come back, and audio output no longer works. It could be related to the audio port in the monitor going to sleep when it goes into power save mode. That seems far-fetched, but easy enough to check.

Next time it happens I'll poke around in device manager, etc., and report back if I see anything unusual.

73,
Chris





Larry Banks
 

Including HDMI ports.

Larry / W1DYJ

On 2/25/2022 10:37, Michael Black via groups.io wrote:
The walk-away problem is usuallyi USB selective suspend.Turn them ALL off on ALL USB devices and hubs.
Mike W9MDB

On Friday, February 25, 2022, 09:22:42 AM CST, Chris VE3NRT<dx@...> wrote:
I have the same problem when I haven't transmitted for a while, using the audio device built into the motherboard. WSJT-X still receives signals and keys the transmitter, but it sends no audio to the rig. Restarting WSJT-X fixes it.

There are at least two reasons not to suspect RFI. First is that restarting a program fixes it, and second is that there is no RF present. There is also no unplugging/replugging required. Just go away for a couple of hours, come back, and audio output no longer works. It could be related to the audio port in the monitor going to sleep when it goes into power save mode. That seems far-fetched, but easy enough to check.

Next time it happens I'll poke around in device manager, etc., and report back if I see anything unusual.

73,
Chris









Glen Jenkins WB4KTF
 

HI,
It appears that many of you are mentioning the Audio Power Management feature in USB ports, but as I mentioned in the original post, I do have them all set to OFF (unchecked). So the USB ports are not going to sleep to save power.
MICHAEL BLACK: What is USB SELECTIVE SUSPEND and where do I find this setting??
I'm not plugging or unplugging devices, everything here is well grounded to a single point ground, even the Desktop PC (thus not powered by a wallwart or external PS). RF is not causing this as there is no RF here when this quits working, I've been idle, only monitoring the band.
--
Glen, WB4KTF
Austin, TX


Michael Black
 

Go to device manager.Start with the USB devices but you really shouild check all the devices to see if they have a Power Management tab.
It's the Power Management tab and "Allow the computer to turn off this device to save power" which defaults to On and need to be Off.
Mike W9MDB

On Friday, February 25, 2022, 11:10:16 AM CST, Glen Jenkins WB4KTF <wb4ktf@...> wrote:

HI,
It appears that many of you are mentioning the Audio Power Management feature in USB ports, but as I mentioned in the original post, I do have them all set to OFF (unchecked).  So the USB ports are not going to sleep to save power. 
MICHAEL BLACK: What is USB SELECTIVE SUSPEND and where do I find this setting??
I'm not plugging or unplugging devices, everything here is well grounded to a single point ground, even the Desktop PC (thus not powered by a wallwart or external PS).  RF is not causing this as there is no RF here when this quits working, I've been idle, only monitoring the band.
--
Glen, WB4KTF
Austin, TX


William Smith
 

Also (HDMI) monitors and potentially other devices that might be (dis)connecting when left alone for a while.

73, Willie N1JBJ


On Feb 25, 2022, at 12:10 PM, Glen Jenkins WB4KTF <wb4ktf@...> wrote:

Audio Power Management feature in USB ports, but as I mentioned in the original post, I do have them all set to OFF (unchecked).


Bruce N7XGR
 

Glen, Start here, Open Device Manager and click on the arrow for the
Human Interface Devices, double click on every one for their properties.
Click on the Power Management tab, if it is checked where it says,
Allow the computer to turn off this device to save power, then uncheck
it and click OK.
Next, Expand the Ports tree, again one by one double click on every one,
Power Management tab and uncheck Allow this computer and click OK.
Next, Expand the Universal Serial Bus Controllers tree and again double
click
on every one, Power tab, uncheck and click OK.
On the Desktop, right click and select Personalize, Click on Change power
settings (Screen Saver)
next window, click on Change plan settings, next window, Change advanced
power settings.
Next window click on, Change settings that are currently unavailable, click
the plus sign
at USB settings, expand USB selective suspend settings, click on settings,
Select Disabled, click OK. If there are any HDMI settings then make sure
that there is
no setting to put the HDMI port to sleep.
Report results.

Bruce N7XGR


On Fri, Feb 25, 2022 at 12:10 PM Glen Jenkins WB4KTF <wb4ktf@...>
wrote:

HI,
It appears that many of you are mentioning the Audio Power Management
feature in USB ports, but as I mentioned in the original post, I do have
them all set to OFF (unchecked). So the USB ports are not going to sleep
to save power.
MICHAEL BLACK: What is USB SELECTIVE SUSPEND and where do I find this
setting??
I'm not plugging or unplugging devices, everything here is well grounded
to a single point ground, even the Desktop PC (thus not powered by a
wallwart or external PS). RF is not causing this as there is no RF here
when this quits working, I've been idle, only monitoring the band.
--
Glen, WB4KTF
Austin, TX






 

I got caught out once with an ethernet adapter. I had a laptop to demo CAD software to clients which required access to the MAC address as the reference for the license key. Unfortunately I had tested it without network or mains power, so the Ethernet MAC was powered-off deeply, so its address was not available. Luckily another test before the live demo exposed the problem.

Power management runs deep within all features of laptops. Anything that can be powered-off will be unless you configure the device to be climate unfriendly.

73 Phil GM3ZZA



Sent from Mail for Windows

From: William Smith
Sent: 25 February 2022 18:00
To: main@wsjtx.groups.io
Subject: Re: [WSJTX] WSJT-X Loses TX Audio Connection to transceiver #AudioIssues

Also (HDMI) monitors and potentially other devices that might be (dis)connecting when left alone for a while.

73, Willie N1JBJ


On Feb 25, 2022, at 12:10 PM, Glen Jenkins WB4KTF <wb4ktf@...> wrote:

Audio Power Management feature in USB ports, but as I mentioned in the original post, I do have them all set to OFF (unchecked).


Chris VE3NRT
 

And it is not just laptops, same thing on my desktop with the kW power supply. Also not just USB devices. Based on Michael's advice I went through the sound devices and found that the wired-in non-USB devices also have power management settings default to off.

73,
Chris


gksmith_1
 

Good afternoon all,

I too had this problem for a long time. The only thing that I found that would stop it from happening was to, in Power Options, set it so that the display would never turn off.

This was in Windows 10.

Since upgrading to Windows 11 I have not had WSJT-X ever fail to transmit audio, even if the operating system had turned off the display in a long period away from the computer.

Maybe it is just my system that behaves like this, I don't know, but it seems like the loss of transmit audio is now a thing that I have put into my past.

73 de WA3ZSC - Jerry

On 02-25-2022 12:10 PM, Glen Jenkins WB4KTF wrote:
HI,
It appears that many of you are mentioning the Audio Power Management feature in USB ports, but as I mentioned in the original post, I do have them all set to OFF (unchecked). So the USB ports are not going to sleep to save power.
MICHAEL BLACK: What is USB SELECTIVE SUSPEND and where do I find this setting??
I'm not plugging or unplugging devices, everything here is well grounded to a single point ground, even the Desktop PC (thus not powered by a wallwart or external PS). RF is not causing this as there is no RF here when this quits working, I've been idle, only monitoring the band.


Michael Black
 

This was(is?) a problem in Windows 10 and was also a problem in Windows 11 until they fixed it.
Mike W9MDB

On Saturday, February 26, 2022, 01:54:01 AM CST, gksmith_1 <gksmith_1@...> wrote:

Good afternoon all,

I too had this problem for a long time.
The only thing that I found that would
stop it from happening was to, in Power
Options, set it so that the display
would never turn off.

This was in Windows 10.

Since upgrading to Windows 11 I have not
had WSJT-X ever fail to transmit audio,
even if the operating system had turned
off the display in a long period away
from the computer.

Maybe it is just my system that behaves
like this, I don't know, but it seems
like the loss of transmit audio is now a
thing that I have put into my past.

73 de WA3ZSC - Jerry

On 02-25-2022 12:10 PM, Glen Jenkins
WB4KTF wrote:
HI,
It appears that many of you are mentioning the Audio Power Management feature in USB ports, but as I mentioned in the original post, I do have them all set to OFF (unchecked).  So the USB ports are not going to sleep to save power.
MICHAEL BLACK: What is USB SELECTIVE SUSPEND and where do I find this setting??
I'm not plugging or unplugging devices, everything here is well grounded to a single point ground, even the Desktop PC (thus not powered by a wallwart or external PS).  RF is not causing this as there is no RF here when this quits working, I've been idle, only monitoring the band.


Timo - OH2BMH
 

I had this very same problem and fixed it by uninstalling the HD audio driver. Here is how:
Go to Programs and Features in the Control Panel and search the list for HD audio driver
(NVIDIA HD audio driver in my case). Uninstall it, restart your PC and the problem is gone.
This driver is only needed if you want to send audio signals via your video cards HDMI connector.
When your monitor wakes up after a ”sleep” period it will by default route your audio to HDMI,
which is good if you use the internal speakers (if installed) in your monitor.
My reply is based on the assumption that you use HDMI to connect your monitor to your PC.
Please note that any ”quick” install of graphic card driver updates will also (re)install the HD
audio driver. Usually driver installation programs offer a selective installation method so that
the user can manually select the components to be installed, and the HD audio driver can be left
out if not needed.

Timo - OH2BMH


Alan G4ZFQ
 

I had this very same problem and fixed it by uninstalling the HD audio driver.
Timo

Simply disabling the HDMI audio worked for me.

73 Alan G4ZFQ


KA9CAR John
 

I found that many USB cables do NOT have the SHIELD connected to both ends, and my com port adapter had the same issue. Once I used all cables with shield continutiy and jumpered over from the usb to the com side on the adapter, the intermittent problems with "loss of usb" went away.

KA9CAR