v2.5 bug with KX-3 #Cat_RigControl #Elecraft


The Greene Family
 

I’m using the recent release of v2.5 on an M1 MacBook Air running the latest version of Big Sur with all the latest upgrades.  The radio is an Elecraft KX-3, connected through the Elecraft supplied USB interface.

Here’s the scenario, as they like to say…

I was operating on FT8, and everything was working fine.  I saw a spot for S9OK on 21 MHz CW.  I headed over there and he was listening up about 3 KHz.  So, I pressed the A>B button so that the second VFO/radio was on S9OK’s frequency.  That also set the mode properly.  I then pressed Split and moved the B VFO up to call S9OK where he was listening.  After a while, with much luck, I worked him on CW.

Then, I went back to FT8 on the same band.

I tried calling a couple stations, with no luck at all.  Looking over at the KX-3, I (finally) saw there was no transmit output.  The Tune button on the WSJT-X panel put the KX-3 into transmit mode, but there was no output.

Without going into the sordid details, what I found was that WSJT-X was not putting the B VFO/Radio into USB mode.  It stayed in CW mode, as when I left CW operation.

My previous installation used WSJT-X 2.3.1 and it didn’t work this way.  When I used the pulldown menu on WSJT-X to set the band on FT8, both the A and B VFO/Radios on the KX-3 were automatically set to USB.  (Pretty cool, BTW)  I made no changes in the setup going from 2.3.1 to 2.5.

The workaround for this is to press A>B on the KX-3, which puts it into USB mode suitable for WSJT-X operation.

The release notes say that some changes had been made to the Hamlib portion of the software for tweaking the K3 series of radios, amongst others.  Could something have been left out?

OT…

In the Preferences panel, under Radio > CAT Control > Serial Port there’s a bunch of options.  Two similar ones are seemingly aimed toward the Elecraft KXUSB-a USB to serial port adaptor.  One is named tty.usbserial-AI035MAD and the other is cu.usbserial-AI035MAD.  They both seem to work.  Is there an advantage of using one over the other?

Thanks!

K1JX


Bill Somerville
 

On 07/10/2021 15:35, The Greene Family wrote:
I’m using the recent release of v2.5 on an M1 MacBook Air running the latest version of Big Sur with all the latest upgrades.  The radio is an Elecraft KX-3, connected through the Elecraft supplied USB interface.

Here’s the scenario, as they like to say…

I was operating on FT8, and everything was working fine.  I saw a spot for S9OK on 21 MHz CW.  I headed over there and he was listening up about 3 KHz.  So, I pressed the A>B button so that the second VFO/radio was on S9OK’s frequency.  That also set the mode properly.  I then pressed Split and moved the B VFO up to call S9OK where he was listening.  After a while, with much luck, I worked him on CW.

Then, I went back to FT8 on the same band.

I tried calling a couple stations, with no luck at all.  Looking over at the KX-3, I (finally) saw there was no transmit output.  The Tune button on the WSJT-X panel put the KX-3 into transmit mode, but there was no output.

Without going into the sordid details, what I found was that WSJT-X was not putting the B VFO/Radio into USB mode.  It stayed in CW mode, as when I left CW operation.

My previous installation used WSJT-X 2.3.1 and it didn’t work this way.  When I used the pulldown menu on WSJT-X to set the band on FT8, both the A and B VFO/Radios on the KX-3 were automatically set to USB.  (Pretty cool, BTW)  I made no changes in the setup going from 2.3.1 to 2.5.

The workaround for this is to press A>B on the KX-3, which puts it into USB mode suitable for WSJT-X operation.

The release notes say that some changes had been made to the Hamlib portion of the software for tweaking the K3 series of radios, amongst others.  Could something have been left out?

OT…

In the Preferences panel, under Radio > CAT Control > Serial Port there’s a bunch of options.  Two similar ones are seemingly aimed toward the Elecraft KXUSB-a USB to serial port adaptor.  One is named tty.usbserial-AI035MAD and the other is cu.usbserial-AI035MAD.  They both seem to work.  Is there an advantage of using one over the other?

Thanks!

K1JX

OM,

if you check the "Preferences->Radio->Mode->Data/Pkt" option then WSJT-X should set the rig mode correctly to USB DATA A mode for you. If it is not doing that then let us know?

Technically the cu. (calling unit) device is the correct one to use, that is intended for application initiated connections whereas the tty. device is used for external logins.

73
Bill
G4WJS.


The Greene Family
 

Thanks for the quick reply.  cu.usbserial-AI035MAD it is.

As I may have mentioned previously, USB DATA A mode in the KX-3 presents a unique situation.  That is, the frequency response rolls off severely below 400 Hz or so.  Other people have reported this, too.  It's a feature of the KX-3 firmware, probably optimized for RTTY operation.  Otherwise, DATA A mode would be ideal.

Most DXpeditions using Fox and Hound mode transmit below 400 Hz, at least until they have more than two streams running.  Oops.

So, I have my radio set for ESSB mode on USB, with the bandwidth set to 4000 Hz.  (It isn't really 4000 Hz, but it likes to tell me that it is...)  ESSB mode turns off the compressor, the TX equalization, and all that, so it's a good alternative.  It rolls off below 200 Hz at the low end, solving the F/H problem.

Anyway, I just reinstalled 2.3.1.  No problem now.  It doesn't have Q65 or MAP65, of course, but I wouldn't be using those on HF in any case.


Bill Somerville
 

On 07/10/2021 16:30, The Greene Family wrote:
Thanks for the quick reply. cu.usbserial-AI035MAD it is.

As I may have mentioned previously, USB DATA A mode in the KX-3 presents a unique situation.  That is, the frequency response rolls off severely below 400 Hz or so.  Other people have reported this, too.  It's a feature of the KX-3 firmware, probably optimized for RTTY operation.  Otherwise, DATA A mode would be ideal.

Most DXpeditions using Fox and Hound mode transmit below 400 Hz, at least until they have more than two streams running.  Oops.

So, I have my radio set for ESSB mode on USB, with the bandwidth set to 4000 Hz.  (It isn't really 4000 Hz, but it likes to tell me that it is...)  ESSB mode turns off the compressor, the TX equalization, and all that, so it's a good alternative.  It rolls off below 200 Hz at the low end, solving the F/H problem.

Anyway, I just reinstalled 2.3.1.  No problem now.  It doesn't have Q65 or MAP65, of course, but I wouldn't be using those on HF in any case.
OM,

you did not say if "Preferences->Radio->Mode" is Data/PKT, or if you had tried that. If you really must use USB mode then what happens if you check the "Preferences->Radio->Mode->USB" option. Either way WSJT-X should be setting the mode of both Rx and Tx VFOs when you use one of the "Preferences->Radio->Split Operating" options. If it is not doing that then I need to know?

As an aside, is the low frequency roll-off you describe on Rx, Tx, or both?

73
Bill
G4WJS.


ve3ki
 

Have you tried using the PBT control to change the KX3's low frequency rolloff? With the rig in DATA A, you might try experimenting with the Width and Shift adjustments from the PBT control while watching the waterfall display (see p.12 in the KX3 User Manual).

73,
Rich VE3KI


On Thu, Oct 7, 2021 at 11:31 AM, The Greene Family wrote:
Thanks for the quick reply.  cu.usbserial-AI035MAD it is.

As I may have mentioned previously, USB DATA A mode in the KX-3 presents a unique situation.  That is, the frequency response rolls off severely below 400 Hz or so.  Other people have reported this, too.  It's a feature of the KX-3 firmware, probably optimized for RTTY operation.  Otherwise, DATA A mode would be ideal.

Most DXpeditions using Fox and Hound mode transmit below 400 Hz, at least until they have more than two streams running.  Oops.

So, I have my radio set for ESSB mode on USB, with the bandwidth set to 4000 Hz.  (It isn't really 4000 Hz, but it likes to tell me that it is...)  ESSB mode turns off the compressor, the TX equalization, and all that, so it's a good alternative.  It rolls off below 200 Hz at the low end, solving the F/H problem.

Anyway, I just reinstalled 2.3.1.  No problem now.  It doesn't have Q65 or MAP65, of course, but I wouldn't be using those on HF in any case.


The Greene Family
 
Edited

Rich,

I did all that.  And then some.

This has been noted as far back as five years ago, although in a different context of earlier JT software.  It is NOT a bug with WSJT-X.  It's how Elecraft chooses to set up the filters in software.  Hey - it's their product and they can design it as they so choose.

Here's somebody who has observed something similar in the KX2:  http://brentgustafson.com/w/Page/ElecraftKX2

Clarke


The Greene Family
 
Edited

Bill,

Without any changes to anything, 2.3.1 works fine and performs as expected and what I am used to.

You ask a good question about whether Tx or Rx bandwidth is affected.  I did not test Tx, to be honest.  But, it's very evident on Rx.  On a dead band, you can turn all the receive gains up and see that the noise floor rolls off below about 400 Hz in Data mode.  In USB mode, when the bandwidth is set to maximum, it's below 200 Hz.  That's with no changes in the WSJT-X set-up whatsoever - just change the radio itself.

I did not just check Data mode with 2.5, since it causes these other operational issues due to bandwidth.  I can check later today, if you'd like me to.

Clarke

Believe me, I'd rather use Data mode when using WSJT-X.  It would make life much simpler for me.


Bill Somerville
 

On 07/10/2021 17:26, The Greene Family wrote:

[Edited Message Follows]

Bill,

Without any changes to anything, 2.3.1 works fine and performs as expected and what I am used to.

You ask a good question about whether Tx or Rx bandwidth is affected.  I did not test Tx, to be honest.  But, it's very evident on Rx.  On a dead band, you can turn all the receive gains up and see that the noise floor rolls off below about 400 Hz in Data mode.  In USB mode, when the bandwidth is set to maximum, it's below 200 Hz.  That's with no changes in the WSJT-X set-up whatsoever - just change the radio itself.

I did not just check Data mode with 2.5, since it causes these other operational issues due to bandwidth.  I can check later today, if you'd like me to.

Clarke

Believe me, I'd rather use Data mode when using WSJT-X.  It would make life much simpler for me.
Clarke,

I am trying to determine if the failure to set the Tx VFO mode happens when you have one of "Preferences->Radio->Mode->USB" or "Preferences->Radio->Mode->Data/Pkt" checked. I would prefer to know for each. This is the third time of asking.

73
Bill
G4WJS.


The Greene Family
 

Sorry.  Am trying to work around work, and a doctor's appointment.

I will tend to that immediately.


The Greene Family
 

Bill,

I set the radio to DATA A mode using the radio controls and verified that both VFO's were in fact set to DATA A. 

Then, tuned to an arbitrary frequency on 15M.  
Put the radio into CW mode.  
Pressed A>B so that both VFOs were on the same frequency, same mode (CW).
Pressed SPLIT.
Tuned VFO B to an arbitrary frequency a couple KHz away.
Verified that both VFOs were indeed operating SPLIT and in CW mode.

Started WSJT-X v2.5
Set "Preferences->Radio->Mode->Data/Pkt" checked.
Selected from pull-down frequency selection 21.074 000 MHz (15M)

Pressed Tune.  
The transmitter keyed.  
The KX-3 display said: "SPLIT N/A" for a second or two.  The "SPLIT" indicator in the display never turned on.
The KX-3 put out power that seemed to be controllable in level with the MIC control.

BTW, I can verify again that the RX frequency response rolls off below 400 Hz.  I also tried placing the transmit frequency at 2500 Hz and at 200 Hz.  There seems to be no difference in output power, which suggests that the filter issue may only be on the RX side.

Then, I redid this. 

Tuned to an arbitrary frequency on 15M.  
Put the radio into CW mode.  
Pressed A>B so that both VFOs were on the same frequency, same mode (CW).
Pressed SPLIT.
Tuned VFO B to an arbitrary frequency a couple KHz away.
Verified that both VFOs were indeed operating SPLIT and in CW mode.

Started WSJT-X v2.5
Set "Preferences->Radio->Mode->USB" checked.
Selected from pull-down frequency selection 21.074 000 MHz (15M)

Pressed Tune.  
The transmitter keyed.  
No output power.  The MIC control adjusted the Keyer Speed, which is what that knob does in CW mode.
The mode indicator in the KX-3 display indicated "CW" when in transmit mode.

Pressing A>B put the B VFO and associated functions in USB mode and it worked properly.

That help?

Clarke