WSJT-X will not work with some Yaesu Radios using the Raspberry Pi due to HAMLIB incompatibility... #WSJTX_config #linux #raspberryPi #Yaesu


regiogringo@...
 

The HAMLIB error messages that many receive from WSJT-X on setup on both the Yaesu FT-991A, FT-DX10, and other Yaesu Radios, is due to an incompatibility issue with the WSJT-X program when installing WSJT-X on the Raspberry Pi. 

The issue is that WSJT-X will not detect the USB drivers when installed on a Raspberry Pi 4 and may not detect USB drivers on other models of the Raspberry
Pi as well.  So, when you go to select audio settings within WSJT-X, your drivers are not likely to be listed in the drivers to select from.  If you try the driver selections indicated within the audio settings, you will only get a HAMLIB error message as a result. 

I finally did get WSJT-X working with my Raspberry Pi4 through my Yaesu FT-991A and my Yaesu FT-DX10 by installing FLRIG, and using it as Rig Control, and firing it up first, before firing up WSJT-X. 

I had no trouble setting up FLRIG with the Raspberry Pi4, the USB drivers were prominently displayed as selections that are available to choose from within FLRIG, but this is not the case with WSJT-X.  If you try using WSJT-X as rig control, and you are using a late model Yaesu radio, chances are WSJT-X will not detect the correct USB drivers, and you'll get a HAMLIB error message.

So, if you want to use a Raspberry Pi as your computer, download KM4ACK's most recent version of "Build A Pi"  (You Tube), then designate your Rig's Name in WSJT-X setup as FLRIG, instead of entering your actual rig's model number.  If you try using WSJT-X as rig control, and you designate your rig's model number in WSJT-X setup, you will get a HAMLIB error message.

I credit Jason, KM4ACK, with resolving this incompatibility issue for me, and appreciate his assistance in getting WSJT-X up an running on my Yaesu radios.  It would be nice if we Yaesu/Raspberry Pi owners could simply use WSJT-X as our rig control, and not have these issues occur on setup. 

Any chance of there being an update to WSJT-X to resolve these issues in the near future so we can simply use WSJT-X as rig control instead of having to use FLRIG operating as rig control to make WSJT-X work with our Raspberry Pi computers?

Thanks!
Randy
KG0BA


Bill Somerville
 

On 04/10/2021 16:00, regiogringo@live.com wrote:
The HAMLIB error messages that many receive from WSJT-X on setup on both the Yaesu FT-991A, FT-DX10, and other Yaesu Radios, is due to an incompatibility issue with the WSJT-X program when installing WSJT-X on the Raspberry Pi.

The issue is that WSJT-X will not detect the USB drivers when installed on a Raspberry Pi 4 and may not detect USB drivers on other models of the Raspberry
Pi as well.  So, when you go to select audio settings within WSJT-X, your drivers are not likely to be listed in the drivers to select from.  If you try the driver selections indicated within the audio settings, you will only get a HAMLIB error message as a result.

I finally did get WSJT-X working with my Raspberry Pi4 through my Yaesu FT-991A and my Yaesu FT-DX10 by installing FLRIG, and using it as Rig Control, and firing it up first, before firing up WSJT-X.

I had no trouble setting up FLRIG with the Raspberry Pi4, the USB drivers were prominently displayed as selections that are available to choose from within FLRIG, but this is not the case with WSJT-X.  If you try using WSJT-X as rig control, and you are using a late model Yaesu radio, chances are WSJT-X will not detect the correct USB drivers, and you'll get a HAMLIB error message.

So, if you want to use a Raspberry Pi as your computer, download KM4ACK's most recent version of "Build A Pi"  (You Tube), then designate your Rig's Name in WSJT-X setup as FLRIG, instead of entering your actual rig's model number.  If you try using WSJT-X as rig control, and you designate your rig's model number in WSJT-X setup, you will get a HAMLIB error message.

I credit Jason, KM4ACK, with resolving this incompatibility issue for me, and appreciate his assistance in getting WSJT-X up an running on my Yaesu radios.  It would be nice if we Yaesu/Raspberry Pi owners could simply use WSJT-X as our rig control, and not have these issues occur on setup.

Any chance of there being an update to WSJT-X to resolve these issues in the near future so we can simply use WSJT-X as rig control instead of having to use FLRIG operating as rig control to make WSJT-X work with our Raspberry Pi computers?

Thanks!
Randy
KG0BA
Randy,

I really don not understand this issue report. You mention audio but the post seems to be about CAT control. I will assume the issue is related to CAT control. When communicating with a rig that offers CAT control via a virtual serial port over a USB connection, the WSJT-X/Hamlib end of the connection is unrelated to it being provided via a USB connection, it is simply a serial port as far as WSJT-X/Hamlib is concerned. There is no difference between that mechanism and any other real or virtual serial port connection.

Please be more specific about what the issue actually is, including error messages please?

73
Bill
G4WJS.


RichW6BOT
 

My Pi /FT-991A work just fine together with WSJT-x and JS8CALL without FLrig.

The Pi image was built from scratch, and WSJT-X and JS8CALL were both loaded without any issue.

I don't understand the problem either.

Rich
W6BOT


regiogringo@...
 
Edited

Hello Bill,

Thank you for your reply...I agree, it seems to be a rig control issue, but it appears to me to be related to the USB driver selections that are offered within WSJT-X when using a Raspberry Pi.  When I made reference to "audio settings" before, I was referring to the tab entitled "AUDIO" under WSJT-X settings, which appear to me to be the selection of drivers that enable the Raspberry Pi to connect to the radio. 

Attached is a photo of the USB driver selections offered by WSJT-X under the "Audio" tab. I've tried each of the selections, and none of them result in a connection to the radio. Instead, I get a HAMLIB error message. I've attached a photo of the HAMLIB error message as well. 

If using a Windows machine, the drivers can be downloaded from Yaesu, but they are specific to the Windows operating system. When I set up WSJT-X on a Windows machine, I have no problems whatsoever, and the (Yaesu (Silicon Labs) drivers are there to select from.  But, when trying to set up WSJT-X on a Raspberry Pi, that's when I have problems connecting to the radio from the selection of drivers offered under the "AUDIO" tab within WSJT-X, and I get the resulting HAMLIB error message.

I wonder if because Yaesu only offers drivers for Windows, perhaps there aren't compatible drivers that will work with the Raspberry Pi, and the selection of drivers offered to select from within WSJT-X aren't compatible with Yaesu radios. 

Please let me know if you have any other questions or observations.  I'm a relative novice with respect to the Raspberry Pi, but I'll try to provide as much information as possible to resolve the issue.

Thank you!
Randy
KG0BA


regiogringo@...
 

Hello Rich, 

I am curious as to which drivers you're using, especially because the drivers offered by Yaesu are specific to the Windows operating system. You must be using drivers that are not the Yaesu published drivers because they're supposedly specific to Windows operating systems, and should not work on a Linux operating system.

Since you have it working on your Raspberry Pi, perhaps I need to load some drivers on my Raspberry Pi that will work with my FT-991A so they're there to select from under the AUDIO tab. Maybe with respect to the build I'm using on my Raspberry Pi4, working drivers were omitted from the selection of drivers I have to choose from. 

Which drivers have you selected within the WSJT-X "Audio" tab?  Can you advise where the working drivers can be downloaded that will work with the Yaesu FT-991A and the Raspberry Pi?

Thanks!

Randy
KG0BA


Bill Somerville
 

On 05/10/2021 14:49, regiogringo@live.com wrote:
Hello Rich,

I am curious as to which drivers you're using, especially because the drivers offered by Yaesu are specific to the Windows operating system. You must be using drivers that are not the Yaesu published drivers because they're supposedly specific to Windows operating systems, and should not work on a Linux operating system.

Since you have it working on your Raspberry Pi, perhaps I need to load some drivers on my Raspberry Pi that will work with my FT-991A so they're there to select from under the AUDIO tab. Maybe with respect to the build I'm using on my Raspberry Pi4, working drivers were omitted from the selection of drivers I have to choose from.

Which drivers have you selected within the WSJT-X "Audio" tab? Can you advise where the working drivers can be downloaded that will work with the Yaesu FT-991A and the Raspberry Pi?

Thanks!

Randy
KG0BA
Randy,

this topic thread is full of misinformation! No user installed drivers are needed for USB audio on any contemporary operating system, the generic USB audio drivers are just fine. On MS Windows user installed drivers are required for the virtual serial port that provides CAT communications with modern rigs using a USB connection to a PC. Linux and the latest macOS versions have suitable virtual serial port drivers available already.

73
Bill
G4WJS.


regiogringo@...
 

Hello Bill,

Perhaps my terminology is incorrect, and being interpreted as "misinformation."  With respect to the attachments I posted in my prior message, a picture is worth a thousand words...

Which of the selections depicted in the prior attachments, which are the selections I am finding under the "AUDIO" tab in WSJT-X Settings, are the proper ones to select for INPUT and OUTPUT if using a Raspberry Pi?

As I mentioned, I have WSJT-X set up on my Windows machine, and it works flawlessly.  So, with respect to the setup and hardware configurations to make WSJT-X work with Windows, I'm familiar with how things are to be configured.  But, this issue with the Raspberry Pi and the HAMLIB error message persists, and I can't figure out why, or what I'm doing wrong.   

Thanks!

Randy
KG0BA


Bill Somerville
 

On 05/10/2021 15:30, regiogringo@live.com wrote:
Hello Bill,

Perhaps my terminology is incorrect, and being interpreted as "misinformation."  With respect to the attachments I posted in my prior message, a picture is worth a thousand words...

Which of the selections depicted in the prior attachments, which are the selections I am finding under the "AUDIO" tab in WSJT-X Settings, are the proper ones to select for INPUT and OUTPUT if using a Raspberry Pi?

As I mentioned, I have WSJT-X set up on my Windows machine, and it works flawlessly.  So, with respect to the setup and hardware configurations to make WSJT-X work with Windows, I'm familiar with how things are to be configured.  But, this issue with the Raspberry Pi and the HAMLIB error message persists, and I can't figure out why, or what I'm doing wrong.

Thanks!

Randy
KG0BA
Randy,

you are conflating audio devices and CAT control, they are not related.

73
Bill
G4WJS.


regiogringo@...
 
Edited

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73


John
 

I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ


On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73



Michael Black
 

Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73






John
 

For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ


On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73









RichW6BOT
 

As Bill indicated, no special drivers installed.

Here are my settings in WSJT-X for the 991A, hope it helps:









Michael Black
 

Is Menu 030 the same on both rigs?  Looks like they should behave the same.

You can test this yourself -- adjust com port and baud rate to suit.  See if the antenna selection follows the band change.

rigctl -m 1037 -r /dev/ttyS0 -s 9600

Rig command: w BSX;
Where the X is the band
Inline image

Hopefully there's no error shown (like ?) but you will see a timeout occur as there should be no response to this command.

Mike W9MDB

On Wednesday, October 6, 2021, 12:20:33 AM CDT, John <ve3kkqve3kkq@...> wrote:


For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ

On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73












John
 

I just checked my FTdx-3000 Menu 31, set to BAND, always has been, so my conclusion is that there is something amiss with the WSJT-X rig file for the FTdx-3000 as the FTdx-5000 file works FB.

John
VE7KKQ


On Wed, Oct 6, 2021 at 8:31 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Is Menu 030 the same on both rigs?  Looks like they should behave the same.

You can test this yourself -- adjust com port and baud rate to suit.  See if the antenna selection follows the band change.

rigctl -m 1037 -r /dev/ttyS0 -s 9600

Rig command: w BSX;
Where the X is the band
Inline image

Hopefully there's no error shown (like ?) but you will see a timeout occur as there should be no response to this command.

Mike W9MDB

On Wednesday, October 6, 2021, 12:20:33 AM CDT, John <ve3kkqve3kkq@...> wrote:


For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ

On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73















Michael Black
 

Did you test the "BSX" command as I recommended and see the behavior?

Mike WMDB




On Wednesday, October 6, 2021, 02:27:08 PM CDT, John <ve3kkqve3kkq@...> wrote:


I just checked my FTdx-3000 Menu 31, set to BAND, always has been, so my conclusion is that there is something amiss with the WSJT-X rig file for the FTdx-3000 as the FTdx-5000 file works FB.

John
VE7KKQ

On Wed, Oct 6, 2021 at 8:31 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Is Menu 030 the same on both rigs?  Looks like they should behave the same.

You can test this yourself -- adjust com port and baud rate to suit.  See if the antenna selection follows the band change.

rigctl -m 1037 -r /dev/ttyS0 -s 9600

Rig command: w BSX;
Where the X is the band
Inline image

Hopefully there's no error shown (like ?) but you will see a timeout occur as there should be no response to this command.

Mike W9MDB

On Wednesday, October 6, 2021, 12:20:33 AM CDT, John <ve3kkqve3kkq@...> wrote:


For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ

On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73


















John
 

No I didn't, how to do that?

John
VE7KKQ


On Wed, Oct 6, 2021 at 2:48 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Did you test the "BSX" command as I recommended and see the behavior?

Mike WMDB




On Wednesday, October 6, 2021, 02:27:08 PM CDT, John <ve3kkqve3kkq@...> wrote:


I just checked my FTdx-3000 Menu 31, set to BAND, always has been, so my conclusion is that there is something amiss with the WSJT-X rig file for the FTdx-3000 as the FTdx-5000 file works FB.

John
VE7KKQ

On Wed, Oct 6, 2021 at 8:31 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Is Menu 030 the same on both rigs?  Looks like they should behave the same.

You can test this yourself -- adjust com port and baud rate to suit.  See if the antenna selection follows the band change.

rigctl -m 1037 -r /dev/ttyS0 -s 9600

Rig command: w BSX;
Where the X is the band
Inline image

Hopefully there's no error shown (like ?) but you will see a timeout occur as there should be no response to this command.

Mike W9MDB

On Wednesday, October 6, 2021, 12:20:33 AM CDT, John <ve3kkqve3kkq@...> wrote:


For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ

On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73





















Michael Black
 

Look at the rigctl line in my previous answer

Mike W9MDB




On Wednesday, October 6, 2021, 06:01:50 PM CDT, John <ve3kkqve3kkq@...> wrote:


No I didn't, how to do that?

John
VE7KKQ

On Wed, Oct 6, 2021 at 2:48 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Did you test the "BSX" command as I recommended and see the behavior?

Mike WMDB




On Wednesday, October 6, 2021, 02:27:08 PM CDT, John <ve3kkqve3kkq@...> wrote:


I just checked my FTdx-3000 Menu 31, set to BAND, always has been, so my conclusion is that there is something amiss with the WSJT-X rig file for the FTdx-3000 as the FTdx-5000 file works FB.

John
VE7KKQ

On Wed, Oct 6, 2021 at 8:31 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Is Menu 030 the same on both rigs?  Looks like they should behave the same.

You can test this yourself -- adjust com port and baud rate to suit.  See if the antenna selection follows the band change.

rigctl -m 1037 -r /dev/ttyS0 -s 9600

Rig command: w BSX;
Where the X is the band
Inline image

Hopefully there's no error shown (like ?) but you will see a timeout occur as there should be no response to this command.

Mike W9MDB

On Wednesday, October 6, 2021, 12:20:33 AM CDT, John <ve3kkqve3kkq@...> wrote:


For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ

On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73
























John
 

Well Michael, your previous email is gibberish to me, you must be a programmer, I'm not, so will require some hand holding.

John
VE7KKQ


On Thu, Oct 7, 2021 at 12:19 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Look at the rigctl line in my previous answer

Mike W9MDB




On Wednesday, October 6, 2021, 06:01:50 PM CDT, John <ve3kkqve3kkq@...> wrote:


No I didn't, how to do that?

John
VE7KKQ

On Wed, Oct 6, 2021 at 2:48 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Did you test the "BSX" command as I recommended and see the behavior?

Mike WMDB




On Wednesday, October 6, 2021, 02:27:08 PM CDT, John <ve3kkqve3kkq@...> wrote:


I just checked my FTdx-3000 Menu 31, set to BAND, always has been, so my conclusion is that there is something amiss with the WSJT-X rig file for the FTdx-3000 as the FTdx-5000 file works FB.

John
VE7KKQ

On Wed, Oct 6, 2021 at 8:31 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Is Menu 030 the same on both rigs?  Looks like they should behave the same.

You can test this yourself -- adjust com port and baud rate to suit.  See if the antenna selection follows the band change.

rigctl -m 1037 -r /dev/ttyS0 -s 9600

Rig command: w BSX;
Where the X is the band
Inline image

Hopefully there's no error shown (like ?) but you will see a timeout occur as there should be no response to this command.

Mike W9MDB

On Wednesday, October 6, 2021, 12:20:33 AM CDT, John <ve3kkqve3kkq@...> wrote:


For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ

On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73



























Michael Black
 

I assume you know the serial device and baud rate.

#1 Open up a terminal window
#2 Run this substituting your serial device and baud rate
rigctl -m 1037 -r /dev/ttyXXX -s 9600
Rig command: w BS5;
...output will happen with timeout
Pick the other band with a different antenna -- example hgere BS6 is 17M.  Choose the band# from the list provide below for your rig to cause an antenna switch.
Rig command: w BS6;

Does the antenna follow with those two commands?

I assume the antenna follows when you switch bands using the rig buttons?

Mike W9MDB





On Thursday, October 7, 2021, 02:11:39 PM CDT, John <ve3kkqve3kkq@...> wrote:


Well Michael, your previous email is gibberish to me, you must be a programmer, I'm not, so will require some hand holding.

John
VE7KKQ

On Thu, Oct 7, 2021 at 12:19 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Look at the rigctl line in my previous answer

Mike W9MDB




On Wednesday, October 6, 2021, 06:01:50 PM CDT, John <ve3kkqve3kkq@...> wrote:


No I didn't, how to do that?

John
VE7KKQ

On Wed, Oct 6, 2021 at 2:48 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Did you test the "BSX" command as I recommended and see the behavior?

Mike WMDB




On Wednesday, October 6, 2021, 02:27:08 PM CDT, John <ve3kkqve3kkq@...> wrote:


I just checked my FTdx-3000 Menu 31, set to BAND, always has been, so my conclusion is that there is something amiss with the WSJT-X rig file for the FTdx-3000 as the FTdx-5000 file works FB.

John
VE7KKQ

On Wed, Oct 6, 2021 at 8:31 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Is Menu 030 the same on both rigs?  Looks like they should behave the same.

You can test this yourself -- adjust com port and baud rate to suit.  See if the antenna selection follows the band change.

rigctl -m 1037 -r /dev/ttyS0 -s 9600

Rig command: w BSX;
Where the X is the band
Inline image

Hopefully there's no error shown (like ?) but you will see a timeout occur as there should be no response to this command.

Mike W9MDB

On Wednesday, October 6, 2021, 12:20:33 AM CDT, John <ve3kkqve3kkq@...> wrote:


For roughly the last year I have been only on FT8. It has only been in the last few months that I put up an end fed half wave, that is when the antenna selection problem started.
So I don't see how Band Stacking has much to do with it as I said, I have only been running FT8, nothing else.
If it were band stacking, then why does the FTdx-5000 selection work yet the FTdx-3000 not, doesn't the FTdx-5000 have Band Stacking?

John
VE7KKQ

On Tue, Oct 5, 2021 at 9:05 PM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Read up on Menu 031 for the Band/Stack option and elsewhere in the manual about band stack.
I think you probably want the Band option.
You should be able to set up the band and press the band button to put it in the band stack.
WSJT-X should be sending a BS band stack command so should be remembering the antenna if it's put in the band stack correctly.

Mike W9MDB




On Tuesday, October 5, 2021, 07:59:56 PM CDT, John <ve3kkqve3kkq@...> wrote:


I have problems with WSJT-X and the FTdx-3000 rig in that my antennas (two) don't get selected as the bands change.

Someone involved with HamLab was helping by sending me a file to include in WSJT-X that would record what was going on. I sent these files as requested several times and suddenly the person "helping" stopped communicating.

So, I now use the FTdx-5000 as my rig as I did before I reported my problem and have no issues.

Hope you get better support than I did.

John
VE7KKQ

On Tue, Oct 5, 2021 at 4:06 PM <regiogringo@...> wrote:

[Edited Message Follows]

Bill,

I agree that it's an issue of Rig control...

There are three tabs that need to be setup, "GENERAL," where call letters and grid square are entered, then the "RIG" section, which should contain the model number of the rig you intend to use, then there is the "AUDIO" tab section, which contains various selections.  If I am conflating Rig Control with Audio, it's because WSJT-X labels the third tab in setup as "AUDIO.  I don't know why they call the third tab "Audio," but that's what WSJT-X calls it, and that's why I refer to it as such, so the reader will know which tab I'm referring to.

So, when exclusively using WSJT-X as rig control, I enter my Rig's model number, under "RIG," and then I enter any of the selections offered under the "AUDIO" tab, which then yields the HAMLIB error message.

The model number for my rig is elementary, a Yaesu FT-991, and that's what I have entered.  I've also tried each and every selection under the "AUDIO" tab,  and I get the HAMLIB error message ("AUDIO" is their term for the tab, not mine). 

When I setup WSJT-X using FLRiG as rig control , the Yaesu (Silicon Labs) USB drivers show up under the tab entitled "AUDIO," but I have to select FLRIG under the tab entitled "RIG," and not the actual Rig's model number.  I also have to fire FLRIG first, before I fire WSJT-X, in order for WSJT-X to work. But, under this scenario, I do NOT get a HAMLIB error message, and WSJT-X works perfectly. 

So, yes, it's a matter of Rig Control, evidenced by my having to select FLRIG first as RIG Control under the tab entitled "RIG," rather than specifying my rig's actual model number under the "RIG" tab. When I select FLRIG as my rig model number under the WSJT-X "RIG" tab, and the Yaesu (Silicon Labs) USB drivers show up to be selected under the "AUDIO" tab, that suggests to me that there may be a USB driver issue as well, since the Yaesu (Silicon Labs) USB drivers do not show up for selection if I setup things solely using WSJT-X as rig control.

I can only report what I'm experiencing, and I have no comprehension as to why I'm getting these HAMLIB error messages, or why WSJT-X won't work when I designate my rig model number for rig control, and select what WSJT-X provides under their "AUDIO" tab to select from. 

Thank you!

Randy
KG0BA
73