locked OSX Big Sur Compile from source #macOS


mark.gregory@...
 

When using the latest Big Sur install with xCode 13 the command 
sudo port install autoconf automake \
   libtool pkgconfig texinfo gcc5 asciidoc \
   fftw-3-single +gcc5 libusb-devel
fails when trying to install libgcc7
it looks like this is an old version of gcc that may have an issue on Big Sur now, am I able to use gcc10 to build
I know that other developers are building for the Apple M1 processor what tool chains are you using please.

Any help would be appreciated.
G4LCH



Bill Somerville
 

On 26/09/2021 18:45, mark.gregory@... wrote:
When using the latest Big Sur install with xCode 13 the command 
sudo port install autoconf automake \
   libtool pkgconfig texinfo gcc5 asciidoc \
   fftw-3-single +gcc5 libusb-devel
fails when trying to install libgcc7 
it looks like this is an old version of gcc that may have an issue on Big Sur now, am I able to use gcc10 to build
I know that other developers are building for the Apple M1 processor what tool chains are you using please.

Any help would be appreciated.
G4LCH

Hi Mark,

ah OK, yes I forgot about that. You can't build libgcc7, which is a dependency for virtually all of the gcc version builds, on Big Sur. That means that it is not possible to build WSJT-X on Big Sur until we get the refactoring done that works around the issues with newer gfortran versions.

Official WSJT-X builds for macOS are built on Mojave.

73
Bill
G4WJS.


mark.gregory@...
 

Hi Bill, I followed your advice and install Mojave on a separate partition, I actually removed Big Sur as I wanted a stable base build environment and its working perfectly now with the tool chains pulled from Mac ports.
Thank you for your help, I was fitting a lot of errors with installing the tool chain using brew, now I can of course upgrade to latest OS using an external drive initially at some stage.

Thanks for all your help guys very much appreciated.
Mark G4LCH


On 26 Sep 2021, at 22:12, Bill Somerville <g4wjs@...> wrote:

On 26/09/2021 18:45, mark.gregory@... wrote:
When using the latest Big Sur install with xCode 13 the command 
sudo port install autoconf automake \
   libtool pkgconfig texinfo gcc5 asciidoc \
   fftw-3-single +gcc5 libusb-devel
fails when trying to install libgcc7 
it looks like this is an old version of gcc that may have an issue on Big Sur now, am I able to use gcc10 to build
I know that other developers are building for the Apple M1 processor what tool chains are you using please.

Any help would be appreciated.
G4LCH

Hi Mark,

ah OK, yes I forgot about that. You can't build libgcc7, which is a dependency for virtually all of the gcc version builds, on Big Sur. That means that it is not possible to build WSJT-X on Big Sur until we get the refactoring done that works around the issues with newer gfortran versions.

Official WSJT-X builds for macOS are built on Mojave.

73
Bill
G4WJS.