locked Help setting up WSJTX #FT8 #Cat_RigControl #JT65


Mark Finkelstein
 

I’m having trouble setting up WSJTX on a MacBook Air to a Lab599 TX500.  Any suggestions or help would be greatly appreciated.


Bill Somerville
 

On 18/08/2021 21:53, Mark Finkelstein via groups.io wrote:
I’m having trouble setting up WSJTX on a MacBook Air to a Lab599 TX500.  Any suggestions or help would be greatly appreciated.
Hi Mark,

assuming you have a suitable USB to serial adapter for the CAT connection, it looks like it emulates a basic Kenwood rig for CAT control. Try using the Kenwood TS-480 setting with 9600 baud 8N1 on the serial port device, and PTT Method as CAT.

73
Bill
G4WJS.


Mark Finkelstein
 

OK I’ll give that a try and let you know. Thank you!

On Aug 18, 2021, at 5:01 PM, Bill Somerville <g4wjs@...> wrote:

On 18/08/2021 21:53, Mark Finkelstein via groups.io wrote:
I’m having trouble setting up WSJTX on a MacBook Air to a Lab599 TX500. Any suggestions or help would be greatly appreciated.
Hi Mark,

assuming you have a suitable USB to serial adapter for the CAT connection, it looks like it emulates a basic Kenwood rig for CAT control. Try using the Kenwood TS-480 setting with 9600 baud 8N1 on the serial port device, and PTT Method as CAT.

73
Bill
G4WJS.




Mark Finkelstein
 

I’m using a Sabrent adapter for Mac and plugging the mike and head phone jacks to the Mic/Sp port on the TX 500. I have ordered the audio cable for the CAT port.

On Aug 18, 2021, at 5:01 PM, Bill Somerville <g4wjs@...> wrote:

On 18/08/2021 21:53, Mark Finkelstein via groups.io wrote:
I’m having trouble setting up WSJTX on a MacBook Air to a Lab599 TX500. Any suggestions or help would be greatly appreciated.
Hi Mark,

assuming you have a suitable USB to serial adapter for the CAT connection, it looks like it emulates a basic Kenwood rig for CAT control. Try using the Kenwood TS-480 setting with 9600 baud 8N1 on the serial port device, and PTT Method as CAT.

73
Bill
G4WJS.




Mark Finkelstein
 

Well first off thank everyone for helping me. I have the software running and am copying transmissions on the band.  I can double click on CQ’s and if I enable the TX it appears to be sending. However, the radio does is not being keyed.  I tried both 20m and 40m with similar results.  I’m using the Sabrent adapter for Mac to the REM/Data port.  Tx500 radio is in Digital mode. I did a time.is and the computer clock is exact.

Any thoughts on where to look?


Bill Somerville
 

On 26/08/2021 23:10, Mark Finkelstein via groups.io wrote:
Well first off thank everyone for helping me. I have the software running and am copying transmissions on the band.  I can double click on CQ’s and if I enable the TX it appears to be sending. However, the radio does is not being keyed.  I tried both 20m and 40m with similar results.  I’m using the Sabrent adapter for Mac to the REM/Data port.  Tx500 radio is in Digital mode. I did a time.is and the computer clock is exact.

Any thoughts on where to look?
Hi Mark,

do you have a CAT interface?

73
Bill
G4WJS.


Mark Finkelstein
 

I do have the CAT cable for the radio that is a USB Connector. I’m using the audio cable and VOX and truthfully I’m not sure what the difference is. The sound card I have, Sabrent, has the 3.5 mm plugs that go in to the audio cable for the TX500 (REM/DATA).

I could try using the CAT cable directly to the computer but I’m not sure if the MacBook Pro has a sound card that will work. Would I need an external sound card with a rectangular USB connection for the CAT cable?

The folks at Lab599 (the radio company) suggested adjusting the TX/RX Gain levels as that may help key the radio. Thoughts?

I’m really close if I can only get the computer to key the radio.

Thanks for all your help!
Mark

On Aug 26, 2021, at 6:53 PM, Bill Somerville <g4wjs@...> wrote:

On 26/08/2021 23:10, Mark Finkelstein via groups.io wrote:
Well first off thank everyone for helping me. I have the software running and am copying transmissions on the band. I can double click on CQ’s and if I enable the TX it appears to be sending. However, the radio does is not being keyed. I tried both 20m and 40m with similar results. I’m using the Sabrent adapter for Mac to the REM/Data port. Tx500 radio is in Digital mode. I did a time.is and the computer clock is exact.

Any thoughts on where to look?
Hi Mark,

do you have a CAT interface?

73
Bill
G4WJS.




Bill Somerville
 

Hi Mark,

CAT control is separate from audio interfaces, you need both for full control of the rig. Looking at images of the TX-500 I see two sockets marked REM/DATA and CAT respectively. If you have a CAT interface then I would expect both to be populated. The CAT cable may need drivers installed for the virtual serial port that is the CAT connection.

73
Bill
G4WJS.

On 27/08/2021 00:30, Mark Finkelstein via groups.io wrote:

I do have the CAT cable for the radio that is a USB Connector. I’m using the audio cable and VOX and truthfully I’m not sure what the difference is.  The sound card I have, Sabrent, has the 3.5 mm plugs that go in to the audio cable for the TX500 (REM/DATA).

I could try using the CAT cable directly to the computer but I’m not sure if the MacBook Pro has a sound card that will work. Would I need an external sound card with a rectangular USB connection for the CAT cable? 

The folks at Lab599 (the radio company) suggested adjusting the TX/RX Gain levels as that may help key the radio.  Thoughts?

I’m really close if I can only get the computer to key the radio.  

Thanks for all your help!
Mark
On Aug 26, 2021, at 6:53 PM, Bill Somerville <g4wjs@...> wrote:

On 26/08/2021 23:10, Mark Finkelstein via groups.io wrote:
Well first off thank everyone for helping me. I have the software running and am copying transmissions on the band.  I can double click on CQ’s and if I enable the TX it appears to be sending. However, the radio does is not being keyed.  I tried both 20m and 40m with similar results.  I’m using the Sabrent adapter for Mac to the REM/Data port.  Tx500 radio is in Digital mode. I did a time.is and the computer clock is exact.

Any thoughts on where to look? 
Hi Mark,

do you have a CAT interface?

73
Bill
G4WJS.



Mark Finkelstein
 

Ok Bill Thanks! I believe the radio manual references some drivers and I’ll get them installed.  I’ll keep you posted!


On Aug 26, 2021, at 7:36 PM, Bill Somerville <g4wjs@...> wrote:


Hi Mark,

CAT control is separate from audio interfaces, you need both for full control of the rig. Looking at images of the TX-500 I see two sockets marked REM/DATA and CAT respectively. If you have a CAT interface then I would expect both to be populated. The CAT cable may need drivers installed for the virtual serial port that is the CAT connection.

73
Bill
G4WJS.

On 27/08/2021 00:30, Mark Finkelstein via groups.io wrote:
I do have the CAT cable for the radio that is a USB Connector. I’m using the audio cable and VOX and truthfully I’m not sure what the difference is.  The sound card I have, Sabrent, has the 3.5 mm plugs that go in to the audio cable for the TX500 (REM/DATA).

I could try using the CAT cable directly to the computer but I’m not sure if the MacBook Pro has a sound card that will work. Would I need an external sound card with a rectangular USB connection for the CAT cable? 

The folks at Lab599 (the radio company) suggested adjusting the TX/RX Gain levels as that may help key the radio.  Thoughts?

I’m really close if I can only get the computer to key the radio.  

Thanks for all your help!
Mark
On Aug 26, 2021, at 6:53 PM, Bill Somerville <g4wjs@...> wrote:

On 26/08/2021 23:10, Mark Finkelstein via groups.io wrote:
Well first off thank everyone for helping me. I have the software running and am copying transmissions on the band.  I can double click on CQ’s and if I enable the TX it appears to be sending. However, the radio does is not being keyed.  I tried both 20m and 40m with similar results.  I’m using the Sabrent adapter for Mac to the REM/Data port.  Tx500 radio is in Digital mode. I did a time.is and the computer clock is exact.

Any thoughts on where to look? 
Hi Mark,

do you have a CAT interface?

73
Bill
G4WJS.






Mark Finkelstein
 

Hi Bill,

Thank you for your patience.  I have everything working but radio control.  It seems the new Mac OS 11.5.2 with the M1 chip doesn’t recognize the driver. There is something about using applications to install the driver and that looks way beyond my abilities.

I tried the Mac support and they really didn’t have an idea about how to install the driver.  Also the driver site says that for the new Mac operating system the driver is a beta version.

Is there any other ways to control the radio that I might try?

Thanks,
Mark




On Aug 26, 2021, at 7:36 PM, Bill Somerville <g4wjs@...> wrote:


Hi Mark,

CAT control is separate from audio interfaces, you need both for full control of the rig. Looking at images of the TX-500 I see two sockets marked REM/DATA and CAT respectively. If you have a CAT interface then I would expect both to be populated. The CAT cable may need drivers installed for the virtual serial port that is the CAT connection.

73
Bill
G4WJS.

On 27/08/2021 00:30, Mark Finkelstein via groups.io wrote:
I do have the CAT cable for the radio that is a USB Connector. I’m using the audio cable and VOX and truthfully I’m not sure what the difference is.  The sound card I have, Sabrent, has the 3.5 mm plugs that go in to the audio cable for the TX500 (REM/DATA).

I could try using the CAT cable directly to the computer but I’m not sure if the MacBook Pro has a sound card that will work. Would I need an external sound card with a rectangular USB connection for the CAT cable? 

The folks at Lab599 (the radio company) suggested adjusting the TX/RX Gain levels as that may help key the radio.  Thoughts?

I’m really close if I can only get the computer to key the radio.  

Thanks for all your help!
Mark
On Aug 26, 2021, at 6:53 PM, Bill Somerville <g4wjs@...> wrote:

On 26/08/2021 23:10, Mark Finkelstein via groups.io wrote:
Well first off thank everyone for helping me. I have the software running and am copying transmissions on the band.  I can double click on CQ’s and if I enable the TX it appears to be sending. However, the radio does is not being keyed.  I tried both 20m and 40m with similar results.  I’m using the Sabrent adapter for Mac to the REM/Data port.  Tx500 radio is in Digital mode. I did a time.is and the computer clock is exact.

Any thoughts on where to look? 
Hi Mark,

do you have a CAT interface?

73
Bill
G4WJS.