WSJTX on Debian Buster #install #linux


Rick Hatton
 

Does anyone know of a wsjtx version >=2.1 that will cleanly install on a fully updated Buster distro? I also have the buster-backports repository enabled. I keep getting dependency errors.

wsjtx depends on libc6 (>= 2.29); however:
  Version of libc6:amd64 on system is 2.28-10.
 wsjtx depends on libgcc-s1 (>= 4.0); however:
  Package libgcc-s1 is not installed.
 wsjtx depends on libreadline8 (>= 6.0); however:
  Package libreadline8 is not installed.
 wsjtx depends on libstdc++6 (>= 9); however:
  Version of libstdc++6:amd64 on system is 8.3.0-6.

The highest version available are:
libc6 2.28
libgcc-s1 - not available
libreadline7
libstdc8

Thanks


Alan Blind
 

I am running v2.1.2 on. Ubuntu Linux PC.

In my case I used "Synaptic Package Manager" to do the install.  Per the Synaptic information, it knows and installs all the necessary dependencies.

Alan. WA9WUD


Rick Hatton
 

I am guessing 2.1.2 is in your  Ubuntu repository. 2.0 is the latest in the Debian Buster repository.


Rick Hatton
 

Also, there is no libgfortran3 in Debian Buster.