UDP Server DNS lookup failed on OS X #wsjt-x-crashing #macOS


barry@...
 

I changed the UDP address from 127.0.0.1 to multicast 224.0.0.1:2237 in the Preferences.
A DNS lookup failed occurs and a popup window is display showing "UDP server DNS lookup failed" and "Network Error".
Preferences is greyed out so I cannot correct the error.
The only thing that can be done is to select "Cancel" on the popup and the program shuts down.  

How can I correct this mistake?


Karza
 

OM [Name?], [Call?]


I changed the UDP address from 127.0.0.1 to multicast 224.0.0.1:2237 in the
Preferences.
A DNS lookup failed occurs and a popup window is display showing "UDP server
DNS lookup failed" and "Network Error".
Preferences is greyed out so I cannot correct the error.
The only thing that can be done is to select "Cancel" on the popup and the
program shuts down.

How can I correct this mistake?
remove :2237 part from the address field.
See WSJT-X user guide
https://physics.princeton.edu/pulsar/k1jt/wsjtx-doc/wsjtx-main-2.4.0.html#REPORTING

73's de Kari, oh2gqc


Colin
 

Likely it is interpreting that string as a host name, not as an IP address.

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of barry@...
Sent: August 6, 2021 02:06
To: main@WSJTX.groups.io
Subject: [WSJTX] UDP Server DNS lookup failed on OS X #mac #wsjt-x-crashing

 

I changed the UDP address from 127.0.0.1 to multicast 224.0.0.1:2237 in the Preferences.
A DNS lookup failed occurs and a popup window is display showing "UDP server DNS lookup failed" and "Network Error".
Preferences is greyed out so I cannot correct the error.
The only thing that can be done is to select "Cancel" on the popup and the program shuts down.  

How can I correct this mistake?


barry@...
 

That's the PROBLEM - The "Preferences" selection under WSJT-X is greyed out.  I have no way of removing the port number from the address.
There needs to be a file that I can erase to allow the program to not quit and allow access to Preferences.

Barry K6ZGW


Colin
 

Hi Barry,

You can find it in the %localappdata%\WSJT-X folder

WSJT-X.ini

has all the settings.

Be sure to quit out before editing. Also you might want to use notepad++ or notepad to carefully edit.

Good luck OM.

73 de Colin VE3MSC

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of barry@...
Sent: August 6, 2021 11:58
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] UDP Server DNS lookup failed on OS X #mac #wsjt-x-crashing

 

That's the PROBLEM - The "Preferences" selection under WSJT-X is greyed out.  I have no way of removing the port number from the address.
There needs to be a file that I can erase to allow the program to not quit and allow access to Preferences.

Barry K6ZGW


Karza
 

Barry,

The file you're looking for is ~/Library/Preferences/WSJT-X.ini,
see https://physics.princeton.edu/pulsar/k1jt/wsjtx-doc/wsjtx-main-2.4.0.html#_file_locations

73's de Kari, oh2gqc


Bill Somerville
 

On 06/08/2021 07:06, barry@byteybird.com wrote:
I changed the UDP address from 127.0.0.1 to multicast 224.0.0.1:2237 in the Preferences.
A DNS lookup failed occurs and a popup window is display showing "UDP server DNS lookup failed" and "Network Error".
Preferences is greyed out so I cannot correct the error.
The only thing that can be done is to select "Cancel" on the popup and the program shuts down.

How can I correct this mistake?
Barry,

that field expects a host name or IP address, the port number is in the port spin box below.

The Preferences menu option is disabled because you already have the Preferences open. Just go back to the Preferences dialog and remove the :2237 from the address entry.

73
Bill
G4WJS.


barry@...
 

Using Time Machine on the Mac, I replaced WSJT-X.ini with the backed up copy from the day before the file was corrupted.  Everything works as before.  

What I was trying to do was to get WSJT-X, GridTracker and MacLoggerDX working together using multicast 224.0.0.1.  GridTracker and WSJT-X were working great but MacLoggerDX was not responding correctly.