#Transmit #K4 - Split Operation -> DATA-R Mode on Elecraft K4 #transmit #Elecraft


Rick Tavan
 

I'm running WSJT-X 2.4.0 on a Dell XPS-13 laptop, running Windows 10 Home 19.09 connected to an Elecraft K4 in DATA mode. Settings | Radio | Split Operation = Rig in order to position the transmit tone in the passband. I believe SPLIT was working a few WSJT-X releases ago. Now, when I double-click a CQ in the left-hand window, it puts the K4 VFO B into DATA-R mode ("reverse") and the K4 complains on its screen that that type of split mode isn't allowed. I suppose it also returns an error to WSJT-X because it then refrains from using SPLIT mode. Instead, it transmits on VFO A which remains at the bottom of the band. I'm pretty sure this was introduced in a recent release of WSJT-X. Any thoughts?

Thanks & 73,

/Rick N6XI

--
--

Rick Tavan
Truckee and Saratoga, CA


ve3ki
 

Two possible work-arounds:

1. In the WSJT-X settings, set Mode to None so WSJT-X won't try to change the rig's mode.

2. In the WSJT-X settings, for Split Operation use Fake It instead of Rig, so WSJT-X won't try to use VFO B.

73,
Rich VE3KI


On Sun, Jul 18, 2021 at 11:02 PM, Rick Tavan wrote:
I'm running WSJT-X 2.4.0 on a Dell XPS-13 laptop, running Windows 10 Home 19.09 connected to an Elecraft K4 in DATA mode. Settings | Radio | Split Operation = Rig in order to position the transmit tone in the passband. I believe SPLIT was working a few WSJT-X releases ago. Now, when I double-click a CQ in the left-hand window, it puts the K4 VFO B into DATA-R mode ("reverse") and the K4 complains on its screen that that type of split mode isn't allowed. I suppose it also returns an error to WSJT-X because it then refrains from using SPLIT mode. Instead, it transmits on VFO A which remains at the bottom of the band. I'm pretty sure this was introduced in a recent release of WSJT-X. Any thoughts?
 
Thanks & 73,
 
/Rick N6XI
 
--
--

Rick Tavan
Truckee and Saratoga, CA


Bill Somerville
 

On 19/07/2021 02:38, Rick Tavan wrote:
I'm running WSJT-X 2.4.0 on a Dell XPS-13 laptop, running Windows 10 Home 19.09 connected to an Elecraft K4 in DATA mode. Settings | Radio | Split Operation = Rig in order to position the transmit tone in the passband. I believe SPLIT was working a few WSJT-X releases ago. Now, when I double-click a CQ in the left-hand window, it puts the K4 VFO B into DATA-R mode ("reverse") and the K4 complains on its screen that that type of split mode isn't allowed. I suppose it also returns an error to WSJT-X because it then refrains from using SPLIT mode. Instead, it transmits on VFO A which remains at the bottom of the band. I'm pretty sure this was introduced in a recent release of WSJT-X. Any thoughts?

Thanks & 73,

/Rick N6XI
Hi Rick,

give WSJT-X V2.5.0 RC3 a try and let us know how it goes please?

73
Bill
G4WJS.


Rick Tavan
 

Yes, on W9MDB's recommendation I tried V. 2.5.0 and it fixed the problem. "Split Operation | Rig" works fine on K4 now. Thanks!

/Rick N6XI

On Mon, Jul 19, 2021 at 2:52 AM Bill Somerville <g4wjs@...> wrote:
On 19/07/2021 02:38, Rick Tavan wrote:
> I'm running WSJT-X 2.4.0 on a Dell XPS-13 laptop, running Windows 10
> Home 19.09 connected to an Elecraft K4 in DATA mode. Settings | Radio
> | Split Operation = Rig in order to position the transmit tone in the
> passband. I believe SPLIT was working a few WSJT-X releases ago. Now,
> when I double-click a CQ in the left-hand window, it puts the K4 VFO B
> into DATA-R mode ("reverse") and the K4 complains on its screen that
> that type of split mode isn't allowed. I suppose it also returns an
> error to WSJT-X because it then refrains from using SPLIT mode.
> Instead, it transmits on VFO A which remains at the bottom of the
> band. I'm pretty sure this was introduced in a recent release of
> WSJT-X. Any thoughts?
>
> Thanks & 73,
>
> /Rick N6XI

Hi Rick,

give WSJT-X V2.5.0 RC3 a try and let us know how it goes please?

73
Bill
G4WJS.






--
--

Rick Tavan
Truckee and Saratoga, CA


Rick Tavan
 

Experimental 2.5.0 solved my K4 problem but it timed out on August 31. The current release is 2.4.0 so I'm back to square 1. Is there a way to extend the lifetime of the experimental release or will the K4 fix be incorporated into a production release some time soon?

Thanks,

Rick N6XI

On Mon, Jul 19, 2021 at 7:50 AM Rick Tavan <rick@...> wrote:
Yes, on W9MDB's recommendation I tried V. 2.5.0 and it fixed the problem. "Split Operation | Rig" works fine on K4 now. Thanks!

/Rick N6XI

On Mon, Jul 19, 2021 at 2:52 AM Bill Somerville <g4wjs@...> wrote:
On 19/07/2021 02:38, Rick Tavan wrote:
> I'm running WSJT-X 2.4.0 on a Dell XPS-13 laptop, running Windows 10
> Home 19.09 connected to an Elecraft K4 in DATA mode. Settings | Radio
> | Split Operation = Rig in order to position the transmit tone in the
> passband. I believe SPLIT was working a few WSJT-X releases ago. Now,
> when I double-click a CQ in the left-hand window, it puts the K4 VFO B
> into DATA-R mode ("reverse") and the K4 complains on its screen that
> that type of split mode isn't allowed. I suppose it also returns an
> error to WSJT-X because it then refrains from using SPLIT mode.
> Instead, it transmits on VFO A which remains at the bottom of the
> band. I'm pretty sure this was introduced in a recent release of
> WSJT-X. Any thoughts?
>
> Thanks & 73,
>
> /Rick N6XI

Hi Rick,

give WSJT-X V2.5.0 RC3 a try and let us know how it goes please?

73
Bill
G4WJS.






--
--

Rick Tavan
Truckee and Saratoga, CA


--
--

Rick Tavan
Truckee and Saratoga, CA


Bill Somerville
 

On 02/09/2021 23:12, Rick Tavan wrote:
Experimental 2.5.0 solved my K4 problem but it timed out on August 31. The current release is 2.4.0 so I'm back to square 1. Is there a way to extend the lifetime of the experimental release or will the K4 fix be incorporated into a production release some time soon?

Thanks,

Rick N6XI
Hi Rick,

the current WSJT-X v2.5.0 release candidate is RC5 and will run until the end of September.

73
Bill
G4WJS.