locked Audio CODEC required changes #AudioIssues


Chris Levingston
 

Audio Codecs are driving me nuts!

I am running the latest builds of Windows 10, Ham Radio Deluxe, WSJT-X and JTAlert on an IC-7610.

I just added another screen today, so WSJT picked up the screen's audio Codec. I saw that and disabled it.
Why? Read on.......

Clicking on the speaker icon at the bottom of the screen shows Playback devices as "Speakers (Realtek(R) Audio)", "Speakers (2-USB Audio CODEC" and "Speakers 3-USB Audio CODEC)."


WSJT initially picked USB CODEC 2 which means that I see transmit but no output power.
I stopped the transmission and picked USB CODEC 3, with the same result.
I then picked the remaining CODEC (Realtek) and all was well.

This happens every day, and WSJT never seems to pick the correct CODEC first and the CODEC that it needs changes from day to day.

Can ANYONE please help with this, please?

73s,

Chris    VK5SA


Bill Somerville
 

On 17/07/2021 08:59, Chris Levingston wrote:
Audio Codecs are driving me nuts!

I am running the latest builds of Windows 10, Ham Radio Deluxe, WSJT-X and JTAlert on an IC-7610.

I just added another screen today, so WSJT picked up the screen's audio Codec. I saw that and disabled it.
Why? Read on.......

Clicking on the speaker icon at the bottom of the screen shows Playback devices as "Speakers (Realtek(R) Audio)", "Speakers (2-USB Audio CODEC" and "Speakers 3-USB Audio CODEC)."


WSJT initially picked USB CODEC 2 which means that I see transmit but no output power.
I stopped the transmission and picked USB CODEC 3, with the same result.
I then picked the remaining CODEC (Realtek) and all was well.

This happens every day, and WSJT never seems to pick the correct CODEC first and the CODEC that it needs changes from day to day.

Can ANYONE please help with this, please?

73s,

Chris    VK5SA

Hi Chris,

have you tried renaming the audio devices to something more meaingful like the models of the rigs they are connected to?

73
Bill
G4WJS.


Michael Black
 

What audio device do you have picked in the Audio tab of WSJT-X?  Sounds like you have the "Default" device picked.

Mike W9MDB




On Saturday, July 17, 2021, 05:31:29 AM CDT, Bill Somerville <g4wjs@...> wrote:


On 17/07/2021 08:59, Chris Levingston wrote:
Audio Codecs are driving me nuts!

I am running the latest builds of Windows 10, Ham Radio Deluxe, WSJT-X and JTAlert on an IC-7610.

I just added another screen today, so WSJT picked up the screen's audio Codec. I saw that and disabled it.
Why? Read on.......

Clicking on the speaker icon at the bottom of the screen shows Playback devices as "Speakers (Realtek(R) Audio)", "Speakers (2-USB Audio CODEC" and "Speakers 3-USB Audio CODEC)."


WSJT initially picked USB CODEC 2 which means that I see transmit but no output power.
I stopped the transmission and picked USB CODEC 3, with the same result.
I then picked the remaining CODEC (Realtek) and all was well.

This happens every day, and WSJT never seems to pick the correct CODEC first and the CODEC that it needs changes from day to day.

Can ANYONE please help with this, please?

73s,

Chris    VK5SA

Hi Chris,

have you tried renaming the audio devices to something more meaingful like the models of the rigs they are connected to?

73
Bill
G4WJS.





chas cartmel
 

Have you tried disabling t2 of the three/

 

73 Charlie

G4EST

www.g4est.me.uk

Stay safe out there

 

 

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Bill Somerville
Sent: 17 July 2021 11:31
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Audio CODEC required changes #AudioIssues

 

On 17/07/2021 08:59, Chris Levingston wrote:

Audio Codecs are driving me nuts!

I am running the latest builds of Windows 10, Ham Radio Deluxe, WSJT-X and JTAlert on an IC-7610.

I just added another screen today, so WSJT picked up the screen's audio Codec. I saw that and disabled it.
Why? Read on.......

Clicking on the speaker icon at the bottom of the screen shows Playback devices as "Speakers (Realtek(R) Audio)", "Speakers (2-USB Audio CODEC" and "Speakers 3-USB Audio CODEC)."


WSJT initially picked USB CODEC 2 which means that I see transmit but no output power.
I stopped the transmission and picked USB CODEC 3, with the same result.
I then picked the remaining CODEC (Realtek) and all was well.

This happens every day, and WSJT never seems to pick the correct CODEC first and the CODEC that it needs changes from day to day.

Can ANYONE please help with this, please?

73s,

Chris    VK5SA

Hi Chris,

have you tried renaming the audio devices to something more meaingful like the models of the rigs they are connected to?

73
Bill
G4WJS.


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


Andy Talbot
 

This won't actually 'help' you with the codec situation, but it should letyou see what and why, and reduce blood pressure :-).    



Virus-free. www.avg.com


Alan G4ZFQ
 

On 17/07/2021 14:42, Andy TALBOT wrote:
This won't actually 'help' you with the codec situation, but it should letyou see what and why, and reduce blood pressure :-).
Andy

I use several USB soundcards on W10. Currently 5.
An old SB Live! for two instances of WSJT-X. At a restart any time after I plug in another device or rearrange devices both instances connect correctly.
The same goes for two instances of Spectrum Laboratory which are also run at the same time.

HDSDR must use a different way of device selection. I also run several instances of that. Every time I disturb sound settings HDSDR needs reconfiguring.

73 Alan G4ZFQ


Paul - W1PR
 

Andy, thanks so much for taking the time to write and post this excellent explanation. Much appreciated!
Is there a way we could convince TigerTronics to change from USB AUDIO CODEC in the SignaLinkUSB to something unique? And the radio manufacturers, too, for that matter.
73 de Paul - W1PR


Joe Subich, W4TV
 

Is there a way we could convince TigerTronics to change from USB AUDIO CODEC in the SignaLinkUSB to something unique? And the radio manufacturers, too, for that matter.
They simply need to use a CODEC that has onboard ROM that can have
a unique name. The CODEC can still call the stock "USB AUDIO CLASS"
driver but the CODEC would have it own name instead of the default
name for any generic USB Audio Class device. The problem is that
all of the manufacturers (except one) simply use the chip maker's
default driver installer.

73,

... Joe, W4TV


On 2021-07-17 6:11 PM, Paul - W1PR wrote:
Andy, thanks so much for taking the time to write and post this excellent explanation. Much appreciated!
Is there a way we could convince TigerTronics to change from USB AUDIO CODEC in the SignaLinkUSB to something unique? And the radio manufacturers, too, for that matter.
73 de Paul - W1PR


Chris Levingston
 

Hi, Mike.



This is what I have on the Audio tab but WSJT has selected Speakers (Realtek(R) Audio).

Chris     VK5SA


Chris Levingston
 

Thanks, Andy.

That article and my blood pressure tablets need to work together!

Chris    VK5SA


Chris Levingston
 

Hi, Bill.

I only use one rig, so don't understand why I have these two USB devices shown.

73s,

Chris    VK5SA


Michael Black
 

What do you mean when you say "WSJT has selected Speakers (Realtek(R)Audio)?

Where do you see that info?  




On Saturday, July 17, 2021, 06:53:30 PM CDT, Chris Levingston <chris@...> wrote:


Hi, Mike.



This is what I have on the Audio tab but WSJT has selected Speakers (Realtek(R) Audio).


Chris     VK5SA




heath calhoun - kb5vai <hcalhoun@...>
 

Probably under audio tab under settings.
Had that until installed external USB sound card.  Then it showed usb codec.





-------- Original message --------
From: "Michael Black via groups.io" <mdblack98@...>
Date: 7/17/21 22:36 (GMT-06:00)
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Audio CODEC required changes #AudioIssues

What do you mean when you say "WSJT has selected Speakers (Realtek(R)Audio)?

Where do you see that info?  




On Saturday, July 17, 2021, 06:53:30 PM CDT, Chris Levingston <chris@...> wrote:


Hi, Mike.



This is what I have on the Audio tab but WSJT has selected Speakers (Realtek(R) Audio).


Chris     VK5SA




Chris Levingston
 

When hovering over the Speaker icon on the task bar.


Cliff Fox (KU4GW)
 

Hi Chris,
               I've been using a freeware app called SoundVolumeView that allows me to save my audio configurations in separate files named for whichever rig model I save them for and then I can choose between my FT-1000MP Mark-V, FT-897D, or FT-991A audio settings config file before or after I start the rig control software whether it be Ham Radio Deluxe or flRig.  I first go to the SoundVolumeView icon that appears near the PC clock and I right click it and tell it which ever saved audio config file I choose from the ones I've saved and it loads it and works great on Windows 10 version 10.0.19042 (Build 19042). You can download the latest version, SoundVolumeView v2.23, in either a 32-bit or 64-bit version at https://www.nirsoft.net/utils/sound_volume_view.html  Scroll to the bottom of the page for the download links. NirSoft says it works with Windows 10, Windows 8, and Windows 7. Hope this may be helpful to you.

Very 73,
Cliff, KU4GW

 


Chris Levingston
 

Thanks, Cliff - will try.

73s

Chris    VK5SA