Ubuntu 18 WSJTX do not launch after update from 2.1.2 to 2.4.0 #install #linux


Mendoza
 

I had wsjtx 2.1.2 running fine on ubuntu 18. Then I went to update to 2.3.0 and it just never launched, although icon was there. I did uninstall and try several "tricks" but never launched. In the software center I had weird record saying I had 2.3.0 uninstalled and 2.1.2 installed. I did format my HD and install Ubuntu 18 from scratch to delete any inaccurate license record. Now with a clean fresh updated ubuntu 18, wsjtx 2.4.0 wont install (a bunch of dependency problems).

I have narrowed down the error on installing wsjtx 2.4.0 on ubuntu 18 to the following:
"Unpacking wsjtx:i386 (2.4.0) ...
dpkg: dependency problems prevent configuration of wsjtx:i386:
wsjtx:i386 depends on libboost-log1.65.1."
However this libboost-log1.65.1 is actually installed, is not missing in my system, see below:

ham@ham-V5-131:~$ apt list libboost-log1*

Listing... Done

libboost-log1.62-dev/bionic 1.62.0+dfsg-5 amd64

libboost-log1.62.0/bionic 1.62.0+dfsg-5 amd64

libboost-log1.65-dev/bionic,now 1.65.1+dfsg-0ubuntu5 amd64 [installed,automatic]

libboost-log1.65.1/bionic,now 1.65.1+dfsg-0ubuntu5 amd64 [installed]

 

ham@ham-V5-131:~$ cd Downloads

ham@ham-V5-131:~/Downloads$ sudo dpkg -i wsjtx_2.4.0_i386.deb

[sudo] password for ham:

Selecting previously unselected package wsjtx:i386.

(Reading database ... 190398 files and directories currently installed.)

Preparing to unpack wsjtx_2.4.0_i386.deb ...

Unpacking wsjtx:i386 (2.4.0) ...

dpkg: dependency problems prevent configuration of wsjtx:i386:

wsjtx:i386 depends on libboost-log1.65.1.

 

dpkg: error processing package wsjtx:i386 (--install):

dependency problems - leaving unconfigured

Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...

Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...

Processing triggers for mime-support (3.60ubuntu1) ...

Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

Errors were encountered while processing:

wsjtx:i386

 

This is preventing wsjtx to be completely installed. I do have wsjtx icon and when clicking to start, it just stays in sand-clock for a while and then I get a warning in ubuntu saying I have installed a package with unment dependencies. When I run the "fix" bay means of "partial upgrade" or by "sudo apt-get install -f" it automatically removes wsjtx because it is the problem.
“The following packages will be REMOVED:
wsjtx:i386”
I am stoked: wsjtx 2.4.0 impossible to install on ubuntu 18.
Any recommendation will be appreciated.

 

 


Rick Chapman
 

Hi Mendoza

Installing with a deb file should resolve all dependencies, so that's a bit odd. Presumably you are using this deb file

I tried installing this in a clean install of Ubuntu 18.04.3 on a vm and got the same dependancy not met as you.

After running:

    sudo apt install libboost-log1.65.1:i386

the deb installed ok with

    sudo apt install wsjtx_2.4.0_i386.deb

Hope this helps

73 de Rick (GM4JIB)

 

On 05/07/2021 16:50, Mendoza wrote:

I had wsjtx 2.1.2 running fine on ubuntu 18. Then I went to update to 2.3.0 and it just never launched, although icon was there. I did uninstall and try several "tricks" but never launched. In the software center I had weird record saying I had 2.3.0 uninstalled and 2.1.2 installed. I did format my HD and install Ubuntu 18 from scratch to delete any inaccurate license record. Now with a clean fresh updated ubuntu 18, wsjtx 2.4.0 wont install (a bunch of dependency problems).

I have narrowed down the error on installing wsjtx 2.4.0 on ubuntu 18 to the following:
"Unpacking wsjtx:i386 (2.4.0) ...
dpkg: dependency problems prevent configuration of wsjtx:i386:
wsjtx:i386 depends on libboost-log1.65.1."
However this libboost-log1.65.1 is actually installed, is not missing in my system, see below:

ham@ham-V5-131:~$ apt list libboost-log1*

Listing... Done

libboost-log1.62-dev/bionic 1.62.0+dfsg-5 amd64

libboost-log1.62.0/bionic 1.62.0+dfsg-5 amd64

libboost-log1.65-dev/bionic,now 1.65.1+dfsg-0ubuntu5 amd64 [installed,automatic]

libboost-log1.65.1/bionic,now 1.65.1+dfsg-0ubuntu5 amd64 [installed]

 

ham@ham-V5-131:~$ cd Downloads

ham@ham-V5-131:~/Downloads$ sudo dpkg -i wsjtx_2.4.0_i386.deb

[sudo] password for ham:

Selecting previously unselected package wsjtx:i386.

(Reading database ... 190398 files and directories currently installed.)

Preparing to unpack wsjtx_2.4.0_i386.deb ...

Unpacking wsjtx:i386 (2.4.0) ...

dpkg: dependency problems prevent configuration of wsjtx:i386:

wsjtx:i386 depends on libboost-log1.65.1.

 

dpkg: error processing package wsjtx:i386 (--install):

dependency problems - leaving unconfigured

Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...

Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...

Processing triggers for mime-support (3.60ubuntu1) ...

Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

Errors were encountered while processing:

wsjtx:i386

 

This is preventing wsjtx to be completely installed. I do have wsjtx icon and when clicking to start, it just stays in sand-clock for a while and then I get a warning in ubuntu saying I have installed a package with unment dependencies. When I run the "fix" bay means of "partial upgrade" or by "sudo apt-get install -f" it automatically removes wsjtx because it is the problem.
“The following packages will be REMOVED:
wsjtx:i386”
I am stoked: wsjtx 2.4.0 impossible to install on ubuntu 18.
Any recommendation will be appreciated.

 

 




Mendoza
 

¡THANKS Rick!  It works.  Now I get the difference between i386 vs amd64 libraries.
Now my wsjt-x 2.4.0 is launching!.
The weird thing is that I have ubuntu18 which is supposed to be 64 bits (amd64) but in wsjt-s 2.4.0 installation instructions it is stated I have to use the i386.deb file because amd68.deb file is intended for ubuntu 20. Anyway..... I can move forward to make it works.
73 XE1MGQ


Rick Chapman
 

Hi Mendoza

Great to hear you succeeded.

73

Rick (GM4JIB)

On 10/07/2021 16:59, Mendoza wrote:
¡THANKS Rick!  It works.  Now I get the difference between i386 vs amd64 libraries.
Now my wsjt-x 2.4.0 is launching!.
The weird thing is that I have ubuntu18 which is supposed to be 64 bits (amd64) but in wsjt-s 2.4.0 installation instructions it is stated I have to use the i386.deb file because amd68.deb file is intended for ubuntu 20. Anyway..... I can move forward to make it works.
73 XE1MGQ