locked #WSJTX_config -- USB vs DATA-USB Modes #WSJTX_config


Charles Albert
 


This is driving me crazy, but I'm not sure I'm even asking the right question. At the risk of giving too much information, please bear with me...

I have a Yaesu FT-991A (with all current firmware) and I want to use FLDIGI and WSJT-X. The rig is connected to the PC running Linux Mint 19.3 (also with all updates) via the USB cable and ports.
FLRIG/FLDIGI can control the rig 100% with no issues. The same goes for WSFT-X and it's limited CAT control.

If I select and use DATA-USB mode, everything seems to work fine...the rig keys, I get data transmission, and all the rest.

And this is where the problem starts...in DATA-USB mode, I never see anything on the respective waterfall and I never hear anything that sounds like data tones from the speaker UNLESS the signal is very strong. However, if I put the rig/software into plain vanilla USB mode, I can see and hear a bunch of signals across the passband, and the software will decode these signals.

BUT...when in USB mode and I try to transmit the rig keys but no data is sent. If the mic "hears" background noise or if I tap the mic, that sound is transmitted.

I've tried Menu Item #106 (SSB MIC SELECT) with the only change being that when in REAR mode, the mic will no longer pick up noise. That is to say, the data is still not transmitted.

I should note that Menu Item #071 (DATA IN SELECT) is set to the default of REAR.

All of this tells me that there is some issue with the rig settings. Maybe.

I'm not sure if there is a problem with the data mode settings that is making the receiver a little deaf or if there is an issue with the software settings that it's not getting the data signals when in DATA-USB mode.

What I'm trying to say is I have run out of ideas!

Any help would be greatly appreciated!

Take Care & 73
de KC6UFM
Charles



Dave KD2SGM
 

Hi Charles,

I have a Yaesu FTDX 3000 so I’m not sure if these settings will help. I spent a long time searching the internet and it took a while to get it right as everyone seems to have that one little change that makes it all work for them. I use Win4YaesuSuite to control everything so again, this may or may not fix your situation.

FTDX 3000 Menu Settings
#40 CAT RTS - Disable
#65 PC KEYING - Off
#67 DATA MODE - OTHERS
#69 OTHER DSP - 0
#75 DATA IN - USB
#76 DATA MIC GAIN - MCVR
#77 DATA OUT LEVEL - 50
MIC GAIN -20

WSJT-X Settings
Radio - FTDX 3000
Serial Port - COM 10 (COM0COM virtual port)
Baud Rate - 38400 (same as radio)
Data Bits - Default
Stop Bits - Default
Handshake - Default
PTT Method - CAT
Mode - Data/ Pkt
Split - Fake It

Good Luck,
Dave, KD2SGM


Charles Albert
 

Thanks for the info, Dave.

The numbers and settings look similar, but I'll have to look at them in detail.

I was able to get my FT991A/Linux/FLDIGI/WSJTX system to work. I simply copied the various filter settings from the SSB group to the DATA group, and the "deafness" went away. Made several 600+ mile contacts on FT8 at 6m yesterday with this setup.

I'm very tempted to just leave it alone now, though I am curious why in looking at about a dozen different HOW TO docs there are the same number of "...these are the only settings that will work..." statements. And that includes the docs for both FLDIGI and WSJTX.

Take Care & 73



On Fri, Jun 25, 2021 at 5:25 AM Dave KD2SGM <dfreeswick@...> wrote:
Hi Charles,

I have a Yaesu FTDX 3000 so I’m not sure if these settings will help. I spent a long time searching the internet and it took a while to get it right as everyone seems to have that one little change that makes it all work for them. I use Win4YaesuSuite to control everything so again, this may or may not fix your situation.

FTDX 3000 Menu Settings
#40 CAT RTS - Disable
#65 PC KEYING - Off
#67 DATA MODE - OTHERS
#69 OTHER DSP - 0
#75 DATA IN - USB
#76 DATA MIC GAIN - MCVR
#77 DATA OUT LEVEL - 50
MIC GAIN -20

WSJT-X Settings
Radio - FTDX 3000
Serial Port - COM 10 (COM0COM virtual port)
Baud Rate - 38400 (same as radio)
Data Bits - Default
Stop Bits - Default
Handshake - Default
PTT Method - CAT
Mode - Data/ Pkt
Split - Fake It

Good Luck,
Dave, KD2SGM