locked VS: [WSJTX] 2.5.0 RC1 - No receive after transmit - rig control disables RX on Yaesu FTDX-3000 VFO A running split #IssueReport


Mark Steele
 

One other interesting note that I believe removes RFI from the equation - I can induce the issue by changing frequencies in WSJT-X.

Let's say I am on 20 meter, if I select 30 meter from the drop down, VFO-A goes deaf (meaning the RX light for VFO-A blinks and WSJT-X shows no audio). Switching to any other frequency causes VFO-A to 'hear' again (RX light goes steady and WSJT-X shows audio / decodes). Switching between another frequency / band causes the cycle to repeat over and over - on / off / on / off.

This test was on 2.5.0 rc-1

Mark


Mark Steele
 

Reino,

Thank you for you testing results.

My walking has stopped after disabling the 'Allow Tx frequency changes while transmitting' as suggested by Bill.

I will try changing the baud rate to the rig to see if that makes any difference.

Best regards,

Mark


Reino Talarmo
 

Hi Mark and Bill,

I tried to repeat that functionality, but could not persuade my FTdx3000 to behave as Mark described. I have somewhat different settings:

bit rate 19200 and all Cat control settings as Default. I tried both Rig and Fake it, but could not make my rig walk up nor down. Mode was None or Data/Pkt no difference. I have not checked version of software of my rig, quite old I assume. I used today 2.5.0-rc1 and yesterday 2.4.0 GA (only with rig split).

I am using Windows 10, if that matters. I did testing at 6 m band.
Just a silly thought is there any possibility of RFI? That every other timeslot issue could indicated that kind of behaviour, but no idea why previous version behave differently, unless CAT message sequence is different and interference affects differently. Far fetched, I think.

 

73, Reino OH3mA

 

Lähettäjä: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] Puolesta Mark Steele
Lähetetty: 05 June 2021 20:01
Vastaanottaja: main@WSJTX.groups.io
Aihe: Re: [WSJTX] 2.5.0 RC1 - No receive after transmit - rig control disables RX on Yaesu FTDX-3000 VFO A running split #BugReport

 

Bill,

Thank you for the explanation. It's interesting that the quirk is present in 2.4.0 GA and 2.5.0 rc-1 but in no previous versions (I have versions going back a couple of years).

I have not updated the firmware on the Yaesu between 2.4.0 rc-4 and 2.4.0 GA / 2.5.0 rc-1 - so it stands to reason that something changed in the way the CAT library is sending commands - perhaps a different command is being used, or the sequence of commands is different or the timing of the commands is different.

A 'diff' of the two libraries might prove that out.

Best regards,

Mark