locked Trying to install WSJT-X ver 2.3.1 #WSJTX_config


KB3TC
 

Trying to install WSJT-X ver 2.3.1 on Ubuntu  I am not very good with linux but trying. When I tried to install using sudo dpkg -i wsjtx_2.3.1_amd64.deb  it comes back with an errors.
Any help is appreciated. I wanted to try out the new FST4 but I am on an older version. Here is the output from the install :
(Reading database ... 212417 files and directories currently installed.)
Preparing to unpack wsjtx_2.3.1_amd64.deb ...
Unpacking wsjtx (2.3.1) over (2.3.1) ...
dpkg: dependency problems prevent configuration of wsjtx:
 wsjtx depends on libboost-log1.62.0 (>= 1.62.0) | libboost-log1.65.1 (>= 1.65.1) | libboost-log1.67.0 (>= 1.67.0) | libboost-log1.71.0 (>= 1.71.0) | libboost-log1.74.0 (>= 1.74.0); however:
  Package libboost-log1.62.0 is not installed.
  Package libboost-log1.65.1 is not installed.
  Package libboost-log1.67.0 is not installed.
  Package libboost-log1.71.0 is not installed.
  Package libboost-log1.74.0 is not installed.
 wsjtx depends on libboost-log1.71.0; however:
  Package libboost-log1.71.0 is not installed.

dpkg: error processing package wsjtx (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Errors were encountered while processing:
 wsjtx


Bill Somerville
 

On 09/05/2021 18:54, KB3TC wrote:
Trying to install WSJT-X ver 2.3.1 on Ubuntu  I am not very good with linux but trying. When I tried to install using sudo dpkg -i wsjtx_2.3.1_amd64.deb  it comes back with an errors.
Any help is appreciated. I wanted to try out the new FST4 but I am on an older version. Here is the output from the install :
(Reading database ... 212417 files and directories currently installed.)
Preparing to unpack wsjtx_2.3.1_amd64.deb ...
Unpacking wsjtx (2.3.1) over (2.3.1) ...
dpkg: dependency problems prevent configuration of wsjtx:
 wsjtx depends on libboost-log1.62.0 (>= 1.62.0) | libboost-log1.65.1 (>= 1.65.1) | libboost-log1.67.0 (>= 1.67.0) | libboost-log1.71.0 (>= 1.71.0) | libboost-log1.74.0 (>= 1.74.0); however:
  Package libboost-log1.62.0 is not installed.
  Package libboost-log1.65.1 is not installed.
  Package libboost-log1.67.0 is not installed.
  Package libboost-log1.71.0 is not installed.
  Package libboost-log1.74.0 is not installed.
 wsjtx depends on libboost-log1.71.0; however:
  Package libboost-log1.71.0 is not installed.

dpkg: error processing package wsjtx (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Errors were encountered while processing:
 wsjtx
Hi OM,

what version of Ubuntu are you using?

73
Bill
G4WJS.