locked No PTT Icom Pro III #Cat_RigControl


Jim Keller
 

Everything was working fine yesterday.   Today I turned on the radio and discovered that PTT using WSJT-x was not functioning.   Either when trying to make a contact or just hitting the tune button.   Any ideas?   The radio is an Icom Pro III.  Signalink is the interface. Using a Windows 10 64 bit PC.   I was using WSJT-X version 2.2.2.   Updated this morning to 2.3.1 after I noticed the problem but its still there.


Thanks,    Jim   W6yxy


JP Tucson, AZ
 

Sounds like a typical Tuesday windows update issue that fouls up audio settings...

recheck your audio levels & settings both pc & wsjtx

On Wed, Mar 31, 2021 at 6:30 AM Jim Keller <jkeller@...> wrote:
Everything was working fine yesterday.   Today I turned on the radio and discovered that PTT using WSJT-x was not functioning.   Either when trying to make a contact or just hitting the tune button.   Any ideas?   The radio is an Icom Pro III.  Signalink is the interface. Using a Windows 10 64 bit PC.   I was using WSJT-X version 2.2.2.   Updated this morning to 2.3.1 after I noticed the problem but its still there.


Thanks,    Jim   W6yxy




--
73 - John - N7GHZ



neil_zampella
 

The Signalink is just a sound card with a VOX interface for PTT, are you using any CI-V cable from the ICOM to the computer? 

Neil, KN3ILZ

On 3/31/2021 8:29 AM, Jim Keller wrote:
Everything was working fine yesterday.   Today I turned on the radio and discovered that PTT using WSJT-x was not functioning.   Either when trying to make a contact or just hitting the tune button.   Any ideas?   The radio is an Icom Pro III.  Signalink is the interface. Using a Windows 10 64 bit PC.   I was using WSJT-X version 2.2.2.   Updated this morning to 2.3.1 after I noticed the problem but its still there.


Thanks,    Jim   W6yxy



Jim Keller
 

John, I checked the settings and they look normal.   Neil, I am using a CIV cable.  I think its functioning properly as I can get the radio to change bands through WSJT-X.  For what its worth the "Test PTT" button in WSJT-X settings is grayed out.  I can't remember if that is normal or not.   I use N3FJP ACL for logging and it tracks the radio frequency correctly so I'm assuming that the CIV cable and driver are ok.

Thanks,   Jim


neil_zampella
 

What are you using to trigger the PTT?  VOX .. if so, you may need to increase the volume on the Signalink.  This has fixed a number of people with that issue.

Secondly, if WSJT-X is changing bands, are you using a COM port sharing program to share the CAT connect with WSJT-X and ACLog?


Neil, KN3ILZ

On 3/31/2021 11:05 AM, Jim Keller wrote:
John, I checked the settings and they look normal.   Neil, I am using a CIV cable.  I think its functioning properly as I can get the radio to change bands through WSJT-X.  For what its worth the "Test PTT" button in WSJT-X settings is grayed out.  I can't remember if that is normal or not.   I use N3FJP ACL for logging and it tracks the radio frequency correctly so I'm assuming that the CIV cable and driver are ok.

Thanks,   Jim



Jim Keller
 

Yes using VOX to trigger the PTT.  I tried increasing the volume on the Signalink but still have the problem.  Normally I can hear the relay in the Signalink activate for PTT.  The relay isn't activating right now.

I don't think I'm using a COM port sharing program.  Both WSJT-x and ACLog use COM Port 3.   I bring up WSJT-x first then bring up ACLog.  When I bring up ACLog I get the following message.  Access to the port "COM 3" is denied.  I hit ok and ACLog captures all the contacts that I make.  Been doing it this way for years so I don't think the problem is related to that.   

I'm beginning to think that either the Signalink is not getting the command to activate the relay or the relay or associated circuitry has gone bad.

Thanks for your help.

Jim   W6yxy


Jim Keller
 

Problem solved.  As they say, a Cockpit error.   I noticed that the Windows speaker symbol in the lower right corner of the screen indicated that the speaker was muted.   Have no recollection of doing that but when I unmuted it I was back in business.

73

Jim  W6yxy


Bob Lewis
 

There is no command to activate the SignaLink-usb PTT relay. When the SignaLink gets a digital audio signal via the USB port then it keys the PTT line to the radio. Is the red PTT led on the SignaLink lighting when you attempt to transmit? Is the SignaLink outputting audio tones to the radio? Use the WSJT-x tune button and then key the radio manually with the [transmit] button on the radio to see if you get output power.

 

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Jim Keller
Sent: Wednesday, March 31, 2021 2:22 PM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] No PTT Icom Pro III #Cat_RigControl

 

Yes using VOX to trigger the PTT.  I tried increasing the volume on the Signalink but still have the problem.  Normally I can hear the relay in the Signalink activate for PTT.  The relay isn't activating right now.

I don't think I'm using a COM port sharing program.  Both WSJT-x and ACLog use COM Port 3.   I bring up WSJT-x first then bring up ACLog.  When I bring up ACLog I get the following message.  Access to the port "COM 3" is denied.  I hit ok and ACLog captures all the contacts that I make.  Been doing it this way for years so I don't think the problem is related to that.   

I'm beginning to think that either the Signalink is not getting the command to activate the relay or the relay or associated circuitry has gone bad.

Thanks for your help.

Jim   W6yxy


Martin G0HDB
 

On Wed, Mar 31, 2021 at 07:47 PM, Jim Keller wrote:
Problem solved.  As they say, a Cockpit error.   I noticed that the Windows speaker symbol in the lower right corner of the screen indicated that the speaker was muted.   Have no recollection of doing that but when I unmuted it I was back in business.
Hi Jim, glad to hear that you've got things working again but your reference to the speaker being muted has got me puzzled - have you got your SignaLink set as the default audio device for Windows?

I use a G4ZLP datamodes interface unit that's functionally almost identical to the SignaLink-USB but without the latter's performance shortcomings; in my Win 10 setup the G4ZLP device isn't configured as the default audio device for Windows - the default device is the Dell motherboard's onboard audio.  I've just tried muting the speaker and it's made no difference whatsoever to the operation of WSJT-X and the G4ZLP interface device - when the PC's speaker is muted WSJT-X and the G4ZLP device continue to output audio and key the PTT.

The danger with setting your SignaLink-USB, or any other external audio codec such as my G4ZLP device, as the default audio device for Windows is that you run the risk of transmitting all the Windows beeps and bongs over the air - Section 4.3 in the WSJT-X User Guide states that all Windows system sounds should be turned off when using the default audio device for WSJT-X's output.

Will it be possible for you to assign another audio device in your system as the default for WIndows so that you can use the SignaLink-USB solely for WSJT-X?  Most PCs have an inbuilt sound capability that can be used as the default for WIndows.

73
--
Martin G0HDB


Bill, WB6JJJ
 

You’re not alone...  My new computer (son designed and built this gaming computer) also mutes the sound every once in a while.  Sometimes a couple times a day, then it will stay unmuted for days???  Weird...

Bill
WB6JJJ 



On Mar 31, 2021, at 8:04 PM, Martin G0HDB <marting0hdb@...> wrote:

On Wed, Mar 31, 2021 at 07:47 PM, Jim Keller wrote:
Problem solved.  As they say, a Cockpit error.   I noticed that the Windows speaker symbol in the lower right corner of the screen indicated that the speaker was muted.   Have no recollection of doing that but when I unmuted it I was back in business.
Hi Jim, glad to hear that you've got things working again but your reference to the speaker being muted has got me puzzled - have you got your SignaLink set as the default audio device for Windows?

I use a G4ZLP datamodes interface unit that's functionally almost identical to the SignaLink-USB but without the latter's performance shortcomings; in my Win 10 setup the G4ZLP device isn't configured as the default audio device for Windows - the default device is the Dell motherboard's onboard audio.  I've just tried muting the speaker and it's made no difference whatsoever to the operation of WSJT-X and the G4ZLP interface device - when the PC's speaker is muted WSJT-X and the G4ZLP device continue to output audio and key the PTT.

The danger with setting your SignaLink-USB, or any other external audio codec such as my G4ZLP device, as the default audio device for Windows is that you run the risk of transmitting all the Windows beeps and bongs over the air - Section 4.3 in the WSJT-X User Guide states that all Windows system sounds should be turned off when using the default audio device for WSJT-X's output.

Will it be possible for you to assign another audio device in your system as the default for WIndows so that you can use the SignaLink-USB solely for WSJT-X?  Most PCs have an inbuilt sound capability that can be used as the default for WIndows.

73
--
Martin G0HDB



Jim Keller
 

Martin, the PC that I use for FT-8 is dedicated for ham use only. No email.  Very limited browsing.   I've turned off the notifications so I don't have a problem with beeps sneaking out.

73

Jim  W6yxy


Bill Somerville
 

On 02/04/2021 03:55, Jim Keller wrote:
Martin, the PC that I use for FT-8 is dedicated for ham use only. No email.  Very limited browsing.   I've turned off the notifications so I don't have a problem with beeps sneaking out.

73

Jim  W6yxy
Jim,

you are using a SignaLink USB which contains a sound card, there's no need to have the SignaLink USB sound card as the either of the Windows default sound devices (Default, or Default Communications). Assign the default sounds to and from your PC built in sound card, so there is no need to suppress sounds from the operating system or other applications like your occasionally used web browser.

73
Bill
G4WJS.


Jim Keller
 

Thanks Bill.  I never thought of doing that.  Sounds like a good idea.  Will give it a try.

73
Jim  W6yxy