Adjusting macOS shared memory system parameters - was Re: [WSJTX] #install


Bill Somerville
 

On 01/03/2021 18:40, John Wiener wrote:
This about the shared memory error after upgrading to Big Sur.  I tried to follow directions from this group but no luck.  shmmax is 4194384
How to correct?  I have no idea what any of this means, BTW. :)
John AB8O
Hi John,

as stated in the ReadMe.txt file instructions, you need to reboot after copying the provided sysctl.conf file to the /etc dirctory.

73
Bill
G4WJS.


Randy Cook
 

I have a MacBookAir (2020) Intel i3 computer used with IC-7300 and WSJT-X. 

When I updated MacOS to 11.2.2, WSJT-X stopped working, and displayed memory error box.  Apparently, an Apple issue. 

The ReadMe installation instructions included with WSJT-X 2.3 did not work. After playing around, I followed the 'Begin Intel' instructions and loaded the sysctl.conf file. Restarted Mac, but memory allocation was still not correct.  I then implemented two sudo commands in the Terminal app, as outlined in the 'Begin M1' instructions. 

      sudo  sysctl  -w  kern.sysv.shmmax=104857600
      sudo  sysctl  -w  kern.sysv.shmall=25600

Combining the two sets of instructions seemed to work. 

I have not restarted my Mac, so do not know if changes are persistent. 

--
Randy K6CRC