Topics

#Cat_RigControl #mac #Cat_RigControl #mac


smith.rip@...
 

Hello all

I just swapped in my Kenwood TS-590sg and attempted to get it up and running with WSJTX. I had had this setup working nicely a few months ago but I put in a different radio for a while.

When I had difficulties ended up updating my logging program (MacLoggerDX) and JSJTX as well as the Silicon Labs USB drivers that are required for the radio.

What I get is this error:

Hamlib error: Communication timed out

rig.c(972):rig_open return while opening connection to rig

Here is my WJTX Configuration. As far as I can tell it is no different from when it was working OK before



When I have the logging program and WSJTX open I can receive and display the traffic on the air. I just don't seem to be able to connect so I can transmit and make contacts.

I am at this point stumped as to what to do to get it working. Will appreciate some guidance.
--
73, Rip K3XO


Bill Somerville
 

On 12/02/2021 21:13, smith.rip@... wrote:

I just swapped in my Kenwood TS-590sg and attempted to get it up and running with WSJTX. I had had this setup working nicely a few months ago but I put in a different radio for a while.

When I had difficulties ended up updating my logging program (MacLoggerDX) and JSJTX as well as the Silicon Labs USB drivers that are required for the radio.

What I get is this error:

Hamlib error: Communication timed out

rig.c(972):rig_open return while opening connection to rig

Here is my WJTX Configuration. As far as I can tell it is no different from when it was working OK before

Hi Rip,

the default baud rate for the USB virtual serial port is 115200, you have 9600 in WSJT-X which is probably wrong.

73
Bill
G4WJS.


Dave Garber
 

in windows,   8 , none, 1  and also had to have dtr and rts   high, maybe your should also be that way

Dave Garber
VE3WEJ / VE3IE


On Fri, Feb 12, 2021 at 4:19 PM <smith.rip@...> wrote:
Hello all

I just swapped in my Kenwood TS-590sg and attempted to get it up and running with WSJTX. I had had this setup working nicely a few months ago but I put in a different radio for a while.

When I had difficulties ended up updating my logging program (MacLoggerDX) and JSJTX as well as the Silicon Labs USB drivers that are required for the radio.

What I get is this error:

Hamlib error: Communication timed out

rig.c(972):rig_open return while opening connection to rig

Here is my WJTX Configuration. As far as I can tell it is no different from when it was working OK before



When I have the logging program and WSJTX open I can receive and display the traffic on the air. I just don't seem to be able to connect so I can transmit and make contacts.

I am at this point stumped as to what to do to get it working. Will appreciate some guidance.
--
73, Rip K3XO



Kenneth Williams
 

I have a TS-570S but I am going to guess that a few things are similar so let me throw out an idea.

Change the handshake to hardware.  My TS-570S uses a hardware handshake and I don't know if this is changable in the menu so that would be my first guess.


Ken
KC6PUQ


smith.rip@...
 

Thanks for the replies and suggestions. I tried all of them but no luck. The frustrating part is that this combination of hardware was working great not that long ago. In between I was using and Icom 7300 that was also working very nicely. But a couple of days ago it suddenly wasn't connecting. I had moved a couple of things around in the shack and I was not sure what was going on so I moved the Kenwood in. At first the Kenwood would not connect either. Then earlier today it connected and I am still not sure what I did to solve that. But WSJTX still wont connect with the radio.

So I am stumped.

--
73, Rip K3XO


Kell / KI7UXT
 
Edited

I'm a complete newbie to WSJT-X and just installed it recently and thought I would share my settings.  On the radio tab, CAT Control/Serial Port, I had to use the /dev/tty.usbmodem1421201 from the drop down.  I was not able to get the "Test Cat" button to turn green with the /dev/cu options from the drop down.  I do not know what the difference b/w tty and cu.  I am using a 2019 MacBook Pro, macOS Big Sur v11.2.1. Everything appears to be working as far as I can tell, except for Tx'ing, I am not getting much power out per the 705's power meter screen.  I suspect that the USB cable I am using could be the problem and likely is not shielded very well.  I've gone through the process of setting the USB sound card input/output settings, but still not getting the full 5w out of the 705.  I have some ferrites on order for the USB cable to see if that makes any difference.

Does anyone have a link to a good quality, shielded USB cable they can share?

Also, if anyone sees any settings in my WSJT-X that should be changed, please comment:




Jim Bennett <w6jhb@...>
 

Here is what works fine for me:



Jim Bennett
Folsom, CA

K7TXA (ex W6JHB as of 1/22/2021)

Being retired doesn't mean I'm not part of the work force - just that I'm not forced to work!



On Feb 13, 2021, at 7:42 AM, Kell / KI7UXT <Kbodholt@...> wrote:

[Edited Message Follows]

I'm a complete newbie to WSJT-X and just installed it recently and thought I would share my settings.  On the radio tab, CAT Control/Serial Port, I had to use the /dev/tty.usbmodem1421201 from the drop down.  I was not able to get the "Test Cat" button to turn green with the /dev/cu options from the drop down.  I do not know what the difference b/w tty and cu.  I am using a 2019 MacBook Pro, macOS Big Sur v11.2.1. Everything appears to be working as far as I can tell, except for Tx'ing, I am not getting much power out per the 705's power meter screen.  I suspect that the USB cable I am using could be the problem and likely is not shielded very well.  I've gone through the process of setting the USB sound card input/output settings, but still not getting the full 5w out of the 705.  I have some ferrites on order for the USB cable to see if that makes any difference.

Does anyone have a link to a good quality, shielded USB cable they can share?

Also, if anyone sees any settings in my WSJT-X that should be changed, please comment:

<Screen Shot 2021-02-13 at 7.25.52 AM.png>

<Screen Shot 2021-02-13 at 7.26.06 AM.png><Screen Shot 2021-02-13 at 7.26.16 AM.png> <Screen Shot 2021-02-13 at 7.26.16 AM.png><Screen Shot 2021-02-13 at 7.26.06 AM.png><Screen Shot 2021-02-13 at 7.25.52 AM.png>




smith.rip@...
 

Hello Kell,

The only thing I see in your setting is the Transmit Audio Source. I have always set it on Rear/Data. This makes sense because your transmit data is being generated by the computer and sent to the readio via the USB cable. At least that is the way I understand it.

Hope this helps ...

Other than that your settings are the same as mine (except, of course, a different radio and driver) and I keep getting the error message. Even letting it sit ovenight didn't fix the problem. :-{

--
73, Rip K3XO


Kell / KI7UXT
 

Thanks Rip, the Transmit Audio Source is gray out so I'm not able to change that. I'll play around with the settings and see if anything allows me to change that.

73 de Kell


smith.rip@...
 

Kell,

I think if you click on DTS or RTS box it will allow you to change it. Then you can click back to CAT. Maybe that will help.

--
73, Rip K3XO


smith.rip@...
 

Thanks to Bill, G4WJS, who put me on the right path. Now all is working.

But one thing at the end of the process that I should mention is that it would only transmit a couple times and then it had no output.

I tried calling CQ on an empty band for a test. It quit after three times. After I exited from the program and reloaded, it went through the sequence again.

After poking around on the internets I read something that triggered a memory of when I first started. The solution to this particular problem is to reduce the sampling rate of the transmitted audio (go to Audio MIDI Setup.app in Utilities on the Mac.) I changed it from 48khz to 44.1 khz. after that it worked fine. It's a pretty obscure solution. the only reason I knew it was because somebody put me on to it a year ago.

Good luck to all and stay safe!
--
73, Rip K3XO