WSJT-X No Longer Opens on Raspberry Pi 3B+ #install #raspberryPi


Bedrock305
 

This Raspberry Pi 3B+ used to work great with WSJT-X, but now it no longer opens.  I can run JS8CALL just fine.

I downloaded both 2.3.0 and 2.4.0 RC-1, and neither of them worked.  First I upgraded what was there to the latest, then I purged it.  Next I installed the 2.3.0 version.

Here is the output that I received from the command line.

pi@raspberrypi:~/Downloads $ sudo dpkg -i wsjtx_2.3.0_armhf.deb
Selecting previously unselected package wsjtx.
(Reading database ... 152945 files and directories currently installed.)
Preparing to unpack wsjtx_2.3.0_armhf.deb ...
Unpacking wsjtx (2.3.0) ...
dpkg: dependency problems prevent configuration of wsjtx:
 wsjtx depends on libboost-log1.62.0 (>= 1.62.0) | libboost-log1.65.1 (>= 1.65.1) | libboost-log1.67.0 (>= 1.67.0) | libboost-log1.71.0 (>= 1.71.0) | libboost-log1.74.0 (>= 1.74.0); however:
  Package libboost-log1.62.0 is not installed.
  Package libboost-log1.65.1 is not installed.
  Package libboost-log1.67.0 is not installed.
  Package libboost-log1.71.0 is not installed.
  Package libboost-log1.74.0 is not installed.
 wsjtx depends on libboost-atomic1.67.0; however:
  Package libboost-atomic1.67.0 is not installed.
 wsjtx depends on libboost-chrono1.67.0; however:
  Package libboost-chrono1.67.0 is not installed.
 wsjtx depends on libboost-date-time1.67.0; however:
  Package libboost-date-time1.67.0 is not installed.
 wsjtx depends on libboost-filesystem1.67.0; however:
  Package libboost-filesystem1.67.0 is not installed.
 wsjtx depends on libboost-log1.67.0; however:
  Package libboost-log1.67.0 is not installed.
 wsjtx depends on libboost-regex1.67.0 (>= 1.67.0-10); however:
  Package libboost-regex1.67.0 is not installed.
 wsjtx depends on libboost-system1.67.0; however:
  Package libboost-system1.67.0 is not installed.
 wsjtx depends on libboost-thread1.67.0; however:
  Package libboost-thread1.67.0 is not installed.
 wsjtx depends on libc6 (>= 2.28); however:
  Version of libc6:armhf on system is 2.24-11+deb9u4.
 wsjtx depends on libgfortran5 (>= 8); however:
  Package libgfortran5 is not installed.
 wsjtx depends on libqt5core5a (>= 5.9.0~beta); however:
  Version of libqt5core5a:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5gui5 (>= 5.8.0); however:
  Version of libqt5gui5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5network5 (>= 5.11.0~rc1); however:
  Version of libqt5network5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5sql5 (>= 5.10.0); however:
  Version of libqt5sql5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5widgets5 (>= 5.11.0~rc1); however:
  Version of libqt5widgets5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libstdc++6 (>= 7); however:
  Version of libstdc++6:armhf on system is 6.3.0-18+rpi1+deb9u1.
 
dpkg: error processing package wsjtx (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 wsjtx
pi@raspberrypi:~/Downloads $ sudo apt install libgfortran5 libqt5widgets5 libqt5network5 \
>      libqt5printsupport5 libqt5multimedia5-plugins libqt5serialport5 \
>      libqt5sql5-sqlite libfftw3-single3 libgomp1 libboost-all-dev \
>      libusb-1.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgfortran5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
 
E: Package 'libgfortran5' has no installation candidate
pi@raspberrypi:~/Downloads $ 
 


Richard Hattaway
 

Hi,
You are missing a load of dependencies needed to install the later versions.  The dependencies must be installed first.
Try, from the Pi@raspberrypi $  prompt  ( not the download prompt )

pi@raspberrypi: $ sudo apt install libgfortran5 libqt5widgets5 libqt5network5

pi@raspberrypi: $ sudo apt install libqt5printsupport5 libqt5multimedia5-plugins libqt5serialport5

pi@raspberrypi: $ sudo apt install libqt5sql5-sqlite libfftw3-single3 libgomp1 libboost-all-dev libusb-1.0-0
 
Then install WSJT.  I believe you can double click on the .deb file in the download directory to accomplish this.. IE the dpkg command line is simply replaced by a double click on the file.

--
73
Dick

W4PID@...


Ria, N2RJ
 

There is an easier way:

pi@myraspberrypi$ sudo dpkg -i install <whatever you want to install>

blah blah blah failed because of dependencies...

pi@myraspberrypi$ sudo apt-get -f install

[messages etc about repos]
Setting up [dependency]...
Setting up [package you wanted to install]

It will first satisfy the deps then install the package.

Even easier - newer versions of apt (>1.1) can install local files AND
satisfy dependencies all at once:

pi@myraspberrypi$ sudo apt install ./foo-1.2.3.deb

Easy peasy.

73
Ria, N2RJ


On Fri, Feb 5, 2021 at 10:01 AM Richard Hattaway via groups.io
<rhattaway=rocketmail.com@groups.io> wrote:

Hi,
You are missing a load of dependencies needed to install the later versions. The dependencies must be installed first.
Try, from the Pi@raspberrypi $ prompt ( not the download prompt )

pi@raspberrypi: $ sudo apt install libgfortran5 libqt5widgets5 libqt5network5

pi@raspberrypi: $ sudo apt install libqt5printsupport5 libqt5multimedia5-plugins libqt5serialport5

pi@raspberrypi: $ sudo apt install libqt5sql5-sqlite libfftw3-single3 libgomp1 libboost-all-dev libusb-1.0-0

Then install WSJT. I believe you can double click on the .deb file in the download directory to accomplish this.. IE the dpkg command line is simply replaced by a double click on the file.

--
73
Dick

W4PID@ARRL.NET




Ria, N2RJ
 

Minor correction (so there is no confusion):

pi@myraspberrypi$ sudo dpkg -i install <whatever you want to install>

should be:

pi@myraspberrypi$ sudo dpkg -i <whatever .deb you want to install>

On Fri, Feb 5, 2021 at 10:15 AM rjairam@gmail.com <rjairam@gmail.com> wrote:

There is an easier way:

pi@myraspberrypi$ sudo dpkg -i install <whatever you want to install>

blah blah blah failed because of dependencies...

pi@myraspberrypi$ sudo apt-get -f install

[messages etc about repos]
Setting up [dependency]...
Setting up [package you wanted to install]

It will first satisfy the deps then install the package.

Even easier - newer versions of apt (>1.1) can install local files AND
satisfy dependencies all at once:

pi@myraspberrypi$ sudo apt install ./foo-1.2.3.deb

Easy peasy.

73
Ria, N2RJ


On Fri, Feb 5, 2021 at 10:01 AM Richard Hattaway via groups.io
<rhattaway=rocketmail.com@groups.io> wrote:

Hi,
You are missing a load of dependencies needed to install the later versions. The dependencies must be installed first.
Try, from the Pi@raspberrypi $ prompt ( not the download prompt )

pi@raspberrypi: $ sudo apt install libgfortran5 libqt5widgets5 libqt5network5

pi@raspberrypi: $ sudo apt install libqt5printsupport5 libqt5multimedia5-plugins libqt5serialport5

pi@raspberrypi: $ sudo apt install libqt5sql5-sqlite libfftw3-single3 libgomp1 libboost-all-dev libusb-1.0-0

Then install WSJT. I believe you can double click on the .deb file in the download directory to accomplish this.. IE the dpkg command line is simply replaced by a double click on the file.

--
73
Dick

W4PID@ARRL.NET




Bedrock305
 

Hello Dick,
 
I made sure WSJT-X was uninstalled completely.  I tried to download and install the dependencies, and it gave me the following output.
 
pi@raspberrypi:~ $ sudo apt install libgfortran5 libqt5widgets5 libqt5network5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgfortran5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libgfortran5' has no installation candidate
 
 
pi@raspberrypi:~ $ sudo apt install libqt5printsupport5 libqt5multimedia5-plugins libqt5serialport5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5multimedia5-plugins is already the newest version (5.7.1~20161021-2).
libqt5multimedia5-plugins set to manually installed.
libqt5printsupport5 is already the newest version (5.7.1+dfsg-3+rpi1+deb9u3).
libqt5printsupport5 set to manually installed.
libqt5serialport5 is already the newest version (5.7.1~20161021-2).
libqt5serialport5 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
 
sudo apt install libqt5sql5-sqlite libfftw3-single3 libgomp1 libboost-all-dev libusb-1.0-0
 
Fully downloaded and installed - too much output to paste in here!
 
 
Do I need that first set of dependencies or is there a way to get them someplace else??
 
73,
 
Chris Ranes NS8Q


Ria, N2RJ
 

Which version of raspberry pi os?

cat /etc/os-release

Or you can try lsb-release -a

Paste the output.

Also before installing the dependency package make sure you run apt update to refresh the repository information.

Also make sure you’re on the latest updates - run:

apt upgrade -y 

then reboot. 


Ria
N2RJ 

On Fri, Feb 5, 2021 at 5:19 PM Bedrock305 <ceranes@...> wrote:
Hello Dick,
 
I made sure WSJT-X was uninstalled completely.  I tried to download and install the dependencies, and it gave me the following output.
 
pi@raspberrypi:~ $ sudo apt install libgfortran5 libqt5widgets5 libqt5network5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgfortran5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libgfortran5' has no installation candidate
 
 
pi@raspberrypi:~ $ sudo apt install libqt5printsupport5 libqt5multimedia5-plugins libqt5serialport5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5multimedia5-plugins is already the newest version (5.7.1~20161021-2).
libqt5multimedia5-plugins set to manually installed.
libqt5printsupport5 is already the newest version (5.7.1+dfsg-3+rpi1+deb9u3).
libqt5printsupport5 set to manually installed.
libqt5serialport5 is already the newest version (5.7.1~20161021-2).
libqt5serialport5 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
 
sudo apt install libqt5sql5-sqlite libfftw3-single3 libgomp1 libboost-all-dev libusb-1.0-0
 
Fully downloaded and installed - too much output to paste in here!
 
 
Do I need that first set of dependencies or is there a way to get them someplace else??
 
73,
 
Chris Ranes NS8Q




Bedrock305
 

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
VERSION_CODENAME=stretch
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


What is I already installed dependencies?

Chris
NS8Q



Bedrock305
 

pi@raspberrypi:~ $ sudo apt update
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.3 kB]
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease                                          
Fetched 25.3 kB in 1s (18.0 kB/s)                  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
pi@raspberrypi:~ $ sudo apt upgrade -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 


Bedrock305
 

Here is the output when I try to install WSJT-X after running updates and upgrades, then rebooting.

pi@raspberrypi:~/Downloads $ sudo dpkg -i wsjtx_2.4.0-rc1_armhf.deb
Selecting previously unselected package wsjtx.
(Reading database ... 168624 files and directories currently installed.)
Preparing to unpack wsjtx_2.4.0-rc1_armhf.deb ...
Unpacking wsjtx (2.4.0-rc1) ...
dpkg: dependency problems prevent configuration of wsjtx:
 wsjtx depends on libboost-atomic1.67.0; however:
  Package libboost-atomic1.67.0 is not installed.
 wsjtx depends on libboost-chrono1.67.0; however:
  Package libboost-chrono1.67.0 is not installed.
 wsjtx depends on libboost-date-time1.67.0; however:
  Package libboost-date-time1.67.0 is not installed.
 wsjtx depends on libboost-filesystem1.67.0; however:
  Package libboost-filesystem1.67.0 is not installed.
 wsjtx depends on libboost-log1.67.0; however:
  Package libboost-log1.67.0 is not installed.
 wsjtx depends on libboost-regex1.67.0 (>= 1.67.0-10); however:
  Package libboost-regex1.67.0 is not installed.
 wsjtx depends on libboost-system1.67.0; however:
  Package libboost-system1.67.0 is not installed.
 wsjtx depends on libboost-thread1.67.0; however:
  Package libboost-thread1.67.0 is not installed.
 wsjtx depends on libc6 (>= 2.28); however:
  Version of libc6:armhf on system is 2.24-11+deb9u4.
 wsjtx depends on libgfortran5 (>= 8); however:
  Package libgfortran5 is not installed.
 wsjtx depends on libqt5core5a (>= 5.9.0~beta); however:
  Version of libqt5core5a:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5gui5 (>= 5.8.0); however:
  Version of libqt5gui5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5network5 (>= 5.11.0~rc1); however:
  Version of libqt5network5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5sql5 (>= 5.10.0); however:
  Version of libqt5sql5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libqt5widgets5 (>= 5.11.0~rc1); however:
  Version of libqt5widgets5:armhf on system is 5.7.1+dfsg-3+rpi1+deb9u3.
 wsjtx depends on libstdc++6 (>= 7); however:
  Version of libstdc++6:armhf on system is 6.3.0-18+rpi1+deb9u1.
 
dpkg: error processing package wsjtx (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 wsjtx
pi@raspberrypi:~/Downloads $ 


When I open up the GUI, browse to my Downloads folder, and double-click or right-click and select Install, I get the following message:

Failed to install file
A package could not be found that allows the action to complete.  More information is available in the detailed report.


Where is this report and is it useful to us?


Chris  NS8Q


Bill Somerville
 

On 05/02/2021 01:57, Bedrock305 wrote:
This Raspberry Pi 3B+ used to work great with WSJT-X, but now it no longer opens.  I can run JS8CALL just fine.

I downloaded both 2.3.0 and 2.4.0 RC-1, and neither of them worked.  First I upgraded what was there to the latest, then I purged it.  Next I installed the 2.3.0 version.
Hi Chris,

the packages we provide for Raspberry Pi OS are built on the Buster version, you need to upgrade your Raspbian to the Raspberyy Pi OS Buster version or build WSJT-X from sources.

73
Bill
G4WJS.


Ria, N2RJ
 

The packages are for buster. You’re running stretch which seems to be not supported.

You’ll have to upgrade to stretch at a minimum, sorry.

73
Ria
N2RJ 






On Fri, Feb 5, 2021 at 6:13 PM Bedrock305 <ceranes@...> wrote:
>
> pi@raspberrypi:~ $ cat /etc/os-release
> PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
> NAME="Raspbian GNU/Linux"
> VERSION_ID="9"
> VERSION="9 (stretch)"
> VERSION_CODENAME=stretch
> ID=raspbian
> ID_LIKE=debian
> HOME_URL="http://www.raspbian.org/"
> SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
> BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
>
>
> What is I already installed dependencies?
>
> Chris
> NS8Q
>
>
>
>
>


Richard Hattaway
 

Hi Chris,

This is a pretty old version.  My 'pretty name' is GNU/Linux 10 (buster) .. I guess I had never tried to cross boundaries between generations of op systems.. ( stretch to buster ) .. but apparently the upgrade / update routine will not cross those.  I always just download a new system when it comes out, and build my chip(s) back to what I had earlier. 

So there may be lots of other stuff on your chip that you want to hang on to.  Things like your WSJT log file, etc.  And who knows what else you use the chip for, and what programs are on it. 

My simple solution is to get another chip ( 16GB or above ) and format it, then go to raspberrypi.org and download the latest operating system.  Then start over with the dependencies and then attempt to install WSJT... and anything else that you are using.  I bet that nasty fortran error disappears when you do this.  The rest of the output looked normal.  

I'm interested in Ria's method of installing a .deb.  I may try that the next time I am faced with one of those.  But being really old and really nosy, I love to see what the little computer is doing so I appreciate the individual commands.

Good luck

73
Dick

W4PID@...


Bedrock305
 

I just realized when you said they were for Buster, that I should've been running the dist-upgrade command.

Here is a webpage with the directions I am following.

https://www.muo.com/tag/raspberry-pi-update-raspbian-os/

I'll let you know how things turn out.

Thanks for the help!

Chris NS8Q


Bedrock305
 

I had success with getting the new version of Raspian Buster installed.  I followed the instructions at the link I posted above, and it worked, but it only installed Raspian Lite.  I tried additional steps to install a Desktop GUI, with no luck.  I ended up using my Windows 10 PC with the SD card in a card reader the Raspberry Pi Imager to load Buster onto the card.  Once that was copied over, I successfully booted up the Pi.  Then I installed the latest WSJT-X and JS8CALL without a problem.

Thanks for everyone's assistance!

73
Chris NS8Q


Bruce N7XGR
 

Chris,  Do this in terminal to give you the Pulse Audio GUI that is in the
main menu under Sound,
sudo apt-get install pavucontrol paprefs
With this you can set the audio levels via the sliders for audio in/out.
Pulse Audio is built into this new Buster Pi OS but to access the GUI
this terminal install will do that.

Bruce  N7XGR

On Sat, Feb 6, 2021 at 7:24 PM Bedrock305 <ceranes@...> wrote:
I had success with getting the new version of Raspian Buster installed.  I followed the instructions at the link I posted above, and it worked, but it only installed Raspian Lite.  I tried additional steps to install a Desktop GUI, with no luck.  I ended up using my Windows 10 PC with the SD card in a card reader the Raspberry Pi Imager to load Buster onto the card.  Once that was copied over, I successfully booted up the Pi.  Then I installed the latest WSJT-X and JS8CALL without a problem.

Thanks for everyone's assistance!

73
Chris NS8Q



Panther 353PA
 

Are you still having the issue? On mine I had to install the latest versions of the missing items. From there I had to unpack the .deb file, update the versions there, repack and it installs. 

I used this as an example. https://medium.com/@fredrickanyera/how-edit-the-dependency-list-in-a-deb-package-f33303981b05