WSTJ-X v2.2.2 Crashed During the RTTY Roundup #ContestMode


Robert A Wilson
 

While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
Thanks,
Robert, KN4CNU


Anthony Luscre
 

I had a similar situation here.
I tried it both through N1MM and as stand-alone and had crashes both ways

On Sun, Jan 3, 2021 at 7:28 PM Robert A Wilson <fishnscout@...> wrote:
While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
Thanks,
Robert, KN4CNU




--
Anthony Luscre

K8ZT
Ohio Section Section Youth Coordinator & Education Outreach
ARRL - The National Association For Amateur Radio™
 
k8zt@... (best for Amateur Radio)

The Web Resource Hoarder- www.ZTLearn.com

K8ZT Radio Website- www.k8zt.com

Amateur Radio Resources for Students/Youth - www.k8zt.com/hry


Stephen Malyszka
 

I also experienced the same problem.  Spent a lot of contest time troubleshooting and many lost Q's. I had well over  a dozen crashes. Luckily I only had to reload WSJTx  and not reboot the computer. Had some crazy Error messages after reloading. It appeared to me that the problem is primarily in FT4 mode. One member from Our club (FRC) used the newer candidate version and didn't experience any problems. 

Now that we have all brought attention to this problem, what is the recommendation from the designers? I assume they are part this group. Was this problem known and a fix implemented in the New candidate version? 

Steve AG2J


On Jan 3, 2021, at 10:10 PM, Anthony Luscre <k8zt73@...> wrote:


I had a similar situation here.
I tried it both through N1MM and as stand-alone and had crashes both ways

On Sun, Jan 3, 2021 at 7:28 PM Robert A Wilson <fishnscout@...> wrote:
While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
Thanks,
Robert, KN4CNU




--
Anthony Luscre

K8ZT
Ohio Section Section Youth Coordinator & Education Outreach
ARRL - The National Association For Amateur Radio™
 
k8zt@... (best for Amateur Radio)

The Web Resource Hoarder- www.ZTLearn.com

K8ZT Radio Website- www.k8zt.com

Amateur Radio Resources for Students/Youth - www.k8zt.com/hry




Robert A Wilson
 

Based on another thread about the same issue, it appears to be an issue with deep inspection. It is suggested to try the latest beta or change the mode from Deep to Normal or Fast.

Robert


On Mon, Jan 4, 2021 at 9:24 AM Stephen Malyszka <s.malyszka.jr@...> wrote:
I also experienced the same problem.  Spent a lot of contest time troubleshooting and many lost Q's. I had well over  a dozen crashes. Luckily I only had to reload WSJTx  and not reboot the computer. Had some crazy Error messages after reloading. It appeared to me that the problem is primarily in FT4 mode. One member from Our club (FRC) used the newer candidate version and didn't experience any problems. 

Now that we have all brought attention to this problem, what is the recommendation from the designers? I assume they are part this group. Was this problem known and a fix implemented in the New candidate version? 

Steve AG2J


On Jan 3, 2021, at 10:10 PM, Anthony Luscre <k8zt73@...> wrote:


I had a similar situation here.
I tried it both through N1MM and as stand-alone and had crashes both ways

On Sun, Jan 3, 2021 at 7:28 PM Robert A Wilson <fishnscout@...> wrote:
While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
Thanks,
Robert, KN4CNU




--
Anthony Luscre

K8ZT
Ohio Section Section Youth Coordinator & Education Outreach
ARRL - The National Association For Amateur Radio™
 
k8zt@... (best for Amateur Radio)

The Web Resource Hoarder- www.ZTLearn.com

K8ZT Radio Website- www.k8zt.com

Amateur Radio Resources for Students/Youth - www.k8zt.com/hry







groups@...
 

On 04/01/2021 03:48, Stephen Malyszka wrote:
I also experienced the same problem. Spent a lot of contest time troubleshooting and many lost Q's. I had well over a dozen crashes. Luckily I only had to reload WSJTx and not reboot the computer. Had some crazy Error messages after reloading. It appeared to me that the problem is primarily in FT4 mode. One member from Our club (FRC) used the newer candidate version and didn't experience any problems.
Now that we have all brought attention to this problem, what is the recommendation from the designers? I assume they are part this group. Was this problem known and a fix implemented in the New candidate version?
Steve AG2J
On Jan 3, 2021, at 10:10 PM, Anthony Luscre <k8zt73@gmail.com> wrote:


I had a similar situation here.
I tried it both through N1MM and as stand-alone and had crashes both ways

On Sun, Jan 3, 2021 at 7:28 PM Robert A Wilson <fishnscout@gmail.com> wrote:
While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
Thanks,
Robert, KN4CNU


--
Anthony Luscre

K8ZT
Ohio Section Section Youth Coordinator & Education Outreach
ARRL - The National Association For Amateur Radio™

k8zt@arrl.net (best for Amateur Radio)

The Web Resource Hoarder- www.ZTLearn.com

K8ZT Radio Website- www.k8zt.com

Amateur Radio Resources for Students/Youth - www.k8zt.com/hry


It would certainly help the developers if you could cut and paste the error message so they see for themselves what is going wrong.

73
Roger
G#4HZA
moderator


Robert A Wilson
 

I can try to provide any error messages. Are they located in a log somewhere? When the application crashed, there was no visible  error message displayed. The windows just closed.
Thanks

On Wed, Jan 6, 2021 at 6:06 AM <groups@...> wrote:
On 04/01/2021 03:48, Stephen Malyszka wrote:
> I also experienced the same problem.  Spent a lot of contest time troubleshooting and many lost Q's. I had well over  a dozen crashes. Luckily I only had to reload WSJTx  and not reboot the computer. Had some crazy Error messages after reloading. It appeared to me that the problem is primarily in FT4 mode. One member from Our club (FRC) used the newer candidate version and didn't experience any problems.
>
> Now that we have all brought attention to this problem, what is the recommendation from the designers? I assume they are part this group. Was this problem known and a fix implemented in the New candidate version?
>
> Steve AG2J
>> On Jan 3, 2021, at 10:10 PM, Anthony Luscre <k8zt73@...> wrote:
>>
>> 
>> I had a similar situation here.
>> I tried it both through N1MM and as stand-alone and had crashes both ways
>>
>>> On Sun, Jan 3, 2021 at 7:28 PM Robert A Wilson <fishnscout@...> wrote:
>>> While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
>>> Thanks,
>>> Robert, KN4CNU
>>>
>>>
>>
>>
>> --
>> Anthony Luscre
>>
>> K8ZT
>> Ohio Section Section Youth Coordinator & Education Outreach
>> ARRL - The National Association For Amateur Radio™
>>
>> k8zt@... (best for Amateur Radio)
>>
>> The Web Resource Hoarder- www.ZTLearn.com
>>
>> K8ZT Radio Website- www.k8zt.com
>>
>> Amateur Radio Resources for Students/Youth - www.k8zt.com/hry
>>
>>
>>
>
>
>
>
>
It would certainly help the developers if you could cut and paste the
error message so they see for themselves what is going wrong.

73
Roger
G#4HZA
moderator




JP Tucson, AZ <samcat88az@...>
 

Hi Robert,

For clarification - did you mean the wsjtx program windows closed, or MSWindows (the OS) shut down?

73 - John - N7GHZ


On Wed, Jan 6, 2021, 7:21 AM Robert A Wilson <fishnscout@...> wrote:
I can try to provide any error messages. Are they located in a log somewhere? When the application crashed, there was no visible  error message displayed. The windows just closed.
Thanks

On Wed, Jan 6, 2021 at 6:06 AM <groups@...> wrote:
On 04/01/2021 03:48, Stephen Malyszka wrote:
> I also experienced the same problem.  Spent a lot of contest time troubleshooting and many lost Q's. I had well over  a dozen crashes. Luckily I only had to reload WSJTx  and not reboot the computer. Had some crazy Error messages after reloading. It appeared to me that the problem is primarily in FT4 mode. One member from Our club (FRC) used the newer candidate version and didn't experience any problems.
>
> Now that we have all brought attention to this problem, what is the recommendation from the designers? I assume they are part this group. Was this problem known and a fix implemented in the New candidate version?
>
> Steve AG2J
>> On Jan 3, 2021, at 10:10 PM, Anthony Luscre <k8zt73@...> wrote:
>>
>> 
>> I had a similar situation here.
>> I tried it both through N1MM and as stand-alone and had crashes both ways
>>
>>> On Sun, Jan 3, 2021 at 7:28 PM Robert A Wilson <fishnscout@...> wrote:
>>> While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
>>> Thanks,
>>> Robert, KN4CNU
>>>
>>>
>>
>>
>> --
>> Anthony Luscre
>>
>> K8ZT
>> Ohio Section Section Youth Coordinator & Education Outreach
>> ARRL - The National Association For Amateur Radio™
>>
>> k8zt@... (best for Amateur Radio)
>>
>> The Web Resource Hoarder- www.ZTLearn.com
>>
>> K8ZT Radio Website- www.k8zt.com
>>
>> Amateur Radio Resources for Students/Youth - www.k8zt.com/hry
>>
>>
>>
>
>
>
>
>
It would certainly help the developers if you could cut and paste the
error message so they see for themselves what is going wrong.

73
Roger
G#4HZA
moderator







Robert A Wilson
 

The wsjt-x program closed. I did have to reboot one time, but I may have not been patient enough to see if it was working properly. That was early on. 

JTAlert starts WSJT-X. On some occasion someone would come back to me and the WSJT-X program would close. At that point, I closed JTAlert and started it again which cranked up WSJT-X.

Robert


On Wed, Jan 6, 2021 at 10:02 AM JP Tucson, AZ <samcat88az@...> wrote:
Hi Robert,

For clarification - did you mean the wsjtx program windows closed, or MSWindows (the OS) shut down?

73 - John - N7GHZ

On Wed, Jan 6, 2021, 7:21 AM Robert A Wilson <fishnscout@...> wrote:
I can try to provide any error messages. Are they located in a log somewhere? When the application crashed, there was no visible  error message displayed. The windows just closed.
Thanks

On Wed, Jan 6, 2021 at 6:06 AM <groups@...> wrote:
On 04/01/2021 03:48, Stephen Malyszka wrote:
> I also experienced the same problem.  Spent a lot of contest time troubleshooting and many lost Q's. I had well over  a dozen crashes. Luckily I only had to reload WSJTx  and not reboot the computer. Had some crazy Error messages after reloading. It appeared to me that the problem is primarily in FT4 mode. One member from Our club (FRC) used the newer candidate version and didn't experience any problems.
>
> Now that we have all brought attention to this problem, what is the recommendation from the designers? I assume they are part this group. Was this problem known and a fix implemented in the New candidate version?
>
> Steve AG2J
>> On Jan 3, 2021, at 10:10 PM, Anthony Luscre <k8zt73@...> wrote:
>>
>> 
>> I had a similar situation here.
>> I tried it both through N1MM and as stand-alone and had crashes both ways
>>
>>> On Sun, Jan 3, 2021 at 7:28 PM Robert A Wilson <fishnscout@...> wrote:
>>> While participating the the RTTY Roundup today, WSJT-X version 2.2.2 running on Windows version 10.0.19041.685 crashed 17 times. It happened every time on receive and most of the time when I'd clicked on a link when someone was calling CQ and they responded. Sometimes it would happen when a direct call was made and they responded. Usually restarting the program got things going again. At one point, a complete reboot was required. It hasn't crashed during regular usage. Something similar to this was happening during Field Day when using a different computer. Let me know if I can provide any additional information.
>>> Thanks,
>>> Robert, KN4CNU
>>>
>>>
>>
>>
>> --
>> Anthony Luscre
>>
>> K8ZT
>> Ohio Section Section Youth Coordinator & Education Outreach
>> ARRL - The National Association For Amateur Radio™
>>
>> k8zt@... (best for Amateur Radio)
>>
>> The Web Resource Hoarder- www.ZTLearn.com
>>
>> K8ZT Radio Website- www.k8zt.com
>>
>> Amateur Radio Resources for Students/Youth - www.k8zt.com/hry
>>
>>
>>
>
>
>
>
>
It would certainly help the developers if you could cut and paste the
error message so they see for themselves what is going wrong.

73
Roger
G#4HZA
moderator










Dave N3CKI
 

I also experienced several WSJTX (v2.2.2) crashes during the RTTY RU contest.  I was using FT4 via N1MM.  I had to reboot the PC each time.  Below are screenshots of the error messages I got in the order I got them.

I also had the problem where WSJTX would not log my sent exchange.  I had to manually enter it on all FT4 QSOS.

73, Dave N3CKI







Stephen Malyszka
 

I stated in a previous post that I had many crashes. I think most occurred while operating FT4. I was using N1MM and had crashes. I eliminated N1MM and went bare bones with just WSJT-x running and still had crashes. Never did I have to reboot my CPU. Reloading WSJT-x was sufficient to recover. Most of the crashes occurred when I double clicked in the message window to work a station or in the process of a QSO. But sometimes it would crash while the application was decoding doing nothing but watching the screen. When I say crash, WSJT-x would just vanish from the screen. There were different error messages after reload. I was able to write down one of them down:

Error Killing jt9.exe Process
KillByName return code:
602

Strange error message since I never used mode JT9. Hope this helps. Would like to hear from the developers if candidate version 2.3.0-rc3 fixes this problem. Please respond.

Thanks in advance.

Steve AG2J


Bill Somerville
 

On 07/01/2021 13:56, Stephen Malyszka wrote:
I stated in a previous post that I had many crashes. I think most occurred while operating FT4. I was using N1MM and had crashes. I eliminated N1MM and went bare bones with just WSJT-x running and still had crashes. Never did I have to reboot my CPU. Reloading WSJT-x was sufficient to recover. Most of the crashes occurred when I double clicked in the message window to work a station or in the process of a QSO. But sometimes it would crash while the application was decoding doing nothing but watching the screen. When I say crash, WSJT-x would just vanish from the screen. There were different error messages after reload. I was able to write down one of them down:

Error Killing jt9.exe Process
KillByName return code:
602

Strange error message since I never used mode JT9. Hope this helps. Would like to hear from the developers if candidate version 2.3.0-rc3 fixes this problem. Please respond.

Thanks in advance.

Steve AG2J
Hi Steve,

as has been reported and replied to here several times, selecting "Menu->Decode->Fast" should avoid this issue with crashes in FT4 mode using RTTY Round Up style contest exchanges.

73
Bill
G4WJS.


Stephen Malyszka
 

Thanks Bill but my question was for the candidate version. Is the problem fixed in that version or do I have to change the FT4 mode decode from Normal to Fast there as well???

Thanks,
Steve


Bill Somerville
 

On 07/01/2021 14:20, Stephen Malyszka wrote:
Thanks Bill but my question was for the candidate version. Is the problem fixed in that version or do I have to change the FT4 mode decode from Normal to Fast there as well???

Thanks,
Steve
Hi Steve,

as far as I know the issues are fixed in WSJT-X v2.3.0 RC3.

73
Bill
G4WJS.


JP Tucson, AZ <samcat88az@...>
 

Bill,

Sorry to say, it's not fixed in v2.3.0-rc2; that's what I was using for noth the FT RU & RTTY RU.

It worked mostly ok in Dec. with only 2 crashes, but some issues with not logging properly (sending good & existing info to the log box).
This past weekend's rtty ru  was a disaster!  Same setup, no updates, but multiple crashes & would't log a lot!  Only had aboutv2 dozen qso's in 2 hours - pathetic & frustrating, so I walked away!

It didn't matter if AP was on or off, decoding level, etc.

I still think the systemic problem we will continue to have with contesting is that we can only test it in a contest!!!

I  think  you guys (BECAUSE YOU HAVE THE BIG MIC TO GET THE WORD OUT...!)  should have psuedo-contests for 3 or 4 hours so that we can hammer away at the program under real contest conditions!  Say once a month or so.



73 - John - N7GHZ


On Thu, Jan 7, 2021, 7:22 AM Bill Somerville <g4wjs@...> wrote:
On 07/01/2021 14:20, Stephen Malyszka wrote:
> Thanks Bill but my question was for the candidate version. Is the
> problem fixed in that version or do I have to change the FT4 mode
> decode from Normal to Fast there as well???
>
> Thanks,
> Steve

Hi Steve,

as far as I know the issues are fixed in WSJT-X v2.3.0 RC3.

73
Bill
G4WJS.





Stephen Malyszka
 

Hi John,
Can you tell me what applications you were running with WSJT-X during crashes? Also what Decode Mode were you using? One of our Club members was in the contest using the N1MM combination along with WSJT-X and didn't have any crashes. However he did report some issues with logging that you mentioned. 

Steve


Kermit Lehman
 

I had one crash using v2.3.0-rc2 on FT8 in the ARRL RTTY.  Was using Deep and AP.  WSJT-X just stopped and closed. No error message on the monitor.

I turned AP OFF and had no more crashing problems after that.

No FT4 problems.

I did have problems with the log data fill-in.  Sometimes it didn't fill in the data and sometimes it carried over data from the previous QSO.

73,
Ken, AB1J


-----Original Message -----
From: JP Tucson, AZ <samcat88az@...>
To: main@wsjtx.groups.io
Sent: Thu, Jan 7, 2021 2:39 pm
Subject: Re: [WSJTX] WSTJ-X v2.2.2 Crashed During the RTTY Roundup

Bill,

Sorry to say, it's not fixed in v2.3.0-rc2; that's what I was using for noth the FT RU & RTTY RU.

It worked mostly ok in Dec. with only 2 crashes, but some issues with not logging properly (sending good & existing info to the log box).
This past weekend's rtty ru  was a disaster!  Same setup, no updates, but multiple crashes & would't log a lot!  Only had aboutv2 dozen qso's in 2 hours - pathetic & frustrating, so I walked away!

It didn't matter if AP was on or off, decoding level, etc.

I still think the systemic problem we will continue to have with contesting is that we can only test it in a contest!!!

I  think  you guys (BECAUSE YOU HAVE THE BIG MIC TO GET THE WORD OUT...!)  should have psuedo-contests for 3 or 4 hours so that we can hammer away at the program under real contest conditions!  Say once a month or so.



73 - John - N7GHZ

On Thu, Jan 7, 2021, 7:22 AM Bill Somerville <g4wjs@...> wrote:
On 07/01/2021 14:20, Stephen Malyszka wrote:
> Thanks Bill but my question was for the candidate version. Is the
> problem fixed in that version or do I have to change the FT4 mode
> decode from Normal to Fast there as well???
>
> Thanks,
> Steve

Hi Steve,

as far as I know the issues are fixed in WSJT-X v2.3.0 RC3.

73
Bill
G4WJS.







JP Tucson, AZ <samcat88az@...>
 

Hi Steve,

Simple answer... none!

The logging issues were all internal to wsjtx, not transferring the shown signal report & location to the log box.



73 - John - N7GHZ

On Thu, Jan 7, 2021, 8:10 AM Stephen Malyszka <s.malyszka.jr@...> wrote:
Hi John,
Can you tell me what applications you were running with WSJT-X during crashes? Also what Decode Mode were you using? One of our Club members was in the contest using the N1MM combination along with WSJT-X and didn't have any crashes. However he did report some issues with logging that you mentioned. 

Steve



JP Tucson, AZ <samcat88az@...>
 

I should add, I running only FT4 this past weekend.




73 - John - N7GHZ


On Thu, Jan 7, 2021, 7:39 AM JP Tucson, AZ <samcat88az@...> wrote:
Bill,

Sorry to say, it's not fixed in v2.3.0-rc2; that's what I was using for noth the FT RU & RTTY RU.

It worked mostly ok in Dec. with only 2 crashes, but some issues with not logging properly (sending good & existing info to the log box).
This past weekend's rtty ru  was a disaster!  Same setup, no updates, but multiple crashes & would't log a lot!  Only had aboutv2 dozen qso's in 2 hours - pathetic & frustrating, so I walked away!

It didn't matter if AP was on or off, decoding level, etc.

I still think the systemic problem we will continue to have with contesting is that we can only test it in a contest!!!

I  think  you guys (BECAUSE YOU HAVE THE BIG MIC TO GET THE WORD OUT...!)  should have psuedo-contests for 3 or 4 hours so that we can hammer away at the program under real contest conditions!  Say once a month or so.



73 - John - N7GHZ

On Thu, Jan 7, 2021, 7:22 AM Bill Somerville <g4wjs@...> wrote:
On 07/01/2021 14:20, Stephen Malyszka wrote:
> Thanks Bill but my question was for the candidate version. Is the
> problem fixed in that version or do I have to change the FT4 mode
> decode from Normal to Fast there as well???
>
> Thanks,
> Steve

Hi Steve,

as far as I know the issues are fixed in WSJT-X v2.3.0 RC3.

73
Bill
G4WJS.





Rory Bowers
 

I have observed a similar issue but only when switching from FT8 to FT4 in which FT4 will not decode.  If I shut down WSJT-X and restart it in FT4 mode it works perfectly.  I have no idea what is causing this.  I am running the 64 bit version on quad core machine with plenty of RAM.
73,
Rory, K5CKS