locked HDMI Monitor audio device power saving - was Re: [WSJTX] Annoyance!

Bill Somerville

On 02/01/2021 18:45, Floyd Sense wrote:
As more than one of you have suggested, two of my three monitors are indeed HDMI and I didn't give any thought to the fact that there were sound devices associated with them.  To test and verify this might be the cause of the problem, I started up JTDX, made sure the correct sound output was selected, and then powered down/up one of the monitors.  When the monitor came back up, JTDX was then connected to the wrong sound output path.  I then duplicated the test using WSJT-X.  So, indeed, it's the re-enumeration resulting from power off/on or sleep that's the source of the problem.  Since the two monitors currently connected via HDMI also have other connection types available, I think I'll opt for simply replacing the cable adaptors with something other than HDMI and that should allow me to continue to use the sleep function for the monitors and eliminate the problem.  My PC video card uses the mini DisplayPort connectors, so I need adapter cables anyway.

Thanks to all who suggested the HDMI possibility.  This correction will probably solve some other sound card related problems that I had previously blamed on Windows updates.

73, Floyd - K8AC
Hi Floyd,

I believe you can disable the audio devices associated with your HDMI connected monitors is you are not using that part of their functionality. If they are disabled then power saving options should not cause rearrangement of the Windows audio devices.