locked Confused, need help


David <dokrent@...>
 

I haven't used WSJT-X for a year. I hooked everything up as I have done before, same computer and other equipment, and used version 1.8. Rig control worked fine, waterfall showed signals, I can see the monitor button is on, and I see the decode button flash after reception, but nothing appears in the band activity window. Okay, decided I might as well update to 2.2 and loaded that one. Great news, band activity and decode is back, but no rig control. Both configurations are exactly the same. I can send PSK31 using Ham Radio Deluxe without a problem. Suggestions?  WIN10


Bill Somerville
 

On 05/10/2020 19:18, David wrote:
I haven't used WSJT-X for a year. I hooked everything up as I have done before, same computer and other equipment, and used version 1.8. Rig control worked fine, waterfall showed signals, I can see the monitor button is on, and I see the decode button flash after reception, but nothing appears in the band activity window. Okay, decided I might as well update to 2.2 and loaded that one. Great news, band activity and decode is back, but no rig control. Both configurations are exactly the same. I can send PSK31 using Ham Radio Deluxe without a problem. Suggestions?  WIN10
Hi David,

more than a Year I think ;)

I assume you are monitoring FT8 mode, WSJT-X v2 introduced a breaking change to the FT8 protocol which is why your older version refused to decode.

The latest versions of WSJT-X on Windows require a little extra one-time setup of Tx audio levels. Checkout this post for a recipe for doing that:

https://wsjtx.groups.io/g/main/topic/setting_windows_wsjt_x_tx/75435187?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,75435187

73
Bill
G4WJS.


Jim Bacher - WB8VSU
 

David, your version of wsjt is too old. Download and install the current version.

Jim Bacher, WB8VSU 
wb8vsu@... 
On Oct 5, 2020, at 4:38 PM, David <dokrent@...> wrote:

I haven't used WSJT-X for a year. I hooked everything up as I have done before, same computer and other equipment, and used version 1.8. Rig control worked fine, waterfall showed signals, I can see the monitor button is on, and I see the decode button flash after reception, but nothing appears in the band activity window. Okay, decided I might as well update to 2.2 and loaded that one. Great news, band activity and decode is back, but no rig control. Both configurations are exactly the same. I can send PSK31 using Ham Radio Deluxe without a problem. Suggestions?  WIN10




David <dokrent@...>
 

Thank you. Version 2 is deciding fine, just no rig control, while ver 1.8 has rig control, both have the same config parameters. I will see if adjusting the audio levels as you suggest gets v1.8 decoding again. But I still can’t figure out why v 2.2 lost CAT control. 


Jim Bacher - WB8VSU
 

David, adjusting levels won't help. Packets are not backwards compatible. Version 2.2 should be able to control your rig, just as the old one did.

Jim Bacher, WB8VSU 
wb8vsu@... 
On Oct 5, 2020, at 8:16 PM, David <dokrent@...> wrote:

Thank you. Version 2 is deciding fine, just no rig control, while ver 1.8 has rig control, both have the same config parameters. I will see if adjusting the audio levels as you suggest gets v1.8 decoding again. But I still can’t figure out why v 2.2 lost CAT control. 




David <dokrent@...>
 

I  understand ver 2.2 should control my rig, but it doesn't while 1.8 does. Ver 1.8 still controls my rig, but won't decode. 


David <dokrent@...>
 

I have installed ver2.2 and this one does decode, but won't control the rig. Version 1.8, still on the computer will control the rig. 


Jim Bacher - WB8VSU
 

David, Version 2.2 controls all old rigs that 1.8 did plus new ones. You just need to check rig settings in the new version settings. If you can't figure what needs changed, this list will need to know what rig you have any what you're settings are.



Jim Bacher, WB8VSU 
wb8vsu@... 
On Oct 5, 2020, at 9:01 PM, David <dokrent@...> wrote:

I have installed ver2.2 and this one does decode, but won't control the rig. Version 1.8, still on the computer will control the rig. 




W1EL Eric
 

OM,

 

What radio are you trying to control?

 

73, Eric (W1EL)

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of David
Sent: Monday, October 05, 2020 21:01
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Confused, need help

 

I have installed ver2.2 and this one does decode, but won't control the rig. Version 1.8, still on the computer will control the rig. 


David <dokrent@...>
 

FT-897D


David <dokrent@...>
 

The enclosed is an image of the config for the radio. Ver 2.2 config is the same as 1.8 and as I stated 1.8 does control the rig. The baud rate, bits, etc. match the Yaesu manual and my actual radio's settings. Thank you all for the help. 


W1EL Eric
 

David,

 

There’s a bug in the rig control routine for Yaesu in V2.2.

Try changing the Radio type to FT-857 and see if you regain control.

The latest version (V2.3, still in beta) has fixed it.

 

73 from eastern Maine, Eric   W1EL

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of David
Sent: Monday, October 05, 2020 21:24
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Confused, need help

 

FT-897D


David <dokrent@...>
 

I just saw that message when I searched for hamlib and tried it and it worked  I was just a few seconds ahead of your email. Thank you all for your patience and help.