locked Subprocess error


DAVID GRIFFITHS
 

I have finally got my transceiver and computer talking to one another and WSJTX seemed to be working alright. However, I got a number of errors.
" Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and 40).Process failed to start:The system cannot find the file specified."
What does this mean and how do I correct it?
Kind regards
David Griffiths G4PKV


Bill Somerville
 

On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
I have finally got my transceiver and computer talking to one another and WSJTX seemed to be working alright. However, I got a number of errors.
" Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and 40).Process failed to start:The system cannot find the file specified."
What does this mean and how do I correct it?
Kind regards
David Griffiths G4PKV
Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.


JP Tucson, AZ
 

Hi Bill,

About when is the new release due to fix the several bugs?



73 - John - N7GHZ


On Mon, Aug 31, 2020, 12:18 PM Bill Somerville <g4wjs@...> wrote:
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.



rturpen@...
 

I ran into this problem on mac, got around it by adding an empty bash script into the .app package.

in wsjtx.app , show contents, create new file in Contents/MacOS named user_hardware, chmod +x so it can execute. contents of new file on next line

#!/usr/bin/env bash

wsjtx will then execute it and get back a good return value, allowing the app to continue. for windows it would be a bat file doing nothing, on linux same as mac os, file locations differ on those platforms, haven’t had a chance to try it on those yet.

73
N0SSL

On Aug 31, 2020, at 12:18 PM, Bill Somerville <g4wjs@...> wrote:

On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
I have finally got my transceiver and computer talking to one another and WSJTX seemed to be working alright. However, I got a number of errors.
" Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and 40).Process failed to start:The system cannot find the file specified."
What does this mean and how do I correct it?
Kind regards
David Griffiths G4PKV
Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.


DAVID GRIFFITHS
 

Many thanks Bill. I have looked at the link you sent me. Which version should I use?. There are several listed.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 31 August 2020 20:18
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.


Bill Somerville
 

Hi David,

I don't understand your question, the link is to the installers for v2.1.2, that is the version I am recommending.

73
Bill
G4WJS.

On 01/09/2020 08:28, DAVID GRIFFITHS wrote:
Many thanks Bill. I have looked at the link you sent me. Which version should I use?. There are several listed.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 31 August 2020 20:18
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.



DAVID GRIFFITHS
 

Hi Bill
Sorry to be a bit obtuse but when I look at the site, I can see a number of folders but I can't see a download link for this version. I have done a search at the top rhs side of the page but I still can't see a download link for this version. I can see one for the latest version. I guess I must be looking in the wrong place. Can you point me in the right direction?
Kind regards
David


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 01 September 2020 10:21
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
Hi David,

I don't understand your question, the link is to the installers for v2.1.2, that is the version I am recommending.

73
Bill
G4WJS.

On 01/09/2020 08:28, DAVID GRIFFITHS wrote:
Many thanks Bill. I have looked at the link you sent me. Which version should I use?. There are several listed.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 31 August 2020 20:18
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.



Bill Somerville
 

David,

I don't know what else I can do to help you. The link I provided below is to the folder that contains the installers for the v2.1.2 version of WSJT-X, I will repeat it again here:


73
Bill
G4WJS.

On 01/09/2020 13:54, DAVID GRIFFITHS wrote:
Hi Bill
Sorry to be a bit obtuse but when I look at the site, I can see a number of folders but I can't see a download link for this version. I have done a search at the top rhs side of the page but I still can't see a download link for this version. I can see one for the latest version. I guess I must be looking in the wrong place. Can you point me in the right direction?
Kind regards
David

From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 01 September 2020 10:21
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
Hi David,

I don't understand your question, the link is to the installers for v2.1.2, that is the version I am recommending.

73
Bill
G4WJS.

On 01/09/2020 08:28, DAVID GRIFFITHS wrote:
Many thanks Bill. I have looked at the link you sent me. Which version should I use?. There are several listed.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 31 August 2020 20:18
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.



Alan G4ZFQ
 

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/
And, if you have, for example, 64 bit Windows then you select wsjtx-2.1.2-win64.exe

73 Alan G4ZFQ


Karza
 

David,

You need to download this file from the link given by Bill:
Click on that link and you will be redirectd to a page looking like this:

Then just wait a few seconds and the download will start.

73's de Kari, oh2gqc


On 1.9.2020 16.00, Bill Somerville wrote:
David,

I don't know what else I can do to help you. The link I provided below is to the folder that contains the installers for the v2.1.2 version of WSJT-X, I will repeat it again here:


73
Bill
G4WJS.

On 01/09/2020 13:54, DAVID GRIFFITHS wrote:
Hi Bill
Sorry to be a bit obtuse but when I look at the site, I can see a number of folders but I can't see a download link for this version. I have done a search at the top rhs side of the page but I still can't see a download link for this version. I can see one for the latest version. I guess I must be looking in the wrong place. Can you point me in the right direction?
Kind regards
David

From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 01 September 2020 10:21
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
Hi David,

I don't understand your question, the link is to the installers for v2.1.2, that is the version I am recommending.

73
Bill
G4WJS.

On 01/09/2020 08:28, DAVID GRIFFITHS wrote:
Many thanks Bill. I have looked at the link you sent me. Which version should I use?. There are several listed.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 31 August 2020 20:18
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.




    



DAVID GRIFFITHS
 

Many thanks Alan. Now I understand.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Alan G4ZFQ <alan4alan@...>
Sent: 01 September 2020 14:14
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
> https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

And, if you have, for example, 64 bit Windows then you select
wsjtx-2.1.2-win64.exe

73 Alan G4ZFQ


DAVID GRIFFITHS
 

Many thanks Karza. I think I have managed to download it. Thanks again.
Kind regards
David


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Karza <kari.sillanmaki@...>
Sent: 01 September 2020 14:20
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
David,

You need to download this file from the link given by Bill:
Click on that link and you will be redirectd to a page looking like this:

Then just wait a few seconds and the download will start.

73's de Kari, oh2gqc


On 1.9.2020 16.00, Bill Somerville wrote:
David,

I don't know what else I can do to help you. The link I provided below is to the folder that contains the installers for the v2.1.2 version of WSJT-X, I will repeat it again here:


73
Bill
G4WJS.

On 01/09/2020 13:54, DAVID GRIFFITHS wrote:
Hi Bill
Sorry to be a bit obtuse but when I look at the site, I can see a number of folders but I can't see a download link for this version. I have done a search at the top rhs side of the page but I still can't see a download link for this version. I can see one for the latest version. I guess I must be looking in the wrong place. Can you point me in the right direction?
Kind regards
David

From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 01 September 2020 10:21
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
Hi David,

I don't understand your question, the link is to the installers for v2.1.2, that is the version I am recommending.

73
Bill
G4WJS.

On 01/09/2020 08:28, DAVID GRIFFITHS wrote:
Many thanks Bill. I have looked at the link you sent me. Which version should I use?. There are several listed.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 31 August 2020 20:18
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.






Karza
 

Or if you are running 64 bit version of Windows, then
the correct file is this:

On 1.9.2020 16.20, Karza wrote:
David,

You need to download this file from the link given by Bill:
Click on that link and you will be redirectd to a page looking like this:

Then just wait a few seconds and the download will start.

73's de Kari, oh2gqc


On 1.9.2020 16.00, Bill Somerville wrote:
David,

I don't know what else I can do to help you. The link I provided below is to the folder that contains the installers for the v2.1.2 version of WSJT-X, I will repeat it again here:


73
Bill
G4WJS.

On 01/09/2020 13:54, DAVID GRIFFITHS wrote:
Hi Bill
Sorry to be a bit obtuse but when I look at the site, I can see a number of folders but I can't see a download link for this version. I have done a search at the top rhs side of the page but I still can't see a download link for this version. I can see one for the latest version. I guess I must be looking in the wrong place. Can you point me in the right direction?
Kind regards
David

From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 01 September 2020 10:21
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
Hi David,

I don't understand your question, the link is to the installers for v2.1.2, that is the version I am recommending.

73
Bill
G4WJS.

On 01/09/2020 08:28, DAVID GRIFFITHS wrote:
Many thanks Bill. I have looked at the link you sent me. Which version should I use?. There are several listed.
Kind regards
David Griffiths


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Bill Somerville <g4wjs@...>
Sent: 31 August 2020 20:18
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: Re: [WSJTX] Subprocess error #WSPR
 
On 31/08/2020 16:38, DAVID GRIFFITHS wrote:
> I have finally got my transceiver and computer talking to one another
> and WSJTX seemed to be working alright. However, I got a number of errors.
> " Running C:\WSJT\wsjtx\bin\user hardware 10 ( also 15,20 and
> 40).Process failed to start:The system cannot find the file specified."
> What does this mean and how do I correct it?
> Kind regards
> David Griffiths G4PKV

Hi David,

there is a known defect in WSJT-X v2.2.2 with WSPR band hopping mode. If
you need band hopping mode then I recommend you use WSJT-X v2.1.2.

https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/

73
Bill
G4WJS.