locked TX audio stops after an hour or so #AudioIssues


Bob
 

Been running WSJT-x v2.2.2 since its release.

Original setup was a K3s that had worked flawlessly in prior releases.  After installing 2.2.2, it would run normally for an hour or two, but at some point it would stop producing TX audio (it would go into TX, but not produce any TX power, nor could you hear anything on the monitor mode).

I changed to a FTDX101MP a week or so ago, and I have the exact same problem with it -- WSJT-X works fine for an hour or so then TX audio goes away.

Will try changing to a different computer next.

Wonder if anyone has seen this?

73, Bob, WB4SON


Bill Somerville
 

On 17/07/2020 00:41, Bob wrote:
Been running WSJT-x v2.2.2 since its release.

Original setup was a K3s that had worked flawlessly in prior releases.  After installing 2.2.2, it would run normally for an hour or two, but at some point it would stop producing TX audio (it would go into TX, but not produce any TX power, nor could you hear anything on the monitor mode).

I changed to a FTDX101MP a week or so ago, and I have the exact same problem with it -- WSJT-X works fine for an hour or so then TX audio goes away.

Will try changing to a different computer next.

Wonder if anyone has seen this?

73, Bob, WB4SON
Hi Bob,

I will assume you are running on MS Windows.

Make sure all the all the USB Hub power saving options have been disabled ("Device Manager->Universal Serial Bus controllers>*USB*Hub->Properties->Power Management" uncheck "Allow the computer to turn off this device to save power"). Make sure you have disable USB suspend in the system power plan ("Power Options->Change plan settings->Change advanced power settings->USB settings->USB selective suspend setting->Plugged in" change to Disabled).

73
Bill
G4WJS.


Russ Ravella
 

Hi Bill,

I’ve been following this post along and saw your suggestion regarding the following setting: 

"Power Options->Change plan settings->Change advanced power settings->USB settings->USB selective suspend setting->Plugged in" change to Disabled

I’ve seen this suggestion before, I’m on Win 10 2004 and the USB option isn’t there (anymore?).  I’m almost positive when I saw the suggestion before I was on the previous version (1909 I think) and it didn’t have a USB option either.  Are you running 2004 and ARE seeing this USB option ?  If so, can you think of anything I could have screwed up that’s causing it not to show in my system ?  I’d sure like to turn this off too !

Thanks,
Russ, KR6W


On Jul 16, 2020, at 5:21 PM, Bill Somerville <g4wjs@...> wrote:

On 17/07/2020 00:41, Bob wrote:
Been running WSJT-x v2.2.2 since its release.

Original setup was a K3s that had worked flawlessly in prior releases.  After installing 2.2.2, it would run normally for an hour or two, but at some point it would stop producing TX audio (it would go into TX, but not produce any TX power, nor could you hear anything on the monitor mode).

I changed to a FTDX101MP a week or so ago, and I have the exact same problem with it -- WSJT-X works fine for an hour or so then TX audio goes away.

Will try changing to a different computer next.

Wonder if anyone has seen this?

73, Bob, WB4SON

Hi Bob,

I will assume you are running on MS Windows.

Make sure all the all the USB Hub power saving options have been disabled ("Device Manager->Universal Serial Bus controllers>*USB*Hub->Properties->Power Management" uncheck "Allow the computer to turn off this device to save power"). Make sure you have disable USB suspend in the system power plan ("Power Options->Change plan settings->Change advanced power settings->USB settings->USB selective suspend setting->Plugged in" change to Disabled).

73
Bill
G4WJS.




Bill Somerville
 

Hi Russ,

I'm sorry, I don't have a Windows 10 system, so I can't help with locating the advanced power plan settings in the latest system settings. I am sure it is there somewhere, I stat by right-clicking the battery or power plug icon in the system tray, and proceed from there.

73
Bill
G4WJS.

On 17/07/2020 07:16, Russ Ravella via groups.io wrote:
Hi Bill,

I’ve been following this post along and saw your suggestion regarding the following setting: 

"Power Options->Change plan settings->Change advanced power settings->USB settings->USB selective suspend setting->Plugged in" change to Disabled

I’ve seen this suggestion before, I’m on Win 10 2004 and the USB option isn’t there (anymore?).  I’m almost positive when I saw the suggestion before I was on the previous version (1909 I think) and it didn’t have a USB option either.  Are you running 2004 and ARE seeing this USB option ?  If so, can you think of anything I could have screwed up that’s causing it not to show in my system ?  I’d sure like to turn this off too !

Thanks,
Russ, KR6W


On Jul 16, 2020, at 5:21 PM, Bill Somerville <g4wjs@...> wrote:

On 17/07/2020 00:41, Bob wrote:
Been running WSJT-x v2.2.2 since its release.

Original setup was a K3s that had worked flawlessly in prior releases.  After installing 2.2.2, it would run normally for an hour or two, but at some point it would stop producing TX audio (it would go into TX, but not produce any TX power, nor could you hear anything on the monitor mode).

I changed to a FTDX101MP a week or so ago, and I have the exact same problem with it -- WSJT-X works fine for an hour or so then TX audio goes away.

Will try changing to a different computer next.

Wonder if anyone has seen this?

73, Bob, WB4SON

Hi Bob,

I will assume you are running on MS Windows.

Make sure all the all the USB Hub power saving options have been disabled ("Device Manager->Universal Serial Bus controllers>*USB*Hub->Properties->Power Management" uncheck "Allow the computer to turn off this device to save power"). Make sure you have disable USB suspend in the system power plan ("Power Options->Change plan settings->Change advanced power settings->USB settings->USB selective suspend setting->Plugged in" change to Disabled).

73
Bill
G4WJS.



Jim Preston N6VH
 

I also have this problem. At times, I start a transmission and the rig keys, but no audio. Oddly enough, I can hear the audio, but it isn't coming from the rig's speaker via the monitior function. Nor is it coming from the computer speaker, which it shouldn't, of course. I have to go to the Audio tab in Settings, switch the audio to the computer soundcard and click OK. Then I go back and switch back to the external soundcard (XONAR U7), click OK, and everything is working again.

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

73,

Jim N6VH


Bob G8HGN
 

Hi,

I was troubled by this and did all the USB stuff to no avail.

It was cured by never allowing the monitor to go to sleep. Since I did this last year, I've not had it happen again.

YMMV but worth a try.

73

Bob G8HGN


On 17/07/2020 15:38, Jim Preston N6VH wrote:
I also have this problem. At times, I start a transmission and the rig keys, but no audio. Oddly enough, I can hear the audio, but it isn't coming from the rig's speaker via the monitior function. Nor is it coming from the computer speaker, which it shouldn't, of course. I have to go to the Audio tab in Settings, switch the audio to the computer soundcard and click OK. Then I go back and switch back to the external soundcard (XONAR U7), click OK, and everything is working again.

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

73,

Jim N6VH





    


Williams, G (af8c)
 

There's more information on USB event  tracing:

https://www.techsupportalert.com/content/how-fix-annoying-windows-usb-problem.htm

https://docs.microsoft.com/en-us/windows-hardware/drivers/usbcon/usb-selective-suspend

https://docs.microsoft.com/en-us/windows-hardware/drivers/usbcon/usb-event-tracing-for-windows

--73, Glenn, AFC


On 7/17/2020 10:57 AM, Bob G8HGN via groups.io wrote:

Hi,

I was troubled by this and did all the USB stuff to no avail.

It was cured by never allowing the monitor to go to sleep. Since I did this last year, I've not had it happen again.

YMMV but worth a try.

73

Bob G8HGN


On 17/07/2020 15:38, Jim Preston N6VH wrote:
I also have this problem. At times, I start a transmission and the rig keys, but no audio. Oddly enough, I can hear the audio, but it isn't coming from the rig's speaker via the monitior function. Nor is it coming from the computer speaker, which it shouldn't, of course. I have to go to the Audio tab in Settings, switch the audio to the computer soundcard and click OK. Then I go back and switch back to the external soundcard (XONAR U7), click OK, and everything is working again.

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

73,

Jim N6VH






    




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



Bill Somerville
 

Hi Bob,

this is a known issue with HDMI connected monitors. HDMI carries USB audio and some graphics cards don't seem to have an option to stop the system USB audio devices being rearranged when the monitor is put to sleep to save power.

73
Bill
G4WJS.

On 17/07/2020 15:57, Bob G8HGN wrote:

Hi,

I was troubled by this and did all the USB stuff to no avail.

It was cured by never allowing the monitor to go to sleep. Since I did this last year, I've not had it happen again.

YMMV but worth a try.

73

Bob G8HGN


On 17/07/2020 15:38, Jim Preston N6VH wrote:
I also have this problem. At times, I start a transmission and the rig keys, but no audio. Oddly enough, I can hear the audio, but it isn't coming from the rig's speaker via the monitior function. Nor is it coming from the computer speaker, which it shouldn't, of course. I have to go to the Audio tab in Settings, switch the audio to the computer soundcard and click OK. Then I go back and switch back to the external soundcard (XONAR U7), click OK, and everything is working again.

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

73,

Jim N6VH


Bob G8HGN
 

Hi Bill,

Yes, I think we went through all this last year and this was my last resort. But it worked!

I just posted to let people try it and see if it worked for them. There's always someone who's new and not seen the prevoius long list of solutions to problems.

73

Bob G8HGN

On 17/07/2020 17:21, Bill Somerville wrote:
Hi Bob,

this is a known issue with HDMI connected monitors. HDMI carries USB audio and some graphics cards don't seem to have an option to stop the system USB audio devices being rearranged when the monitor is put to sleep to save power.

73
Bill
G4WJS.

On 17/07/2020 15:57, Bob G8HGN wrote:

Hi,

I was troubled by this and did all the USB stuff to no avail.

It was cured by never allowing the monitor to go to sleep. Since I did this last year, I've not had it happen again.

YMMV but worth a try.

73

Bob G8HGN


On 17/07/2020 15:38, Jim Preston N6VH wrote:
I also have this problem. At times, I start a transmission and the rig keys, but no audio. Oddly enough, I can hear the audio, but it isn't coming from the rig's speaker via the monitior function. Nor is it coming from the computer speaker, which it shouldn't, of course. I have to go to the Audio tab in Settings, switch the audio to the computer soundcard and click OK. Then I go back and switch back to the external soundcard (XONAR U7), click OK, and everything is working again.

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

73,

Jim N6VH




    


Herb Blue - WB8ASI
 

My USB setting was also missing in Win10.  Googled and found this.....https://answers.microsoft.com/en-us/windows/forum/all/usb-settings-in-power-plan-options-on-windows-10/38753b89-65d0-49c1-8f91-2bb50f9b19a0
I was successful using Method 2.  My "Attributes" file was already there so I didn't need to create a new one.  I just changed the setting from 0 to 2, and presto the USB selection appears and I was able to disable it.   Herb WB8ASI


Gary - AG0N
 

On Jul 17, 2020, at 08:38, Jim Preston N6VH <N6VH@...> wrote:

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.
I’ve long had this problem on rare occasion, but it does happen. When it happens, it seems like a timing issue. To make it work, I just hit HALT and immediately follow with the button next to it (Enable TX?). I can’t see it right now because I’m not home. In other words, stop the transmission and re-enable it again. If you’re fast, you’ll get enough sent that it will decode on the other end. With me, this is always the first transmission for that QSO and seems to occur when I choose to call someone right before the cycle starts.

Maybe this will work for you. Give it a try. I’ve never really considered it a problem, just a timing issue.

Gary - AG0N


JP Tucson, AZ
 

Try reverting to v2.1.2 & see if the problem goes away.

V2.2.2 kept crashing on field day, and I don't know if it is related, but again, we know v2.1.2 worked.



73 - John - N7GHZ


On Fri, Jul 17, 2020, 11:14 AM Gary - AG0N <mcduffie@...> wrote:


> On Jul 17, 2020, at 08:38, Jim Preston N6VH <N6VH@...> wrote:
>
> I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

I’ve long had this problem on rare occasion, but it does happen.  When it happens, it seems like a timing issue.  To make it work, I just hit HALT and immediately follow with the button next to it (Enable TX?).  I can’t see it right now because I’m  not home.  In other words, stop the transmission and re-enable it again.  If you’re fast, you’ll get enough sent that it will decode on the other end.  With me, this is always the first transmission for that QSO and seems to occur when I choose to call someone right before the cycle starts.

Maybe this will work for you.  Give it a try.  I’ve never really considered it a problem, just a timing issue.

Gary - AG0N


Geoff - W8GNM
 

Yes, this issue has been discussed in several previous posts including the one below:

https://wsjtx.groups.io/g/main/message/12515?p=,,,20,0,0,0::relevance,,w8gnm,20,2,0,74687970

Disabling all of the USB sleep functions in device manager and in the power configuration as previously recommended, still did not fix this problem using a non-USB, DAX, digital audio connection from WSJT-x 2.2.2 to a Flex 6600M.   Setting the power configuration to never allow my HDMI monitor to go to sleep in addition to all the USB disabling stuff seems to have fixed the problem for me.   I think Bill is correct that the ability of the HDMI audio/video interface to interact with the rest of the system is part of the problem.  73, Geoff - W8GNM


Jim Preston N6VH
 

Bob,

Thanks for the tip. I'll give it a try and see if it helps. Of course, since it only happens occasionally, It might be a while before I will be able to tell. Incidentally, I'm definitely not new, but the previous comments from last year might have been before I was having this problem, and I didn't remember the comments. At my age I'm allowed to be a little forgetful. :-)  Before I got a new computer, I wasn't using HDMI, so that might be why I wasn't experiencing this situation.

73,

Jim N6VH

On 7/17/2020 7:57 AM, Bob G8HGN wrote:

Hi,

I was troubled by this and did all the USB stuff to no avail.

It was cured by never allowing the monitor to go to sleep. Since I did this last year, I've not had it happen again.

YMMV but worth a try.

73

Bob G8HGN


On 17/07/2020 15:38, Jim Preston N6VH wrote:
I also have this problem. At times, I start a transmission and the rig keys, but no audio. Oddly enough, I can hear the audio, but it isn't coming from the rig's speaker via the monitior function. Nor is it coming from the computer speaker, which it shouldn't, of course. I have to go to the Audio tab in Settings, switch the audio to the computer soundcard and click OK. Then I go back and switch back to the external soundcard (XONAR U7), click OK, and everything is working again.

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

73,

Jim N6VH






    


HB9BRJ
 

Same issue here: TX audio starts several seconds after the TRX goes to TX. Next TX slot is ok again.

In Win10 Pro 2004, this is the path to the setting described earlier in this thread:

Start | Settings | System | Power & sleep |  Additional power settings |
Change plan settings (of the selected plan) | Change advanced power settings |
USB settings | USB selective suspend setting.

Default is enabled. Just changed it to disabled. Hopefully this will solve the problem.

73, Markus HB9BRJ


Jim Preston N6VH
 

Bill,

I set the monitor to never sleep, and still have this problem. I have the USB ports set to never sleep, and USB selective suspend disabled, as I said. The only thing that helps is, in WSJT-X audio setting, switching to speakers, and then back to Headphones (Xonar U7). This is not set to be the default communication device presently, however the situation was the same when it was set as the default communication device.

73,

Jim N6VH

On 7/17/2020 9:21 AM, Bill Somerville wrote:
Hi Bob,

this is a known issue with HDMI connected monitors. HDMI carries USB audio and some graphics cards don't seem to have an option to stop the system USB audio devices being rearranged when the monitor is put to sleep to save power.

73
Bill
G4WJS.

On 17/07/2020 15:57, Bob G8HGN wrote:

Hi,

I was troubled by this and did all the USB stuff to no avail.

It was cured by never allowing the monitor to go to sleep. Since I did this last year, I've not had it happen again.

YMMV but worth a try.

73

Bob G8HGN


On 17/07/2020 15:38, Jim Preston N6VH wrote:
I also have this problem. At times, I start a transmission and the rig keys, but no audio. Oddly enough, I can hear the audio, but it isn't coming from the rig's speaker via the monitior function. Nor is it coming from the computer speaker, which it shouldn't, of course. I have to go to the Audio tab in Settings, switch the audio to the computer soundcard and click OK. Then I go back and switch back to the external soundcard (XONAR U7), click OK, and everything is working again.

I have followed Bill's instructions for USB ports not going to sleep and the USB selective suspend set to disabled. They were already set that way, incidentally. This isn't an issue with RFI either, since it can happen before I have made any transmissions.

73,

Jim N6VH




    


David Burden
 

Jim,

I have the same issue. I stop and restart WSJTX and problem is fixed. So it is a real issue, affect a few people and something to do with the audio drivers or sound card. I operate on a new Dell in windows 10 - but the same problem occurs on my Acer laptop also runnings Windows 10. I can instantly tell the problem has recurred, as i hear the TX output in my speakers rather than "nothing" as I usually hear. 

73 David VK3BDX


Alan G4ZFQ
 

I can instantly tell the problem has recurred, as i hear the TX output in my speakers rather than "nothing" as I usually hear.
David,

This seems like maybe a USB issue?
Something temporally causes the sound devices to re-enumerate.
A dodgy cable/connector?

73 Alan G4ZFQ


JP Tucson, AZ
 

Nope..
 
This issue has a definite trend to it, as multiple hams are reporting this "quits after an hour" thing!

It's not a cable or hardware issue.

It's either an operating system / configuration problem (like a power saving thing) (and quite likely a windows update issue again...) or it's an issue with the wsjt-x update(s); which seems more likely as it didn't seem to become an issue until about a month or so  ago.  



73 - John - N7GHZ


On Wed, Jul 22, 2020, 12:18 AM Alan G4ZFQ <alan4alan@...> wrote:
> I
> can instantly tell the problem has recurred, as i hear the TX output in
> my speakers rather than "nothing" as I usually hear.

David,

This seems like maybe a USB issue?
Something temporally causes the sound devices to re-enumerate.
A dodgy cable/connector?

73 Alan G4ZFQ


Tom V. Segalstad
 

 

Dear OM John, N7GHZ

 

So why is it, that my WSJT-X Version 2.2.2 has been on constantly (day + night) since the day that version was released and installed on my ASUSTech Laptop PC with Windows 10 (Version 1903) – with daily use on HF and VHF on my Icom IC-7300 and Icom IC-756PRO3 + PA – without any stop or problem at all?

 

I’m beginning to wonder: Is my error-free installation and use of WSJT-X Version 2.2.2 an anomaly?

 

73 from Tom, LA4LN

 

 

Sent from E-mail for Windows 10

 

Fra: JP Tucson, AZ
Sendt: onsdag 22. juli 2020 kl. 11.30
Til: main@WSJTX.groups.io
Emne: Re: [WSJTX] TX audio stops after an hour or so #audio_issues #audio_issues

 

Nope..

 

This issue has a definite trend to it, as multiple hams are reporting this "quits after an hour" thing!

 

It's not a cable or hardware issue.

 

It's either an operating system / configuration problem (like a power saving thing) (and quite likely a windows update issue again...) or it's an issue with the wsjt-x update(s); which seems more likely as it didn't seem to become an issue until about a month or so  ago.  

 

 

73 - John - N7GHZ

 

On Wed, Jul 22, 2020, 12:18 AM Alan G4ZFQ <alan4alan@...> wrote:

> I
> can instantly tell the problem has recurred, as i hear the TX output in
> my speakers rather than "nothing" as I usually hear.

David,

This seems like maybe a USB issue?
Something temporally causes the sound devices to re-enumerate.
A dodgy cable/connector?

73 Alan G4ZFQ

 


--
Tom (LA4LN)