locked #audio_issues #microphone #AudioIssues


Gregory Reichenbach
 

After updating Windows yesterday, my laptop's microphone picks up ambient audio from the room and WSJT-X hears it, mixes it with the radio's received audio, and it shows up in the waterfall and interferes with decoding.  Can't figure out how to make the laptop microphone stop without turning off the audio from the radio too.  Must be a windows setting, but can't find it.  Help please.


Greg Reichenbach
Stony Ridge OH
W8GSR


Bill Somerville
 

On 21/06/2020 14:59, Gregory Reichenbach wrote:
After updating Windows yesterday, my laptop's microphone picks up ambient audio from the room and WSJT-X hears it, mixes it with the radio's received audio, and it shows up in the waterfall and interferes with decoding.  Can't figure out how to make the laptop microphone stop without turning off the audio from the radio too.  Must be a windows setting, but can't find it.  Help please.


Greg Reichenbach
Stony Ridge OH
W8GSR

Hi Greg,

WSJT-X has probably reverted to using the default audio devices because the Windows update scrambled the audio device names. Try going to "Settings->Audio" and set the correct audio devices for the rig.

73
Bill
G4WJS.


Gregory Reichenbach
 
Edited

Bill, thanks very much for the reply.  Unfortunately, that's not the problem.  I have only one device each on the laptop for mic and speakers.  Just in case, I tried changing the selection to "default" then back to the specific audio devices, but that made no difference.  I suspect there's a windows setting somewhere that is allowing access to the mic.

I have tried switching off "allow apps to access your microphone" and "allow desktop apps to access your microphone" but either of those prevents wsjt-x from receiving the rig audio. I have switched off mic access from all the "microsoft store apps." Here is a screenshot of the "desktop apps" that have access to my mic. My best guess is that maybe the "scripted diagnostics native host" is the problem?


Bill Somerville
 

On 21/06/2020 15:46, Gregory Reichenbach wrote:
Bill, thanks very much for the reply.  Unfortunately, that's not the problem.  I have only one device each on the laptop for mic and speakers. Just in case, I tried changing the selection to "default" then back to the specific audio devices, but that made no difference. I suspect there's a windows setting somewhere that is allowing access to the mic.
Greg,

the built in mic should be disabled when you plug in something to the line in, or combined line in/mic socket. If your mic is live then I would check that the plug is correctly inserted.

73
Bill
G4WJS.


Lars Berg
 

Stay away from the 2004 update . See

https://answers.microsoft.com/en-us/insider/forum/all/windows-10-version-2004-audio-bug-latest/

 

73 de Lars SM3CCM

 

Skickades från E-post för Windows 10

 

Från: Bill Somerville
Skickat: den 21 juni 2020 16:50
Till: main@WSJTX.groups.io
Ämne: Re: [WSJTX] #audio_issues #microphone

 

On 21/06/2020 15:46, Gregory Reichenbach wrote:
> Bill, thanks very much for the reply.  Unfortunately, that's not the
> problem.  I have only one device each on the laptop for mic and
> speakers. Just in case, I tried changing the selection to "default"
> then back to the specific audio devices, but that made no difference.
> I suspect there's a windows setting somewhere that is allowing access
> to the mic.

Greg,

the built in mic should be disabled when you plug in something to the
line in, or combined line in/mic socket. If your mic is live then I
would check that the plug is correctly inserted.

73
Bill
G4WJS.

 


ve3ki
 

In the Windows Sound Control Panel applet "Properties" settings for the microphone input, there may be a check box called "Listen to this device". If that check box is checked, input from that device will be echoed directly to the specified output device. In your situation, you don't want your microphone echoed to your speaker output, so that check box should be unchecked.

If the Windows Sound Control Panel applet shows separate input devices for microphone and line in (for example, if you have separate jacks for each input), you may be able to mute the microphone input without affecting the line input.

73,
Rich VE3KI


On Sun, Jun 21, 2020 at 10:50 AM, Bill Somerville wrote:
On 21/06/2020 15:46, Gregory Reichenbach wrote:
Bill, thanks very much for the reply.  Unfortunately, that's not the
problem.  I have only one device each on the laptop for mic and
speakers. Just in case, I tried changing the selection to "default"
then back to the specific audio devices, but that made no difference.
I suspect there's a windows setting somewhere that is allowing access
to the mic.
Greg,

the built in mic should be disabled when you plug in something to the
line in, or combined line in/mic socket. If your mic is live then I
would check that the plug is correctly inserted.

73
Bill
G4WJS.


Ian Kahn
 

You might need to go into Device Manager and completely disable the mic at the hardware level. That, of course, would disable it for all future use, until you re-enable it.

73 de,

Oan, MV4C

On Sun, Jun 21, 2020, 10:11 AM Gregory Reichenbach <gsreichenbach@...> wrote:
After updating Windows yesterday, my laptop's microphone picks up ambient audio from the room and WSJT-X hears it, mixes it with the radio's received audio, and it shows up in the waterfall and interferes with decoding.  Can't figure out how to make the laptop microphone stop without turning off the audio from the radio too.  Must be a windows setting, but can't find it.  Help please.


Greg Reichenbach
Stony Ridge OH
W8GSR


Reino Talarmo
 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Lars Berg
Sent: 21. kesäkuuta 2020 17:59
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] #audio_issues #microphone

 

Stay away from the 2004 update . See

https://answers.microsoft.com/en-us/insider/forum/all/windows-10-version-2004-audio-bug-latest/

 

73 de Lars SM3CCM

 

Skickades från E-post för Windows 10

 

Från: Bill Somerville
Skickat: den 21 juni 2020 16:50
Till: main@WSJTX.groups.io
Ämne: Re: [WSJTX] #audio_issues #microphone

 

On 21/06/2020 15:46, Gregory Reichenbach wrote:
> Bill, thanks very much for the reply.  Unfortunately, that's not the
> problem.  I have only one device each on the laptop for mic and
> speakers. Just in case, I tried changing the selection to "default"
> then back to the specific audio devices, but that made no difference.
> I suspect there's a windows setting somewhere that is allowing access
> to the mic.

Greg,

the built in mic should be disabled when you plug in something to the
line in, or combined line in/mic socket. If your mic is live then I
would check that the plug is correctly inserted.

73
Bill
G4WJS.

 


Istvan Nyul
 

The link returns a “Page Not Found” on the MS webpage.

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of Lars Berg
Sent: Sunday, June 21, 2020 10:59
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] #audio_issues #microphone

 

Stay away from the 2004 update . See

https://answers.microsoft.com/en-us/insider/forum/all/windows-10-version-2004-audio-bug-latest/

 

73 de Lars SM3CCM

 

Skickades från E-post för Windows 10

 

Från: Bill Somerville
Skickat: den 21 juni 2020 16:50
Till:
main@WSJTX.groups.io
Ämne: Re: [WSJTX] #audio_issues #microphone

 

On 21/06/2020 15:46, Gregory Reichenbach wrote:
> Bill, thanks very much for the reply.  Unfortunately, that's not the
> problem.  I have only one device each on the laptop for mic and
> speakers. Just in case, I tried changing the selection to "default"
> then back to the specific audio devices, but that made no difference.
> I suspect there's a windows setting somewhere that is allowing access
> to the mic.

Greg,

the built in mic should be disabled when you plug in something to the
line in, or combined line in/mic socket. If your mic is live then I
would check that the plug is correctly inserted.

73
Bill
G4WJS.

 


Gregory Reichenbach
 

VE3KI: I tried that; didn't work.  There's only one "device" - no separate settings for line in or mic.

Ian: I tried that too.  Strangely, disabling the mic from device manager doesn't seem to have any effect on anything.  Windows says the mic is disabled, but WSJT-X still receives audio from the rig AND from the laptop mic.

Unless someone has something else, I think I'll try undoing the 2004 update, and then just not updating windows for a while, hoping Micro$oft straightens it out.

Thanks all,
73

Greg Reichenbach
Stony Ridge OH
W8GSR


On Sun, Jun 21, 2020 at 11:08 AM Ian Kahn <nv4c.ian@...> wrote:
You might need to go into Device Manager and completely disable the mic at the hardware level. That, of course, would disable it for all future use, until you re-enable it.

73 de,

Oan, MV4C

On Sun, Jun 21, 2020, 10:11 AM Gregory Reichenbach <gsreichenbach@...> wrote:
After updating Windows yesterday, my laptop's microphone picks up ambient audio from the room and WSJT-X hears it, mixes it with the radio's received audio, and it shows up in the waterfall and interferes with decoding.  Can't figure out how to make the laptop microphone stop without turning off the audio from the radio too.  Must be a windows setting, but can't find it.  Help please.


Greg Reichenbach
Stony Ridge OH
W8GSR



Gregory Reichenbach
 

Bill: Agreed that "the built in mic should be disabled when you plug in something to the line in, or combined line in/mic socket. If your mic is live then I would check that the plug is correctly inserted."  Tried that previously; didn't work.

HOWEVER, your comment led me to testing the audio gain on the rig.  And... it turns out WSJT-X is not getting the audio signal from the cable, but from audio coupling, despite the fact that the cable is plugged in all the way.  So I think either windows or WSJT-X is not recognizing the audio from the cable at all.  Further suggestions?


Bill Somerville
 

On 21/06/2020 16:43, Gregory Reichenbach wrote:
Bill: Agreed that "the built in mic should be disabled when you plug in something to the line in, or combined line in/mic socket. If your mic is live then I would check that the plug is correctly inserted."  Tried that previously; didn't work.

HOWEVER, your comment led me to testing the audio gain on the rig.  And... it turns out WSJT-X is not getting the audio signal from the cable, but from audio coupling, despite the fact that the cable is plugged in all the way.  So I think either windows or WSJT-X is not recognizing the audio from the cable at all. Further suggestions?
Hi Greg,

I suspected that you were only getting Rx audio via the built in mic. You still could have a hardware issue with the line-in/mic socket, but given the coincidence with a Windows Update there has to be some suspicion it is an operating system issue. Are you on the Fast Ring windows update schedule? If not then you should contact Microsoft Support and ask why your Line-in/mic socket has stopped working after a general Windows 10 update.

73
Bill
G4WJS.


Lars Berg
 

Sorry for the broken link. Reino’s link is OK.

It seems that Microsoft has been aware of the audio bug since April. In spite of that they made a general release, including the bug, of 2004. Shame…

73 Lars SM3CCM

Skickades från E-post för Windows 10

 

Från: Reino Talarmo
Skickat: den 21 juni 2020 17:32
Till: main@WSJTX.groups.io
Ämne: Re: [WSJTX] #audio_issues #microphone

 

The link was broken, at least for me. I found it as:

https://answers.microsoft.com/en-us/insider/forum/all/windows-10-version-2004-audio-bug-latest/5f1e54bf-2031-478d-a903-6cd3037236f3

 

73, Reino OH3mA

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Lars Berg
Sent: 21. kesäkuuta 2020 17:59
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] #audio_issues #microphone

 

Stay away from the 2004 update . See

https://answers.microsoft.com/en-us/insider/forum/all/windows-10-version-2004-audio-bug-latest/

 

73 de Lars SM3CCM

 

Skickades från E-post för Windows 10

 

Från: Bill Somerville
Skickat: den 21 juni 2020 16:50
Till: main@WSJTX.groups.io
Ämne: Re: [WSJTX] #audio_issues #microphone

 

On 21/06/2020 15:46, Gregory Reichenbach wrote:
> Bill, thanks very much for the reply.  Unfortunately, that's not the
> problem.  I have only one device each on the laptop for mic and
> speakers. Just in case, I tried changing the selection to "default"
> then back to the specific audio devices, but that made no difference.
> I suspect there's a windows setting somewhere that is allowing access
> to the mic.

Greg,

the built in mic should be disabled when you plug in something to the
line in, or combined line in/mic socket. If your mic is live then I
would check that the plug is correctly inserted.

73
Bill
G4WJS.

 

 


Gregory Reichenbach
 

Here's the solution I eventually found, which worked:

In HD Audio Manager, click on "connector settings" (the folder icon at the upper right)
Check the box marked "enable auto popup dialog, when device has been plugged inf"
Unplug the "headset jack" (connected to the rig), then plug back in
The dialog pops up, asking "which device did you plug in?"
Check the box marked "headset"

Thanks again everyone
Greg W8GSR