locked wsjt-x and fkex 6700 transmit issues


Don - kx9q
 

I have recently noticed that if I walk away from the radio with wsjt-x active and I come back about an hour later I can no longer transmit - FT8 or FT4.  The radio goes into transmit mode but no output. If I stop and restart wsjt-x I then get output when I go into transmit mode.  I am running the latest version of wsjt-x.  The setting in wsjt-x is the following: radio - Kenwood TS-2000.  It seems like something is shutting down in the software over a period of inactivity.  Any suggestions?

Don - kx9q


Pat Patterson
 

Don, I also have a Flex 6700 that I use with WSJT-X.  I use the native Flex 6000 radio type. The Kenwood emulation hasn't been needed for a long time.  Examples of that config can be found on the Flex Community.  If needed I can forward it to you. During the 6M Es season I have the Flex and WSJT-X going 24/7.  There is still a bug with DAX.  It should be stopped and restarted about once a day to prevent a condition that causes a distorted transmit signal. 

73,
Pat, W5VY 


On Wed, Jun 17, 2020, 11:56 PM Don - kx9q <don@...> wrote:
I have recently noticed that if I walk away from the radio with wsjt-x active and I come back about an hour later I can no longer transmit - FT8 or FT4.  The radio goes into transmit mode but no output. If I stop and restart wsjt-x I then get output when I go into transmit mode.  I am running the latest version of wsjt-x.  The setting in wsjt-x is the following: radio - Kenwood TS-2000.  It seems like something is shutting down in the software over a period of inactivity.  Any suggestions?

Don - kx9q


Bill Somerville
 

On 18/06/2020 02:43, Don - kx9q wrote:
I have recently noticed that if I walk away from the radio with wsjt-x active and I come back about an hour later I can no longer transmit - FT8 or FT4.  The radio goes into transmit mode but no output. If I stop and restart wsjt-x I then get output when I go into transmit mode.  I am running the latest version of wsjt-x.  The setting in wsjt-x is the following: radio - Kenwood TS-2000.  It seems like something is shutting down in the software over a period of inactivity.  Any suggestions?

Don - kx9q
Hi Don,

as far as we know this is either a Windows issue or a problem with the Flex DAX audio multiplexer. Make sure you have disabled all power saving options in Windows that might effect any USB devices. Even though your rig's interaction with WSJT-X may not be directly using USB  connections, their re-enumeration when being shut down to save power could cause all audio devices to be renumbered, WSJT-X does not get any notification when that happens.

Note that HDMI monitors involve USB so if they power down that could cause this issue too.

73
Bill
G4WJS.


gmendenh1947
 

I am having the same problem with a Flex 6600M using an IP connection from the computer to the radio via the DAX, so it is not a USB port timeout.
I don't know what other timeout to look for.   The Rx audio via DAX is fine an never times out.
Here is my post under another topic: 

Problem: WSJT-x Tx audio disconnects from Flex DAX after sitting idle

Current software configuration: WSJT-x v 2.2.0, Flex DAX v 2.6.2.50, Windows 10 Pro v 1909.
FlexRadio 6600M transceiver running v 2.6.2.50 software.

After WSJT-x in FT8 mode sits in a receive/monitor condition for several hours, the Tx audio connection via Flex DAX to the Flex 6600M transceiver is lost.
DAX is still connected to the radio, but the connection from WSJT-x is broken.
The Rx audio connection from the Flex 6600M via DAX remains working OK.

This problem with the loss of Tx audio has existed over the past several versions of WSJT-x and DAX.
Several other FlexRadio users are having exactly the same problem using Flex 6700 radios.

The problem can be fixed by shutting down WSJT-x and restarting it which causes the current activity window to be lost which is inconvenient
or without restarting WSJT-x by going to the WSJT-x FILE/SETTINGS/AUDIO/OUTPUT menu and changing from the "DAX AUDIO TX" selection to another selection and clicking OK, then going back through the FILE/SETTINGS/AUDIO/OUTPUT menu and changing back to "DAX AUDIO TX" selection and then clicking OK.


Pat Patterson
 

Now that 6M as started closing at times I’ve also noticed the issue of the Flex 6700 DAX TX connection to WSJT-X closing after long intervals of no activity….no user input.  I confirm that either restarting WJST-X restores the DAX TX connection or going into WJST-X Setting -> Audio and choose another “Output” selection and click OK.  Then choose DAX Audio TX  and clicking OK will also restore the connection.  I didn’t see this behavior with any of the 2.0 RC versions.  I installed 2.2.1 right before the VHF Contest but was busy building/operating my Rover and didn’t spot the issue with the Flex.  I just checked after about six hours of inactivity and TX audio was still connected.  Flex 6700 on SSDR 3.1.2, WJST-X v2.2.1 on Windows 10 Pro Version 2004(upgrade installed 6/11/2020).

 

Pat, W5VY

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of gmendenh1947
Sent: Thursday, June 18, 2020 9:27 PM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] wsjt-x and fkex 6700 transmit issues

 

I am having the same problem with a Flex 6600M using an IP connection from the computer to the radio via the DAX, so it is not a USB port timeout.
I don't know what other timeout to look for.   The Rx audio via DAX is fine an never times out.
Here is my post under another topic: 

Problem: WSJT-x Tx audio disconnects from Flex DAX after sitting idle

Current software configuration: WSJT-x v 2.2.0, Flex DAX v 2.6.2.50, Windows 10 Pro v 1909.
FlexRadio 6600M transceiver running v 2.6.2.50 software.

After WSJT-x in FT8 mode sits in a receive/monitor condition for several hours, the Tx audio connection via Flex DAX to the Flex 6600M transceiver is lost.
DAX is still connected to the radio, but the connection from WSJT-x is broken.
The Rx audio connection from the Flex 6600M via DAX remains working OK.

This problem with the loss of Tx audio has existed over the past several versions of WSJT-x and DAX.
Several other FlexRadio users are having exactly the same problem using Flex 6700 radios.

The problem can be fixed by shutting down WSJT-x and restarting it which causes the current activity window to be lost which is inconvenient
or without restarting WSJT-x by going to the WSJT-x FILE/SETTINGS/AUDIO/OUTPUT menu and changing from the "DAX AUDIO TX" selection to another selection and clicking OK, then going back through the FILE/SETTINGS/AUDIO/OUTPUT menu and changing back to "DAX AUDIO TX" selection and then clicking OK.


gmendenh1947
 

I believe that disabling the Windows "USB Selective Suspend" will solve your problem.  Even though I use only an IP connection (no USB audio device) via DAX Tx audio connection from WSJT-x to my Flex 6600M,  apparently a virtual USB port is used.   Instructions on how to disable "USB Selective Suspend" can be found at this link.

https://www.windowscentral.com/how-prevent-windows-10-turning-usb-devices

This fix worked for me and a Flex 6700 user.

Geoff - W8GNM


Neal Pollack
 

Geoff:

While I am glad that "something" worked for you, USB suspend/sleep has absolutely nothing to do with Flex ethernet control.  It is not a "virtual USB port".   WSJT-X controls the Flex radio over ethernet using TCP UDP packets.  Nothing else.   I have a Flex 6600, and have seen the same exact issue with no TX after long idle periods.  Killing and restarting WSJT-X always fixes it.  But the WSJT-X code is not doing anything with USB ports in this configuration.   The issue does seem tied to the virtual AUDIO ports. I tried your USB suspend setting, and I still get the NO TX issue after long idle times.   I am leaning toward thinking there may be some similar timeout issue with Windows 10 audio devices, or a slow memory leak or bug in WSJT-X with regard to this.  In all cases, restarting WSJT-X fixes it, so you can't blame the Windows 10 USB layer or the Flex DAX layer.   Let's keep hunting....

Neal


Bill Somerville
 

On 21/06/2020 20:45, Neal Pollack wrote:
Geoff:

While I am glad that "something" worked for you, USB suspend/sleep has absolutely nothing to do with Flex ethernet control.  It is not a "virtual USB port".   WSJT-X controls the Flex radio over ethernet using TCP UDP packets.  Nothing else.   I have a Flex 6600, and have seen the same exact issue with no TX after long idle periods.  Killing and restarting WSJT-X always fixes it.  But the WSJT-X code is not doing anything with USB ports in this configuration.   The issue does seem tied to the virtual AUDIO ports. I tried your USB suspend setting, and I still get the NO TX issue after long idle times.   I am leaning toward thinking there may be some similar timeout issue with Windows 10 audio devices, or a slow memory leak or bug in WSJT-X with regard to this.  In all cases, restarting WSJT-X fixes it, so you can't blame the Windows 10 USB layer or the Flex DAX layer.   Let's keep hunting....

Neal
Neal,

you are missing the point. The virtual audio devices provided by DAX are amongst the devices that get re-enumerated when some other device is powered own to save power. The fact that your rig is connected to you PC via via Ethernet is not particularly relevant to the issue you are suffering.

73
Bill
G4WJS.


Bill Somerville
 

On 22/06/2020 03:23, Don - kx9q wrote:
Bill

I have also experienced the same issue with the same setup.  So how do you determine what device or devices are getting powered down?

Don - kx9q
Hi Don,

the problem seems to revolve around anything that could carry audio and supports hot-plugging. that boils down to USB and things that carry USB connections. Setting all USB hubs to not be powered down to save energy in their properties under Device Manager, and setting the system Power Plan not to suspend USB devices both are essential. Another problem area is HDMI monitor connections, HDMI carries USB connections and some graphics cards seem to have no easy way to stop them powering down the monitor when idle. As a last resort, there are applications that simulate mouse movements on a regular basis to try and persuade Windows that the system is not idle.

73
Bill
G4WJS.


Dave_G0WBX
 

As a last resort, there are applications that simulate mouse movements on a regular basis to try and persuade Windows that the system is not idle.


You can make your own...

    https://darkbluebit.com/arduino/mouse-jiggler/    (NO affiliation.)

73

Dave G0WBX.


-- 
Created on and sent from a Unix like PC running and using free and open source software:


gmendenh1947
 

I did not realize as Bill pointed out, that my HDMI video connection to my monitor timing out could also contribute to this problem.
In addition to setting my Win 10 power configuration to maximum performance, I have separately set my monitor timeout to NEVER.
I have also disabled all USB sleep options in device manager.  Could the hard drive suspend timer also have an effect on this problem?
I'm still testing to see if all this effort completely eliminates the problem.