locked Remote Desktop Audio Loss


Daniel Loranger
 

I use remote desktop to access and control my rig about 95% of the time, and I have found there is one very annoying behavior that has persisted for a long time. Hope someone can help identify a fix.

setup

I have my windows box with the radio and etc connected.  All is running fine.

issue
I remote desktop connect to my windows box with a laptop (windows), android phone/tablet/etc.  The audio is always dead and I have to go into the settings and toggle the audio source for the mic.  As soon as I do this the audio recovers and all is well.  Is there a way to make the audio self recover in wsjt-x?  I am not forwarding the audio, everything is staying local to the desktop machine.  changing this on the mobile phone is annoying at best, the cursor is not meant for this fine work remotely.

expected behavior
I have the radio and app running, I connect remotely, the audio remains connected and streaming so I don't have to fiddle with the settings.


Bill Somerville
 

On 14/06/2020 19:22, Daniel Loranger wrote:
I use remote desktop to access and control my rig about 95% of the time, and I have found there is one very annoying behavior that has persisted for a long time. Hope someone can help identify a fix.

setup

I have my windows box with the radio and etc connected.  All is running fine.

issue
I remote desktop connect to my windows box with a laptop (windows), android phone/tablet/etc.  The audio is always dead and I have to go into the settings and toggle the audio source for the mic.  As soon as I do this the audio recovers and all is well.  Is there a way to make the audio self recover in wsjt-x?  I am not forwarding the audio, everything is staying local to the desktop machine.  changing this on the mobile phone is annoying at best, the cursor is not meant for this fine work remotely.

expected behavior
I have the radio and app running, I connect remotely, the audio remains connected and streaming so I don't have to fiddle with the settings.
Hi Daniel,

this is an annoying "feature" of RDP. It creates its own virtual audio devices and causes Windows to re-number its existing audio devices. WSJT-X gets no notification of this so cannot do anything about it.

73
Bill
G4WJS.


Dave_G0WBX
 

Much the same when you plug another interface in, while a program is
already running.  Most are oblivious of any changes, unless the OS
re-enumerates things in a way that an existing device fall's out of view...

Best to start the RDP session and get all that sorted, then start up
WSJTx.  It should then have visibility of any "extra" audio devices, RDP
created, or you have plugged in.

73.

Dave G0WBX.

Note!  NEVER run (or have visible ports for it)  RDP over the public
internet.  It's a known security black spot, and currently on the radar
of all internet mischief makers.  If you need to do that, establish a
point to point VPN first, then run it over that.   Same applies to VNC
and other remote control stuff too.

<<
--
Created on and sent from a Unix like PC running and using free and open source software:


Erik Icket
 

Hi Daniel,

You may try Teamviewer or DWService for accessing your remote desktop. These do not disconnect the established audio connections upon connect / disconnect.

73's Erik
ON4PB