locked Problem: WSJT-x Tx audio disconnects from Flex DAX after sitting idle #AudioIssues


gmendenh1947
 

Current software configuration: WSJT-x v 2.2.0, Flex DAX v 2.6.2.50, Windows 10 Pro v 1909.
FlexRadio 6600M transceiver running v 2.6.2.50 software.

After WSJT-x in FT8 mode sits in a receive/monitor condition for several hours, the Tx audio connection via Flex DAX to the Flex 6600M transceiver is lost.
DAX is still connected to the radio, but the connection from WSJT-x is broken.
The Rx audio connection from the Flex 6600M via DAX remains working OK.

This problem with the loss of Tx audio has existed over the past several versions of WSJT-x and DAX.
Several other FlexRadio users are having exactly the same problem using Flex 6700 radios.

The problem can be fixed by shutting down WSJT-x and restarting it which causes the current activity window to be lost which is inconvenient
or without restarting WSJT-x by going to the WSJT-x FILE/SETTINGS/AUDIO/OUTPUT menu and changing from the "DAX AUDIO TX" selection to another selection and clicking OK, then going back through the FILE/SETTINGS/AUDIO/OUTPUT menu and changing back to "DAX AUDIO TX" selection and then clicking OK.


Jerry AA2T
 

Seen something similar, sitting for awhile, hit enable, ptt goes, no audio. If I cycle halt and back to enable quickly it works. Using win 10 Home 1909. Not a big issue for me. I do find also occasionally as the activity window has just filled, I hit enable like in first second, one out of 100 qso I get same effect, ptt no audio. I suspect an OS issue.


Bill Somerville
 

On 05/06/2020 14:55, rogich via groups.io wrote:
Seen something similar, sitting for awhile, hit enable, ptt goes, no audio. If I cycle halt and back to enable quickly it works. Using win 10 Home 1909. Not a big issue for me. I do find also occasionally as the activity window has just filled, I hit enable like in first second, one out of 100 qso I get same effect, ptt no audio. I suspect an OS issue.
OM,

are you using the same rig and setup as the OP?

73
Bill
G4WJS.


John Faivre
 

I have had a similar issue with my win10-64 Laptop to my uBitx transceiver. When the pc stopped the hard drive, or turned off the displays for inactivity the TX audio would be routed to the PC speakers. The settings in WSJT-x would still indicate the proper settings, as did the sound settings in the laptop. To get it back I had to either close and reopen WSJT, or go into sound settings on the pc and change them, then change them back, or restart the pc. The only way that I have found to avoid the problem is to set all the hdd, display, standby settings to never sleep.


gmendenh1947
 

I believe that disabling the Windows "USB Selective Suspend" will solve this problem.  Even though I use only an IP connection (no USB audio device) via DAX Tx audio connection from WSJT-x to my Flex 6600M,  apparently a virtual USB port is used.   Instructions on how to disable "USB Selective Suspend" can be found at this link.   https://www.windowscentral.com/how-prevent-windows-10-turning-usb-devices

This fix worked for me and a Flex 6700 user.

Geoff - W8GNM


gmendenh1947
 

Perhaps there is a way that the WSJT-x software could be modified to periodically reset the "USB Selective Suspend" timeout and eliminate the need to have to manually disable this Windows power saving function which is affecting so many users.


neil_zampella <neilz@...>
 

That would involve accessing the Windows system itself, which is not something regular programs are allowed to do.   I wouldn't want regular applications messing with my system. 

The only time the USB power settings need to be checked is when Windows gets an update, and Microsoft tries to >> help << you by turning on things you specifically turned off.     M$ should not do that unless asked to do so.

Neil, KN3ILZ

On 6/20/2020 9:47 AM, gmendenh1947 wrote:

Perhaps there is a way that the WSJT-x software could be modified to periodically reset the "USB Selective Suspend" timeout and eliminate the need to have to manually disable this Windows power saving function which is affecting so many users.

    


Bill Somerville
 

Hi Neil,

don't worry, WSJT-X is a user mode application and it doesn't require elevated rights to do its job. We will not be changing that, nor adjusting any system settings on the user's behalf.

The WSJT-X installer uses elevated rights briefly to write the Windows Registry with the uninstall settings, the main application does not use, nor should ever be run with elevated rights.

73
Bill
G4WJS.

On 20/06/2020 15:42, neil_zampella wrote:

That would involve accessing the Windows system itself, which is not something regular programs are allowed to do.   I wouldn't want regular applications messing with my system.

The only time the USB power settings need to be checked is when Windows gets an update, and Microsoft tries to >> help << you by turning on things you specifically turned off.     M$ should not do that unless asked to do so.

Neil, KN3ILZ

On 6/20/2020 9:47 AM, gmendenh1947 wrote:
Perhaps there is a way that the WSJT-x software could be modified to periodically reset the "USB Selective Suspend" timeout and eliminate the need to have to manually disable this Windows power saving function which is affecting so many users.


Geoff - W8GNM
 

Bill, why couldn't WSJT-x periodically generate a blip of Tx audio data without keying PTT to keep the Tx connection alive so there is no need to  worry about whether the USB port timeout is enabled?


Geoff - W8GNM
 

I don't think it is necessary to access the Windows system to keep the port from timing out.  It would just require a short bit of Tx audio data to be periodically sent by WSJT-x automatically without activating the PTT function.  This way the keep alive Tx audio data would not be transmitted.


Bill Somerville
 

On 20/06/2020 21:17, Geoffrey Mendenhall wrote:
Bill, why couldn't WSJT-x periodically generate a blip of Tx audio data without keying PTT to keep the Tx connection alive so there is no need to worry about whether the USB port timeout is enabled?
Hi Geoffrey,

apart from the fact that many users have VOX arrangements for keying, it wouldn't help anyway. The problem is some device being powered down that in turn causes all the audio devices to be renumbered internally. WSJT-X gets no notification that the device it sends audio to is no longer the one initially chosen. Note also that using an audio device does not involve a connection, unlike using a serial port when one process takes exclusive access to a device. Because there is no connection, Windows does not know that an audio device is in use when it decides to rearrange them all.

73
Bill
G4WJS.


Jim Rogers <rogers9466@...>
 

Maybe you need to talk to Flex. Maybe they need a check box to mitigate the issue.

Jim, W4ATK

On Jun 20, 2020, at 3:24 PM, Bill Somerville <g4wjs@...> wrote:

On 20/06/2020 21:17, Geoffrey Mendenhall wrote:
Bill, why couldn't WSJT-x periodically generate a blip of Tx audio data without keying PTT to keep the Tx connection alive so there is no need to worry about whether the USB port timeout is enabled?
Hi Geoffrey,

apart from the fact that many users have VOX arrangements for keying, it wouldn't help anyway. The problem is some device being powered down that in turn causes all the audio devices to be renumbered internally. WSJT-X gets no notification that the device it sends audio to is no longer the one initially chosen. Note also that using an audio device does not involve a connection, unlike using a serial port when one process takes exclusive access to a device. Because there is no connection, Windows does not know that an audio device is in use when it decides to rearrange them all.

73
Bill
G4WJS.


Chuck Adams
 

Port won't time out if you reset the power settings on it to Max Performance.   Not Max Power Saving.  Try that. 



Sent from my T-Mobile 5G Device



-------- Original message --------
From: Geoffrey Mendenhall <geoff@...>
Date: 6/20/20 4:22 PM (GMT-05:00)
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Problem: WSJT-x Tx audio disconnects from Flex DAX after sitting idle #audio_issues #flex

I don't think it is necessary to access the Windows system to keep the port from timing out.  It would just require a short bit of Tx audio data to be periodically sent by WSJT-x automatically without activating the PTT function.  This way the keep alive Tx audio data would not be transmitted.


m_scot_alex
 

I've been using (up to) two 6700s since 2014 under Win7-64 and Win10-64, and have never had to contend with audio port re-enumeration because I set the PCs that I running SmartSDR to Windows and the PC vendor's 'max performance / no sleep' settings. Also note that most audio peripherals, such as those containing the Realtek chipset, will cause Windows to re-enumerate the audio subsystem when, for example, a headset is plugged into a motherboard headset socket.

I would suggest that operators turn off all power saving features during SSDR operating sessions and not do anything to or with PC while operating SSDR that will cause Windows to make hardware configuration setting changes.

73,

Mike - N8MSA 


Geoff - W8GNM
 

On Sat, Jun 20, 2020 at 09:38 AM, gmendenh1947 wrote:
In addition to disabling the Windows "USB Selective Suspend" as described above, I have found that using Windows device manager to individually turn off power saving in the "properties tab" / "power management" / "Allow computer to turn off ......" on each USB device, is also necessary to resolve this problem after rebooting the computer.
I have seen the other responses that recommend changing the power management scheme to "maximum performance"/"never sleep" which is probably another way to solve this problem if you don't need any other power conservation on the PC.


Steve Phillips - NS4P
 

You might also use Device Manager to check the settings under Ports (COM & LPT).  For my Icom 7610 the Icom virtual serial port drivers created entries there that also needed the Power Management settings changed.

Steve - NS4P