locked Another Data Point - Missing Every other Seq of Decodes


Hasan Schiers N0AN
 

After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan


Carl - WC4H
 

Hi Hasan.

I always read your posts.

I did not see this one in the HamApps group (JTAlerts).  It sounds like it might be a problem with JTAlerts.

73.
Carl - WC4H


Hasan Schiers N0AN
 

Rebooting and restarting X, JTA and DXLabSuites now allows mouse movement without losing decodes in X.

It ran for about 3 days in this config before starting to misbehave. I'll set my timer. It looks like a "long term" problem. (more than a day or so of continual running)

Hasan


On Sat, Mar 21, 2020 at 8:25 AM Hasan Schiers N0AN via Groups.Io <hbasri.schiers6=gmail.com@groups.io> wrote:

After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan


Hasan Schiers N0AN
 

Since it involves X not decoding, I put it here. Besides, I've been told if I don't like JTA and I think it's causing problems to stop using it, so I don't post there.

The fact is there is some sort of interaction going on. I don't know what is causing it. All I can do is report what happens. ...and if that becomes a problem here, I'll stop posting here, too.

73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:41 AM Carl - WC4H via Groups.Io <wc4h.dx=yahoo.com@groups.io> wrote:
Hi Hasan.

I always read your posts.

I did not see this one in the HamApps group (JTAlerts).  It sounds like it might be a problem with JTAlerts.

73.
Carl - WC4H


Bill Somerville
 

On 21/03/2020 13:25, Hasan Schiers N0AN wrote:
After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan

Hi Hasan,

when this issue reoccurred did you have "Settings->Reporting->UDP Server->Accept UDP requests" checked or unchecked? If checked, did unchecking it resolve the issue?

73
Bill
G4WJS.


Hasan Schiers N0AN
 


Hi Bill,

It was checked, and it is checked now after rebooting and restarting things.
It took > 2 days to show up. So, how to proceed?
Wait for it to show up again , then uncheck it, or uncheck it now and see if it goes > 3 days?
73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:46 AM Bill Somerville <g4wjs@...> wrote:
On 21/03/2020 13:25, Hasan Schiers N0AN wrote:
After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan

Hi Hasan,

when this issue reoccurred did you have "Settings->Reporting->UDP Server->Accept UDP requests" checked or unchecked? If checked, did unchecking it resolve the issue?

73
Bill
G4WJS.



Bill Somerville
 

Hi Hasan,

keep it checked and try unchecking it as a first step when the issue reoccurs.

73
Bill
G4WJS.

On 21/03/2020 13:49, Hasan Schiers N0AN wrote:

Hi Bill,

It was checked, and it is checked now after rebooting and restarting things.
It took > 2 days to show up. So, how to proceed?
Wait for it to show up again , then uncheck it, or uncheck it now and see if it goes > 3 days?
73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:46 AM Bill Somerville <g4wjs@...> wrote:
On 21/03/2020 13:25, Hasan Schiers N0AN wrote:
After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan

Hi Hasan,

when this issue reoccurred did you have "Settings->Reporting->UDP Server->Accept UDP requests" checked or unchecked? If checked, did unchecking it resolve the issue?

73
Bill
G4WJS.



Hasan Schiers N0AN
 

Thanks, Bill, will do...it will probably be a day or two if it acts like last time.
Hasan


On Sat, Mar 21, 2020 at 8:53 AM Bill Somerville <g4wjs@...> wrote:
Hi Hasan,

keep it checked and try unchecking it as a first step when the issue reoccurs.

73
Bill
G4WJS.

On 21/03/2020 13:49, Hasan Schiers N0AN wrote:
Hi Bill,

It was checked, and it is checked now after rebooting and restarting things.
It took > 2 days to show up. So, how to proceed?
Wait for it to show up again , then uncheck it, or uncheck it now and see if it goes > 3 days?
73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:46 AM Bill Somerville <g4wjs@...> wrote:
On 21/03/2020 13:25, Hasan Schiers N0AN wrote:
After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan

Hi Hasan,

when this issue reoccurred did you have "Settings->Reporting->UDP Server->Accept UDP requests" checked or unchecked? If checked, did unchecking it resolve the issue?

73
Bill
G4WJS.




Marion D. Kitchens
 


I find your post informative.  Keep them coming, please.
 
de K4GOK,  Marion
 
On Sat, 21 Mar 2020 08:45:13 -0500 "Hasan Schiers N0AN" <hbasri.schiers6@...> writes:

Since it involves X not decoding, I put it here. Besides, I've been told if I don't like JTA and I think it's causing problems to stop using it, so I don't post there.

The fact is there is some sort of interaction going on. I don't know what is causing it. All I can do is report what happens. ...and if that becomes a problem here, I'll stop posting here, too.

73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:41 AM Carl - WC4H via Groups.Io <wc4h.dx=yahoo.com@groups.io> wrote:
Hi Hasan.

I always read your posts.

I did not see this one in the HamApps group (JTAlerts).  It sounds like it might be a problem with JTAlerts.

73.
Carl - WC4H
 


Dave Corio
 

Hasan, just a thought. Are you using Logitech Setpoint as your mouse software? It's been known to interfere with other ham apps, so that could be a possibility.

I used to use Setpoint, but it took up so much of my PCs limited resources I finally got rid of it completely.

GL es 73
Dave - KB3MOW


Al Groff
 

Hasan,
  Another thing to try is shut down SpotCollector when it occurs..
AL, K0VM

On 3/21/2020 8:49 AM, Hasan Schiers N0AN wrote:


Hi Bill,

It was checked, and it is checked now after rebooting and restarting things.
It took > 2 days to show up. So, how to proceed?
Wait for it to show up again , then uncheck it, or uncheck it now and see if it goes > 3 days?
73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:46 AM Bill Somerville <g4wjs@...> wrote:
On 21/03/2020 13:25, Hasan Schiers N0AN wrote:
After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan

Hi Hasan,

when this issue reoccurred did you have "Settings->Reporting->UDP Server->Accept UDP requests" checked or unchecked? If checked, did unchecking it resolve the issue?

73
Bill
G4WJS.




    


neil_zampella <neilz@...>
 

Hasan,

I'm not sure who said that.   If it was Laurie,  I'm sure he was in the middle of trying to fix a bunch of other nitpiks, but I'm fairly sure it wasn't him.    If it was anyone else, ignore them as they're not the ones that count, me included.  

While I'm fairly sure Laurie sees these posts here, I'm also sure that he's hip deep in the middle of a niggling issue.

Neil, KN3ILZ

On 3/21/2020 9:45 AM, Hasan Schiers N0AN wrote:
Since it involves X not decoding, I put it here. Besides, I've been told if I don't like JTA and I think it's causing problems to stop using it, so I don't post there.

The fact is there is some sort of interaction going on. I don't know what is causing it. All I can do is report what happens. ...and if that becomes a problem here, I'll stop posting here, too.

73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:41 AM Carl - WC4H via Groups.Io <wc4h.dx=yahoo.com@groups.io> wrote:
Hi Hasan.

I always read your posts.

I did not see this one in the HamApps group (JTAlerts).  It sounds like it might be a problem with JTAlerts.

73.
Carl - WC4H


    

Virus-free. www.avg.com


Hasan Schiers N0AN
 

Thanks input, Al, and nice to hear you on the 75m Iowa SSB net!
Bill (WJS) and I have a current test regime going that should yield some informative results.

It will take a few days, (because the symptoms don't show up immediately, last time it tool between 2 and 3 days of 24/7 operation), but when it manifests again, instead of closing JTA, I will disable Accept UDP Requests in WSJT-X.
I'm betting it will restore all decodes immediately, just like shutting JTA down did and does.

What do these two things have in common? JTA talks UDP with X, and in this 2nd test case, Shutting off "Accept UDP Requests in X" looks like it might accomplish the same thing.

Looking forward to it!

73, N0AN
Hasan


On Sat, Mar 21, 2020 at 10:09 AM Al Groff via Groups.Io <al.k0vm=yahoo.com@groups.io> wrote:
Hasan,
  Another thing to try is shut down SpotCollector when it occurs..
AL, K0VM

On 3/21/2020 8:49 AM, Hasan Schiers N0AN wrote:

Hi Bill,

It was checked, and it is checked now after rebooting and restarting things.
It took > 2 days to show up. So, how to proceed?
Wait for it to show up again , then uncheck it, or uncheck it now and see if it goes > 3 days?
73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:46 AM Bill Somerville <g4wjs@...> wrote:
On 21/03/2020 13:25, Hasan Schiers N0AN wrote:
After running perfectly for 3 days, 24/7 (and changing nothing, no start or stop other programs, etc),  I noticed this morning that as I was using JTA to turn the sound back on, that all of a sudden, I messed an entire sequence of decodes.

I stopped what I was doing, didn't touch a thing, and the normal behavior of every sequence decoding returned.

Then, I did nothing more than move the mouse during the next decode period. I did not click on anything. I just moved the mouse: no decode, skipped.

If I played with the mouse the decode would skip an entire seq.

If I just let things sit, seq after seq, decoded exactly as it should.

I moved the mouse again, and the sequence was skipped.

At that point, I closed JTA. Immediately decodes returned and no matter how much mouse movement or what other programs I played with, no more decodes were skipped.

Not blaming anything on any software, just describing the behavior. I have no idea if this is a result of running long term, or not. When I have time, I'll reboot the machine, set up as I had for the prior 3 days. and see what happens.
73, N0AN
Hasan

Hi Hasan,

when this issue reoccurred did you have "Settings->Reporting->UDP Server->Accept UDP requests" checked or unchecked? If checked, did unchecking it resolve the issue?

73
Bill
G4WJS.




    



 

Hasan,

It could be that JTAlert is acquiring too much memory through continually operating for two days. Keep a look at your memory allocation in Task Manager. If you have to start swapping to handle the mouse movements then it is a bug with JTAlert not releasing memory when it's finished each task.

Phil GM3ZZA

On Saturday, 21 March 2020, 13:45:32 GMT, Hasan Schiers N0AN <hbasri.schiers6@...> wrote:


Since it involves X not decoding, I put it here. Besides, I've been told if I don't like JTA and I think it's causing problems to stop using it, so I don't post there.

The fact is there is some sort of interaction going on. I don't know what is causing it. All I can do is report what happens. ...and if that becomes a problem here, I'll stop posting here, too.

73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:41 AM Carl - WC4H via Groups.Io <wc4h.dx=yahoo.com@groups.io> wrote:
Hi Hasan.

I always read your posts.

I did not see this one in the HamApps group (JTAlerts).  It sounds like it might be a problem with JTAlerts.

73.
Carl - WC4H

--
73 Phil GM3ZZA


Hasan Schiers N0AN
 

Yep, it could certainly be a memory leak somewhere, but the "Disable Accepting UDP" will tell us a lot, at least to start. Tnx idea.
73, N0AN
Hasan


On Sat, Mar 21, 2020 at 11:16 AM Philip Rose via Groups.Io <pvrose=btinternet.com@groups.io> wrote:
Hasan,

It could be that JTAlert is acquiring too much memory through continually operating for two days. Keep a look at your memory allocation in Task Manager. If you have to start swapping to handle the mouse movements then it is a bug with JTAlert not releasing memory when it's finished each task.

Phil GM3ZZA

On Saturday, 21 March 2020, 13:45:32 GMT, Hasan Schiers N0AN <hbasri.schiers6@...> wrote:


Since it involves X not decoding, I put it here. Besides, I've been told if I don't like JTA and I think it's causing problems to stop using it, so I don't post there.

The fact is there is some sort of interaction going on. I don't know what is causing it. All I can do is report what happens. ...and if that becomes a problem here, I'll stop posting here, too.

73, N0AN
Hasan


On Sat, Mar 21, 2020 at 8:41 AM Carl - WC4H via Groups.Io <wc4h.dx=yahoo.com@groups.io> wrote:
Hi Hasan.

I always read your posts.

I did not see this one in the HamApps group (JTAlerts).  It sounds like it might be a problem with JTAlerts.

73.
Carl - WC4H

--
73 Phil GM3ZZA