locked Meinberg NTP at Windows startup


John Morphet
 

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?

John, WØZI


@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause


Kai-KE4PT
 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT


On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?

John, WØZI


@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause



    


Jim Bacher - WB8VSU
 

Meinberg's tweaking of time is dependent on how far your clock is off. If it's fairly close it will slowly drift the computer back to a more accurate time. If it's way off it will brute force it back. My guess is one second off is within its drifting time back method. 

And as Kai said there is a lot going on at startup. Let every thing warm up for a few minutes, and it will resolve by itself. 


Jim Bacher, WB8VSU 
wb8vsu@... 
https://trc.guru

On Mon, Feb 10, 2020 at 10:32 AM, Kai-KE4PT
<k.siwiak@...> wrote:


John Morphet
 

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 



 

 


Bill Somerville
 

On 10/02/2020 15:16, John Morphet wrote:
I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?

John, WØZI

Hi John,

the Meinberg NTP Client has to obey the rules of NTP time adjustment since it is a reference implementation of that. Time adjustments must maintain the clock ticks as monotonic and backward steps are therefore not allowed. If you PC realtime clock chip drifts ahead of time then every time the machine is powered off it's time will require slowing down to resynchronize to UTC on startup. This could take a while. The NTP protocol can be modified to cope with exactly this problm and others where large adjustment steps are required on startup. It is enabled by adding the 'iburst' attribute to one or more of the servers configured. For example my server lines in my ntp.conf file ("Start Menu->Edit NTP Configuration") look like this:

# The 'iburst' keyword speeds up initial synchronization, please check the documentation for more details!
server raspberrypi iburst prefer
server 0.uk.pool.ntp.org minpoll 11 iburst
server 1.uk.pool.ntp.org minpoll 11 iburst
server 2.uk.pool.ntp.org minpoll 11 iburst
server 3.uk.pool.ntp.org minpoll 11 iburst

Note that raspberrypi on my network is a Stratum 1 server I run synchronized to GPS satellite services using a PPS source. Most users would select just pool servers that are geographically close by, in my case the pool servers are just for backup if my local NTP server is out of action.

73
Bill
G4WJS.


David Piersall
 

I dragged the "Restart NTP Service" icon from the start menu to my Windows desktop. When I start my laptop for a new session running wsjt-x, I right-click on the icon, select "run as administrator", wait about 10 seconds, and then my time is correct.

Dave Piersall, N6ORB


On Monday, February 10, 2020, 07:54:33 AM PST, Jim Bacher - WB8VSU <wb8vsu@...> wrote:


Meinberg's tweaking of time is dependent on how far your clock is off. If it's fairly close it will slowly drift the computer back to a more accurate time. If it's way off it will brute force it back. My guess is one second off is within its drifting time back method. 

And as Kai said there is a lot going on at startup. Let every thing warm up for a few minutes, and it will resolve by itself. 


Jim Bacher, WB8VSU 
wb8vsu@... 
https://trc.guru

On Mon, Feb 10, 2020 at 10:32 AM, Kai-KE4PT
<k.siwiak@...> wrote:


jwvaughn
 

John,

 

You could run the batch file using the task scheduler and delay N minutes after the computer starts up. It will then start with no intervention on your part and after the computer has settled out.

 

Jerry

 

From: WSJTX@groups.io [mailto:WSJTX@groups.io] On Behalf Of John Morphet
Sent: Monday, February 10, 2020 10:08
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 

 

 

 


Neal Campbell K3NC
 

Why not use the option to run it as a service and let it be automatic?  Also, I would recommend you replace the battery on your motherboard!

On Mon, Feb 10, 2020 at 1:50 PM jwvaughn via Groups.Io <jwv_not=yahoo.com@groups.io> wrote:

John,

 

You could run the batch file using the task scheduler and delay N minutes after the computer starts up. It will then start with no intervention on your part and after the computer has settled out.

 

Jerry

 

From: WSJTX@groups.io [mailto:WSJTX@groups.io] On Behalf Of John Morphet
Sent: Monday, February 10, 2020 10:08
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 

 

 

 


--

Neal
K3NC
Migrating to neal@... shortly!


John Morphet
 

The task scheduler appears to be the solution. When I set up an advanced task, I noticed the option to not start the task unless there is a network connection. The light came on and I realized that since I have a wifi connection on that computer, there is no network connection at startup. It takes a little time to initiate the wifi connection. When I created the task for task scheduler, I enabled the don’t run the task until there is a network connection. I also have a 2 minute delay and set highest priority. It seems to be working now. I will experiment with it and see if I disable the time delay and priority to see if those settings actually helped. For now it is working and I appreciate all the suggestions.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of jwvaughn via Groups.Io
Sent: Monday, February 10, 2020 11:48 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,

 

You could run the batch file using the task scheduler and delay N minutes after the computer starts up. It will then start with no intervention on your part and after the computer has settled out.

 

Jerry

 

From: WSJTX@groups.io [mailto:WSJTX@groups.io] On Behalf Of John Morphet
Sent: Monday, February 10, 2020 10:08
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 

 

 

 


Bill Somerville
 

John,

why are you not running Meinberg NTP CLient as a WIndows service, that is the default installation. When configured as a service it will be automatically started *after* the network is up and running. That combined with using the *iburst* option on your server configurations will ensure that, however wayward your PC clock is when undisciplined, it will be gracefully brought into synchronization with UTC on system restarts without any user intervention.

73
Bill
G4WJS.

On 10/02/2020 20:53, John Morphet wrote:

The task scheduler appears to be the solution. When I set up an advanced task, I noticed the option to not start the task unless there is a network connection. The light came on and I realized that since I have a wifi connection on that computer, there is no network connection at startup. It takes a little time to initiate the wifi connection. When I created the task for task scheduler, I enabled the don’t run the task until there is a network connection. I also have a 2 minute delay and set highest priority. It seems to be working now. I will experiment with it and see if I disable the time delay and priority to see if those settings actually helped. For now it is working and I appreciate all the suggestions.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of jwvaughn via Groups.Io
Sent: Monday, February 10, 2020 11:48 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,

 

You could run the batch file using the task scheduler and delay N minutes after the computer starts up. It will then start with no intervention on your part and after the computer has settled out.

 

Jerry

 

From: WSJTX@groups.io [mailto:WSJTX@groups.io] On Behalf Of John Morphet
Sent: Monday, February 10, 2020 10:08
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 

 

 

 



VE3GTC, Graham
 

I seem to recall that Meinberg ntp should be run as a service with it's own account.

If you have shut your computer off and restarted some time later then the service will have also started but it will take amount of time, not very long, in order to get the time back on time. This adjustment will not be immediate but may take several minutes.

Forcing it as you are doing is not necessary.

On WIN10 right click on the task bar and open Task manager. There should be a Startup tab which shows which apps are set to start on "Startup". As a mater of practice I disable everything in this tab that I can. this does not mean that the app will not run, only that it will not startup when you start your computer and consume resources and time in getting your computer going. Your computer will start much faster and your apps will still run when you manually start them.

cheers, Graham ve3gtc

On Mon, Feb 10, 2020 at 1:08 PM John Morphet <jmorphet@...> wrote:

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 



 

 



John Morphet
 

Hi Bill,

 

I am running the default configuration whatever it was at the time I installed it. The way Meinberg would behave is that it would eventually resolve the time delta, but not when I first started the computer. Your suggestion will probably work  and I will try it when I have time. Just to satisfy my curiosity. The task scheduler solution was the easiest for me, because I am familiar with it and it did work. Your solution is new territory for me.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Bill Somerville
Sent: Monday, February 10, 2020 2:09 PM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,

 

why are you not running Meinberg NTP CLient as a WIndows service, that is the default installation. When configured as a service it will be automatically started *after* the network is up and running. That combined with using the *iburst* option on your server configurations will ensure that, however wayward your PC clock is when undisciplined, it will be gracefully brought into synchronization with UTC on system restarts without any user intervention.

 

73
Bill
G4WJS.

 

On 10/02/2020 20:53, John Morphet wrote:

The task scheduler appears to be the solution. When I set up an advanced task, I noticed the option to not start the task unless there is a network connection. The light came on and I realized that since I have a wifi connection on that computer, there is no network connection at startup. It takes a little time to initiate the wifi connection. When I created the task for task scheduler, I enabled the don’t run the task until there is a network connection. I also have a 2 minute delay and set highest priority. It seems to be working now. I will experiment with it and see if I disable the time delay and priority to see if those settings actually helped. For now it is working and I appreciate all the suggestions.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of jwvaughn via Groups.Io
Sent: Monday, February 10, 2020 11:48 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,

 

You could run the batch file using the task scheduler and delay N minutes after the computer starts up. It will then start with no intervention on your part and after the computer has settled out.

 

Jerry

 

From: WSJTX@groups.io [mailto:WSJTX@groups.io] On Behalf Of John Morphet
Sent: Monday, February 10, 2020 10:08
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 

 

 

 

 


Neal Campbell K3NC
 

You no longer need to run it as a service with its own windows account, it now defaults to the system account and works just fine.

Neal
K3NC
Migrating to neal@... shortly!


On Mon, Feb 10, 2020 at 5:30 PM John Morphet <jmorphet@...> wrote:

Hi Bill,

 

I am running the default configuration whatever it was at the time I installed it. The way Meinberg would behave is that it would eventually resolve the time delta, but not when I first started the computer. Your suggestion will probably work  and I will try it when I have time. Just to satisfy my curiosity. The task scheduler solution was the easiest for me, because I am familiar with it and it did work. Your solution is new territory for me.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Bill Somerville
Sent: Monday, February 10, 2020 2:09 PM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,

 

why are you not running Meinberg NTP CLient as a WIndows service, that is the default installation. When configured as a service it will be automatically started *after* the network is up and running. That combined with using the *iburst* option on your server configurations will ensure that, however wayward your PC clock is when undisciplined, it will be gracefully brought into synchronization with UTC on system restarts without any user intervention.

 

73
Bill
G4WJS.

 

On 10/02/2020 20:53, John Morphet wrote:

The task scheduler appears to be the solution. When I set up an advanced task, I noticed the option to not start the task unless there is a network connection. The light came on and I realized that since I have a wifi connection on that computer, there is no network connection at startup. It takes a little time to initiate the wifi connection. When I created the task for task scheduler, I enabled the don’t run the task until there is a network connection. I also have a 2 minute delay and set highest priority. It seems to be working now. I will experiment with it and see if I disable the time delay and priority to see if those settings actually helped. For now it is working and I appreciate all the suggestions.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of jwvaughn via Groups.Io
Sent: Monday, February 10, 2020 11:48 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,

 

You could run the batch file using the task scheduler and delay N minutes after the computer starts up. It will then start with no intervention on your part and after the computer has settled out.

 

Jerry

 

From: WSJTX@groups.io [mailto:WSJTX@groups.io] On Behalf Of John Morphet
Sent: Monday, February 10, 2020 10:08
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

Kai,

 

It makes sense that all the startup apps might take away focus from the restartntp batch file. The key reason that Win 10 should not be used for deterministic applications. Sounds like my only solution would be to find a way to run it last, set the priority higher than anything else, or delay it long enough that everything else has finished (moving target). Alternatively, just run it manually from the desktop after starting has finished. I was trying to do it automatically because I sometimes forget (getting old) and then in the middle of a QSO, I notice my DT is too far off. This only happens when I first turn on the computer.  Give it enough time it will pull the DT in.

 

John, WØZI

 

From: WSJTX@groups.io <WSJTX@groups.io> On Behalf Of Kai-KE4PT
Sent: Monday, February 10, 2020 8:32 AM
To: WSJTX@groups.io
Subject: Re: [WSJTX] Meinberg NTP at Windows startup

 

John,
The Windows OS, and your virus protection software, have tons of tasks running in the background, especially at startup, that are steal focus away from time-sensitive operations that Meinberg, Tardis, and other time synchronizers provide. My suggestion is to wait a few minutes after start-up to let those background task finish, then run your time synchronizer.

Cheers,
Kai, KE4PT

On 2/10/2020 10:16, John Morphet wrote:

I am running Meinberg NTP on a Windows 10 machine. It is working well except when I first start the computer in the morning. I have noticed that when I start my computer in the morning the time is usually off by about a second. If I run the restartntp.bat (shown below) from my desktop, the time gets corrected. I have copied the shortcut to the restartntp.bat file to the Windows startup folder. I thought that would adjust my time every time I started the computer, but it doesn't seem to work. Does anyone know how to fix this?
 
John, WØZI
 
 
@echo off
REM ********** RESTART NTP SERVICE *************
echo Trying to stop NTP service:
net stop ntp
REM Insert a delay ...
echo Wait 10 seconds before restart ...
ping -n 10 127.0.0.1 > NUL
echo Trying to restart NTP service:
net start ntp
pause
 

 

 

 

 



Markku SM5FLM
 

I had the same problem, and despite lot of troubleshooting, and doing various suggestions, I never could get a correct time set, when starting the PC.

I solved this by uninstalling Meinberg and installing NetTime instead. The installation was easy, with no confusing configurations.

Now the PC clock is set correctly immediately on boot. Which is important for me, because I'm only using digital modes (FT8), and didn't want to wait for the clock to be synced.

In my opinion Meinberg is just to complex to understand for a none NTP expert.

So my recommendation is to install NetTime (http://www.timesynctool.com/).

/Markku


Dave_G0WBX
 

Other ways to sync Windows 10 to remote time sources.

https://www.windowscentral.com/how-manage-time-servers-windows-1

Works well enough on modern computers.

73.

Dave G0WBX.


-- 
Created on and sent from a Unix like PC running and using free and open source software:


VE3GTC, Graham
 

link is missing a ZERO on the end, should be:


cheers, Graham ve3gtc
 


On Tue, Feb 11, 2020 at 3:59 AM Dave_G0WBX via Groups.Io <g8kbvdave=googlemail.com@groups.io> wrote:

Other ways to sync Windows 10 to remote time sources.

https://www.windowscentral.com/how-manage-time-servers-windows-1

Works well enough on modern computers.

73.

Dave G0WBX.


-- 
Created on and sent from a Unix like PC running and using free and open source software:



Dave_G0WBX
 

well spotted, copy paste finger trouble.

73

Dave 'wbx

--
Created on and sent from a Unix like PC running and using free and open source software: