locked WSJT-X on K3S


Michael WA7SKG
 

I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8. Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG


A Wallace <awallace@...>
 

FWIW on my FT991 I set the Custom Switch button to take me to the correct
menu item. Switching becomes easy-peasy between voice and Data. Adrian
VK5AW.

--------- Original Message --------
From: WSJTX@groups.io
To: WSJTX@groups.io <WSJTX@groups.io>
Subject: [WSJTX] WSJT-X on K3S
Date: 09/01/20 02:29


I was helping a friend set up his K3S for FT8 this afternoon. Haven't
played with one of those before, quite a challenge. Our main problem was
getting audio into the transmitter. What finally worked was to go into
the radio menu and set MIC SEL to LINE IN. Immediately made contacts in
Florida, Russia, and Japan. PSKReporter showed reception all over the
US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who
says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to
Pkt/Data and it did not work. I had to set it to None. Then set the
radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a
nuisance to have to go into the menu and change the MIC SEL each time
you want to move from voice to FT8. Most radios I set up, I chose the
Pkt/Data and when I select a band in the band map, it automatically sets
the radio to DATA and audio flows properly. That does not seem to be the
case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to
go into the menu and make changes every time he wants to go from SSB to
FT8?

Any insights appreciated.

73,
Michael WA7SKG












________________________________________________________________
Message sent using Telaen Webmail 1.3.0.beta


Jim Brown
 

On 1/8/2020 6:29 PM, Michael WA7SKG wrote:
Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?
Right. RTFM. :) Elecraft radios remember lots of settings by band and mode.

73, Jim K9YC


James Shaver (N2ADV) <N2ADV@...>
 

Once the appropriate menu settings are cared for (quite common in just about every new radio these days) it’s simply a matter of putting the radio in data mode.  My K3 was pretty simple to set up with WSJTX.  


ve3ki
 

The radio should be in DATA A mode (there are four data modes - you have to select the correct one using the DATA MD button at the lower right corner of the keypad together with the VFO B knob). In DATA A, MIC SEL is set to LINE IN by default. By using DATA A, you don't have to turn compression off or adjust audio levels back and forth between phone and data modes, and you don't need to keep changing MIC SEL every time you change modes. The default filter bandwidth in DATA A is only 500 Hz, so you will have to widen it, which is a simple matter of twiddling the HI CUT and LO CUT knobs to where you want them. The filter setting is remembered.

Once you have put the K3 or K3S (they are functionally the same) into the DATA A submode on each band you use, that will be remembered on each band, and you can configure WSJT-X to use Data mode

Setting audio levels is different in Elecraft rigs from other radios - you need to adjust the audio level so the K3's ALC meter reads 4-5 bars, which indicates the onset of ALC action. Do NOT reduce the audio level to reduce transmitted power; keep the audio level sufficient to produce the required ALC meter reading and use the K3's PWR control to select the desired output power.

73,
Rich VE3KI


On Wed, Jan 8, 2020 at 09:29 PM, Michael WA7SKG wrote:
I was helping a friend set up his K3S for FT8 this afternoon. Haven't
played with one of those before, quite a challenge. Our main problem was
getting audio into the transmitter. What finally worked was to go into
the radio menu and set MIC SEL to LINE IN. Immediately made contacts in
Florida, Russia, and Japan. PSKReporter showed reception all over the
US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who
says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to
Pkt/Data and it did not work. I had to set it to None. Then set the
radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a
nuisance to have to go into the menu and change the MIC SEL each time
you want to move from voice to FT8. Most radios I set up, I chose the
Pkt/Data and when I select a band in the band map, it automatically sets
the radio to DATA and audio flows properly. That does not seem to be the
case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to
go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG


Michael WA7SKG
 

That was the configuration I started out with, except for SPLIT, where I had NONE. I guess I don't understand how SPLIT works in this context. You said the audio is set to LINE IN. Is that MIC SEL on the K3S? Setting MODE to DATA/PKT, it put the radio into DATA mode, but I got no output. I put MODE back into NONE, set the radio to USB, and set MIC SEL to LINE IN and it worked. However, then I had no audio from the microphone until I went back into the menu and changed MIC SEL to F.PNL. I could not find any other audio option that offered LINE IN.

I'm obviously missing something somewhere.

Michael WA7SKG


Bob McGraw K4TAX wrote on 1/8/20 7:28 PM:

Michael:
The K3 setup is very easy.   Use the DATA/PKT mode and use SPLIT.   The audio should be set for Line IN.   I do use the USB connection between the computer and the radio.   I do not use any audio cables, ptt cable or such.   Everything is handled on the USB communications thus only one cable between the computer and the radio.
Here is a screen shot of mine for my K3S.   There is no need to change anything when going between CW, SSB, AM, FT-8 or other digital modes. The software handles 100% of the radio configuration.   Your COM port may be different than mine.   Use Device Manager to see which port the K3S is connected.
73
Bob, K4TAX
On 1/8/2020 8:29 PM, Michael WA7SKG wrote:
I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8.  Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,


Michael WA7SKG
 

First off, I am working with a K3S, not a 991. I have worked with Icoms, Yaesus, Kenwoods, and a few others, I am somewhat familiar with them. This is the first Elecraft, and it is considerably different from any of those.

I have yet to find any command references for sending commands to the K3S for mode, frequency or any other changes. I know there must be some, I just haven't found them.

What is this Custom Switch button of which you speak? I have extensively searched the WSJT-X documentation and can find no reference to such item.

I have set up several FT-991s for WSJT-X. Properly configured, the FT-991 automatically switches between voice and data when using WSJT-X, no custom switches or extra measures are required to switch between voice and data.

Michael WA7SKG


A Wallace wrote on 1/8/20 6:52 PM:

FWIW on my FT991 I set the Custom Switch button to take me to the correct
menu item. Switching becomes easy-peasy between voice and Data. Adrian
VK5AW.
--------- Original Message --------
From: WSJTX@groups.io
To: WSJTX@groups.io <WSJTX@groups.io>
Subject: [WSJTX] WSJT-X on K3S
Date: 09/01/20 02:29


I was helping a friend set up his K3S for FT8 this afternoon. Haven't
played with one of those before, quite a challenge. Our main problem was
getting audio into the transmitter. What finally worked was to go into
the radio menu and set MIC SEL to LINE IN. Immediately made contacts in
Florida, Russia, and Japan. PSKReporter showed reception all over the
US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who
says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to
Pkt/Data and it did not work. I had to set it to None. Then set the
radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a
nuisance to have to go into the menu and change the MIC SEL each time
you want to move from voice to FT8. Most radios I set up, I chose the
Pkt/Data and when I select a band in the band map, it automatically sets
the radio to DATA and audio flows properly. That does not seem to be the
case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to
go into the menu and make changes every time he wants to go from SSB to
FT8?

Any insights appreciated.

73,
Michael WA7SKG



Michael WA7SKG
 

Finally, someone who knows how to actually answer a question. Bless you, Sir. This is exactly what I was looking for. I was unaware there were multiple DATA modes.That was definitely not clear in the manuals.

Armed with this valuable information, I shall return to my friend and am confident I can now correct his configuration.

Thank you again.

73,
Michael WA7SKG


ve3ki wrote on 1/8/20 8:49 PM:

The radio should be in DATA A mode (there are four data modes - you have to select the correct one using the DATA MD button at the lower right corner of the keypad together with the VFO B knob). In DATA A, MIC SEL is set to LINE IN by default. By using DATA A, you don't have to turn compression off or adjust audio levels back and forth between phone and data modes, and you don't need to keep changing MIC SEL every time you change modes. The default filter bandwidth in DATA A is only 500 Hz, so you will have to widen it, which is a simple matter of twiddling the HI CUT and LO CUT knobs to where you want them. The filter setting is remembered.
Once you have put the K3 or K3S (they are functionally the same) into the DATA A submode on each band you use, that will be remembered on each band, and you can configure WSJT-X to use Data mode
Setting audio levels is different in Elecraft rigs from other radios - you need to adjust the audio level so the K3's ALC meter reads 4-5 bars, which indicates the onset of ALC action. Do NOT reduce the audio level to reduce transmitted power; keep the audio level sufficient to produce the required ALC meter reading and use the K3's PWR control to select the desired output power.
73,
Rich VE3KI
On Wed, Jan 8, 2020 at 09:29 PM, Michael WA7SKG wrote:
I was helping a friend set up his K3S for FT8 this afternoon. Haven't
played with one of those before, quite a challenge. Our main problem
was
getting audio into the transmitter. What finally worked was to go into
the radio menu and set MIC SEL to LINE IN. Immediately made contacts in
Florida, Russia, and Japan. PSKReporter showed reception all over the
US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who
says there is no propagation?
My first surprise was in the WSJT configuration, I set the mode to
Pkt/Data and it did not work. I had to set it to None. Then set the
radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a
nuisance to have to go into the menu and change the MIC SEL each time
you want to move from voice to FT8. Most radios I set up, I chose the
Pkt/Data and when I select a band in the band map, it automatically
sets
the radio to DATA and audio flows properly. That does not seem to be
the
case for the Elecraft.
Did I miss something in the configuration? Surely one does not have to
go into the menu and make changes every time he wants to go from SSB
to FT8?
Any insights appreciated.
73,
Michael WA7SKG


AD0DQ Tony
 

Michael, thanks for helping out your friend.
Rich, your explanation was wonderful.

AD0DQ

On Jan 9, 2020, at 1:08 AM, Michael WA7SKG <wa7skg@...> wrote:

Finally, someone who knows how to actually answer a question. Bless you, Sir. This is exactly what I was looking for. I was unaware there were multiple DATA modes.That was definitely not clear in the manuals.

Armed with this valuable information, I shall return to my friend and am confident I can now correct his configuration.

Thank you again.

73,
Michael WA7SKG


ve3ki wrote on 1/8/20 8:49 PM:
The radio should be in DATA A mode (there are four data modes - you have to select the correct one using the DATA MD button at the lower right corner of the keypad together with the VFO B knob). In DATA A, MIC SEL is set to LINE IN by default. By using DATA A, you don't have to turn compression off or adjust audio levels back and forth between phone and data modes, and you don't need to keep changing MIC SEL every time you change modes. The default filter bandwidth in DATA A is only 500 Hz, so you will have to widen it, which is a simple matter of twiddling the HI CUT and LO CUT knobs to where you want them. The filter setting is remembered.
Once you have put the K3 or K3S (they are functionally the same) into the DATA A submode on each band you use, that will be remembered on each band, and you can configure WSJT-X to use Data mode
Setting audio levels is different in Elecraft rigs from other radios - you need to adjust the audio level so the K3's ALC meter reads 4-5 bars, which indicates the onset of ALC action. Do NOT reduce the audio level to reduce transmitted power; keep the audio level sufficient to produce the required ALC meter reading and use the K3's PWR control to select the desired output power.
73,
Rich VE3KI
On Wed, Jan 8, 2020 at 09:29 PM, Michael WA7SKG wrote:
I was helping a friend set up his K3S for FT8 this afternoon. Haven't
played with one of those before, quite a challenge. Our main problem
was
getting audio into the transmitter. What finally worked was to go into
the radio menu and set MIC SEL to LINE IN. Immediately made contacts in
Florida, Russia, and Japan. PSKReporter showed reception all over the
US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who
says there is no propagation?
My first surprise was in the WSJT configuration, I set the mode to
Pkt/Data and it did not work. I had to set it to None. Then set the
radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a
nuisance to have to go into the menu and change the MIC SEL each time
you want to move from voice to FT8. Most radios I set up, I chose the
Pkt/Data and when I select a band in the band map, it automatically
sets
the radio to DATA and audio flows properly. That does not seem to be
the
case for the Elecraft.
Did I miss something in the configuration? Surely one does not have to
go into the menu and make changes every time he wants to go from SSB
to FT8?
Any insights appreciated.
73,
Michael WA7SKG


Tom Schaefer NY4I
 

Set MIC+LIN to ON.    (Page 55 of the manual).

If set to ON, and MIC SEL is set for FP or RP, the present mic OR line input can be used for transmit audio.

Note: Setting MIC SEL to LINE overrides the MIC+LIN menu entry (its parameter becomes "N-A"). When MIC+LIN is in effect, rotating the MIC control shows MIC gain. Set MIC SEL to LINE to adjust LINE IN gain. 



You just have to be careful to not talk if you have a mic connected as I believe the MIC is hot while transmitting. I have not tested if the mic stays hot in awhile though as I run with MIC+LIN OFF and set it to LINE in (with a PF button programmed to switch).

The data mode you want is DATA A and NOT PSK (that is for the internal PSK decoder).

The biggest change for people not used to the K3 is that for digital mode like this you DO want ALC deflection. You want to set it for the 5th bar is barely lighting up. That is different than other radios where you do not want ANY ALC deflection.

See page 34 and 30 for more info.

Tom NY4I


On Jan 8, 2020, at 9:29 PM, Michael WA7SKG <wa7skg@...> wrote:

I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8.  Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG



John Hill
 

The mic input is muted during TX.  BTW, you should always select the CAT PTT Method because it eliminates the need for a separate DTR or RTS input.  RX audio will trip VOX if you have the volume up to high if you attempt to the VOX method.

John W2HUV

On January 9, 2020 at 2:44 PM Tom Schaefer NY4I <thomasmschaefer@...> wrote:

Set  MIC+LIN to ON.    (Page 55 of the manual).

If set to ON, and MIC SEL is set for FP or RP, the present mic OR line input can be used for transmit audio.

Note: Setting MIC SEL to LINE overrides the MIC+LIN menu entry (its parameter becomes "N-A"). When MIC+LIN is in effect, rotating the MIC control shows MIC gain. Set MIC SEL to LINE to adjust LINE IN gain. 



You just have to be careful to not talk if you have a mic connected as I believe the MIC is hot while transmitting. I have not tested if the mic stays hot in awhile though as I run with MIC+LIN OFF and set it to LINE in (with a PF button programmed to switch).

The data mode you want is DATA A and NOT PSK (that is for the internal PSK decoder).

The biggest change for people not used to the K3 is that for digital mode like this you DO want ALC deflection. You want to set it for the 5th bar is barely lighting up. That is different than other radios where you do not want ANY ALC deflection.

See page 34 and 30 for more info.

Tom NY4I


On Jan 8, 2020, at 9:29 PM, Michael WA7SKG < wa7skg@...> wrote:

I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8.  Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG




 


Tom Schaefer NY4I
 

Yep. Always give the benefit of the doubt to Elecraft with the little details like muting the front mic when in a Data mode :)

Thanks,

Tom NY4I

On Jan 9, 2020, at 4:26 PM, JOHN HILL <john.e.hill@...> wrote:

The mic input is muted during TX.  BTW, you should always select the CAT PTT Method because it eliminates the need for a separate DTR or RTS input.  RX audio will trip VOX if you have the volume up to high if you attempt to the VOX method.

John W2HUV
On January 9, 2020 at 2:44 PM Tom Schaefer NY4I <thomasmschaefer@...> wrote:

Set  MIC+LIN to ON.    (Page 55 of the manual).

If set to ON, and MIC SEL is set for FP or RP, the present mic OR line input can be used for transmit audio.

Note: Setting MIC SEL to LINE overrides the MIC+LIN menu entry (its parameter becomes "N-A"). When MIC+LIN is in effect, rotating the MIC control shows MIC gain. Set MIC SEL to LINE to adjust LINE IN gain. 



You just have to be careful to not talk if you have a mic connected as I believe the MIC is hot while transmitting. I have not tested if the mic stays hot in awhile though as I run with MIC+LIN OFF and set it to LINE in (with a PF button programmed to switch).

The data mode you want is DATA A and NOT PSK (that is for the internal PSK decoder).

The biggest change for people not used to the K3 is that for digital mode like this you DO want ALC deflection. You want to set it for the 5th bar is barely lighting up. That is different than other radios where you do not want ANY ALC deflection.

See page 34 and 30 for more info.

Tom NY4I


On Jan 8, 2020, at 9:29 PM, Michael WA7SKG < wa7skg@...> wrote:

I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8.  Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG




 


John Hill
 

Tom,

I always use the USB mode.

John W2HUV

On January 9, 2020 at 4:31 PM Tom Schaefer NY4I <thomasmschaefer@...> wrote:

Yep. Always give the benefit of the doubt to Elecraft with the little details like muting the front mic when in a Data mode :)

Thanks,

Tom NY4I

On Jan 9, 2020, at 4:26 PM, JOHN HILL < john.e.hill@...> wrote:

The mic input is muted during TX.  BTW, you should always select the CAT PTT Method because it eliminates the need for a separate DTR or RTS input.  RX audio will trip VOX if you have the volume up to high if you attempt to the VOX method.

John W2HUV
On January 9, 2020 at 2:44 PM Tom Schaefer NY4I < thomasmschaefer@...> wrote:

Set  MIC+LIN to ON.    (Page 55 of the manual).

If set to ON, and MIC SEL is set for FP or RP, the present mic OR line input can be used for transmit audio.

Note: Setting MIC SEL to LINE overrides the MIC+LIN menu entry (its parameter becomes "N-A"). When MIC+LIN is in effect, rotating the MIC control shows MIC gain. Set MIC SEL to LINE to adjust LINE IN gain. 



You just have to be careful to not talk if you have a mic connected as I believe the MIC is hot while transmitting. I have not tested if the mic stays hot in awhile though as I run with MIC+LIN OFF and set it to LINE in (with a PF button programmed to switch).

The data mode you want is DATA A and NOT PSK (that is for the internal PSK decoder).

The biggest change for people not used to the K3 is that for digital mode like this you DO want ALC deflection. You want to set it for the 5th bar is barely lighting up. That is different than other radios where you do not want ANY ALC deflection.

See page 34 and 30 for more info.

Tom NY4I


On Jan 8, 2020, at 9:29 PM, Michael WA7SKG < wa7skg@...> wrote:

I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8.  Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG




 



 


Bill Somerville
 

On 09/01/2020 21:26, John Hill wrote:
BTW, you should always select the CAT PTT Method because it eliminates the need for a separate DTR or RTS input.
John,

that is only true if you do not need to switch other devices. A common setup is to use RTS to drive an external sequencer that ensures LNAs are taken out of circuit, PAs keyed, then the rig is keyed, so as to avoid any expensive consequences.

73
Bill
G4WJS.


John Hill
 

Bill,

Thanks for the feedback!  I don't need to switch other devices, but I can see how the DTR or RTS method could be used to trigger a sequencer.

John W2HUV

On January 9, 2020 at 7:16 PM Bill Somerville < g4wjs@...> wrote:


On 09/01/2020 21:26, John Hill wrote:
BTW, you should always select the CAT PTT Method because it eliminates
the need for a separate DTR or RTS input.
John,

that is only true if you do not need to switch other devices. A common
setup is to use RTS to drive an external sequencer that ensures LNAs are
taken out of circuit, PAs keyed, then the rig is keyed, so as to avoid
any expensive consequences.

73
Bill
G4WJS.


Bob McGraw - K4TAX <rmcgraw@...>
 

I don't advise using MIC + LIN because during transmit, anything picked up by the mike will also be transmitted.    This would then be voice transmitted in the non-voice band allocations.   Largely in violation of FCC rules.

MIC SEL should be set for LINE IN.   DATA MD should be set for DATA A.  Connections between the computer and radio is accomplished by ONE USB cable which handles RX audio, TX audio and CAT commands.   There should be nothing plugged in the LINE in or out on the back of the radio.

The Radio setup for WSJT is as in the following screen capture on the right side. 

The audio level as set by a combination of PWR slider on the WSJT-X screen and the LINE gain as set by the MIC control should be such that there are 4 bars on solid on the ALC scale and the 5th bar flickering.   Then the actual transmit power is set by the PWR control on the radio.


73

Bob, K4TAX



On 1/9/2020 1:44 PM, Tom Schaefer NY4I wrote:

Set MIC+LIN to ON.    (Page 55 of the manual).

If set to ON, and MIC SEL is set for FP or RP, the present mic OR line input can be used for transmit audio.

Note: Setting MIC SEL to LINE overrides the MIC+LIN menu entry (its parameter becomes "N-A"). When MIC+LIN is in effect, rotating the MIC control shows MIC gain. Set MIC SEL to LINE to adjust LINE IN gain. 



You just have to be careful to not talk if you have a mic connected as I believe the MIC is hot while transmitting. I have not tested if the mic stays hot in awhile though as I run with MIC+LIN OFF and set it to LINE in (with a PF button programmed to switch).

The data mode you want is DATA A and NOT PSK (that is for the internal PSK decoder).

The biggest change for people not used to the K3 is that for digital mode like this you DO want ALC deflection. You want to set it for the 5th bar is barely lighting up. That is different than other radios where you do not want ANY ALC deflection.

See page 34 and 30 for more info.

Tom NY4I


On Jan 8, 2020, at 9:29 PM, Michael WA7SKG <wa7skg@...> wrote:

I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8.  Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG




    


Bob McGraw - K4TAX <rmcgraw@...>
 

If one uses the Data A mode and uses the single USB cable between the computer and radio, none of the other settings or values is required.  No VOX, no DTS, no DTR and the TX EQ is automatically bypassed along with Speech Processing. 

Keep it simple, use one USB cable for RX audio, TX audio, CAT commands including PTT.    Most hams seem to think they need 5 to 10 cables to make stuff work when in this case one will do nicely.   I run my K3S that way and it sure is nice plus it works 100% of the time with no need for futzing with levels, cables, connectors or changes to the radio configuration.

73

Bob, K4TAX

On 1/9/2020 3:31 PM, Tom Schaefer NY4I wrote:

Yep. Always give the benefit of the doubt to Elecraft with the little details like muting the front mic when in a Data mode :)

Thanks,

Tom NY4I

On Jan 9, 2020, at 4:26 PM, JOHN HILL <john.e.hill@...> wrote:

The mic input is muted during TX.  BTW, you should always select the CAT PTT Method because it eliminates the need for a separate DTR or RTS input.  RX audio will trip VOX if you have the volume up to high if you attempt to the VOX method.

John W2HUV
On January 9, 2020 at 2:44 PM Tom Schaefer NY4I <thomasmschaefer@...> wrote:

Set  MIC+LIN to ON.    (Page 55 of the manual).

If set to ON, and MIC SEL is set for FP or RP, the present mic OR line input can be used for transmit audio.

Note: Setting MIC SEL to LINE overrides the MIC+LIN menu entry (its parameter becomes "N-A"). When MIC+LIN is in effect, rotating the MIC control shows MIC gain. Set MIC SEL to LINE to adjust LINE IN gain. 



You just have to be careful to not talk if you have a mic connected as I believe the MIC is hot while transmitting. I have not tested if the mic stays hot in awhile though as I run with MIC+LIN OFF and set it to LINE in (with a PF button programmed to switch).

The data mode you want is DATA A and NOT PSK (that is for the internal PSK decoder).

The biggest change for people not used to the K3 is that for digital mode like this you DO want ALC deflection. You want to set it for the 5th bar is barely lighting up. That is different than other radios where you do not want ANY ALC deflection.

See page 34 and 30 for more info.

Tom NY4I


On Jan 8, 2020, at 9:29 PM, Michael WA7SKG < wa7skg@...> wrote:

I was helping a friend set up his K3S for FT8 this afternoon. Haven't played with one of those before, quite a challenge. Our main problem was getting audio into the transmitter. What finally worked was to go into the radio menu and set MIC SEL to LINE IN. Immediately made contacts in Florida, Russia, and Japan. PSKReporter showed reception all over the US, Switzerland, Russia, Japan, the Carribbean, West Africa, etc. Who says there is no propagation?

My first surprise was in the WSJT configuration, I set the mode to Pkt/Data and it did not work. I had to set it to None. Then set the radio to USB, not Data, and change the MIC SEL to LINE IN. It seems a nuisance to have to go into the menu and change the MIC SEL each time you want to move from voice to FT8.  Most radios I set up, I chose the Pkt/Data and when I select a band in the band map, it automatically sets the radio to DATA and audio flows properly. That does not seem to be the case for the Elecraft.

Did I miss something in the configuration? Surely one does not have to go into the menu and make changes every time he wants to go from SSB to FT8?

Any insights appreciated.

73,
Michael WA7SKG