locked WSJT-X loses my output setting periodically #AudioIssues


Richard Berry
 

I use a SignaLink USB so I have the Output set to Speaker (2-USB Audio CODEC) but periodically when I start WSJT-X it comes up outputting to the computer's speakers even though the setting still says Speaker (2-USB Audio CODEC).  If  I change it to Speakers (Realtek) then back to Speaker (2-USB Audio CODEC) everything is OK again for a while.  

Today I was working FT8, walked away from the shack for about an hour and when I came back there was NO audio output anywhere.  The Output still said Speaker (2-USB Audio CODEC), so again I changed it to Speakers (Realtek) then back to Speaker (2-USB Audio CODEC) and everything was fine again.

Why does WSJT-X keep losing the established Output device?  I thought it was just not enumerating the device correctly on startup but today it did it while running! 

 I do not have this problem on Input.  

Dick
KF5SA


Michael Black
 

Your USB is going to sleep.

Under Power Options, Advanced settings.  disable USB selective suspend.

de Mike W9MDB


On Tuesday, November 21, 2017, 9:33:16 PM CST, Richard Berry <shadowberr@...> wrote:


I use a SignaLink USB so I have the Output set to Speaker (2-USB Audio CODEC) but periodically when I start WSJT-X it comes up outputting to the computer's speakers even though the setting still says Speaker (2-USB Audio CODEC).  If  I change it to Speakers (Realtek) then back to Speaker (2-USB Audio CODEC) everything is OK again for a while.  

Today I was working FT8, walked away from the shack for about an hour and when I came back there was NO audio output anywhere.  The Output still said Speaker (2-USB Audio CODEC), so again I changed it to Speakers (Realtek) then back to Speaker (2-USB Audio CODEC) and everything was fine again.

Why does WSJT-X keep losing the established Output device?  I thought it was just not enumerating the device correctly on startup but today it did it while running! 

 I do not have this problem on Input.  

Dick
KF5SA


Richard Berry
 

Good thought but it's already Disabled.  

This ONLY happens on WSJT-X ... never on DM780.  

Dick


Pete Singleton
 

Me too!
I've disabled USB selective suspend in Control Panel, Power Options, Hi-performance plan, advanced settings.
I've disabled power saving in Device Manager, USB (various).
If I don't use transmit for a while the audio goes to my speakers rather than the codec.

Any helpful suggestions?
M0PTB


Bill Somerville
 

On 04/10/2021 18:24, Pete Singleton wrote:
Me too!
I've disabled USB selective suspend in Control Panel, Power Options, Hi-performance plan, advanced settings.
I've disabled power saving in Device Manager, USB (various).
If I don't use transmit for a while the audio goes to my speakers rather than the codec.

Any helpful suggestions?
M0PTB
Hi Pete,

do you have an HDMI monitor? Does the problem go away if you disable the energy saving on the HDMI monitor?

73
Bill
G4WJS.


Colin
 

Peter,

Here’s an article that touches on the USB settings – sounds like you’ve covered most, perhaps not all:

https://forum.diffractionlimited.com/threads/prevent-disconnects-turn-off-usb-selective-suspend.7848/

 

If a USB device, including a serial port or virtual USB/RS232 serial port gets shut down even temporarily by windows, the OS will then decide to disconnect it and anything attached, including the audio codec, so will switch to another codec.

 

Good luck,

Colin VE3MSC

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of Pete Singleton
Sent: October 4, 2021 13:25
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] WSJT-X loses my output setting periodically #audio_issues

 

Me too!
I've disabled USB selective suspend in Control Panel, Power Options, Hi-performance plan, advanced settings.
I've disabled power saving in Device Manager, USB (various).
If I don't use transmit for a while the audio goes to my speakers rather than the codec.

Any helpful suggestions?
M0PTB


Pete Singleton
 

Yes!  Setting 'Turn off the display' to 'Never' fixed the problem.  I just turn the monitor off when I'm away from it.

I speculate that it isn't going to sleep isn't the problem, more the monitor speakers grabbing input when they wake up.

73
Pete
M0PTB